ReportsMagic V1.0A 追加情報

マジックソフトウェア・ジャパン
株式会社２００5年４月

ReportsMagic Ver1.0A 追加情報

RMDesigner
RMViewer

本文書には､ReportsMagic として提供されたプログラム に関して、マニュアルの記載事項以外の追加情報が記述されています。

  • 本バージョンのご利用にあたって
  • 動作環境及び注意事項
  • サンプルフォーム、アプリケーション
  • Ver1.0Aの改善内容
  • Ver1.0Aのベータ機能
  • 制限事項及び留意事項
  • RMViewer C/S版とWeb版

本バージョンのご利用にあたって

ベータ版、体験版をご利用になったお客様に

ベータ版、体験版から製品版に移行する場合には、以下の点にご留意ください。

  • 本製品版をインストールするにあたりましては、ベータ版、体験版のモジュールが残って思わぬ悪影響を与えることを避けるため、ベータ版、体験版のアンインストールを行い、ファイル等の設定を完全に削除してください。
  • ベータ版、体験版で作成したフォームデータは、製品版で使用することはできません。

RMViewer（ActiveX)のアップデート

メンテナンス処理、アップグレード処理で RMViewer（ActiveX)の再登録を実行した場合、「RMViewer体験版のご案内」、「RMViewerCtl.ocx の DllRegisterServerは成功しました」等のダイアログが表示される場合があります。その場合は、Enterを入力してそのまま継続してください。

ベータ機能／ご意見、要望事項について

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外となります。又、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールにて japan_v9beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

動作環境及び注意事項

  • RMDesigner

    Windows 2000／XP／2003
  • RMViewer

    Windows | 98 SE／2000／XP／2003
    ブラウザ | Internet Explorer 5.5 SP2以上
    Magic（ActiveX)組込み | V9Plus
    Magic　exe起動 | V8、V9、V9Plus

サンプルフォーム、アプリケーション

RMDesignerのインストール時にサンプルプログラムのインストール選択している場合は、サンプルフォーム、及びMagicアプリケーションがインストールされます。

RMDesigner での確認

  • RMDesigner で RMDesigner\Sample\RMdata上の各フォームを開き、ツール／テストでサンプルデータを選択します。
サンプルフォーム | フォーム名 | サンプルデータ | 備考
家族構成 （マルチデータフォーム） | EmpfamilyCsv.rfr | EmpfamilyCsv.csv | CSV形式
 | EmpfamilyCsvhead.rfr | EmpfamilyCsvhead.csv | CSVヘッダー付き形式
 | EmpfamilydbFORM.rfr | EmpfamilydbForm.dat | dbFORM形式
 | EmpfamilyXml.rfr | Empfamily.xml | XML形式
勘定科目名 （dbFORM） | HIKAKU.ｒｆｒ | HIKAKU.dat | dbFORMのフォームを読み込んで作成したものです。
 | HIKAKU.FRM | HIKAKU.dat | オリジナルのdbFORMのフォームです。新規フォームを作成し、「ファイル／dbFORM読み込み 」で 読み込むことができます。その後、「ツール／帳票設定」のデータ形式をdbFORM形式にして、確認します。
複合文書 | Fukugo.rfr | Fukugo.xml | 納品書、請求書、納品受領書の複合文書です。
バーコード | バーコード.rfr | バーコード.xml | バーコードの一覧表です。
イメージ | イメージ.rfr | イメージ.xml | イメージ処理のサンプルです。
複数ページ | Fukusu.rfr | Fukusu.xml | 暗黙の改ページのサンプルです。

RMViewerでの確認

  • RMDesigner－サンプルのメニューをクリックして起動してください。
メニュー | サンプルフォーム | 起動方法
家族構成.HTML | 家族構成 | ブラウザ起動
家族構成 | 家族構成 | RMViewer.exe起動
複合文書.HTML | 複合文書 | ブラウザ起動
複合文書 | 複合文書 | RMViewer.exe起動
複数ページ.HTML | 複数ページ | ブラウザ起動
複数ページ | 複数ページ | RMViewer.exe起動

RMDesignerで添付しているRMViewerは体験版です。

HTMLの場合、フォーム、印刷データのパスをドライブ指定で記述していますが、URLに変更することも可能です。

●例
<param name="RfrFile" value="http://localhost/ReportsMagic/EmpfamilyXml.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/Empfamily.xml">
<param name="ToolBar" value="on">

Magicと連携したサンプル

家族構成のXMLフォーム（EmpfamilyXml.rfr）を使用したサンプルアプリケーションです。
RMDesigner－サンプルの「Magic起動」のメニューをクリックして起動してください。
プログラムリポジトリの「ReportsMagic サンプル-メイン」をＦ７で実行してください。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
Magic Viewer ActiveX | Magicから ActiveX 呼び出しで、RMViewerを実行します。
Magic Viewer EXE | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。
HTML Viewer | ブラウザから、RMViewerを実行します。 表示用のHTML（家族構成.htm）を生成し、オープンします。

Ver1.0Aの改善内容

dbFORM

  • dbFORMフォームの読込で、項目にアンダーバーが付く件に対応しました。
  • dbFORMフォームの読込で、横倍角に対応しました。
  • dbFORM形式でイメージデータが表示されない件に対応しました。
    文字列／データ項目名の最後の文字を I にします。　例：％％１７－４Ｉ

データ連携

  • CSV形式で、印刷データにシングルバイトの"が含まれると正しくデータ認識できない件に対応しました。
    シングルバイトの"を含めたい場合は、""と表現します。
  • XML形式で、印刷データに、シングルバイトの"や、&quot;が含まれると正しくデータ認識できない件に対応しました。

その他

  • 「テスト実行」を行うと、フォームの項目名が実データに更新される場合がある件に対応しました。
  • スタテック（固定）文字列は、枠を表示をしないようにしました。
  • バーコードのデータが不正な場合は、「バーコードエラー」と表示するようになりました。
  • 文字列でテキストに下線を指定した場合、スペース部分は下線が引かれない件に対応しました。

RMViewer

  • フォームファイルをオープンし印刷データ取り込み前は、項目データが項目タグ名や、サンプルが表示されている件に対応しました。

Ver1.0Aのベータ機能

イメージ

  • イメージをデータフィールドとして使用する場合、イメージ形式としてJPEGに対応しました。

制限事項及び留意事項

イメージ
  • スタティクなイメージ読み込みは、イメージ形式によっては実際のイメージと異なる表示になる場合があります。
  • イメージをデータフィールドとして使用する場合、サポートしているイメージ形式は以下の種類です。
    BMP、PNG

印刷

  • Windowsのプリンタドライバを使用しての印刷のみをサポートしています。

dbFORM

  • dbFORMのフォームを読み込んだ場合、若干イメージが異なる場合があります。
  • 文字単位のフォント指定、属性指定は、できません。
  • 文字の囲み、傍点、袋文字、影付き、立体、下付、上付はサポートされていません。
  • 縦書きの場合、１バイト文字は縦書きになりません。

データ連携

  • 項目書式は将来の拡張のために用意されているもので、現在は未使用です。使用しないでください。

データ項目ウインドウ

  • データ項目ウインドウを表示している状態で、フォーム上のデータ項目を削除しても、データ項目ウインドウには反映されません。その場合は、データ項目ウインドウの再表示を実行してください。
  • データ項目ウインドウにデータ項目が存在してもフォームに割りついていない項目は、フォームを格納しても保存されません。
  • フォームに割り付けたデータ項目のプロパティを開いて項目TAGを変更した場合、以前のデータ項目は残り、新規に変更した項目が追加されます。
その他
  • 使用できる文字コードは、シフトJISのみです。
  • 外字を使用する場合は、実行するPCに事前に外字を登録しておく必要があります。
  • 文字列を固定幅フォント－文字ピッチ０の状態で使用すると、解像度の異なるコンピュータで表示イメージが異なる場合があります。その場合は、文字ピッチを指定するようにしてください。

RMViewer

  • RMViewer（ActiveX)をMagicのバッチタスクで印刷することは出来ません。バッチタスクで印刷する場合は、RMViewer（EXE)を使用してください。

RMViewer C/S版とWeb版

RMViewer C/S版とWeb版は、フォームファイル、印刷データファイルに対するアクセス方法に制限がありますので、RMViewerの起動方法を考量する必要があります。

  • RMViewer C/S
種類 | 起動例
RMViewer.exe | RMViewer.exe /rfr=sample.rfr /rdata=sample.xml /dsp=y
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\sample.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\sample.xml">
<param name="ToolBar" value="on">
</object>
  • RMViewer Web
種類 | 起動例
RMViewer.exe | RMViewer.exe /rfr=http://localhost/ReportsMagic/sample.rfr /rdata=http://localhost/ReportsMagic/sample.xml /dsp=y
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="http://localhost/ReportsMagic/sample.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/sample.xml">
<param name="ToolBar" value="on">
</object>


ベータ版評価レポートのお願い

ベータ機能評価レポート

ベータ機能に関するご質問等は、マジックソフトウェアジャパンのサポートセンターではお受けいたしておりませんが、ご意見、ご質問、気が付いた点などは、下記の「ベータ 機能評価レポート」に記入して、メールで japan_v9beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。

ReportsMagic Ver1.0A ベータ機能評価レポート

記入日： ２００５年　 月　 日
会社名：
担当者：
E-mail：
ＴＥＬ：
ＦＡＸ：
サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境
ＰＣ機種：
ＣＰＵ：
ＲＡＭ：
ＯＳ： （ ）Windows98／（ ）Windows2000（SP： ）／（ ）WindowsXP／（ ）Windows2003
ＩＭＥ：
ビデオカード：
   使用ブラウザ：（ ）IE5.5 （SP： )、　（ ） IE6（SP： ）
  製品　（ ） RMDesigner　（Ver ）／（ ） RMViewer　（Ver ）
          （ ）Magic V9Plus （Ver ）／ （ ）Magic V9 （Ver ）／ （ ）その他（ ）
２．不具合の場合

不具合を確認した場合は、こちらに記入してください。 該当する（ ）に＊を挿入してください。

Ａ （ ） 一部支障あり
Ｂ （ ） 正常に動作しない
Ｃ （ ） インストール・起動不可

２．１．再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

２．２．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なう
ために、極力画面のハードコピー、フォームデータ、サンプルプログラム等の提供をお願い
いた します。）

３．要望事項
機能追加、改善要望等がありましたら、こちらに記入してください。
 （できるだけ詳細にお書きください。）

４．その他ご意見

以上