Magic uniPaaS V1Plus 追加情報

マジックソフトウェア・ジャパン株式会社
２０１１年１２月

Magic uniPaaS® V1Plus 1.9g2追加情報

uniPaaS Studio
uniPaaS Client
uniPaaS Enterprise Server
uniPaaS RichClient Server

このファイルには、Magic uniPaaS V1Plus について、マニュアルに記載されていない注意点や制限事項など重要な情報が記載されています。

内容

  • 本バージョンのご利用にあたって [image] 必ずお読みください。
  • 添付ドキュメントについて
  • サポートされているOS・DBMS
  • ソフトウェアメンテナンス [image] 必ずお読みください。
  • Magic uniPaaS V１Plus のFAQ
  • 修正履歴
  • 参考技術情報
  • 付録
  • 各種リンク情報
  • ベータ評価レポート
  • Magic uniPaaS V1Plus 使用許諾契約書


本バージョンのご利用にあたって

インストール製品について

今回のリリースで提供されるMagic製品は、下記の通りです。

製品名 | 提供ライセンス
uniPaaS Studio (開発版) | インストール時のデフォルトはデモライセンスで、最大データソース数、レコード数、プログラム数などに制限があります。弊社 UDC でユーザ登録を行い、ライセンス発行をして、ライセンス情報を取得してください。その後、ライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。
uniPaaS Client (実行版) | 製品梱包箱のシールにライセンス情報(シリアル番号、アクティベーションキーなど)が記載されているので、インストール後にライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。
uniPaaS Enterprise Server (サーバ版) | 弊社UDCでユーザ登録を行い、ライセンス発行をして、ライセンス情報を取得してください。その後、ライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。 uniPaaS Enterprise Serverのライセンスだけでは、リッチクライアント機能は利用できません。
uniPaaS RichClient Server (サーバ版) | 弊社UDCでユーザ登録を行い、ライセンス発行をして、ライセンス情報を取得してください。その後、ライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。 uniPaaS RichClient Serverのライセンスでは、リッチクライアント機能以外のサーバ機能は利用できません。 また、uniPaaS RichClient Server for Mobileのライセンスでは、モバイル端末以外のリッチクライアント要求を受け付けません。

インストールとライセンス登録の詳細については、CD-ROM の Online ディレクトリに各製品ごとのインストールマニュアルがあります。ここに詳しく説明してありますので、そちらを参照してください。

ベータ機能について

本バージョンが提供する機能のうち、ベータ機能、サポート外機能とされている機能があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外ですが、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールで japan_v10beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

現バージョンでの既知の問題・制限事項

現バージョンでの既知の問題・制限事項については、修正履歴 を参照してください。

アップグレード時のRIA環境について

Magic uniPaaSをアップグレードした場合、リッチクライアントアプリケーションを正しく動作させるために以下の点に注意してください。

RIAモジュールのバージョン設定

Magic uniPaaS のインストールフォルダ内のRIAModulesサブフォルダ内にコピーされるファイルを基に、リッチクライアントインタフェースビルダによって実行環境（デフォルトは、PublisheApplications\<アプリケーション名>）にコピーするように変更されました。

MAGIC.INIファイルの［MAGIC_RIA］セクションの'ClientModulesPath'パラメータが定義されていると正しく動作しない場合があります。アップグレード後、このパラメータを削除してください。

マニフェストファイルの更新

アップグレードバージョンと同じuniPaaS Studioを使用してリッチクライアントインタフェースビルダでRIAのマニフェストファイルを再作成し、更新してください。

旧バージョンからの移行について

Magic eDeveloper V10 および Magic uniPaaS V1 (Ver 1.5SP1x)、Magic uniPaaS V1Plus（Ver1.8x） のプロジェクトおよびキャビネットファイルは、互換性がありません。リポジトリ出力/入力が必要となります。

Magic uniPaaS V1以前のバージョンで開発したアプリケーションを移行する場合の注意事項は、リファレンスヘルプの「マイグレーション」の説明を参照してください。Magic eDeveloper V10 とのリッチクライアント機能の違いについては、「Magic V10のリッチクライアントとの違い」を参照してください。

Broker Monitorの情報は、Magic uniPaaS V1と同じレジストリ上で管理されています。このため、Magic uniPaaS V1とMagic uniPaaS V1Plusを同じPCに混在させている場合、先に実行した内容をデフォルト値として保存します。 Broker Monitorに情報が表示されない場合は、使用するMRBのポート番号（Ver1.9は、5315）を別途登録するようにしてください。

Magic uniPaaS V1Plusは、ブラウザクライアント機能をサポートしておりません。関連するモジュールのインストール処理も行われません。

Ver1.8から移行する場合は、「uniPaaS V1Plus Ver 1.8との違い」も参照してください。

ゲートウェイ利用時の注意事項について

各DBMSに固有な新機能、留意・制限事項、および互換性についての情報は、リファレンスヘルプの「Magic uniPaaSで使用するデータベース／データベースゲートウェイの追加情報」にまとめてあります。あわせて参照してください。

Broker Monitorの使用について

MRBのステータスを確認するユーティリティーとしてBroker Monitorが添付されていますが､これを常時起動して監視していると定期的にMRBに対してリクエストを発行するため、MRBに負荷を掛けることになります。運用環境でBroker Monitorを常時起動することは､避けていただくことを推奨します。コマンドラインリクエスタ（Mgrqcmdl.exe）でMRBのステータスを確認することができますので､こちらを使用するようにしてください。

RMConverterについて

Magic V9Plus以前のアプリケーションを移行した場合、[レコードメイン]に定義されている処理コマンドは、[RM互換]ロジックユニットに定義されます。このようなプログラムは、Magic uniPaaS V1Plusの機能が利用できない場合があり、イベントやコントロールに対応したロジックユニットに処理を移す必要があります。 [RM互換]ロジックユニットの定義内容をイベントドリブン形式に変換するユーティリティとして RMConverterを公開しています。

以下のリンク先からダウンロードしてインストールすることができます。

http://www.magicsoftware.co.jp/files/beta/RMConverter/RMConverter.htm

RMConverterは、レコードメインで書かれたロジックを、イベントドリブン型のプログラムへと移行する際の補助をするためのものであり、100%の完全移行を保証するものではありません。また、[RM互換]ロジックユニット内に複雑なロジックが定義されていると処理されない場合があります。変換を行った後には、必ず、動作確認を行い、必要に応じて手動で修正を行ってください。

気がついた点、ご意見・ご要望などは、メール（japan_v10beta@magicsoftware.com）でお受けいたしますが、対応をお約束することはできませんので、予めご了承ください。


添付ドキュメントについて

今回のリリースで提供されるドキュメントは以下の通りです。

ヘルプとReadMeは、全製品に添付されます。それ以外の技術文書は、uniPaaS Studioにのみ添付されます。

ドキュメント名 | 形式 | 備考
Magic uniPaaS V1Plus ヘルプ | HTMLヘルプ (CHM) | HTML形式のリファレンスマニュアルです。PDF形式では提供されていません。
Magic uniPaaS V1Plus ReadMe |  | 本 ReadMe ファイルです。
Magic uniPaaSパーティショニング トラブルシューティングガイド | PDF | Magic uniPaaSでアプリケーションを開発する上で知っていただきたい、技術情報が記載されています。
インストールガイド
Magic uniPaaS コンポーネント開発
イベントドリブンアーキテクチャ
データ管理とMagic uniPaaS
インタラクティブなリッチクライアントの開発と実行
マスタリングuniPaaS
.NETサンプルガイド
Magic uniPaaSにおける.NETの基本
MSVSSによるバージョン管理 |  | Microsoft Visual SourceSafe を使用したMagic uniPaaSプロジェクトのバージョン管理の方法について解説します。
CVSによるバージョン管理 |  | CVSを使用したMagic uniPaaSプロジェクトのバージョン管理の方法について解説します。
Microsoft Team Foundation Serverによるバージョン管理 |  | Microsoft Team Foundation を使用したMagic uniPaaSプロジェクトのバージョン管理の方法について解説します。
移行チュートリアル |  | Magic V9Plus以前のアプリケーションをMagic uniPaaS V1Plus用に移行するため知っておく必要がある情報が記載されたチュートリアルです。サンプルアプリケーションを使用します。
Magic uniPaaS for IBM i インストールガイド |  | Magic uniPaaS for IBM iのインストール方法について解説しています。
Magic uniPaaS for IBM i 開発ガイド |  | Magic uniPaaS for IBM iを利用してプログラムを開発する上で、必要な技術情報が記載されています。


サポートされているOS・DBMS

ここでは、Magic uniPaaS V1Plus のシステム要件を記します。

Magic uniPaaS V1Plus サポートDBMS一覧表

DBMS | Version | Magic uniPaaS V1Plus
Pervasive.SQL | V9 | ○(SP1以降)
 | V10 | ○
Oracle | 9i | ○ (R2以降)
 | 10g | ○
 | 11g | ○
MS-SQL | 2005 | ○
 | 2008 | ○
DB2 for IBM i | V5R3/V5R4 | ○
 | V6R1 | ○
 | V7R1 | ○

凡例 … ○：動作確認済、△：制限あり、－：対象外、予定：評価予定

  • 各DBMSとも、日本語版にのみ対応しています。

  • その他の言語バージョンのDBMS製品については、DBMSベンダーが日本語版OS上で日本語データの動作保証をしている場合に限り、サポート対象となります。

Magic uniPaaS V1Plus サポートOS一覧表

Windows Version | uniPaaS Studio uniPaaS Client | uniPaaS Enterprise Server uniPaaS RichClient Server
XP Professional(SP3以上) | ○ | ×
Server 2003 (Standard, Enterprise) | ○ | ○
Vista（Business/Enterprise/Ultimate） | ○ | ×
Server 2008(Standerd/Enterprise) | ○ | ○(x64)
7 （Professional/Ultimate) | ○(x64) | ×
Server 2008R2(Standerd/Enterprise) | × | ○(x64)

凡例 … ○： 動作確認済、△： 制限あり、× ： 動作保証対象外、予定： 評価予定

  • x86 (32bits) アーキテクチャのみサポートしています。Windows Server 2008、Windows7のみ64ビットOSをサポートします。

  • 日本語版の Windows 製品にのみ対応しています。その他の言語バージョンでは、動作保証されていません。

  • Windows 7を使用した場合の現在把握している制限事項等は、以下のリンク先を参照してください。最新情報は、MSJのWebサイトで公開する予定です。

WindowsVista/7利用時の注意事項

Windows Server 2008利用時の注意事項

その他のソフトウェア要件

用途 | ソフトウェア | 対応バージョン
バージョン管理用 | Microsoft Team Foundation Server | TFS2010
 | Microsoft Visual Sourcesafe | 6.0dSP6、2005
 | CVSNT | 2.0.58d
 | Jalindi Igloo | 1.03
リッチクライアント実行用 | Internet Explorer | 7、8
 | .Net Framework CLR | 2.0.50727.0以上
リッチクライアント実行用 （モバイル） | Windows Mobile | 6.x
 | .Net Compact Framework CLR | 2.0
 | OpenNETCF | 2.2
Webサービス | SOA Enablement Server for Java | 6.6
 | JDK/JRE | 1.6

  • リッチクライアントアプリケーションをクライアントにインストールする（最初に実行させる）場合のみ、Internet Explorerが必要です。

  • モバイルリッチクライアントは、実行させるモバイル端末によって制限事項が発生する場合があります。確認した端末に関する情報は、MSJのHPに随時掲載する予定です。

  • ブラウザクライアント機能は、サポート対象外です。

  • CVSは、バンドルされているバージョン'(CVSNT 2.0.58d) のみをサポートしています。他のバージョンについてはサポート対象外となります。

  • CVSNTの利用にあたっては、添付のオンラインドキュメント「CVSを使ったバージョン管理」に設定や注意事項等の説明がありますので、CVSを使ってバージョンコントロールを行う場合には、必ず良く読んでください。

  • チーム開発やバージョン管理を行う場合は、Microsoft Team Foundation Server をご利用を推奨します。

  • TFS2010を使用する場合は、クライアント側のPCに”Visual Studio チームエクスプローラ 2010”と"Team Foundation Server MSSCCI Provider 2010"をインストールする必要があります。

  • Microsoft Visual Sourcesafe の6.0d SP6 は、以下からダウンロードできます。

http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja


ソフトウェアメンテナンス

ソフトウェア・メンテナンスについて

uniPaaS Enterprise Server V1Plus／uniPaaS RichClient Server V1Plusは、ソフトウェア・メンテナンス対象製品となっており、ライセンスによりソフトウェア・メンテナンス終了日が管理されています。

メンテナンス終了日を過ぎた場合の動作

Magic uniPaaS V1Plusのモジュール作成日付が、使用ライセンスのメンテナンス終了日を過ぎている場合は、アップグレード時にインストーラによって、あるいは、実行時に実行モジュールによってメンテナンス終了日のチェックを行います。以下にそれぞれのケースについて説明します。

アップグレード時

インストーラは、事前に使用されているライセンス情報をチェックします。メンテナンス終了日を過ぎている場合には、インストーラはライセンスの確認ダイアログを表示します。

ライセンスサーバのアドレスを確認の上、表示されているアドレス以外のライセンスサーバを使用している場合は、修正し、[次へ]をクリックしてください（表示内容に間違いがない場合は、[キャンセル]をクリックして終了した後、ライセンス内容を確認してください）。

再度ライセンスのチェックを行います。ここでメンテナンス終了日が超過していることが確認できた場合、以下の警告メッセージを表示してアップグレード処理を終了します

ファイアウォールがインストールされている場合、ライセンスサーバへのアクセスができない場合があります。「ファイアウォールが実行されている場合の対応」を参考にして、事前にファイアウォールでライセンスサーバを許可するように設定してください。

Magic uniPaaS実行時

メンテナンス終了日を過ぎたライセンスを使用すると、Magic uniPaaS起動時にエラーになります。

対応方法

使用しているライセンスのメンテナンス終了日の確認方法

インストーラは使用しているライセンスのメンテナンス終了日をチエックしますが、以下の方法でインストール前に確認することが可能です。

がインストールされているPCのC:\FlexLMのLicense.datをテキストエディタで開きます。uniPaaS Enterprise ServerおよびuniPaaS RichClient Serverのスタートメニューから｢ライセンスサーバ→ライセンスファイルの表示｣を選択しても表示されます。

以下の例のような赤字の部分を確認してください。

SERVER ServerName 12ab34cd56ef TCP:744
DAEMON MAGIC C:\FlexLM\LMG.EXE

FEATURE MGENT1P1 MAGIC 1.800 01-jan-0 10 1234567890ABCDEF123 \
VENDOR_STRING=PT=MGENT1,C=3FFFFFF,P=S,M=0,SSL=Y,MED=30-apr-2009,BC=1234567890ABCDEF123 \
OVERDRAFT=0 DUP_GROUP=NONE ISSUER=evaluation ck=211 SN=190000001

  • ライセンス名（FEATURE XXXXXXX）

    • MGENT1P1 …… uniPaaS Enterprise Server

    • MGRIA1P1 …… uniPaaS RichClient Server

    • MGMBL1P1 …… uniPaaS RichClient Server for Mobile

  • メンテナンス終了日（MED=dd-mmm-yyyy）

上記の例では、Magic Enterprise Serverのライセンスで、メンテナンス終了日が2009年4月30日になっています。

使用しているライセンスのメンテナンス終了日が過ぎている場合

ソフトウェア・メンテナンス契約を更新している場合は、UDCを使用してライセンスコードの再発行を行ってください。新しいライセンスを取得したら、現在のライセンスを一旦削除した上で、再度登録し直してください。

ソフトウェア・メンテナンスの更新手続き、ライセンス発行は、サイト単位に設定しているサイト管理者が行います。

ソフトウェア・メンテナンスの更新手続きを行っていない場合は、更新手続きが必要です。更新手続は、Magic uniPaaSの購入元、又は最寄の営業所にご確認ください。

新規インストールの場合

インストール時には、ライセンス情報のチェックは行われません。

メンテナンス終了日は事前に発行されたライセンス情報で、Magic uiPaaSのモジュール作成日付はインストーラの起動時に確認することができます。

ファイアウォールが実行されている場合の対応

ライセンスサーバ用PC やクライアントPC 側でファイアウォールが実行されている場合、ライセンス情報のパケットが遮断される可能性があります。このような場合の対処方法は、以下のようになります。

ベンダデーモンのポート番号を指定する

ライセンスファイルの２行目にベンダデーモンのTCP のポート番号を指定します。OSが使用していない番号を指定してください。

例：この例では、2100 番をベンダデーモンのポート番号として指定しています。

SERVER ServerName ANY TCP:744
DAEMON MAGIC C:\FlexLM\LMG.EXE PORT=2100

ファイアウォール側でポートを許可する

ファイアウォール側で以下のポート番号を許可するように設定します。

  • ライセンスサーバのポート番号：デフォルトは、744 です。

  • ベンダデーモンのポート番号：上記の例では、2100 になります。


Magic uniPaaS V１Plus FAQ

製品に関するFAQ

お問い合わせの多い質問に対する 回答を列挙いたしました。
これ以外にも、MSJのHPには、Magic uniPaaSに関するFAQが掲載されています。

Q

uniPaaS Client V1Plus－ライセンスサーバを使用しますか？

A

使用しません。
これにより、以下のようなメリットがあります。

  • 事前ユーザ登録が不要（ユーザ登録が無くても使用可能）

  • ライセンスサーバのPCが不要

  • ホストIDが不要になり、導入時、システム変更時の作業負荷の低減

Q

uniPaaS Client V1Plus－起動してまもなくして「使用ユーザ数の上限を超えました。」のメッセージが表示されます。

A

Magic uniPaaS V1Plusでは、ライセンスサーバを使用しなくなったため、ライセンスのチエックに時間が掛かるようになりました。 起動後、約20秒後に使用ユーザ数の上限を超えている場合は、上記のメッセージを表示します。　その後、約1分後にMagic uniPaaS は終了します。

従って、同時アクセスユーザ構成の場合は、以下のような考慮が必要です。

  • 運用での回避：
    エラーダイアログが表示されたら、即時に入力作業を終了しMagic uniPaaSを終了するようにする。

  • アプリケーションでの対応：
    アプリケーション側でログインしているユーザ数とMagicライセンス数をチエックし、超えている場合はエラーメッセージを表示し終了するようにする。

  • インストールベースライセンスにする：
    クライアント台数分のライセンスをご購入となります。

Q

仮想環境上での使用は、サポートされていますか？　その場合ライセンスはどうなりますか？

A

仮想環境（Hyper-V、VMWare など）上で、Magic uniPaaSは実環境同様に動作しますが、仮想環境での動作を保証するものではありません。 仮想環境固有の問題についてはサポートできません。

サポートセンターにおいては、Hyper-V、VMWareの仮想化環境を用意しており、仮想化環境上で実行しているuniPaaS製品についての質問も受け付けますが、仮想環境上の固有な問題であると判明した場合には、それ以上の原因・対策の追求、HotFix等のご提供等の対応が出来ない場合があります。

またMagic uniPaaS製品は、他社のDBMS製品を通してデータにアクセスしているので、ご利用になるDBMS製品が仮想環境で動作保証されていることが前提となります。仮想環境における動作保証については、各DBMSベンダー様にご確認ください。

仮想化環境に固有な問題になる可能性があるものとしては、以下のようなものが考えられます。

  • サーバ製品でライセンスサーバも動作させる場合、HOST-IDも仮想化されるため、特別なライセンスを発行する必要がある可能性もあります。ライセンスサーバは仮想環境ではなく、実サーバにインストールすることをお勧めします。

  • 仮想化ソフトウェアの高可用性・負荷分散機能等を利用する場合、実ハードウェアでは想定されないような環境的変化がある場合があり、uniPaaSの動作に影響を与える可能性があります。

  • 仮想化ソフトウェア上でサーバ製品をフェイルオーバー構成で使用する場合、別途スタンバイライセンスが必要になります。

  • ライセンスの詳細に関しては、最寄の営業所か、Webからお問合せください。

Q

MetaFrameやWindowsターミナルサーバ上でMagic uniPaaSを使用した場合正常に動作しない場合があります。

A

MetaFrameやWindowsターミナルサーバ上でMagic uniPaaSを使用する場合は、いくつかの注意事項があります。詳細は、http://esupp.magicsoftware.co.jp/TechInfoDoc/Q2001615.htmを参照してください。

Q

Windows VistaやWindows 2008を使用したときにDB関数やIO関数が正しく動作しない場合があります。

A

VistaおよびWin2008において採用されたSMBv2プロトコルの影響と思われます。Magicを使用しない環境において、サーバ側に作成した直後のファイルをクライアント側からdirコマンドを実行したときにもファイルの存在が確認できないことがあります。

そのため、Pervasive SQLファイルのように物理的にファイルを作成するDBMSにおいてこのような現象が発生することがあります。

以下のような回避方法をご検討願います。

  • ワークファイルなどは、クライアント側に作成する。

  • DBDel関数でファイルを削除せず、バッチタスクの削除モードでレコードのみを削除する。

  • IOExist関数を繰り返し実行して、「True」が返されてから、次の処理を実行する。


修正履歴

ここでは、Magic uniPaaS V1Plusの修正履歴を説明します。

本バージョンでの修正内容

バージョン | 新機能 | 改善内容 | 動作変更 | 留意・制限事項
Ver1.9g2 |  |  |  |
Ver1.9gPT1 |  |  |  |
Ver1.9g |  |  |  |
Ver1.8JSP1c |  |  |  |
Ver1.8JSP1bPT2 |  |  |  |
Ver1.8JSP1bPT1 |  |  |  |
Ver1.8JSP1b |  |  |  |
Ver1.8JSPaPT1 |  |  |  |
Ver1.8JSP1a |  |  |  |


uniPaaS V1Plus 1.9g2での改善内容

Magic uniPaaS Ver1.9g2での改善内容

ここでは、Magic uniPaaS Ver1.9g2での改善内容を掲載します。

リッチクライアント

QCJ# | 内容
2001794 | サブフォームから別のサブタスクをコールしてから、そのタスクをクローズしてレコードを登録すると、インデックス重複が発生することがある問題
2001795 | モバイルのリッチクライアントタスクで、非インタラクティブタスクであっても、ウィンドウが表示される問題
2001809 | サブフォームから別のサブタスクをコールしてから、そのタスクをクローズしてキャンセルを実行すると、「レコードが失われていました」というエラーが発生することがある問題
2001812 | サブフォームから別のサブタスクをコールしてから、そのタスクをクローズしてロールバックを実行しても、レコードが作成されることがある問題
2001814 | テーブル上のレコードを移動すると、変数で位置付けしたリンクが正しく評価されないことがある問題
2001833 | [テーブル]コントロールのカラムの[パーキング可]を式で制御した場合、式がFALSEに変更された後、そのカラムの次レコードにパーキングされないことがある問題
2001834 | ［レコード後］で更新された項目をサブフォームのパラメータに設定した場合、その値が正しく登録されない問題
2001836 | コール先のフォームの高さを式で定義した場合、２回目以降ウィンドウをオープンすると、指定したサイズより小さいサイズで表示される問題
2001840 | リストボックスで任意の項目を選択してから左右矢印キーを押下すると、選択肢が外れるか、クライアントが異常終了することがある問題
2001844 | フレームを使用したプログラムで、実行されたコマンドがアクティビティモニタに記録されなくなることがある問題
2001846 | [チェックボックス]をクリックした後で、コントロール検証による［エラー］処理コマンドが実行されても、チェックがキャンセルされない問題
2001850 | [タスク特性／実行モード]に変数を設定した場合、イベントテーブルでその変数を変更しても、正しく動作しないことがある問題
2001856 | [強制終了]を「レコード更新時」に設定したユーザイベント内で行作成を行った後、キャンセルを実行すると「レコードは失われていました」のエラーが表示されることがある問題
2001861 | フレームを使用したプログラムの中で、［テーブル］コントロールのスクロールバーの領域にマウスカーソルをおいてコンテキストメニューを表示すると、異常終了することがある問題
2001869 | ［並行実行］特性が「Yes」のプログラムから、[テーブル]コントロールのカラムに可視パラメータを設定したプログラムをコールすると、画面が表示されるまでに時間がかかることがある問題
2001871 | [テーブル]コントロール上のコンボボックスのドロップダウンリストにスクロールバーが表示されることがある問題
2001889 | [テーブル]コントロール上のコンボボックスでキーボードで項目を選択した後、カーソルを移動すると選択した項目がクリアされることがある問題
2001890 | フレームを使用したプログラムでフォーム側に[テーブル]コントロールを表示した場合、インクリメンタルサーチを実行すると異常終了することがある問題
2001894 | 文字列の比較処理をクライアント側で実行すると、正しく評価されないことがある問題
2001899 | サブフォームで親タスクの変数を更新した後、キャンセルを実行すると「レコードが失われていました」のエラーが発生することがある問題
2001900 | サブタスクでキャンセルを実行しても［コントロール検証］が実行されない問題

フォーム

QCJ# | 内容
2001852 | マージ処理において、テンプレートファイルが25KB以上で、<!$MGINCLUDE>のマージタグを含む場合、余分なコードが入ることがある問題
2001870 | コンボボックスの［選択項目リスト］を設定し、［選択表示リスト］を設定しない場合、実行時に初期値の選択肢が表示されないことがある問題
2001887 | クラス1以上のフォームで、平面の［テーブル］コントロールに背景色を設定しても、テーブルのタイトル文字に背景色が表示されない問題

MRB/リクエスタ

QCJ# | 内容
952687 | ネットワークの回線状況によってリクエストがリトライされた場合、不定期にスレッド数がダブルカウントされることがある問題

Studio

QCJ# | 内容
2001875 | 長い式に対して、クロスリファレンスを実行すると、異常終了することがある問題
2001895 | プロジェクト名にスペースが含まれている場合、リッチクライアントインタフェースビルダで作成された公開ページ、マニフェストファイル名のスペースがアンダースコアに置き換わる問題 以下のファイルが存在する場合、前回の設定が有効にあるため、予め削除するようにしてください。 \Builders\RC\RC_metadata

DBMS

QCR# | DBMS | 内容
2001854 | Pervasive SQL | NUMERIC型のカラムをString Numberで取得すると、前のレコードの値が残って不正な値になる問題
2001901 | Oracle | Oracle のセッションを切断した後で再接続できないことがある問題

印刷処理

QCJ# | 内容
2001845 | ［入出力ファイル］テーブルの「プリンタ」欄が全角5文字以上の場合、"［プリンタ］テーブルが定義されていません。"のエラーになる問題
2001862 | [フォーム]特性の[フォーム拡大] を「O:1ページ」または「M:複数ページ」に設定したGUI形式フォームに、複数行編集可のエディットコントロールを定義した場合、実行時に異常終了することがある問題
2001874 | ［設定/動作環境/動作設定］の［印刷中断許可］のデフォルト値を「No」に変更
2001882 | 作業フォルダをインストールフォルダ以外にして起動した場合、印刷プレビューのメニューが英語表記になる問題

テキスト印刷ユーティリティ

QCR# | 内容
2001873 | テキスト形式印刷で、印字モード変更ユーティリティ(SETPRUPR.SETPR_UPR)を１ページ内に複数回実行した場合、２回目以降の変更が反映されない問題
2001885 | 特定の環境でファイル出力ユーティリティ(WPRW.exe)を実行した場合、［印刷］ダイアログをオープンしたり、Acrobatなどでファイルの出力先のダイアログをオープンさせてから、操作を中止すると、ファイル出力ユーティリティがフリーズすることがある問題
2001892 | ファイル出力ユーティリティで、パラメータ（印字モード）を指定しても、無効になる場合がある問題


uniPaaS V1Plus 1.9g PT1での改善内容

Magic uniPaaS Ver1.9g(PT1)での改善内容

ここでは、Magic uniPaaS Ver1.9g(PT1)での改善内容を掲載します。

リッチクライアント

QCR# | 内容
2001712 | 登録モードで実行した場合、パーキング条件が設定されていると、キャンセル時に前の行の値がクリアされることがある問題
2001730 | 数値型の［カラム特性/範囲]において最小値と最大値をハイフンでつなげて指定した場合、範囲の数値の後に文字があると、数値入力時にエラーになる問題
2001744 | ［タスク後］においてVecGet()関数を実行した場合、VecSet()関数で値を設定していないセルで、2番目以降のセルの値がセルモデルのデフォルト値にならない問題
2001788 | フォーム状態情報の保存先が正しくない問題
2001797 | [コントロール特性/色］欄の式で「0」を指定すると、ビープ音がなることがある問題
2001798 | リッチクライアントを起動すると、デスクトップ上にログファイル（uniRC_YYYY_MM_DD.log）が作成される問題
2001804 | ［非表示で再表示］特性が「No」に設定されたサブフォームがネストしていると、位置特性が正しく計算されない問題
2001815 | 並行実行のプログラムをコールした場合、コール元のプログラムが、「コンテキストタイムアウト」ではなく、「アンロードタイムアウト」の設定時間でタイムアウトになる問題
2001816 | サブフォームのテーブルに[可視]パラメータを設定したカラムが多数ある場合、実行時に入力するまでに時間がかかる問題
2001821 | ［タブ］コントロールの初期値を先頭の値以外に設定している場合、プログラム起動直後にそのタブをクリックすると、先頭のタブが選択される問題
2001822 | 複数行編集の垂直スクロールバーが「No」でも、垂直スクロールバーが「Yes」のエディットコントロールにパーキングした後、スクロールバーが表示される問題
2001826 | RichClient ServerにセットアップされたRIAビルダを実行してもマニフェストが正しく作成できない問題
2001827 | エディットコントロールの範囲にスペースを含むマスク文字があると、スペースが正しく入力できない問題
2001828 | タブコントロール上のテーブルの位置が、開発時のフォームエディタでレイアウトした時と実行した時で異なる問題
2001835 | リッチクライアントタスク実行中、クライアントとサーバ間の通信のセキュリティ向上

開発機能

QCR# | 内容
2001800 | ［データビュー］エディタ上で変数のモデル欄を何度もクリックすると異常終了する問題

実行機能

QCR# | 内容
2001785 | 入出力ファイルの使用する文字セットがUnicodeの場合、テキスト入力できないことがある問題
2001786 | メールヘッダにDKIM（DomainKeys Identified Mail）の情報があると、MailMsgFile() 関数の実行で異常終了する問題
2001830 | Stat(0,...)関数と文字項目を組み合わせた式が、自身のタスクモードを正しく返さないことがある問題

ユーティリティ

QCR# | 内容
2001803 | 変換ユーティリティ（V9converter.exe）を使用すると定義式にあるリテラル（DATE、TIME、LOGなど）が削除される問題
2001808 | 変換ユーティリティ（V9converter.exe）を使用で日本語固有関数が変換されない問題
 | ユーザ機能コンポーネント（UserFunctionality）で、英語の表記が残っている問題


uniPaaS 1.9g PT1での新機能

Magic uniPaaS Ver1.9g(PT1)での新機能

Magic for IBM i クライアントゲートウェイ

uniPaaS V1 Plus Ver1.9g に対応したMagic for IBM i クライアントゲートウェイを提供します。uniPaaS V1Plus Ver1.8xと同等の機能です。

DDL Maker

Magic uniPaaS で作成したBtrieve ファイルを、SQLテーブルとしてアクセスできるようにするためのユーティリティを提供します。詳細は、DDLMakerフォルダ内の DDLMakerGuide.pdf をご覧ください。


uniPaaS 1.9gでの新機能

Magic uniPaaS Ver1.9gでの新機能

開発機能

［データソース］テーブル（Ctrl+D）

（Magic eDeveloper V9と同じように）タスクが使用する全てのデータソースを表示する管理テーブルが追加されました。
このテーブルには、チョイスコントロールに定義されたデータソースも表示されます。
タスクを開いている状態で、プルダウンメニュー（タスク環境／データソース）またはCtrl+Dショートカットによってアクセスすることができます。

アクティビティモニタの改善

アクティビティモニタの画面は、複数のカラムを持つテーブル表示になりました。このデータをXMLファイルとして保存することができます。
この変更によって動作に関する詳細情報に加え、より簡単な動作フローを監視することができます。

モデル

［データビューの一部］特性が、項目モデルに追加され、モデルレベルで定義することでタスクに継承されるようになりました。

コメント機能の拡張

オブジェクトに定義されたコメントの内容を［タスク］エディタの下部の［説明］欄に表示できるようになりました。/*～*/で囲まれたコメントが表示されますが、定義用の文字をMAGIC.INIの[MAGIC_ENV]セクションで変更することもできます。

例えば以下のように定義すると、/J ～ J/ で囲まれたコメントが表示対象となります。

ShortDescriptionChar=J

この機能を利用することで、コメントとして登録された内容の表示を切り替えることができます。

コンポーネントアプリケーションの［アプリケーション特性］の［コンポーネントとしてコメントを公開］をチェックすることで、ホストアプリケーション側でコンポーネント側のコメントを表示することができます。

ソース管理

ソース・コントロール機能

現在のソースコントロール機能（すべてのファイルがローカルにコピーされる方法）に加えて、新しいソースコントロール機能が追加されました。これは、共有する場所 （シャドウフォルダ）から、 チェックアウトしたオブジェクトのみをローカルにコピーする方法です。オブジェクトをチェックインすると、ローカル上のファイルはシャドウフォルダ側に移動します。
この機能を使用するには、ソースコントロール・サーバはシャドウフォルダをサポートしなければなりません、そして、プロジェクトの作成時または、サーバからプロジェクトを 開く場合にMagic uniPaaS上でシャドウフォルダを指定する必要があります。

詳細は、リファレンスヘルプを参照してください。

Team Foundation Serverは、シャドウフォルダをサポートしていません。

ソース・コントロールの変更セットをサポート

変更セット（ChangeSet）がサポートされたソース管理サーバ（例：MicrosoftのTeam Foundation Server）を使用して複数のオブジェクトに対してチェックインを行った場合、一つの処理コマンドでソース管理サーバにオブジェクトをロードさせることができます。Team Exploreを使用してプロジェクトに接続することで、オブジェクトのSource Controlのプロパティで、プロジェクト内のどのファイルがチェックインされたかを確認することができます。

Visual Studio Souce Safeは、変更セットをサポートしていません。

バージョン管理のコメントダイアログ

Magic uniPaaSのバージョン管理用コメントダイアログを表示させるかどうかを指定するフラグが[MAGIC_SPECIALS]セクションに追加されました。

ダイアログを表示させない場合は、以下のように設定します。

SpecialShowCheckOutScreen=N

SpecialShowCheckInScreen=N

バージョン管理プロバイダによっては、コメント入力が必要であり、独自のダイアログが表示されない場合があります。このような場合は、この設定を使用しないでください。

例：Visual Studio Souce Safe 6.0の場合は、「SpecialShowCheckInScreen」が利用できません。

実行機能

範囲、位置付、ソートの指定用コンポーネント

新しく追加された、範囲/位置付用関数を使用するためのコンポーネント（ソースファイル付き）を利用することができます。このコンポーネントは、範囲/位置付/ソート処理を行うためのMagicのデフォルトの組み込み機能を置き換えることができます。
コンポーネントは、オンラインタスクとリッチクライアントタスクの両方のインタフェースがあります。
これにより、リッチクライアントタスクの［タスク特性］で［位置付］､［範囲］､［ソート］の各特性が有効になりました。

詳細は、リファレンスヘルプを参照してください。

カラムクリック：新しいイベント

［カラムクリック］という内部イベントが追加されました。このイベントは、カラムのクリックをとらえ、ユーザがカラムヘッダをクリックした場合に、実行されるロジックを定義することができます。

ドラッグ＆ドロップ：複数ファイル

編集フィールドに複数のファイルをドラッグした場合、ファイル名の間のセパレータ文字は、カンマの代わりにパイプ（|）に変わりました。これによって、ファイル名にカンマが含まれている場合でも正しく処理できるようになりました。

新しい関数

範囲、位置付、ソートの動的指定

以下の関数は、範囲指定や位置付け、ソートを動的に行うために追加されました。
RangeAdd()、RangeReset()、LocateAdd()、LocateReset()、SortAdd()、SortReset()。
これらの関数を使用すると、新しい範囲/位置付/ソートの基準がメモリに保存され、［ビュー再表示］イベントによって実行されます。
この関数を使用したコンポーネントプログラムを利用することで、範囲/位置付/ソートのユーザインターフェースをより使いやすいものにすることができます。

TaskTypeGet()

タスクタイプを返す新しい関数が追加されました。
この関数は、オンライン、バッチまたはリッチクライアント・タスクで利用できます。

TaskInstance()

タスクのインスタンスIDを返す新しい関数が追加されました。
タスクインスタンスは、現在の実行中のタスクに対する独特のIDです。タスクが再起動されると、新しいインスタンスIDを持ちます。
この関数によって、タスクインスタンス毎に永続データを保存することができます。

RqHttpStatusCode()

HTTPレスポンスを制御することができます。
この関数を使用することで、例えば、Webページが移動したことを知らせる「301 Moved Permanently」を返すことができます。

HTTPCall()

HTTPメソッドを実行させることができます。HTTPGet/HTTPPost関数を使用しているプログラムは、今後こちらの関数を使用することを推奨します。
Get/Put/Post/Deleteメソッドのみ動作します。

拡張された関数

DBViewSize()関数

［ビュー事前読込］特性が「No」の場合、DBViewSize()関数は、0を返すようになりました。

旧バージョンでは、フェッチされたレコード数でなく、ウィンドウ上に表示されているレコード数を返していました。

RqRtBlock()関数

新しいパラメータが追加され、エンジンにアクセスするユーザがいない場合、ブロックされたエンジンを終了させるかどうかを指定することができるようになりました。

.NET統合での改善

関数のオートコンプリート機能 が改善され、「DotNet」という文字列も対象になりました。「do」と入力して､Ctrl+Spaceを押下すると､"DotNet"がリストに表示されるようになりました。

SQL

SQLサーバー：date型とtime型

SQLServer 2008でdate型とtime型を追加することができます。

ダイレクトSQLパラメータ：データのトリミング

ダイレクトSQLステートメントに送られるパラメータをトリミングするためのパラメータが変更されました。

MAGIC.INIファイルの［MAGIC_SPECIALS］セクションで以下のように設定します。

SpecialTrimParamDSQL = Y

旧バージョンでは、［dbMAGIC］セクションのTrimParamDSQLパラメータによって行われた処理と同じ機能です。

Pervasive.SQL ゲートウェイ

Pervasive.SQL ゲートウェイ（MGPervasiveSQL.dll）がサポートされました。カスタムインストール時に選択することで追加されます。使用する場合は、リファレンスの記述を参照の上、注意して使用してください。

環境設定

フォーム状態の持続と事前定義イベント：ファイルの位置付

フォーム状態（FormsUserState_xxx.XML）と［事前定義ロジック］（PreferredEvents.XML）のデータの格納場所が変更されました。

  • 旧：‘C:\Documents and Settings\<user>\Local Settings\Application Data\MSJ’

  • 新：‘C:\Documents and Settings\<user>\Application Data\MSJ

Windows Vista/7/2008 Serverの場合は、以下のフォルダになります。

C:\Users\<user>\AppData\Roaming\MSJ\uniPaaS

コンテキスト非稼働タイムアウトのデフォルト値

［コンテキスト非稼働タイムアウト]のデフォルト値が変更され、24時間（864000）になりました。

構文チェックユーティリティの拡張

使用していない式

構文チェックで使用していない式が見つかった場合の動作を指定するオプションが、動作環境に追加されました。「S=全てスキップ」、「E=全て削除」、「O=ダイアログを開く」のどれかを指定することができます。

［動作環境］の［動作設定］タブで［未使用の式に対するチェック処理］の設定を更新することで、必要な動作を指定することができます。

結果ファイル

構文チェッカーの結果をファイルに保存することができます。

［動作環境］の［外部参照］タブで［チェック結果の出力ファイル］の設定に結果ファイルを定義することができます。

リッチクライアント

プログラム実行

アプリケーションのエントリポイントでないRIAプログラムでは、公開名を設定する必要がなくなりました。F7で実行させることも可能になりました。

動作環境

デプロイ処理を簡略化し、Webサーバの安全性を増すために、RIAModules用のエイリアスを不要にしました（新規インストールでは､作成されません）。
リッチクライアントコンポーネントビルダーは、公開用アプリケーション・フォルダ（デフォルト：PublishedApplications）にRIAモジュールとリソースをコピーします。

uniPaaS Studioのアップグレードを単純化するために、（RIAModule\Desktopにインストールされている）古いRIAモジュールは、アップデートされたファイルで上書きされます。（RIAバージョンによるサブフォルダは、なくなりました）。これによって、MAGIC.INIファイルに定義されたClientModulesPathパラメータを更新するという処理が必要なくなり、［MAGIC_RIA］セクションからパラメータが削除されました。

MDIサポート

リッチクライアント・アプリケーションでMDIがサポートされます。

MDI特性の宣言は、メインプログラムで「M=リッチクライアントMDIフレーム」を定義し、［タスク特性］の［インタフェース］タブで､［リッチクライアントMDI］のチェックボックスをクリックすることで実現されます。

リッチクライアントでMDIを使用して動作させるため情報については、リファレンスヘルプを参照してください。

タスクを自動的に閉じる

親ウィンドウをクリックすると、ウインドウを自動的に閉じるかどうか指定するオプションが追加されました。この機能は、オンラインタスクの動作との互換性を提供するものです。
［動作環境］の［動作設定］タブで［親タスクをアクティブにすると子（RC）タスクを閉じる］の設定によってこの動作を定義することができます。

子タスクが SDIフォームの場合に有効になります。

イメージの場所

［イメージの読込元］というコントロール特性が［イメージ］コントロールに追加されました。画像ファイルをサーバに置くかクライアントに置くかを指定することができます。イメージをサーバ上のファイル として参照する場合、Magic uniPaaSは自動的に画像ファイルをクライアントへ移して表示させます。これによってWebサーバでイメージを公開させたり、手動でファイルをクライアント側にコピーさせる必要がなくなります。 オンラインタスクと同じような指定方法でファイルを表示させることができます。

リソースの場所

（例えば壁紙イメージや［タブ］コントロールのイメージ一覧ファイルのような）外部リソースファイルを参照するイメージ以外のオブジェクトは、サーバファイルとして評価され、Magic uniPaaSはファイルをクライアントへ自動的に転送して表示します。これによって、Webサーバでリソースを公開したり、手動でクライアント側に転送させる必要がなくなります。

RIAモジュールのアップグレード/ダウングレード

モバイル機器や、（ClickOnceを使用することなく）uniRC.exeから直接リッチクライアントアプリケーションを実行するとき、サーバ側のバージョンがクライアント側のバージョンと異なる場合、クライアントマシンのリッチクライアント・モジュールは自動的にアップデートされます。

親のウィンドウ上でのタスクの実行

［コール］処理コマンドを使用してサブフォーム上でプログラム/タスクを実行する機能が拡張されました。親タスクや別プログラムのフォーム上に定義されたサブフォームを指定することができるようになりました。

永続的なフォームステータスのサポート

永続的なフォームステータスが、リッチクライアント・アプリケーションに対してサポートされます。
この動作は、［フォーム特性］の[フォーム状態の維持]特性で定義します。
FormStateClear()関数も、リッチクライアントでサポートされます。

インクリメンタルサーチのサポート

インクリメンタルサーチ（照会モード位置付）がリッチクライアント・タスクでサポートされます。

プッシュボタンの整列指定

[水平整列]と[垂直整列]の各特性が、リッチクライアントの［プッシュボタン］コントロールでサポートされます。

サーバ側のデバッガのサポート

デバッガ機能は、リッチクライアント・タスクでサーバ側の処理コマンドをサポートします。

ClientFileOpenDlg()とClientFileSaveDlg()関数

ClientFileOpenDlg()とClientFileSaveDlg()関数が拡張され、初期ディレクトリのパラメータに"パス名+ファイル名"を 指定した場合、そのファイルが表示されるようになります。

ニュートラル関数

以下の関数は、ニュートラル関数として変更されました。（1.8では、サーバ関数）
DbViewSize()、DbViewRowIdx()、INIGet()､INIPut()､ProjectDir()、Term()、User()

クライアント関数

以下の関数は、クライアント側の関数としてサポートされるようになりました。
CtrlHWND()とWinHWND()。

ファイル転送

ServerFileToClient()とClientFileToServer()という2つの関数が追加されました。これによってクライアント・マシンとサーバ・マシンの間に簡単にファイルを転送することができます。

エラー画面のカスタマイズ

エラーのメッセージボックスをカスタマイズするために､Mgreq.iniのDefErrorというキーワードをリッチクライアントでも使用することができるようになりました。リッチクライアントでは、htmlファイルのみ使用できます。また、マージ機能は利用できません。

ドラッグ&ドロップ

ドラッグ&ドロップ機能がリッチクライアントフォームの［エディット］コントロールのみでサポートされます。

データ出力のサポート

オンライン機能に組み込まれているデータ出力ユーティリティがリッチクライアントでも使用できるようになりました。
リッチクライアントプログラムからエンドユーザがこのコンポーネントを呼び出すことができます。

詳細は、リファレンスヘルプを参照してください。

HTTPリクエスト経由でのCookies渡し

HTTPリクエストを通してクライアントからCookieを渡すことができます。公開用HTMLファイル内で必要なCookieを定義することでこの機能を利用することができるようになりました。

詳細は、リファレンスヘルプを参照してください。

バックグラウンド・エンジン：パスワード入力

Input password=Yes､DeploymentMode=Backgroundとして定義されるMagic Studioからプログラムを実行すると、実行エンジンはMagic Studioでのユーザー名とパスワードを使用し、［ログオン］ダイアログをオープンしません。

RIAの通信データの圧縮

リッチクライアントによって行われる通信データの圧縮レベルを指定することが出来るようになりました。

公開用WebページのXMLアイランドに赤字のように設定します。

<xml id="rcExecProps">
<properties>
<property key="protocol" val="<!$MG_Protocol>"/>
<property key="server" val="<!$MG_AppServerName>"/>
<property key="requester" val="<!$MG_ScriptsFolderRequesterName>"/>
<property key="appname" val="<!$MG_ProjectName>"/>
<property key="prgname" val="<!$MG_ProgramName>"/>
<property key="arguments" val=""/>
<property key="envvars" val="<!$MG_EnvVariablesToRead>"/>
<property key="UseWindowsXPThemes" val="<!$MG_usewinxptheme>"/>
<property key="HTTPCompressionLevel" val="Normal"/>
<property key="DisplayStatisticInformation" val="N"/>
<property key="InternalLogLevel" val=""/>

詳細は、リファレンスヘルプを参照してください。

リッチクライアントモバイル

アプリケーションの最小化

WinMinimize()関数を使用することで､そのようなタスクからでも、アプリケーションを最小することができます。これによってアプリケーションを隠し、バックグラウンド側に移すことができます。アプリケーションを再度実行するか、WinMaximize()関数を使用することで、アプリケーションを実行モードに戻すことができます。

カスタマイズ

リッチクライアントコンポーネントビルダーは､モバイル・アプリケーションのスプラッシュ画面を指定できるように拡張されました。これによって、任意の画像ファイルを指定することができます。
また、次のリソースファイルを（Visual Studio等で）手動で更新することで、アプリケーションのアイコンをカスタマイズすることもできます：Add_On\Builders\Templates\MobileResource.dll

モバイル側のキャッシュを削除しないとアイコンが反映されない場合があります。

.NET Compact Framework 3.5

リッチクライアント・モバイル用モジュールは、.NET Compact Framework 3.5上で.NETアセンブリとの連携することができるようになりました。 これらのアセンブリを利用する場合、モバイル機器に.NET Compact Framework 3.5をインストールする必要があり､リッチクライアントコンポーネントビルダーによって作成される （CF35サブフォルダ内の）V3.5用の実行パッケージを使用する必要があります。

インストール

リッチクライアントコンポーネントビルダ

リッチクライアントコンポーネントビルダは、uniPaaS Richclient Serverと追加コンポーネント（インターネットリクエスタを選択した場合）でもインストールされます。これによって、uniPaaS Studioをインストールすることなく運用サイトで実行することができます。

サンプルアプリケーション

リッチクライアント用のサンプルアプリケーション（RIA_Demo）は、データベースとしてメモリテーブルを使用するように変更されました。また、Ver1.9の新機能を利用するように変更されています。詳細は、添付ドキュメント（RIA_Demo.pdf）を参照してください。

Systinet Serverのバージョンアップ

バンドルされている Systinet Server for Java（SOA Enablement Server for Java）が Ver6.6にバージョンアップされました。JDK/JREも、1.6にアップされています。

既にSystinet Server やJDK/JREがインストール済みの場合、これに対するアップグレード処理は行われません。Magic uniPaaSのアップグレード前にアンインストールして環境変数（JAVA_HOME、WASP_HOME）を削除するか、手動でインストールスしてください。

Systinet Server for Java は、SOA Enablement Server for Java という名前に変更されました。ライセンスは、HPからWSO2に移行されています。


uniPaaS V1Plus 1.9gでの改善内容

Magic uniPaaS Ver1.9gでの改善内容

ここでは、Magic uniPaaS Ver1.9gでの改善内容を掲載します。

リッチクライアント

QCR# | 内容
198176 | 複数のタブやデータが含まれている場合に、［タブ］コントロールがちらつく場合がある題
201341 | F7による起動に時間がかかる問題
240268 | BLOB型項目をパラメータとしてサブフォームに渡した場合、サブフォームが正しく再表示されない問題
246860 | リッチクライアント・プログラムの実行時に、ビープ音がなる問題
461973 | 呼び出し側タスクの［タスク後］ロジックユニットにサーバ側の処理コマンドと実行する必要のないクライアント側の処理コマンドが定義されている場合、呼び出されたタスクの［タスク前］の最初の処理コマンドが実行されない問題
607757 | ［NULL値可］特性が「Yes」に設定され、プログラムにリンクがある場合、新規レコードを登録後に呼び出されたプログラムに渡されるパラメータはNULLになってしまう問題
709563 | ［非表示で再表示］特性が「No」に設定されたサブフォームがネストしていると、位置特性が正しく計算されない問題
709824 | 論理名が含まれるパスが定義されたイメージボタンのコントロール上にパークすると、次にパーク可能なコントロールに対する［コントロール検証］ロジックユニットが［キャンセル］イベントの発行後に実行される問題
718931 | InformationBox.Show（)メソッドを呼び出した後に例外がスローされる問題
727887 | メインプログラムに定義された式がリッチクライアント・プログラムから評価されたる場合、VarName（VarInp（0))の式が空白を返す問題
729851 | コンテナコントロールの位置特性に式が定義されている場合、コンテナ・コントロールの位置が正しく設定されない問題
730020 | Scriptsフォルダ内のMGBCL019_00ENG.xmlファイルでメッセージが更新されない問題
732129 | 呼び出されたタスクがモデルから継承されたSDIウインドウを利用している場合、［コール］処理コマンドがサーバ側ではなく混在モードとしてマークされる問題
734893 | BLOB型項目をパラメータとしてサブフォームに渡した場合、Magic uniPaaSが特定の条件で異常終了する問題
734935 | 値が呼び出されたプログラムで更新された場合、This（)関数が呼び出したプログラムの更新されたパラメータ値を表示しない問題
735737 | 別のデータ項目の書式が使用されたデータ項目の値を更新すると、Magic uniPaaSが異常終了する問題
769915 777585 | SSLを使用した場合、プロキシが定義されていても、リッチクライアント・アプリケーションは直接サーバに接続してしまう問題
773856 | ネストされたフレームを使用すると、スクロールバが表示される問題
778385 | フォーカスがサブフォーム内部にあり、プログラムにいくつかの範囲が定義されている場合、［前レコード］イベントが正しく動作しない問題
780533 | リッチクライアント準備ユーティリティを実行した後にオンラインタスクをリッチクライアントタスクに変更すると、四角形の［スタティック］モデルが」リッチクライアントタスクの［スタティック］コントロールに定義されない問題
780545 | サブフォームタスクが存在し、［更新確認］ダイアログで［キャンセル］をクリックした場合、フォーカスが親タスクに返る問題
781950 | 透過色がサポートされないコントロール（例えば［ツリー］コントロール）をで使用された場合、Magic uniPaaSがビープ音を鳴らす問題
783448 | サーバ側の処理コマンドが［コール.NET］処理コマンドの前に定義された場合、［コール.NET］処理コマンドで定義された.NETコードが実行されない問題
796041 | ［スタイル］特性が「ハイパーテキスト」に設定され、透過色が定義されたプッシュボタンが正しく表示されない問題
797821 | 呼び出されたプログラムのコントロールに定義された自動ヘルプが、親プログラムのステータスバーに表示されない問題
798850 | ［フォーム］エディタの［コントロール］パレットで［グループ］コントロールを右クリックすると、［グループ］モデルの代わりに［モデル］リポジトリに定義されている［ラベル］モデルの名前が表示される問題
799209 | ［サブフォーム］コントロールの［可視］特性が「True」に設定されている場合、［タスク前］ロジックユニットに定義されてイベントが発行されない問題
800622 | 処理場所が未定の関数とサーバ側関数が組み合わさった式が「False」と評価される問題
803146 | ［ツリー］コントロールのノードが正しい色で表示されない問題
913264 | ［ブラウザ］コントロールの［境界］特性がサポートされていないのにかかわらず指定できる問題
914216 | 関連したアセンブリが保存されたディレクトリの名前に特殊文字（ #@!$%）が含まれる場合、ユーザ定義のコントロールが表示されない問題
915924 | ［サブフォーム］コントロールの高さ（または幅）がフォームの高さ（または幅）と同じで、フォームのサイズが早く小さくすると、スクロールバーが表示される問題
926162 | ［エラー］処理コマンドが、［タブで移動］特性が「False」に設定されたコントロールに対する［コントロール検証］ロジックユニット内で使用され、Tabキーが押下された場合、エラーモードの［エラー］処理コマンドは、警告モードと同じように動作し、次のフィールドをスキップします。
926203 | ［位置］特性の少なくとも3つパラメータに式が定義された［グループ］コントロールに［エディット］コントロールを配置した場合、パークできない問題
926758 | データ項目が定義されたテーブルカラムの値が、リッチクライアントプログラムのテーブルカラムの上で［複写］イベントを呼び出した後に削除される問題
930571 | ブラウザクライアントタスクをリッチクライアントに変更した場合、［ユーザアクションXX］イベントが自動的にユーザイベントに変更されない問題
933116 | フォーム上に［リッチエディット］コントロールとして配置されたBLOB型項目を持つリッチクライアントプログラムを実行すると、エラーが表示される問題
934809 | ［動作環境で］で［小数点］の設定を‘.’から‘,’に変更すると、［位置］特性が正しく計算されない場合がある問題
938173 | VarSet（)関数が失敗した場合、VarSet（)関数の後に定義された処理コマンドが実行されない場合がある問題
941440 | イメージボタンがサブフォームプログラムに配置され、サブフォームが［タブ］コントロールに配置されている場合、6分割のイメージボタンが正しく表示されない問題
941895 | .NETのContexMenuStripオブジェクトの［MouseLeave］と［MouseUp］イベントが発行された場合、例外が発生する場合がある問題
941967 | 別のコントロールが［エラー］処理コマンドを呼び出す前に無効に設定されている場合、［エラー］処理コマンドの［OK］ボタンをクリックした後にパーク不可コントロール上にフォーカスが表示される問題
975881 | レコード位置付に失敗した場合、［タスク前］ロジックユニットで［ウェイト］特性が「No」で発行されたイベントは実行されない問題
988064 | カラムタイトルが式で定義されている場合、レコードをスクロールしても変更されない問題
988962 | Ctrl+PlusとCtrl+Minusイベントのロジックユニットが、リッチクライアントタスクで実行されない問題
991757 | サブフォーム上の最初のコントロールが不可視の場合、親タスクからサブフォームに対してCtrlGoto()関数を実行しても、サブフォーム上の次のパーク可能なコントロールにパークしない問題
991937 | サブフォームタスクの実行モードを式で定義した場合、実行時に有効にならない問題
997803 | データ項目の［範囲］特性に定義されたオプションの先頭にスペースが含まれている場合、文字型項目に対する範囲が正しく表示されない問題
998756 | ［ブラウザー］コントロールがフォーム上に配置されているとSetCrsr（)関数が動作しない問題
2001519 | リッチクライアントインターフェースビルダでアプリケーションアイコンを設定しても、有効にならない問題
2001747 | ビュー再表示を行うと、VecGet関数で取得した文字列が?に変更される問題
2001759 | サブフォームのTab順序が最初の場合、実行時にプッシュボタンを押すと、レコードレベルが終了していないのに、レコード後処理が実行されることがある問題
2001760 | ［リッチエディット］コントロールに入力されているテキストデータにフォントや色属性が設定されている場合、MSWordやWordPadにコピー＆ペーストしても、フォントや色が反映されない問題
2001769 | 'Alt+Right'キー（行末尾)を押下すると、通過する項目に対する［コントロール検証］ロジックユニットが2回実行されることがある問題

フォーム

QCR# | 内容
242762 | 親タスクのフォームが［自動タブ順序］を無効にされ、サブタスクに［RM互換］ロジックユニットが定義されている場合、コントロールの［タブ順序］がサブタスクの［フォーム］エディタにズームして入った後に変更される問題
505226 | ［テーブル］コントロールの［下辺位置］特性が「最下行まで」に設定され、フォームが最大化された場合、Magic uniPaaSが異常終了する場合がある問題
730144 | ［テーブル］コントロールの［ハイライト行のスタイル］特性が「背景とコントロール」でない場合、CtrlHWND（)関数が値を返さない問題
767224 | フォームが変更されなかった場合、［フォーム］エディタから［ESC］キーを押下された後、ロジック/データビュー/フォームの各タブにフォーカスが戻る際、時間がかかる問題
774558 | ［ウィンドウタイプ］特性で「MDIU調整」を使用した場合、条件によってMagic uniPaaSが異常終了する問題
777846 | サブタスクにパラメータを渡す処理で、渡す側と受け取る側でパラメータの書式が合っていても、構文チェックのエラーが発生する場合がある問題
780342 | サブフォームのプログラムにDB Where句が定義され、［項目変更］ロジックユニット内で［サブフォーム再表示］イベントが発行されると、Magic uniPaaSが異常終了する問題
780769 | ［複数行］特性を「Yes」に設定した［エディット］コントロールの［データ］特性の式で無効なデータ項目を設定すると、実行時にMagic uniPaaSがクラッシュする場合がある問題
916544 | ハイパーテキストボタンの［ホバー色］に透過色を設定した場合、ボタンをクリックしてテキストを変更させると前のテキストが残ってしまう問題
930456 | ［タブ］コントロールの［項目リスト］特性に呼び出されたタスクによって更新される式が定義されている場合、タブをクリックしてもフォーカスが正しく設定されない場合がある問題
932788 | フォームに指定したフォントによって、［位置］特性が正しく計算されない場合がある問題
933178 | ［タブ］コントロールのタブにサブフォームが（リンクされずに）配置されており、［可視］特性の式でサブフォームの表示を制御している場合、実行時にタブの切り替えを行うとMagic uniPaaSが異常終了する場合がある問題
934006 | プログラムに複数のサブフォームが定義されている場合、親タスクの［閉じる］ボタンをクリックしても、タスクが終了せず、キャレットが別のサブフォームのパーク可能なコントロールに移動すことがある問題。
934876 | テーブルに配置されたコントロールの背景色が透過の場合、ハイライト行の色がVer9と異なる場合がある問題
935172 | ActiveXコントロールとしてアセンブリ登録した場合、適切なコントロールでなくてもタイプライブラリのリストに表示される問題
940708 | ［タブ］コントロールの［位置］特性の値を変更した後、［フォーム］エディタを再び入ろうとすると、Magic uniPaaSが異常終了する場合がある問題
941528 | Windows立体の［タブ］コントロールにリンクされている［四角形］コントロールをリンク解除すると、Magic uniPaaSが異常終了する場合がある問題
981715 | キャレットが一方のサブフォーム上にパークしている時、別のサブフォームタスクでカラムソートを実行すると、Magic uniPaaSが異常終了する場合がある問題
986683 | ［タブ］コントロールに配置されているサブフォームが分割ウインドウのプログラム（またはサブタスク）を表示する場合、サブフォームが表示されない問題
989638 | コンボボックスにUnicode型のデータ項目がリンクされたとき、コンボボックスから特定の値を選択し、Tabキーを押下しても選択された値が正しく表示されない

関数

QCR# | 内容
719882 | KBPut（)関数が、文字『<』と『>』の間に定義されたテキストを削除してしまう問題
734301 | ファイルが添付されたメールがMagic uniPaaSから送られると、添付ファイルの印がGmailで表示されない問題
777301 | Ifステートメント内でMarkedTextGet（)関数が使用されると、戻り値としてゴミが返る場合がある問題
779696 | ［コール公開名］処理コマンドによって呼び出されたプログラムでRights（)関数が使用されている場合、2回目の実行時に間違った値が返る場合がある問題
780409 | ユーザー定義関数の［戻り値］欄でデータ項目が選択できない場合がある問題
804669 | COMHandleGet（)関数が失敗した場合、（負数ではなく）常に0が返る問題
805666 | MnuAdd（)関数がバッチタスクで実行された場合、メニューが無効表示される問題
933956 | UTF8FromANSI（)関数が、左側の空白をトリミングしてしまう問題
937879 | キャレットが分割された子ウィンドウのフィールドにパークしている場合、SetContextFocus（)関数が並行プログラム上で動作しない問題
938021 | CTXProg（)関数がオンラインプログラムで実行されると、"unknown"を返す問題
940587 | SharedValPack（)関数が小文字で作成されても、大文字の共有項目として保存される場合がある問題
942167 | User(2)関数が並行プログラムで実行された場合、値を返さない問題
994167 | DataviewVars()関数の2番目のパラメータに0以外の値が設定され、テーブルのカラム順番が実行時に変更されると、関数の戻り値が画面に表示された順番にならない問題

XML

QCR# | 内容
714140 | XMLビューを使用した場合、CDATAエントリからデータを読み込むことができない場合がある問題
778585 | XMLデータの定義取得時、名前空間を持つDecimalSimpleTypeが、数値型ではなく文字型にマッピングされてしまう場合がある問題
782577 | memoタイプの単純要素を持つXMLを処理すると、Magic uniPaaSがハングアップ状態になる場合がある問題
783779 | XMLデータソースの文字型または論理型の項目をNULLに設定してもデフォルト値が設定されてしまう問題
930192 | ［動作環境］の［3桁区切り］が‘,’、［小数点］が‘.’に設定された場合、XMLデータソースに不正な数字を書き込むことができる場合がある問題

DBMS

QCR# | DBMS | 内容
734551 |  | ［共有］特性が「読込／なし」と「書込」の各タスク間でのトランザクションの開始位置が異なる問題
785077 |  | ダイレクトSQL Where句の入力パラメータとしてデフォルト値で変数/パラメータ項目を使用すると、該当するレコードを取得できない問題
942096 | Memory | ［ソート／一時用データベース］が「Memory」に設定された場合、インデックスの一部の項目でカラムソートを実行させた後に、データビューが正しくソートされない問題
993477 | MS-SQL | SQLクエリにおいてログファイルは、%の代わりに%%を表示する問題

Studio

QCR# | 内容
516033 | 行番号が255の権利を定義しようとすると、「不正な権利」エラーが表示される問題
732071 | 複数のオブジェクト（プログラム/モデル/データソースなど)をマルチマークした状態で、［行ジャンプ］ダイアログが表示されない問題
783599 | ［デフォルトプロジェクト］と［ユーザID］を指定してuniPaaS Studioを起動した場合、uniRTE.exeが直ぐに起動されない場合がある問題
785721 | カンマが含まれる権利名を式エディタ内で使用すると、権利名が消える問題
804215 | サブタスクの［カラム特性］の変更が二度目の変更操作では反映されなくなる場合がある問題
913661 | 折りたたまれた複数のリンク定義を同時に削除できない問題
920257 | メインプログラムに定義されたデータ項目上でクロスリファレンスを実行すると、エラーメッセージが表示される場合がある問題
938085 | ［完全に一致する単語］オプションを選択してテキスト検索を行うと、式の一部にシングルクオーテーションやブラケットが含まれるものが検索できない問題
939463 | 同じ式に検索対象のテキストが2つ以上の含まれている場合、テキスト置換処理は2つのテキストまでしか行わず、3番目以降のテキストが置換されない問題
983926 | Windows VistaまたはWindows 7の環境で、［RM互換］ロジックユニットと他のロジックユニットとの間で行の移動登録を行うと、Magiuc uniPaaSが異常終了する場合がある問題
988404 | 同じデバッグポートを使用する２つのMagicエンジンを実行しようとしてもエラーが発生しない問題
992886 | 自動処理で定義取得を実行すると、ビューのすべてのフィールドが2重に取得される場合がある問題

印刷

QCR# | 内容
774744 | 透過イメージが、プリンタによっては正しく印刷されない問題
806606 | 複数行の［エディット］コントロールの［位置］特性に式が定義され、フォームの［フォーム拡大］特性が「複数ページ」に設定されていると正しく印刷されない場合がある問題
935256 | ［フォーム出力］処理コマンドの［ページ］特性を「スキップ」に設定し、フォームの［フォーム拡大］特性を「1ページ」に設定して実行した場合、2ページ以降、空白が出力される問題
937528 | ［動作環境］で［WindowsXPのテーマを使用］を「Yes」に設定し、'Windowsクラシック'以外のテーマを使用した場合、［印刷プレビュー］画面の［印刷］ボタンが無効のように表示される問題
940567 | 印刷ダイアログを表示して印刷する場合、前回のダイアログで設定された用紙サイズで出力されてしまう問題
999049 | プログラムのメインウィンドウを最小化した状態で、SDIプログラムから印刷プレビューを開くと、印刷プレビューのウインドウも最小化されて表示されない問題
2001693 | テキスト形式印刷で、印刷ドキュメント名が変更できない問題 テキスト形式印刷で、マルチインスタンスで正常に印刷できない問題

メニュー

QCR# | 内容
774043 | 親タスクでパークした状態で、［自動再表示］特性が「Yes」に設定されたサブフォームにパラメータとして送られる値を変更すると、ツールバーの［行作成］と［行削除］のアイコンが無効になる問題
779307 | ホストアプリケーションにプログラムが1つも定義されていない場合、ホストメニューから呼び出されたコンポーネントプログラムのコンテキストメニューのサブメニューが無効になる問題
916185 | MnuAdd() や MenuIdx()関数を使用して動的にメニューを追加するコンポーネントアプリケーションに17以上のメニューが定義されている場合、追加されたメニューが正しく動作しない問題
917942 | 並行プログラムが実行している時、メインプログラムに定義されているMnuCheck（)関数が動作しない問題

Webサービス

QCR# | 内容
777905 | データ項目のインデックスが2桁の場合、プログラムのエクスポートとインポートを実行すると、［コールWebサービス］処理コマンドのヘッダとして定義された項目の参照内容が変更されてしまう問題
782645 | ［RTF］コントロールとして定義されたBLOB項目にデータを貼り付け、Webサービスのパラメータとして渡すと、エラーが返される問題
803365 | ［コールWebサービスライト］処理コマンドでWSDLファイルを読み込むと、無効なXSDファイルが作成される場合がある問題
915940 | WSDLファイルにパラメータが設定され、［方向］パラメータに「In/Out」が設定され、［XSDタイプ］パラメータが「xsd:long 」の場合、Webサービスを呼び出すとエラーが表示される問題
939583 | SOAPヘッダに余分な文字（0x0a 0x20)が追加される場合がある問題
939917 | WSDLビルダーでパラメータに対するスキーマを選択すると、Magiuc uniPaaSが異常終了する場合がある問題
995393 | WSDLを使用して作成された.xsdファイルを読み込むと、String型のパラメータがBLOBとして扱われる場合がある問題
932975 | ［Webサービスライト］処理コマンドを使用して送信するSOAPヘッダのクローズタグ（</XXXX>）が2重に作成される問題

バージョン管理

QCR# | 内容
781478 | 異なるログイン名とパスワードを指定して、VSSのバージョン管理データベース内に新しいプロジェクトを作成しようとすると、エラーメッセージが表示される問題
930238 | 先頭以外のフォルダ上にパークしている状態でリポジトリのチェックアウトを実行すると、Magiuc uniPaaSが異常終了する場合がある問題

デバッガ

QCR# | 内容
735165 | ログファイル（デフォルト：mgerror.log）にメッセージが正しく記録されない場合がある問題
751140 | ［エラー］処理コマンドが「エラー」または、「復帰」モードで実行されたとき、ログに正しい書式でタイムスタンプが書き込まれない問題
783856 | 文字型項目が3,000も格納されているベクトルデータをデバッグ中、［項目］ペインでベクトル項目を展開しようとすると、Magiuc uniPaaSが異常終了する場合がある問題
805724 | エラーメッセージにパーセント（%）文字が定義され、プログラムがバックグラウンドで実行されている場合、アクティブモニターにテキストが正しく表示されない場合がある問題
909584 | コンボボックスに割り当てられたデータ項目が文字型で、［リンク項目］にUnicode型のデータ項目が定義されている場合（その逆の場合も）、構文チェッカーでエラーが表示される問題
938781 | ブレイクポイントの実行条件が「常に」から「False」に変更され、継続（F7）が押下されると実行が停止した後で、Magiuc uniPaaSが異常終了する場合がある問題
971889 | ブレークポイントが［エラー］処理コマンド上に定義されたプログラムを実行すると、Magiuc uniPaaSが異常終了する場合がある問題
994523 | Magic.iniファイルの［MAGIC_PRINTERS］セクションに追加されたエントリの内容によって、この設定を使用するプログラム上でF8（構文チェック）を実行すると、Magic uniPaaSが異常終了する場合がある問題

実行

QCR# | 内容
257744 514069 | MGINCLUDEタグが含まれているマージテンプレートを使用してマージプログラムを実行すると、Magiuc uniPaaSが異常終了する場合がある問題
713677 | NULLを返すDLLを呼び出すとMagiuc uniPaaSが異常終了する場合がある問題
722360 | ホストアプリケーションのメニューから呼び出されたコンポーネントプログラムを終了すると、Magiuc uniPaaSが異常終了する場合がある問題
726742 | Windows VistaやWindows7上でMnuCheck（)関数を使用しても、内部イベントを発行するメニューに対応するツールバーのアイコンがチェック表示されない問題
728934 | バッチプログラムに変数項目と、パラメータ項目が定義されたロジックユニットのみが定義されている場合、パラメータが渡らない問題
729839 | ［コールOSコマンド］処理コマンドの実行後にSetCrsr（)関数が正しく動作しない場合がある問題
734006 | 項目がハンドラの戻り値によって更新される場合、実項目の更新値が表示されない問題
761700 | ［エラー］処理コマンドで'%'と'n'を含んだテキストを表示させると、Magiuc uniPaaSが異常終了する場合がある問題
777712 | Datetimeフィールドの一部に対して範囲が定義され、実行時に時刻フィールドでソートが実行された場合、レコードが正しく表示されない問題
781010 | HTMLマージの出力先をBLOB項目にすると、正しく出力されない場合がある問題
781438 | １レコードしかないテーブルをスクリーンモードで表示している状態で、プログラムを登録モードで実行すると、［前行］イベントが実行されない問題
784246 | ［使用する文字セット］特性を「UTF-8」に設定した入出力ファイルから正しくテキストが読み込めない場合がある問題
784949 | コントロールの［有効］特性を式で設定すると、実行時にタブ順序が正しく計算されない場合がある問題
803912 | ［コンポーネント］リポジトリに空白行を作成すると、[ロギング]の［外部ログファイル］にファイル名が設定される問題
804476 | メインプログラムの［タスク前］から並行プログラムを呼び出すコンポーネントを読み込む場合、ホストアプリケーションの実行時にMagic uniPaaSが異常終了する場合がある問題
805604 | 親タスクのフォーム上に定義されているプッシュボタンからイベントが発行された場合、プッシュボタンの［発行元］特性が「フォーカス上のタスク」に設定されていると、ロジックユニットにパラメータが渡されない場合がある問題
922886 | ［ウィンドウサイズ変更］イベントによるロジックユニットからプログラムを呼び出すと、［フォーム状態ID］が定義されたフォームのレコードが正しく表示されない場合がある問題
935818 | 実行エンジンがバックグラウンドで実行されると、各リクエスト毎にMLS用の言語ファイルを読み込む問題
935853 | 呼び出されたプログラムのフォームサイズが呼び出しているプログラムのフォーム以上の場合、呼び出されたプログラムの［開始時の位置］特性が「親ウィンドウの中央」に設定されたフォームが正しいサイズで表示されない問題
936041 | ［ウェイト］特性が「No」に設定されたユーザイベントが［レコード前］で発行された場合、［カラムのマーキング］特性が「Yes」に設定されたカラムをクリックすると［レコード前］ロジックが複数回実行される問題
938200 | 別のオンラインプログラムがメインプログラムの［タスク後］から呼び出されるように定義された、SDIプログラムを閉じると、Magiuc uniPaaSが異常終了する場合がある問題
938203 | ［全て閉じる］イベントがメニューに定義されたバッチプログラムから発行されても、全てのウインドウが閉じない問題
938735 | 別のアプリケーションにフォーカスがある状態でモーダルウィンドウのサブタスクが起動された場合、親タスクのタスクバーアイコンをクリックすると、フォーカスが親タスクに移動する問題
939419 | uniRTE.exeのショートカットの［実行時の大きさ］を「最小化」に設定しても、通常ウインドウで起動される問題
939775 | Logon()関数を使用してログオンしたユーザ名が、並行実行のSDIプログラムのステータスバーに表示されない問題
939904 | ヘッダ内のコメント行から次のコメント行にスクロールすると、キャレットが（コメントテキストの先頭ではなく）処理コマンドの選択位置に移動する問題
941121 | 65～70MBのテキストファイルをデータベース内のBLOB項目に読み込ませると、Magiuc uniPaaSが異常終了する場合がある問題
942693 | ネストされた［ブロック］処理コマンドに「復帰」モードの［エラー］処理コマンドが定義された場合、間違った処理コマンドが実行される場合がある問題
970052 | ［カラムのマーキング］特性がタスクモードに依存するように設定された場合、カラムの色が正しく表示されない場合がある問題
983699 | MagicEnginePathパラメータに値が設定されない場合、コンポーネント用COMの呼び出しを行うとエラーが発生する問題
990172 | ［有効］特性に式が定義されているプッシュボタンが、カラムのタイトルに定義されているテーブルでレコードの位置付を行うと、エラーメッセーが表示される場合がある問題

ユーティリティ

QCR# | 内容
730193 | ［RM互換］ロジックユニットがタスクの唯一のロジックユニットの場合、［RM互換］ロジックユニット内で行の移動登録（Ctrl+Shift+M)ができない問題
732171 | mgrqcmdlを使用してリクエストを発行し、ブローカモニターの［リクエスト］ウィンドウ内のリクエストID（#）を複数回クリックすると、ブローカモニターが異常終了する場合がある問題
781381 | Unicode型項目カラムが［コンボボックス］コントロールに割り当てられている場合、データ出力実行後に間違ったデータが表示される問題
969960 | Magicインターフェースビルダで多数の要素が定義されている既存のコンポーネントにイベントを追加すると、ECIファイルに書き込まれない場合がある問題

MRB

QCR# | 内容
782266 | MRBがサービスで実行され、［ディスクトップとの対話サービスに許可］のサービス特性がチェックされていない場合、［エラー］処理コマンド実行後、Magic uniPaaSがハングアップ状態になる問題
920276 | Magicエンジンが MaxConcurrentRequestsで定義したスレッド数に達した場合、ログには -109のエラーが多数記録される問題
932270 | バックグラウンドモードで実行しているMagicエンジンがで異常終了し、エラーメッセージをすぐに閉じじなかった場合、Magicエンジンが終了しても、ブローカモニター上は"unreachable"として表示されたままになる問題


uniPaaS 1.9gでの制限事項

Magic uniPaaS Ver1.9gでの留意・制限事項

リッチクライアント

  • (2000666)[タスク特性]の[事前読込]特性が｢Yes｣に設定されたタスクで[ビュー再表示]イベントを発行すると、チャンクサイズまでのデータしか読み込みません。ビュー再表示を行うタスクは[事前読込]特性を｢No｣に設定してください。

  • (2000729)［ウィンドウタイプ］特性が「モーダル」のウィンドウではステータス行は表示されません。ステータス行のエラーメッセージはそのタスク起動元のSDIタイプのウィンドウに表示されます。

  • (2000742)子タスクからRollback('FALSE'LOG,1)を実行しても、親タスクのロールバックはできません。

  • (2000748)パラメータを渡さないサブフォームを[タブ]コントロールに配置した場合、実行時にタブを変更しても、サブフォームのデータの変更がコミットされません。

  • (2000764)[レコード後]でリンクテーブルの項目に対して加算モードの［項目更新］処理コマンドを定義すると、リンク項目の変更時の更新処理が正常に行われないことがあります。

  • (2000812)リッチクライアントで、リンクの［戻り値］特性に親タスクの論理型変数が定義されている場合、［キャンセル］イベントによって戻り値がリセットされません。

  • (2001030)サブフォームに設定したタスク(［空のデータビュー許可］特性「Yes」）のデータビューが空の状態でも、［データビューが空］イベントが発生しません。この場合、［コール］処理コマンドでタスクを呼び出すことで対応できます。

  • (2001069)リッチクライアントで、変数項目の値を別の変数項目に代入する場合、変数の値がNULLの時、変数の［NULL計算値］特性の値が代入されます。

  • (2001076)オンラインプログラムやVer10用のリッチクライアントタスクから移行した場合、［複数行編集］特性「Yes」の［エディット］コントロールの［CR許可］特性が「No」に設定されます。このため、デフォルトでは複数行編集のコントロールに改行コードが挿入できません。

  • (2001095)Acrobat 9がインストールされたクライアントPCで、［ブラウザ］コントロール上のPDFファイルを表示すると、終了時に異常終了する場合があります。

  • (2001112)［タブ］コントロール、［イメージ］コントロールの［イメージ一覧ファイル名］特性に直接BMPファイルを指定する場合、以下のフラグを設定する必要があります。

[MAGIC_SPECIALS]
SpecialConvAddSlash=N

  • (2001144)数値型項目の書式で３桁区切りが有効になっている場合、「,」を含めた桁数分まで入力が可能になります。ただし、書式の桁数を超えていると項目移動ができません。

  • (2001184)選択プログラム終了後、［項目変更］ロジックユニット内に定義されたFlow()関数の戻り値が、オンラインタスクとは異なる値が返ることがあります。

  • （2001191）プッシュボタンに対しては、XPのテーマは無効になります。

  • (2001244)リッチクライアントのキャッシュパスに自動作成される環境ファイル(ユーザフォント定義ファイル、キーボード割付ファイル、論理名テーブル)の名前は、固定で設定されます。同一サーバ上で異なる環境ファイルを使用するアプリケーションを複数実行する場合には、同一の環境ファイルをマージするか、アプリケーション毎にリッチクライアントのキャッシュパスを設定して下さい。

リッチクライアント（モバイル）

  • キーボードを「ひらがな/カタカナ」に設定すると、英数字入力へのモード変更ができません。

  • （2001445）unicode特有文字は表示できません。unicode対応フォントを別途インストールする必要があります。

  • ［サブフォーム］や［タブ］コントロールが配置された画面では、実行時にソフトキーボードを表示すると、画面がリサイズされません。

  • ［タブ］コントロールを画面サイズ一杯に配置した場合、画面を横長にすると、［タブ］コントロール上のコントロールが表示されないことがあります。

Unicode

  • (2000556)MAGIC.INIの[MAGIC_SPECIALS]SpecialAnsiExpression = Y　を設定すると、Unicode型やBLOB型（［内容］特性が「U=Unicode」）の項目に対して、Unicode特有の値を更新すると、「????..」として更新されます。

開発機能

  • プログラムの公開名にDBCSや特殊文字を使用しないことを推奨します。

  • (2000238)MS-IME2002を使用した場合、uniPaaS Studioからプログラムを実行して[アクティビティモニタ]から検索画面で2バイト文字を入力したとき、Enterキーで文字を確定しないと文字が表示されない場合があります。

  • (2000316)クラス0のフォームの編集において、［テーブル］コントロールにリンクされているコントロールをテーブルの外に移動するとリンクが外れます。

  • (2000353)V9Plusで他のプログラムとデータの受け渡しを行う変数が［リンク］コマンドより後に定義されているプログラムを移行すると、リンクの［戻り値］特性に定義された変数項目が自動的に追加されるために、正しく動作しない場合があります。

  • (2000429)［データ］リポジトリで、タイトル行にカーソルを置いてAPGを実行した時、作成モードしか選択できません。

  • (2000431)平面スタイルの［コンボボックス］コントロールの背景色は36番のアプリケーション基本色で表示されます。表示色を変更したい場合は、コンボボックスのスタイルを変更するか、36番の色を変更してください。[テーブル]コントロールの子コントロールとなるコンボボックスの場合、平面スタイルでなくても36番のアプリケーション基本色で表示されます。

  • (2000462)［スタイル］特性が「Windows立体」の［タブ］コントロール上に［テーブル］コントロールをリンクさせることができません。「凸立体」に変更することでリンクすることができます。

  • (2000520)Windows Vistaの場合、フォームの［コントロール］パレットのウィンドウ枠が透過色になるため、後ろの表示が写り込みます。

  • (2000791)文字列抽出ツールは、Unicode固有文字には対応していません。

  • (2001158)コンポーネントジェネレータは、開発ライセンスがないと実行できません。

実行機能

  • アプリケーションの実行中に、アプリケーション（ECF）ファイルを更新しないでください。更新した場合の動作は保証できません。

  • (2000103)ユーザ定義関数に2バイト文字を使用した関数を定義することはできません。

  • (2000186)［入出力ファイル］テーブルの［メディア］カラムを「V=項目」、［文字セット］特性を「UTF-8」に設定すると、格納したデータが文字化けする場合があります。

  • (2000236)［プッシュボタン］コントロールに定義された項目に対する［項目変更］ロジックユニットを設定した場合、実行時にボタンを押下してもイベントは発行されません。

  • (2000286)HTTPGet関数、またはHTTPPost関数でUTF-8のデータをBLOB型のUnicodeタイプのデータで受け取ると、2バイト文字が正しく取得できません。バイナリタイプで受け取るようにしてください。

  • (2000453)［サブフォーム］コントロールを使用して、サブフォームから親ウィンドウのコントロールをクリックした場合、TaskId()関数ではサブフォームのタスクIDが返り、HandledCtrl()関数では値が返りません。

  • (2000817)並行実行のタスクから呼び出されたプログラムによる印刷出力処理でプレビューを表示した場合、［プレビュー］ウィンドウがMagicの画面の背後で表示される場合があります。

  • (2000904)Windows Vista上でMS-IME2007を使用している場合、［エディット］コントロールの［漢字入力］特性を「5」に設定しても、"半Rカナ"が有効にならないことがあります。

  • (2001094)ATOKを使用している場合、文字パレットから全角文字を選択すると、文字化けが生じる場合があります。

  • （2001197）［フローモード］特性が「A=後置」または「B=前置」に設定している処理コマンドを、［RM互換］ロジックユニット以外では実行できません。

アプリケーションサーバ機能

  • (2000309)［フォーム出力］処理コマンドで［入出力ファイル］テーブルの［メディア］カラムに「リクエスタ」、［文字セット］特性を「Unicode」に設定し、そのプログラムを他のクライアントから［コールリモート］処理コマンドで起動すると、結果ファイルはShift_JISコードで出力されます。 ［文字セット］特性がUTF-8/Shift_JISの場合は、それぞれのコードで出力されます。

バージョン管理

  • プロジェクトのバージョン管理ソフトは、Microsoft Visual SourceSafe (6.0d、あるいは 2005)、およびCVSNTをサポートしています。PVCSはサポートしておりません。バージョン管理を使用した開発を行う前に、必ずそれぞれのオンラインマニュアルをお読みください。

  • 同じプロジェクトファイルを複数のMagicエンジンで開く場合は、必ずバージョン管理機能を使用してください。使用しない場合は、開くことができません。

  • (2000405)バージョン管理でVisual SourceSafe(VSS)を使用した場合、履歴等を実行するとVSSの画面が呼び出されますが、この画面にあるヘルプボタンをクリックするとエラーが発生し、それ以降マウス操作ができなくなります。

  • (2000881)VSS 6.0dの環境でバージョン管理を利用し、「サーバから開く」を実行すると、「No project file found in selected source control project」というエラーで、プロジェクトが選択できないことがあります。この場合、VSS6.0dをSP6にアップデートして下さい。
    SP6は、以下のURLからダウンロードできます。
    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja

Oracle

  • (2000411) RAW型のカラムタイプを定義取得するとBLOB型にマッピングされますので、適宜文字型 (記憶型式：String)に変更する必要があります。

  • (2000558) BLOB型（記憶型式：Unicode Blob）の項目の内容を全角英数字（ＡＢＣ１２３など）で更新すると、文字化けが発生します。

Pervasive SQL

  • 外部キーが定義されたテーブルを定義取得すると、インデックステーブルにキーが定義されます。

Webサービス

プロバイダアプリケーションの注意事項

  • 公開プログラム名、およびパラメータ名には英数字と _ (アンダースコア文字)のみで先頭に数字を使用できません。

  • 異なる公開プログラム間で、同じ名前で違う型のパラメータを設定すると、正しく動作しない場合があります。

  • 入力パラメータがXMLデータの場合、パラメータをBLOB型で定義し、名前はXSDスキーマのルートと同じ名前に設定してください。

  • 入出力パラメータがXMLデータの場合、設定されたXSDファイルのエレメントの順序が、Systinetのパッケージを作成した後にアルファベット順に変更されることがあります。これにより、コンシューマに提供するスキーマとあわなくなることがあるため、あらかじめXSDのエレメントの名前をV01_xxx, V02_xxxなどの接頭辞を付加することで回避してください。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面のサービスネームスペースにはデフォルトでMAGIC.INIのオーナ名が付加されます。オーナ名にスペースや . (ドット文字)が含まれる場合、デフォルトの値では jarファイルが作成できませんので適切な値に変更する必要があります。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面の「説明」に日本語の2バイト文字を入力すると、jarファイルが作成できません。

コンシューマからWebサービスコールを実行するときの注意事項

  • ［サービス］テーブルで既存のWebサービスのWSDLを再読み込みした場合には、Magicエンジンを再起動してください。さらにそのサービスを設定したWebサービスコールを再度定義しないと正しく実行できないことがあります。

  • プロバイダにXMLデータをBLOB型で渡す場合、Shift_JISのエンコードで渡してください。

その他

  • Magic eDeveloper V10がインストールされたPCにuniPaaS Studio V1をインストールした場合、どちらかをアンインストールすると MgComCreater.dll がレジストリから削除されます。このような場合は、WindowsのRegsvr32.exeを使用して残った製品のインストールフォルダ内にあるMgComCreater.dllを登録し直してください。


uniPaaS 1.8J SP1c での新機能

Magic uniPaaS Ver1.8J SP1cでの新機能

IBM i V7R1対応

IBM i V7R1に対応しました。V7R1に対応したホストライブラリが提供されています。 IBM i Gateway を使用する上での注意点は、Magic uniPaaS for IBM i 追加情報を参照してください。


uniPaaS V1PlusSP1cでの改善内容

Magic uniPaaS Ver1.8J SP1cでの改善内容

ここでは、Magic uniPaaS Ver1.8J SP1cでの改善内容を掲載します。

SP1bPT1/PT2の改善内容も反映されています。

リッチクライアント

QCJ# | 内容
2001481 | サブフォームで照会リンクを定義したタスクの実行時に、親タスク終了時にレコード後処理が実行されることがある問題
2001636 | Zen、ZenS、Han、ZKanaを他の文字列関数のパラメータに使用した場合、文字列関数が文字単位で処理される問題
2001647 | リッチエディットコントロールの日本語データをエディットコントロールに更新すると文字化けが発生する問題
2001656 | ブラウザコントロールに長い日本語ファイル名を指定すると、表示されないことがある問題
2001661 | あるテーブルの複数のレコードを更新する際、同時に別のテーブルのレコード作成、更新を行うと、処理が失敗することがある問題

実行機能

QCJ# | 内容
2000904 | Windows VistaでIME2007を使用した場合、エディットコントロールの漢字入力パラメータ=5が無効になる問題
2001544 | ウェイトYesのOSコマンドでバッチファイルを実行する場合、cmd /cを付加しないと動作しない問題
2001630 | DVal関数の第1パラメータの年月日が書式の桁数に満たない場合、戻り値に正しい日付が返らない問題
2001632 | ZenS関数で第1パラメータに直接文字を指定し、第2パラメータに2を指定した場合、戻り値が途中で切れることがある問題
2001636 | Zen、ZenS、Han、ZKanaを他の文字列関数のパラメータに使用した場合、文字列関数が文字単位で処理される問題
2001648 | タスク終了条件=「Yes」、チェック時期=「A=後置」のタスクを実行すると、キャンセルイベントでタスクが終了する問題
2001659 | Han関数のパラメータが全角カナで濁点または半濁点を含む場合、戻り値の文字列が途中で切れる問題
2001674 | CSVファイルのデータ入力で、日付データの0値が省略されている場合、正常に取り込めない問題
2001690 | MailSend関数の添付ファイル名が長い場合、異常終了することがある問題

開発機能

QCJ# | 内容
2001634 | 変数定義のないタスクから呼ばれるタスクにブレークポイントを置いてデバッグモードで実行すると、Studioが異常終了する問題
2001637 | 日付型の書式の間に空白があると異常終了することがある問題
2001672 | NULL値可=Yesのカラムモデルを、Pervasive.SQLのテーブルのカラムに設定すると、チェッカーでエラーになる問題
2001677 | 「動作環境／SSL CA 証明書ファイル」にデータのゴミが入ることがある問題
2001692 | 同じライセンスファイルを複数端末で使用した環境でのライセンスチェックが強化されました(*1)

*1 エラーが発生した場合には、次のようなメッセージが表示されます。

データベースゲートウェイ

QCJ# | DBMS | 内容
2001578 | MS SQL Server | SQLコマンド実行後、DataViewToText()関数を実すると、異常終了することがある問題
2001616 | Oracle | テーブルのカラムで'TIMESTAMP'型があると、定義取得できないことがある問題
2001655 | IBMi ISAM | OpenQueryやダイレクトSQLを使用して｢理｣や｢務｣を含む文字を検索すると抽出されない問題

インストーラ

QCJ# | 内容
 | Windows 2008 Server上でライセンスサーバのインストイールを行う際、タスクスケジューラに登録することが出来るようにしました。


uniPaaS V1PlusSP1cでの制限事項

Magic uniPaaS Ver1.8J SP1cでの留意・制限事項

リッチクライント

  • (2000666)[タスク特性]の[事前読込]特性が｢Yes｣に設定されたタスクで[ビュー再表示]イベントを発行すると、チャンクサイズまでのデータしか読み込みません。ビュー再表示を行うタスクは[事前読込]特性を｢No｣に設定してください。

  • (2000729)［ウィンドウタイプ］特性が「モーダル」のウィンドウではステータス行は表示されません。ステータス行のエラーメッセージはそのタスク起動元のSDIタイプのウィンドウに表示されます。

  • (2000742)子タスクからRollback('FALSE'LOG,1)を実行しても、親タスクのロールバックはできません。

  • (2000748)パラメータを渡さないサブフォームを[タブ]コントロールに配置した場合、実行時にタブを変更しても、サブフォームのデータの変更がコミットされません。

  • (2000764)[レコード後]でリンクテーブルの項目に対して加算モードの［項目更新］処理コマンドを定義すると、リンク項目の変更時の更新処理が正常に行われないことがあります。

  • (2000812)リッチクライアントで、リンクの［戻り値］特性に親タスクの論理型変数が定義されている場合、［キャンセル］イベントによって戻り値がリセットされません。

  • (2001030)サブフォームに設定したタスク(［空のデータビュー許可］特性「Yes」）のデータビューが空の状態でも、［データビューが空］イベントが発生しません。この場合、［コール］処理コマンドでタスクを呼び出すことで対応できます。

  • (2001069)リッチクライアントで、変数項目の値を別の変数項目に代入する場合、変数の値がNULLの時、変数の［NULL計算値］特性の値が代入されます。

  • (2001076)オンラインプログラムやVer10用のリッチクライアントタスクから移行した場合、［複数行編集］特性「Yes」の［エディット］コントロールの［CR許可］特性が「No」に設定されます。このため、デフォルトでは複数行編集のコントロールに改行コードが挿入できません。

  • (2001095)Acrobat 9がインストールされたクライアントPCで、［ブラウザ］コントロール上のPDFファイルを表示すると、終了時に異常終了する場合があります。

  • (2001112)［タブ］コントロール、［イメージ］コントロールの［イメージ一覧ファイル名］特性に直接BMPファイルを指定する場合、以下のフラグを設定する必要があります。

[MAGIC_SPECIALS]
SpecialConvAddSlash=N

  • (2001144)数値型項目の書式で３桁区切りが有効になっている場合、「,」を含めた桁数分まで入力が可能になります。ただし、書式の桁数を超えていると項目移動ができません。

  • (2001184)選択プログラム終了後、［項目変更］ロジックユニット内に定義されたFlow()関数の戻り値が、オンラインタスクとは異なる値が返ることがあります。

  • (2001191)プッシュボタンに対しては、XPのテーマは無効になります。

  • (2001244)リッチクライアントのキャッシュパスに自動作成される環境ファイル(ユーザフォント定義ファイル、キーボード割付ファイル、論理名テーブル)の名前は、固定で設定されます。同一サーバ上で異なる環境ファイルを使用するアプリケーションを複数実行する場合には、同一の環境ファイルをマージするか、アプリケーション毎にリッチクライアントのキャッシュパスを設定して下さい。

リッチクライアント（モバイル）

  • キーボードを「ひらがな/カタカナ」に設定すると、英数字入力へのモード変更ができません。

  • (2001445)unicode特有文字は表示できません。unicode対応フォントを別途インストールする必要があります。

  • ［サブフォーム］や［タブ］コントロールが配置された画面では、実行時にソフトキーボードを表示すると、画面がリサイズされません。

  • ［タブ］コントロールを画面サイズ一杯に配置した場合、画面を横長にすると、［タブ］コントロール上のコントロールが表示されないことがあります。

  • (2001527)リッチクライアントフレーム形式のフォームでは、フレームの分割線やフレーム内の画面が表示されません。

Unicode

  • (2000556)MAGIC.INIの[MAGIC_SPECIALS]SpecialAnsiExpression = Y　を設定すると、Unicode型やBLOB型（［内容］特性が「U=Unicode」）の項目に対して、Unicode特有の値を更新すると、「????..」として更新されます。

開発機能

  • プログラムの公開名にDBCSや特殊文字を使用しないことを推奨します。

  • (2000238)MS-IME2002を使用した場合、uniPaaS Studioからプログラムを実行して[アクティビティモニタ]から検索画面で2バイト文字を入力したとき、Enterキーで文字を確定しないと文字が表示されない場合があります。

  • (2000316)クラス0のフォームの編集において、［テーブル］コントロールにリンクされているコントロールをテーブルの外に移動するとリンクが外れます。

  • (2000353)V9Plusで他のプログラムとデータの受け渡しを行う変数が［リンク］コマンドより後に定義されているプログラムを移行すると、リンクの［戻り値］特性に定義された変数項目が自動的に追加されるために、正しく動作しない場合があります。

  • (2000429)［データ］リポジトリで、タイトル行にカーソルを置いてAPGを実行した時、作成モードしか選択できません。

  • (2000431)平面スタイルの［コンボボックス］コントロールの背景色は36番のアプリケーション基本色で表示されます。表示色を変更したい場合は、コンボボックスのスタイルを変更するか、36番の色を変更してください。[テーブル]コントロールの子コントロールとなるコンボボックスの場合、平面スタイルでなくても36番のアプリケーション基本色で表示されます。

  • (2000462)［スタイル］特性が「Windows立体」の［タブ］コントロール上に［テーブル］コントロールをリンクさせることができません。「凸立体」に変更することでリンクすることができます。

  • (2000520)Windows Vistaの場合、フォームの［コントロール］パレットのウィンドウ枠が透過色になるため、後ろの表示が写り込みます。

  • (2000791)文字列抽出ツールは、Unicode固有文字には対応していません。

  • (2001158)コンポーネントジェネレータは、開発ライセンスがないと実行できません。

  • (2001536) Windows 7 上でMagic Studioを起動し、動作環境の[実行モード]を変更すると、不定期にuniRTE.exeの自動起動が行えず、応答なしになることがあります。

実行機能

  • アプリケーションの実行中に、アプリケーション（ECF）ファイルを更新しないでください。更新した場合の動作は保証できません。

  • (2000103)ユーザ定義関数に2バイト文字を使用した関数を定義することはできません。

  • (2000186)［入出力ファイル］テーブルの［メディア］カラムを「V=項目」、［文字セット］特性を「UTF-8」に設定すると、格納したデータが文字化けする場合があります。

  • (2000236)［プッシュボタン］コントロールに定義された項目に対する［項目変更］ロジックユニットを設定した場合、実行時にボタンを押下してもイベントは発行されません。

  • (2000286)HTTPGet関数、またはHTTPPost関数でUTF-8のデータをBLOB型のUnicodeタイプのデータで受け取ると、2バイト文字が正しく取得できません。バイナリタイプで受け取るようにしてください。

  • (2000453)［サブフォーム］コントロールを使用して、サブフォームから親ウィンドウのコントロールをクリックした場合、TaskId()関数ではサブフォームのタスクIDが返り、HandledCtrl()関数では値が返りません。

  • (2000817)並行実行のタスクから呼び出されたプログラムによる印刷出力処理でプレビューを表示した場合、［プレビュー］ウィンドウがMagicの画面の背後で表示される場合があります。

  • (2000904)Windows Vista上でMS-IME2007を使用している場合、［エディット］コントロールの［漢字入力］特性を「5」に設定しても、"半Rカナ"が有効にならないことがあります。

  • (2001094)ATOKを使用している場合、文字パレットから全角文字を選択すると、文字化けが生じる場合があります。

  • (2001197)［フローモード］特性が「A=後置」または「B=前置」に設定している処理コマンドを、［RM互換］ロジックユニット以外では実行できません。

アプリケーションサーバ機能

  • (2000309)［フォーム出力］処理コマンドで［入出力ファイル］テーブルの［メディア］カラムに「リクエスタ」、［文字セット］特性を「Unicode」に設定し、そのプログラムを他のクライアントから［コールリモート］処理コマンドで起動すると、結果ファイルはShift_JISコードで出力されます。 ［文字セット］特性がUTF-8/Shift_JISの場合は、それぞれのコードで出力されます。

バージョン管理

  • プロジェクトのバージョン管理ソフトは、Microsoft Visual SourceSafe (6.0d、あるいは 2005)、およびCVSNTをサポートしています。PVCSはサポートしておりません。バージョン管理を使用した開発を行う前に、必ずそれぞれのオンラインマニュアルをお読みください。

  • 同じプロジェクトファイルを複数のMagicエンジンで開く場合は、必ずバージョン管理機能を使用してください。使用しない場合は、開くことができません。

  • (2000405)バージョン管理でVisual SourceSafe(VSS)を使用した場合、履歴等を実行するとVSSの画面が呼び出されますが、この画面にあるヘルプボタンをクリックするとエラーが発生し、それ以降マウス操作ができなくなります。

  • (2000881)VSS 6.0dの環境でバージョン管理を利用し、「サーバから開く」を実行すると、「No project file found in selected source control project」というエラーで、プロジェクトが選択できないことがあります。この場合、VSS6.0dをSP6にアップデートして下さい。
    SP6は、以下のURLからダウンロードできます。
    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja

Oracle

  • (2000411) RAW型のカラムタイプを定義取得するとBLOB型にマッピングされますので、適宜文字型 (記憶型式：String)に変更する必要があります。

  • (2000558) BLOB型（記憶型式：Unicode Blob）の項目の内容を全角英数字（ＡＢＣ１２３など）で更新すると、文字化けが発生します。

Webサービス

プロバイダアプリケーションの注意事項

  • 公開プログラム名、およびパラメータ名には英数字と _ (アンダースコア文字)のみで先頭に数字を使用できません。

  • 異なる公開プログラム間で、同じ名前で違う型のパラメータを設定すると、正しく動作しない場合があります。

  • 入力パラメータがXMLデータの場合、パラメータをBLOB型で定義し、名前はXSDスキーマのルートと同じ名前に設定してください。

  • 入出力パラメータがXMLデータの場合、設定されたXSDファイルのエレメントの順序が、Systinetのパッケージを作成した後にアルファベット順に変更されることがあります。これにより、コンシューマに提供するスキーマとあわなくなることがあるため、あらかじめXSDのエレメントの名前をV01_xxx, V02_xxxなどの接頭辞を付加することで回避してください。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面のサービスネームスペースにはデフォルトでMAGIC.INIのオーナ名が付加されます。オーナ名にスペースや . (ドット文字)が含まれる場合、デフォルトの値では jarファイルが作成できませんので適切な値に変更する必要があります。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面の「説明」に日本語の2バイト文字を入力すると、jarファイルが作成できません。

コンシューマからWebサービスコールを実行するときの注意事項

  • ［サービス］テーブルで既存のWebサービスのWSDLを再読み込みした場合には、Magicエンジンを再起動してください。さらにそのサービスを設定したWebサービスコールを再度定義しないと正しく実行できないことがあります。

  • プロバイダにXMLデータをBLOB型で渡す場合、Shift_JISのエンコードで渡してください。

テキスト用プリンタドライバ

  • Magic uniPaaS に添付されておいるテキスト印刷ドライバは、マルチスレッドに対応していません。

その他

  • Magic eDeveloper V10やuniPaaS Studio V1がインストールされたPCにuniPaaS Studio V1Plusをインストールした場合、どちらかをアンインストールすると MgComCreater.dll がレジストリから削除されます。このような場合は、WindowsのRegsvr32.exeを使用して残った製品のインストールフォルダ内にあるMgComCreater.dllを登録し直してください。


Magic uniPaaS V1 Plus Ver 1.8J SP1b パッチモジュール (PT1)追加情報

Magic uniPaaS Ver1.8J SP1b PT1での改善内容

ここでは、Magic uniPaaS Ver1.8J SP1b PT1での改善内容を掲載します。

リッチクライアント機能

QCJ# | 内容
2001401 | サブフォームの[自動再表示特性]を｢Yes｣に設定した場合、サブフォームの再表示と同時にフォームがクローズすると、異常終了することがある問題
2001538 | 3階層のタスクでトランザクション内部エラーが発生することがある問題
2001554 | ズームで呼び出された子タスクで、[サブフォーム再表示]イベントと、[強制終了]=｢レコード更新前｣のユーザイベントが実行されると、子タスクが１度しか実行されない問題
2001559 | ClipAdd関数とClipWrite関数で複数項目の値をクリップボードに送った場合、タブ区切りにならない問題
2001564 | MAGIC.INIに[MAGIC_SPECIALS]SpecialClientSecureMessages=Y を指定すると、実行時にクライアント側でエラーが発生することがある問題
2001571 | サブフォームで[ソート可]=｢Yes｣のカラムのタイトルをクリックしても、コントロール検証レベルが通過しない問題
2001573 | [事前読込]=｢No｣で、バッチ更新を行う子タスクを実行するプログラムで、正しくデータ更新されないことがある問題
2001590 | ログオンダイアログの日本語化
2001593 | [漢字入力]特性が設定されたエディットコントロールからコンボボックスにフォーカスが移ったとき、IMEモードが半角英数に変更されない問題
2001608 | ClientGetUniqueMachineID関数の戻り値の長さを固定長に変更

モバイルリッチクライアント機能

QCJ# | 内容
2001457 | サブフォームにカーソルを移動してソフトキーボードを開くと、コントロールがソフトキーボードの後ろに隠れる問題
2001556 | 非インタラクティブのタスクを使用している場合、ソフトウェアキーボードを開いたまま終了しようとするとハングアップすることがある問題

クライアント実行機能

QCJ# | 内容
2001194 | Microsoft Excelのセルをコピーして、エディットコントロールに貼り付けすると、データの末尾にCR/LFが入ることがある問題
2001539 | オンラインとバッチが子タスクで並列に構成されたプログラムで、トランザクションコミット時に異常終了することがある問題
2001540 | オンラインとバッチが子タスクで並列に構成されたプログラムで、オンラインで定義されないカラムがバッチで正しく更新されないことがある問題
2001541 | Oracleデータベースにアクセスし、同一トランザクションの異なったタスクでデータ作成を行うと、異常終了することがある問題
2001549 | ZKana関数の引数の末尾に半角スペースがないと、正しく実行されない問題
2001565 | オンラインタスクで画面を最大化し、レコードを最下行に位置付けてプログラムコールを行うと、異常終了することがある問題
2001569 | [事前読込]=｢No｣で、バッチ更新を行う子タスクを実行するプログラムで、正しくデータ更新されないことがある問題
2001580 | DVal関数で日付文字列が年号+空白の場合、｢1989/01/01｣に変換される問題
2001581 | FileInfo関数でファイルの更新日付を取得した際、更新時刻が午前9時より前の場合、前日の日付が取得される問題
2001611 | 印刷プレビューが表示されたとき、Windowsのタスクバーに｢Magic 印刷プレビュー｣のボタンが追加されない問題

アプリケーションサーバ機能

QCJ# | 内容
2001612 | WOW64上で使用する際、利用可能な仮想メモリアドレス空間（ユーザ領域）が4GBまで対応

開発機能

QCJ# | 内容
780416 | Windows7でStudioを実行すると、コンポーネントリポジトリで.NETアセンブリを新規に登録する際、参照タブから正しく選択できない問題
2001491 | プロジェクトをオープンしていない状態でユーザイベントタイプの[事前定義ロジック]を定義してズームすると、異常終了することがある問題
2001515 | 子タスクから親タスクのフォームのコントロールを複数選択しようとすると、異常終了することがある問題
2001528 | MAGIC.INIに[MAGIC_SPECIALS]SpecialDefaultTransactionMode=P を設定しても、APGで[オプション]=｢照会｣ で作成したプログラムのトランザクションモードが遅延に設定される問題

設定

QCJ# | 内容
2001558 | コマンドラインオプションに /User=xxxx を指定しても、ログオンダイアログのユーザIDに値が設定されない問題

MRB

QCJ# | 内容
2001526 | Brokerモニターを実行し、コンテキストウィンドウを開いた状態で、アプリケーションサーバウィンドウのアプリケーションサーバを選択すると、ステータスが｢BusyRequest｣になる問題題
2001609 | Brokerモニターが不定期に異常終了することがある問題


Magic uniPaaS V1 Plus Ver 1.8J SP1b パッチモジュール (PT2)追加情報

Magic uniPaaS Ver1.8J SP1b PT2での改善内容

ここでは、Magic uniPaaS Ver1.8J SP1b PT2での改善内容を掲載します。

リッチクライアント

QCJ# | 内容
2001621 | (SP1bPT1) ProcessorIDが取得できないPC上で、RIAアプリケーションが正常に実行できない問題
2001629 | (SP1bPT1) サブフォームのプログラムで[タスク特性/選択プログラム]が無効になる問題

モバイルリッチクライアント機能

QCJ# | 内容
2001617 | (SP1bPT1) MGMBL1P1のライセンスで、RIAアプリケーションが正常に実行できない問題
2001619 | MGRIA1P1のライセンスで実行した場合、IsMobileClient関数がFalseになる問題

クライアントサーバ実行機能

QCJ# | 内容
2001622 | DVal関数の第1パラメータに数値＋スペースを設定した場合、戻り値が'0000/00/00'にならない問題
2001630 | DVal関数の第1パラメータの月が1桁の場合、戻り値が正しく返らない問題


uniPaaS 1.8J SP1b での新機能

Magic uniPaaS Ver1.8J SP1bでの新機能

Windows7対応

Windows7に対応しました。Windows7上で使用する場合の注意点は、Windows Vista/7での制限事項を参照してください。最新情報は、随時MSJのWebサイトで公開する予定です。

IBM i 対応

IBM i Gatewayをサポートしました。IBM i Gateway を使用する上での注意点は、Magic uniPaaS for IBM i 追加情報を参照してください。


uniPaaS V1PlusSP1bでの改善内容

Magic uniPaaS Ver1.8J SP1bでの改善内容

ここでは、Magic uniPaaS Ver1.8J SP1bでの改善内容を掲載します。

リッチクライアント

QCJ# | 内容
2001399 | ［F2］、［Esc］キーを押下した場合や［キャンセル］イベントを割り当てたボタンをクリックした場合、コントロール検証の動作がV10と異なる問題
2001400 | テーブルの新規レコードから、データを入力せずに次行に移動しようとすると、コントロール検証ハンドラが動作する問題
2001447 | データを変更して画面再表示を行う処理を数回繰り返すと、データが正しく表示されないことがある問題
2001449 | ビュー再表示を行った後、削除データが表示されることがある問題
2001496 | リッチクライアントサーバライセンス（MGRIA1P1/MGMBL1P1）を使用した場合、［動作環境］ダイアログの［アプリケーションサーバ］タブが表示されない問題
2001501 | 日付型項目の入力途中で別の項目に移動すると、不正な日付に変更されることがある問題
2001506 | Unicode固有文字を含む文字列に対して、Zen、ZenS、Han、ZKanaを実行すると、??に変換される問題
2001508 | ［エディット］コントロールの［パスワードエディット］特性が「Yes」に設定している文字型項目がコピーできてしまう問題
2001514 | ［イメージ］コントロールの［スタイル］特性を「コントロールスケール」に設定し、かつオリジナルのイメージファイルの表示サイズがコントロールのサイズ (高さと幅)より小さい場合、プログラムが異常終了することがある問題
2001530 | ［実行モード］を「オンライン」から「バックグラウンド」（またはその逆）に変更すると、リッチクライアント実行モジュール（uniRC.exe）が、追加して起動される問題
2001532 | 浮動小数点のデータを整数の変数項目に更新して演算処理を行なうと、小数点以下を四捨五入せずに計算する問題

実行機能

QCJ# | 内容
2001356 | 遅延トランザクション使用時にレコードロックの情報が残ることがある問題
2001407 | サブフォーム上にあるプッシュボタンにカーソルが移動しても外枠の色が変化しない問題
2001465 | ［テーブル］コントロールのスクロールバーを動かしたときに、レコードの内容がクリアされることがある問題
2001474 | 印刷プレビュー画面を閉じてオンライン画面に戻ると、カーソル（キャレット）が表示されなくなる問題
2001486 | 日付項目の書式がYYYY/MMの場合、0を入力しても0000/00にならないことがある問題
2001500 | ラインモードのオンラインプログラムで、行挿入後にデータ登録せずに修正モードに変更した場合、カーソルが画面末尾の次に移動する問題
2001511 | mgerror.logに発生日時が記録されない問題
2001512 | 日付項目の書式がJYY/MMの場合、Hだけの入力時の動作がV10と異なる問題
2001516 | Right関数を実行すると、元の文字列の値が置き換えられることがある問題
2001520 | プレビューの[印刷]ダイアログで[部数]に2以上の値を指定し、[部単位]のチェックを外した場合、[部数]の指定が無視される問題
2001522 | オンラインタスクで文字型項目の書式に「#」を指定した場合、全角の数字が入力できてしまう問題
2001525 | Webサービスにおいて、SystinetからMagicエンジンにリクエストが渡らない問題

アプリケーションサーバ機能

QCJ# | 内容
2001507 | サーバエンジンが起動している状態でブローカモニターを実行すると、モニターが即終了してしまう問題

開発機能

QCJ# | 内容
2001426 | ［コールプログラム］処理コマンドのパラメータの内部の値が不正になった場合、リポジトリ出入力で修正されない問題
2001462 | SQLコマンドのパラメータの追加時に、式エディタのウィンドウタイトルバーの「X」をクリックすると開発エンジンが異常終了する場合がある問題
2001463 | .NETのイベントを定義した場合、パラメータが自動生成されない問題
2001513 | VSS(Microsoft Visual SourceSafe)で並行開発を行っていると、不定期に修正したソースが保存されないことがある問題


uniPaaS V1PlusSP1bでの制限事項

Magic uniPaaS Ver1.8J SP1bでの留意・制限事項

リッチクライアント

  • (2000666)[タスク特性]の[事前読込]特性が｢Yes｣に設定されたタスクで[ビュー再表示]イベントを発行すると、チャンクサイズまでのデータしか読み込みません。ビュー再表示を行うタスクは[事前読込]特性を｢No｣に設定してください。

  • (2000729)［ウィンドウタイプ］特性が「モーダル」のウィンドウではステータス行は表示されません。ステータス行のエラーメッセージはそのタスク起動元のSDIタイプのウィンドウに表示されます。

  • (2000742)子タスクからRollback('FALSE'LOG,1)を実行しても、親タスクのロールバックはできません。

  • (2000748)パラメータを渡さないサブフォームを[タブ]コントロールに配置した場合、実行時にタブを変更しても、サブフォームのデータの変更がコミットされません。

  • (2000764)[レコード後]でリンクテーブルの項目に対して加算モードの［項目更新］処理コマンドを定義すると、リンク項目の変更時の更新処理が正常に行われないことがあります。

  • (2000812)リッチクライアントで、リンクの［戻り値］特性に親タスクの論理型変数が定義されている場合、［キャンセル］イベントによって戻り値がリセットされません。

  • (2001030)サブフォームに設定したタスク(［空のデータビュー許可］特性「Yes」）のデータビューが空の状態でも、［データビューが空］イベントが発生しません。この場合、［コール］処理コマンドでタスクを呼び出すことで対応できます。

  • (2001069)リッチクライアントで、変数項目の値を別の変数項目に代入する場合、変数の値がNULLの時、変数の［NULL計算値］特性の値が代入されます。

  • (2001076)オンラインプログラムやVer10用のリッチクライアントタスクから移行した場合、［複数行編集］特性「Yes」の［エディット］コントロールの［CR許可］特性が「No」に設定されます。このため、デフォルトでは複数行編集のコントロールに改行コードが挿入できません。

  • (2001095)Acrobat 9がインストールされたクライアントPCで、［ブラウザ］コントロール上のPDFファイルを表示すると、終了時に異常終了する場合があります。

  • (2001112)［タブ］コントロール、［イメージ］コントロールの［イメージ一覧ファイル名］特性に直接BMPファイルを指定する場合、以下のフラグを設定する必要があります。

[MAGIC_SPECIALS]
SpecialConvAddSlash=N

  • (2001144)数値型項目の書式で３桁区切りが有効になっている場合、「,」を含めた桁数分まで入力が可能になります。ただし、書式の桁数を超えていると項目移動ができません。

  • (2001184)選択プログラム終了後、［項目変更］ロジックユニット内に定義されたFlow()関数の戻り値が、オンラインタスクとは異なる値が返ることがあります。

  • (2001191)プッシュボタンに対しては、XPのテーマは無効になります。

  • (2001244)リッチクライアントのキャッシュパスに自動作成される環境ファイル(ユーザフォント定義ファイル、キーボード割付ファイル、論理名テーブル)の名前は、固定で設定されます。同一サーバ上で異なる環境ファイルを使用するアプリケーションを複数実行する場合には、同一の環境ファイルをマージするか、アプリケーション毎にリッチクライアントのキャッシュパスを設定して下さい。

リッチクライアント（モバイル）

  • キーボードを「ひらがな/カタカナ」に設定すると、英数字入力へのモード変更ができません。

  • (2001445)unicode特有文字は表示できません。unicode対応フォントを別途インストールする必要があります。

  • ［サブフォーム］や［タブ］コントロールが配置された画面では、実行時にソフトキーボードを表示すると、画面がリサイズされません。

  • ［タブ］コントロールを画面サイズ一杯に配置した場合、画面を横長にすると、［タブ］コントロール上のコントロールが表示されないことがあります。

  • (2001527)リッチクライアントフレーム形式のフォームでは、フレームの分割線やフレーム内の画面が表示されません。

Unicode

  • (2000556)MAGIC.INIの[MAGIC_SPECIALS]SpecialAnsiExpression = Y　を設定すると、Unicode型やBLOB型（［内容］特性が「U=Unicode」）の項目に対して、Unicode特有の値を更新すると、「????..」として更新されます。

開発機能

  • プログラムの公開名にDBCSや特殊文字を使用しないことを推奨します。

  • (2000238)MS-IME2002を使用した場合、uniPaaS Studioからプログラムを実行して[アクティビティモニタ]から検索画面で2バイト文字を入力したとき、Enterキーで文字を確定しないと文字が表示されない場合があります。

  • (2000316)クラス0のフォームの編集において、［テーブル］コントロールにリンクされているコントロールをテーブルの外に移動するとリンクが外れます。

  • (2000353)V9Plusで他のプログラムとデータの受け渡しを行う変数が［リンク］コマンドより後に定義されているプログラムを移行すると、リンクの［戻り値］特性に定義された変数項目が自動的に追加されるために、正しく動作しない場合があります。

  • (2000429)［データ］リポジトリで、タイトル行にカーソルを置いてAPGを実行した時、作成モードしか選択できません。

  • (2000431)平面スタイルの［コンボボックス］コントロールの背景色は36番のアプリケーション基本色で表示されます。表示色を変更したい場合は、コンボボックスのスタイルを変更するか、36番の色を変更してください。[テーブル]コントロールの子コントロールとなるコンボボックスの場合、平面スタイルでなくても36番のアプリケーション基本色で表示されます。

  • (2000462)［スタイル］特性が「Windows立体」の［タブ］コントロール上に［テーブル］コントロールをリンクさせることができません。「凸立体」に変更することでリンクすることができます。

  • (2000520)Windows Vistaの場合、フォームの［コントロール］パレットのウィンドウ枠が透過色になるため、後ろの表示が写り込みます。

  • (2000791)文字列抽出ツールは、Unicode固有文字には対応していません。

  • (2001158)コンポーネントジェネレータは、開発ライセンスがないと実行できません。

  • (2001536) Windows 7 上でMagic Studioを起動し、動作環境の[実行モード]を変更すると、不定期にuniRTE.exeの自動起動が行えず、応答なしになることがあります。

実行機能

  • アプリケーションの実行中に、アプリケーション（ECF）ファイルを更新しないでください。更新した場合の動作は保証できません。

  • (2000103)ユーザ定義関数に2バイト文字を使用した関数を定義することはできません。

  • (2000186)［入出力ファイル］テーブルの［メディア］カラムを「V=項目」、［文字セット］特性を「UTF-8」に設定すると、格納したデータが文字化けする場合があります。

  • (2000236)［プッシュボタン］コントロールに定義された項目に対する［項目変更］ロジックユニットを設定した場合、実行時にボタンを押下してもイベントは発行されません。

  • (2000286)HTTPGet関数、またはHTTPPost関数でUTF-8のデータをBLOB型のUnicodeタイプのデータで受け取ると、2バイト文字が正しく取得できません。バイナリタイプで受け取るようにしてください。

  • (2000453)［サブフォーム］コントロールを使用して、サブフォームから親ウィンドウのコントロールをクリックした場合、TaskId()関数ではサブフォームのタスクIDが返り、HandledCtrl()関数では値が返りません。

  • (2000817)並行実行のタスクから呼び出されたプログラムによる印刷出力処理でプレビューを表示した場合、［プレビュー］ウィンドウがMagicの画面の背後で表示される場合があります。

  • (2000904)Windows Vista上でMS-IME2007を使用している場合、［エディット］コントロールの［漢字入力］特性を「5」に設定しても、"半Rカナ"が有効にならないことがあります。

  • (2001094)ATOKを使用している場合、文字パレットから全角文字を選択すると、文字化けが生じる場合があります。

  • (2001197)［フローモード］特性が「A=後置」または「B=前置」に設定している処理コマンドを、［RM互換］ロジックユニット以外では実行できません。

アプリケーションサーバ機能

  • (2000309)［フォーム出力］処理コマンドで［入出力ファイル］テーブルの［メディア］カラムに「リクエスタ」、［文字セット］特性を「Unicode」に設定し、そのプログラムを他のクライアントから［コールリモート］処理コマンドで起動すると、結果ファイルはShift_JISコードで出力されます。 ［文字セット］特性がUTF-8/Shift_JISの場合は、それぞれのコードで出力されます。

バージョン管理

  • プロジェクトのバージョン管理ソフトは、Microsoft Visual SourceSafe (6.0d、あるいは 2005)、およびCVSNTをサポートしています。PVCSはサポートしておりません。バージョン管理を使用した開発を行う前に、必ずそれぞれのオンラインマニュアルをお読みください。

  • 同じプロジェクトファイルを複数のMagicエンジンで開く場合は、必ずバージョン管理機能を使用してください。使用しない場合は、開くことができません。

  • (2000405)バージョン管理でVisual SourceSafe(VSS)を使用した場合、履歴等を実行するとVSSの画面が呼び出されますが、この画面にあるヘルプボタンをクリックするとエラーが発生し、それ以降マウス操作ができなくなります。

  • (2000881)VSS 6.0dの環境でバージョン管理を利用し、「サーバから開く」を実行すると、「No project file found in selected source control project」というエラーで、プロジェクトが選択できないことがあります。この場合、VSS6.0dをSP6にアップデートして下さい。
    SP6は、以下のURLからダウンロードできます。
    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja

Oracle

  • (2000411) RAW型のカラムタイプを定義取得するとBLOB型にマッピングされますので、適宜文字型 (記憶型式：String)に変更する必要があります。

  • (2000558) BLOB型（記憶型式：Unicode Blob）の項目の内容を全角英数字（ＡＢＣ１２３など）で更新すると、文字化けが発生します。

Webサービス

プロバイダアプリケーションの注意事項

  • 公開プログラム名、およびパラメータ名には英数字と _ (アンダースコア文字)のみで先頭に数字を使用できません。

  • 異なる公開プログラム間で、同じ名前で違う型のパラメータを設定すると、正しく動作しない場合があります。

  • 入力パラメータがXMLデータの場合、パラメータをBLOB型で定義し、名前はXSDスキーマのルートと同じ名前に設定してください。

  • 入出力パラメータがXMLデータの場合、設定されたXSDファイルのエレメントの順序が、Systinetのパッケージを作成した後にアルファベット順に変更されることがあります。これにより、コンシューマに提供するスキーマとあわなくなることがあるため、あらかじめXSDのエレメントの名前をV01_xxx, V02_xxxなどの接頭辞を付加することで回避してください。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面のサービスネームスペースにはデフォルトでMAGIC.INIのオーナ名が付加されます。オーナ名にスペースや . (ドット文字)が含まれる場合、デフォルトの値では jarファイルが作成できませんので適切な値に変更する必要があります。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面の「説明」に日本語の2バイト文字を入力すると、jarファイルが作成できません。

コンシューマからWebサービスコールを実行するときの注意事項

  • ［サービス］テーブルで既存のWebサービスのWSDLを再読み込みした場合には、Magicエンジンを再起動してください。さらにそのサービスを設定したWebサービスコールを再度定義しないと正しく実行できないことがあります。

  • プロバイダにXMLデータをBLOB型で渡す場合、Shift_JISのエンコードで渡してください。

その他

  • Magic eDeveloper V10やuniPaaS Studio V1がインストールされたPCにuniPaaS Studio V1Plusをインストールした場合、どちらかをアンインストールすると MgComCreater.dll がレジストリから削除されます。このような場合は、WindowsのRegsvr32.exeを使用して残った製品のインストールフォルダ内にあるMgComCreater.dllを登録し直してください。


uniPaaS V1PlusSP1aPT1での改善内容

Magic uniPaaS Ver1.8J SP1a PT1での改善内容

ここでは、Magic uniPaaS Ver1.8J SP1a PT1での改善内容を掲載します。

リッチクライアント機能

QCJ# | 内容
2001469 | ［フォーム特性］の［タイトルバー］特性を=「Yes」に設定し、かつ［フォーム名］が空欄の場合、実行時にフォームのタイトルバーが表示されない問題
2001471 | 親タスクから子タスクを起動する間に他のアプリケーション（メモ帳など）をアクティブにすると、タスクバーのアイコンをクリックしても子タスクではなく親 タスクがアクティブになる問題
2001475 | 「Caps Lock」 がオンの場合、パスワードエディットをクリックすると、バルーンヘルプが直前の項目で表示される問題
2001476 | 親タスクから「強制終了」=[N:なし] 以外のユーザイベントを実行して子タスクをコールした場合、その子タスクから起動したユーザイベントが正しく動作しないことがある問題
2001478 | ［イメージ］コントロールで指定されたイメージファイルが存在しない場合、エラーダイアログが表示される問題

実行機能

QCJ# | 内容
733236 | COMGetHandle関数で取得したハンドル値をCOMSetHandle関数で別のCOMオブジェクトに設定しても値が設定されない問題
2001023 | DDEPoke関数においてUnicode固有文字が正しく処理されない問題
2001210 | Unicode型のセルを指定したベクトル型項目を［コールCOM］処理コマンドのパラメータに指定すると、データにゴミが入ることがある問題
2001463 | (MS-SQLServer)テーブル/カラムのSQLタイプに小文字でタイプを指定した場合、サブフォームのテーブルがスクロールできない問題
2001464 | (MS-SQLServer)［カラム特性］の［タイプ］特性にDBMS固有のタイプ名を設定した場合、実行時にデータの位置付が正しく行われないことが ある問題
2001466 | ［共有］特性を「N=なし」に設定しても、テーブルロックがかからないことがある問題
2001472 | 背景に透過色を使用した場合、後ろのウィンドウのデータが表示される問題
2001473 | ［コールWebサービスLite］処理コマンドを実行すると、戻り値に含まれた2バイト文字が化けることがある問題
2001487 | Str関数の書式にTrim関数を使用すると、データの末尾が欠けることがある問題

アプリケーションサーバ機能

QCJ# | 内容
2001467 | バックグラウンドモードでGUI印刷を実行した場合、サーバエンジンが異常終了する問題

開発機能

QCJ# | 内容
2001458 | ［コールWebサービスLite］処理コマンド［戻り値］特性においてBLOB項目が選択できない問題
2001461 | ［データソース］リポジトリの数値型項目に対して、書式に2バイト文字（#ヵ月など)が含まれる場合、構文チェックでエラーになる問題
2001463 | .NETのイベントを定義した場合、パラメータが自動生成されない問題
2001480 | ［コール.NET］処理コマンドで、文法エラーのあるC#コードを書いたとき、OKボタンを押してもエラーダイアログが表示されない問題

V9Converter

QCJ# | 内容
2001479 | V9コンバータで作成されたプロジェクトに対して、モデルリポジトリにv9 compatible formのモデルが新たに追加されるが、そのモデルがプログラムのテーブルコントロールのモデルに設定されない問題


uniPaaS V1Plusでの新機能

Magic uniPaaS Ver1.8J SP1aでの新機能

リッチクライアント

.NET 統合

Magic uniPaaSのRIA開発機能では、クライアントモジュールの一部として様々な種類の.NETアセンブリやコントロールを簡単に統合することができます。.NETモジュールの追加や処理の方法については、ホワイトペーパの『.NETサンプルガイドを』を参照してください。

RIAライセンス

RIA用のアプリケーションサーバのライセンス名が変更されました。Magic uniPaaS V1では、Magic側で設定するライセンス名は「MGENT11」でしたが、V1Plusでは、「MGRIA1P1」を指定するようになりました。このライセンスを指定された場合、RIA用のリクエトのみ処理され、それ以外は拒否されます。

RIAキャッシュのセキュリティ向上

新しいキャッシュメカニズムによって、HTTP上でアクセス可能なキャッシュフォルダを定義する必要が無くなりました。キャッシュは、インターネットリクエスタによって管理され、HTTP上でアクセス可能なキャッシュフォルダに要求しなくなりました。

これにより、WebサーバとMRB/uniPaaS Richclient Server の間にファイアーウォールがある場合、Windowsのファイル共有のためのポートを開ける必要がなくなりました。

RIA用のニュートラル関数の追加

以下の関数は、リッチクライアントタスクでニュートラルとして扱われ、実行する際にサーバへのアクセスが不要になりました。

AddDateTime()、 AppName()、 BlobSize()、 DifDateTime()、 mTime()、mTStr()、 mTVal().

［コール］処理コマンドの向上

［コール］処理コマンドに［フォーカスを保持］特性が追加されました。これは、フォーカスを現在のコントロールに残すか、呼び出されたプログラムまたはタスクの最初のコントロールに移動するかどうかを定義します。

この特性は、タスク、レコード、またはコントロール以外のロジックユニットから呼び出した場合で、［出力先］特性にサブフォームかフレームが指定されている場合に有効になります。

［コールOS］処理コマンドの拡張

［コールOS］処理コマンドの［ウェイト］特性は、［実行］特性が「クライアント」の場合でもサポートされるようになりました。また、「クライアント」の場合は、［表示］特性もサポートされるようになりました。

［イメージ］コントロールの［スタイル］特性

リッチクライアントの［イメージ］コントロールに、［スタイル］特性が追加されました。ここで、｢境界なし｣を選択するとイメージをシームレスに表示させることができます。

外部イベント

外部イベントがリッチクライアントタスクでもサポートされるようになりました。リッチクライアントの［ブラウザ］コントロールで表示されているHTMLページから情報を受け取るために使用できます。

このイベントは、以下の関数で発行させることができます。

window.external.MGExternalEvent(parameter).

IE7のデフォルト設定では、［ブラウザステータステキスト変更］イベントがブロックされるため、代わりに外部イベントを利用するようにしてください。

BrowserScriptExecute()の変更

BrowserScriptExecute()関数は、「言語」と呼ばれるパラメータが追加されました。JavaScript以外の言語でスクリプトを実行する場合は、このパラメータを使用する必要があります。

セッション統計

各RIAのセッションは、その実行統計情報を維持しています。以下の方法のどれかを利用することでこの情報を参照することができます。

  • セッションが終了したら時点で表示する。RIAの初期起動時に開くhtmlファイル（デフォルト名：アプリケーション名.Publish.html）の'DisplayStatisticInformation'プロパティを｢Y｣に変更し、プロパティを有効にしたうえでこのhtmlファイルでRIAアプリケーションをインストールすると表示されます。

  • 追加されたClientSessionStatisticsGet関数を使用することで、現在のセッションの情報が取得できます。

クライアントのログレベル

uniPaaS Studioにて［プログラム］リポジトリ上から実行する場合、出力させたいログのログレベルは、magic.iniファイルの[MAGIC_RIA]セクションに定義されたInternalLogLevelキーワードによって制限することができます。

このキーワードは、クライアントによって許可された最大のログレベルを定義するため、クライアント側の実行特性ファイルを処理処理しても完全なログを作成することはできません。キーワードが設定されていない場合、最大のレベルはSERVERになります。

uniPaaS RichClient Serverでアプリケーション実行時にログを出力するする場合は、初期起動時に使用するhtmlのパラメータを有効にしてください。

［代入］特性にサーバ実行の式

［代入］特性でサーバ側の式を設定できるようになりました。

式は適切に実行されますが、レコードをアクセスする際にパフォーマンスを低下させるため、なるべく使用しないでください。

構文チェックユーティリティーは、［代入］特性にサーバ側の式が定義されている場合、推薦できない旨を示すメッセージが表示されます。

［ログオン］ダイアログのカスタマイズ

リッチクライアントアプリケーションで使用される［ログオン］ダイアログをカスタマイズすることができます。

変更するには、公開用Webページ（publish.html）ファイルの中の「rcExecProps」のIDを持つ､XMLアイランド内にキーワードを定義する必要があります。詳細は、『リファレンスヘルプ』を参照してください。

［リッチエデット］コントロールの書式設定

［リッチエデット］コントロールで実行時に書式（色やフォントなど）を変更させることができます。以下の内部イベントを発行するためのショートカット定義やメニュー定義を行う事で実行できます。

  • 右揃え

  • 左揃え

  • 箇条書き

  • インデント

  • インデント解除

  • 色の変更

  • フォントの変更

モバイルRIA

モバイルRIAの実行

Magic uniPaaS V1Plusでのモバイル用アプリケーション開発は、通常のRIA開発と同じように行うことができます。通常のRIAとモバイルRIAの主な違いは、モバイル端末の表示領域や、タッチスクリーンやスタイル、実行方法などの予め予想されるユーザ操作を考慮する必要があるということです。

uniPaaS StudioのRCコンポーネントビルダは、モバイル開発をサポートするために拡張されています。詳細は、『インタラクティブなリッチクライアントの開発と実行』の｢実行環境｣セクションを参照してください。

モバイル用アプリケーションを開発する上でいくつか考慮する点があります。モバイル開発での注意点を参照してください。

開発機能

処理コマンドの無効化

新しいオプションとして、処理コマンドを使用不可にする機能が追加されたました。無効化された処理は実行時に無視されます。

この機能は、指定されたコードを使用不可にすることで、その処理に設定された条件式を変更することなく処理をスキップさせることができます。これによって一時的なブロックを作成する必要が無くなります。

ショートカットキー：Ctrl+Shift+D、またはコンテキストメニューや［編集］メニューの「行を有効化/行を無効化」を選択することで選択できます。

リンクのアクセスモード

データソース（データベーステーブルまたはXMLドキュメント）の［アクセス］特性は、［リンク］コマンドのタイプによって自動的に決定されます。リンクタイプが「照会」か「結合」、｢外部結合｣の場合、［アクセス］特性は「読込」に設定されます。リンクタイプが「書込」または「登録」の場合は、「書出」に設定されます。

この変更によって、読込アクセスが必要な場合に書出アクセスでリンクが行われることによって発生する不要なロックを防止することができます。

この動作を旧バージョンとの互換性を維持するためには、Magic.iniの［MAGIC_SPECIALS］セクションに以下のパラメータを追加してください。

SpecialLinkWriteAccess=Y

［RM互換］ロジックユニット削除後のTAB順序の維持

［RM互換］ロジックユニットを削除する際、フォーム上のコントロールの配置順がビュー項目の定義順と異なる場合、フォーム上のコントロールの［タブ順序］特性は、ビュー項目の順番にもとづいて設定されます（［自動タブ順序］に従って再設定されなくなりました）。

デフォルトのタスクタイプ

新規作成するプログラムのデフォルトのタスクタイプを予め指定することができます。［設定］メニューから［動作環境／動作設定］を選択し、［デフォルトのタスクタイプ］と呼ばれる新しいオプションを使用します。この特性を設定することによって、Magic uniPaaSでプログラムを作成する際、タスクタイプを変更することなくRIA用のプログラムを開発することができるようになります。

LDAP関数の追加

LDAP用の関数としてが追加されました。これによってLDAPを使用しているOSディレクトリでのユーザとグループの作成／更新が可能になります。

関数は以下の通りです：

  • LDAPConnect ……LDAPによる別のセッションを作成します。この関数で取得されたセッションIDを他のLDAP関数で指定することで指定されたセッション上の操作を実行させることができます。

  • LDAPDisconnect ……LDAPセッションを終了します。

  • LDAPUserAdd ……ユーザをLDAPに追加します。(SSL経由でのみ利用できます。)

  • LDAPUserDel ……ユーザをLDAPから削除します。

  • LDAPUserModify ……LDAPに登録されているユーザ情報を更新します。

  • LDAPGroupAdd ……グループをLDAPに追加します。

  • LDAPGroupDel ……グループをLDAPから削除します。

  • LDAPUserGroupAssign ……ユーザをLDAP上のグループに追加します。

  • LDAPUserGroupRemove ……ユーザをLDAP上のグループから削除します。

RQContexts()関数の追加

RQContexts関数が追加されました、この関数は実行中のコンテキスト毎のMRBの状態を取得することができます。

RQLoad()関数の拡張

RQLoad()関数が拡張され、以下の2つの値が返されるようになりました。

  • 毎日のリクエスト数

  • 毎日の応答時間の累計

フォーム表示

グラデーション色のサポート

グラデーションを有効にした背景を使用することで、アプリケーションのユーザーインターフェイスを拡張することができます。［グラデーションスタイル］と［グラデーション色］と呼ばれる2つの新しい特性が追加されました。これらの特性を使用することで、背景の画像を指定することなくグラデーション効果を定義することができます。使用できるオブジェクトは以下の通りです。

GUI表示フォーム

  • フォーム

  • ［スタティック］コントロール……［楕円］を除く。［スタイル］特性が｢平面｣の場合のみ有効

リッチクライアント表示フォーム

  • フォーム

  • ［スタティック］コントロール

  • ［タブ］コントロール

  • ［プッシュボタン］コントロール……［ボタンスタイル］特性が｢プッシュボタン｣または｢ハイパースタイル｣の場合のみ有効

  • ［チェックボックス］……［表示方法］特性が｢ボタン｣の場合のみ有効

  • ［ラジオボタン］……［表示方法］特性が｢ボタン｣の場合のみ有効

イメージボタンの拡張

［プッシュボタン］コントロールの［スタイル］特性を｢イメージ｣または、「イメージ上のテキスト｣に設定した場合、以下のイメージをサポートするようになりました。

  • ホットトラック……マウスポインタがプッシュボタン上にある状態に表示されます。

  • デフォルトプッシュボタン……プッシュボタンがフォームのデフォルトボタンとして定義されている場合に表示されます。

このイメージを表示させる場合は、同じサイズのイメージを6つ連結したイメージファイルを指定し、［動作環境］ダイアログの［動作設定／プッシュボタン用イメージ数］の設定を｢6｣に指定する必要があります。

実行機能

遅延トランザクション内のDB SQL Where句

DB SQL Where句は、遅延トランザクションタスクでもサポートされるようになりました。

遅延トランザクションタスク内でDB SQL Where句を使用する場合は、同じデータソースを複数のタスクでアクセスしていると、一方のタスクで更新された内容を他方のタスクで参照できなくなります。このため、構文チェックユーティリティを実行すると、警告メッセージが表示されます。

内部通信の暗号化

MagicリクエスタやMRB、およびMagicエンジンの間でやり取りされるメッセージは、商業用の暗号化アルゴリズムを使用して、暗号化することができます。この機能を有効にするには、mgreq.iniファイルにEncryptedCommunicationと呼ばれる新しいキーワードを使用することで設定できます。

ログオン関数の動作

旧バージョンでは、タスク内でLogon関数を使用した場合、そのプログラム内でのみ有効でした。プログラムが終了するとユーザ情報は戻ります（プログラム内のタスクの切り替えでは変わりません）。

この動作は変更され、指定されたユーザによってプログラムが終了しても有効になるようになりました。

旧バージョンと同じように動作させる必要がある場合、プログラムを終了する前にLogon関数を実行し直す必要があります。

内部論理名の値の更新

内部用論理名‘TempDir’と‘WorkingDir’の値は、コマンドラインパラメータを使用して変更することができるようになりました。この機能によって、各ユーザまたはエンジンの起動環境毎に異なる値を設定することができます。

Webサービスの簡易呼出

Webサービスのクライアント機能は、Easycomライブラリを使用することで、Magic Ver9と同じような方法で利用できるようになりました。これによって、SystinetをインストールすることなくWebサービスを呼ぶことができます。

この機能を使用するには、［外部コール］処理コマンドで「Webサービスライト」と呼ばれる新しいオプションを選択してください。

この機能は、Webサービスを呼ぶ簡易的な方法であり、通常の［コールWebサービス］が利用できるSystinetが提供する機能やセキュリティを持っていません。

[コールWebサービス]処理コマンドで定義された内容でプロジェクトを移行する方法については、『リファレンスヘルプ』を参照してください。


uniPaaS V1Plusでの改善内容

Magic uniPaaS Ver1.8J SP1aでの改善内容

ここでは、Magic uniPaaS Ver1.8J SP1aでの改善内容を掲載します。

リッチクライアント

QCJ# | 内容
0245338 | パーキングする項目がないサブフォームを定義し、そのタスクに対して［出力先］特性を指定した［コール］処理コマンドを実行すると、キャレットが消える問題
0721529 | データビューが空のサブフォームに対して、CtrlGoto関数でその中のコントロールにアクセスしようとするとエラーが出る問題
0734215 | ［位置］特性の値がテーブルに設定され、すべてのカラムの位置がNoになっていると、そのテーブルの幅が無視される問題
0767458 | FileDLG関数のデフォルトが、前に開いたフォルダでなく、常にワークフォルダになる問題
0768765 | SQLコマンドタスクとして定義されたリッチクライアントを実行すると、ソートが機能しない問題
0780401 | １つの項目に対して複数の［ラジオボタン］コントロールが関連付けられた場合、実行時に［項目変更］イベントが正しく機能しない問題
0780555 | メインプログラムのイベントテーブルに定義されたMnuEnabl関数、MnuShow関数が正しく機能しない問題
0780719 | ２つのサブフォームが定義されたタスクの実行時に、１つのサブフォームにカーソルがあって、親タスクのサブフォーム再表示の［イベント実行］処理コマンドによって、もう片方のサブフォームに対する再表示が機能しない問題
0782876 | ［ブラウザ］コントロールに直接bmpファイルを設定して実行すると、bmpファイルのビューアが起動される問題
0793138 | ［タブ］コントロール上のコントロールに対する［コントロール検証］ロジックユニット内に［コール］処理コマンドが定義されていると、連続して処理コマンドが実行されることがある問題
0804604 | 修正したレコードからカーソルが移動しないと、［レコード書込］イベントによって実際の更新が行われない問題
0926815 | ［終了］条件が「Yes」, ［チェック時期］が「前置」のリッチクライアントプログラムを呼び出した場合、渡したパラメータの値が更新されない問題
0933982 | ［キャッシュ］特性が「Yes」に設定されたサブフォームに対して、20バイト以上のパラメータを渡すと、正しく受け取れない場合がある問題
0934042 | ［代入］特性が設定された変数項目が複数定義され、フォーム上にラジオボタンが配置しているタスクを実行した場合、PageDown／PageUpキーを押下すると変数項目の［代入］特性が正しく実行されないことがある問題
0988324 | 式が設定されたコントロールが、実行時に、［フォーム］エディタ上に定義内容と異なる位置に表示されることがある問題
2001200 | 日付型項目の値をDeleteキーで削除して、［強制終了］カラムが「編集」のユーザイベントを実行すると、日付が「2000/01/01」となる問題
2001253 | サブフォームでタブ変更時にタブ内のコントロールの［コントロール後］でエラーが発生した場合、タブのラベルが変更される問題
2001263 | ClientDirDlg関数の初期フォルダパラメータが空白の場合、フォルダの参照ダイアログが開かない問題
2001306 | テーブル上に配置されたプッシュボタンが、［フォーム特性］のデフォルトボタンに設定されている場合、実行時にカーソルが2行目以降、かつプッシュボタン以外にあってEnterキーを押下すると、1行目のレコードに移動してボタンのイベントが実行される問題
2001315 | サブフォームの［非表示で再表示］特性を「No」、［可視］特性を変数項目で指定した場合、実行時に［可視］特性の値がTRUEに変更された場合、サブフォームの表示と共にプログラムの［レコード前］が2度実行される問題
2001325 | 3階層のサブフォームで構成されたプログラムを実行し、一番下のタスク画面の任意のコントロールをクリックしても無効になる問題
2001326 | ［キャンセル］イベントを実行した場合、データビュー内で「サーバ」と認識されている項目に対して、［項目変更］ロジックユニットが動作しない問題
2001349 | ［テーブル］コントロールの［位置］特性の［高さ］を「1」以上に設定した場合、実行時にウィンドウの高さをマウスドラッグで調整すると合、テーブル上のプッシュボタンやチェックボックスが表示されなくなる問題
2001352 | ［テーブル］コントロールの「区切り」特性が「Yes」の場合、区切り線の色が1画面目と2画面目で異なる問題
2001402 | ［タスク特性］の［空のデータビュー許可］特性が「Yes」に設定されている場合、変数が割り当てられていないプッシュボタンのイベントが実行されないことがある問題
2001413 | ［タスク特性］の［インタラクティブ］特性がオフのプログラムからコールされたプログラムで、［タブ］コントロールの子のサブフォームが動作しない問題
2001418 | ［タブ］コントロールの［ラベル］特性に式を設定したプログラムを実行すると、メモリリークが発生することがある問題
2001421 | カラムの［範囲］特性が指定されていて、［NULL値可］特性が「Yes」に設定されている場合、コントロールが表示されなかったり、表示位置が正しくない場合がある問題
2001437 | 複数のサブフォームを条件によって表示を切り替えるプログラムを終了すると、異常終了することがある問題
2001441 | ［テーブル］コントロール上に配置した［スタティック］コントロールのスタイルが反映されない問題
2001442 | リッチクライアントプログラムで、代入式にてMID関数を利用すると再計算が行われない問題
2001444 | データビューの順序とフォーム上のタブ順序が異なるコントロール間をマウスで移動すると、それ以降にあるコントロールの［コントロール検証］ロジックユニットが実行される問題

実行機能

QCJ# | 内容
0774947 | ［RM互換］ロジックユニットが定義されたタスクにおいて、最初のレコードの前に定義されたKBPut(1)が1回目しか有効にならない問題
0775206 | サブフォームタスクのフォームの色が透過色の場合、その中の［テーブル］コントロールに対する［可視］特性が機能しない問題
0779882 | コントロールの式に設定されたユーザ定義関数において、タスク世代をパラメータに持つ関数が正しく機能しない問題
0784682 | ［データビューが空］イベントで起動されたタスクで［強制終了］が「レコード」に設定されたユーザイベントが定義されていると、実行時にそのイベントが発行されるとタスクが終了する問題
0937843 | CndRange()関数がTrueとして評価された場合、範囲式にワイルドカードが含まれていると、データ抽出が正しく行われない問題
0937933 | リストボックスとして割り当てられたベクター型の変数項目に本来の半分の長さのデータしか保存されない問題
0940282 | ユーザ定義関数を変数項目に設定した場合、テーブルの実データが正しく表示されないことがある問題
0940850 | ［テーブル］コントロール中のコンボボックスに設定されたコンテキストメニューが実行時に表示されない問題
0979221 | サブフォーム以外にパークするコントロールがない場合、サブフォームタスクの終了時に無応答状態になる問題
0984905 | ［強制終了］が「レコード」に設定されたユーザイベントを実行すると［コントロール検証］ロジックユニットが実行される問題
0988897 | FileExist関数のパラメータにフォルダ名、あるいはUNC表記を設定すると正しい値が返らない問題
0989215 | ［コール］処理コマンドのパラメータにユーザ定義関数の戻り値を設定した場合、並行実行タスクで呼び出すとパラメータが正しく渡らない問題
0992768 | 印刷プレビュー機能を実行中にスクロールバーをクリックすると、異常終了することがある問題
0995797 | シングルモードに設定されたリストボックスに対するCtrl+Home / Ctrl+End が有効にならない問題
0998278 | アクセス権利がないと、FileExist関数の戻り値がFalseになる問題
2001383 | MailConnect関数でCRAM-MD5に対応したSMTPサーバに接続すると異常終了する問題
2001411 | UnicodeToANSI関数の変換結果が途中で切り捨てられる問題
2001414 | オンラインプログラムで、リストボックスの［リンク項目］特性にUnicode型の項目が定義されかつ［選択モード］特性が「マルチ」の場合、項目選択後にリストボックスからフォーカスが離れたときに選択状態（反転表示）が解除される問題
2001415 | ［ライン］コントロールの位置とサイズを式定義した場合、ラインの終端のが正しく表示されない問題
2001431 | リンクが複数定義されている場合、2つ目以降のリンク項目に対する［項目変更］イベントのCHG_PRVの値が正しく取得できない問題
2001450 | ［プッシュボタン］コントロールの［スタイル］特性が「ハイパーテキスト」でかつ、背景色が透過指定している場合、プッシュボタンからカーソルが移動すると、外枠の表示が残る問題

開発機能

QCJ# | 内容
0799050 | 孫タスクを別の子タスクに移動したり、上書きした場合、孫タスクの中の親の変数の式が正しく設定されない問題
0931671 | 式が表示される箇所で、実際は列の幅が長くても、途中で切れて表示される問題
0939689 | ビットの深さが32ビットのBMPイメージが表示できない問題
2001387 | 式定義で、ExpCalc()関数の後ろに何らかの記述をしていると、構文チェックユーティリティでエラーとして扱われる問題
2001451 | デバックモードでブレークポイントを設定して実行すると異常終了することがある問題

ゲートウェイ

QCJ# | 内容
2001439 | (Oracle) DBカラム名に2バイトコードが含まれる場合、OrderBy句が正しく生成されないことがある問題


uniPaaS V1Plusでの制限事項

Magic uniPaaS Ver1.8J SP1aでの留意・制限事項

リッチクライアント

  • (2000666)[タスク特性]の[事前読込]特性が｢Yes｣に設定されたタスクで[ビュー再表示]イベントを発行すると、チャンクサイズまでのデータしか読み込みません。ビュー再表示を行うタスクは[事前読込]特性を｢No｣に設定してください。

  • (2000729)［ウィンドウタイプ］特性が「モーダル」のウィンドウではステータス行は表示されません。ステータス行のエラーメッセージはそのタスク起動元のSDIタイプのウィンドウに表示されます。

  • (2000742)子タスクからRollback('FALSE'LOG,1)を実行しても、親タスクのロールバックはできません。

  • (2000748)パラメータを渡さないサブフォームを[タブ]コントロールに配置した場合、実行時にタブを変更しても、サブフォームのデータの変更がコミットされません。

  • (2000764)[レコード後]でリンクテーブルの項目に対して加算モードの［項目更新］処理コマンドを定義すると、リンク項目の変更時の更新処理が正常に行われないことがあります。

  • (2000812)リッチクライアントで、リンクの［戻り値］特性に親タスクの論理型変数が定義されている場合、［キャンセル］イベントによって戻り値がリセットされません。

  • (2001030)サブフォームに設定したタスク(［空のデータビュー許可］特性「Yes」）のデータビューが空の状態でも、［データビューが空］イベントが発生しません。この場合、［コール］処理コマンドでタスクを呼び出すことで対応できます。

  • (2001069)リッチクライアントで、変数項目の値を別の変数項目に代入する場合、変数の値がNULLの時、変数の［NULL計算値］特性の値が代入されます。

  • (2001076)オンラインプログラムやVer10用のリッチクライアントタスクから移行した場合、［複数行編集］特性「Yes」の［エディット］コントロールの［CR許可］特性が「No」に設定されます。このため、デフォルトでは複数行編集のコントロールに改行コードが挿入できません。

  • (2001095)Acrobat 9がインストールされたクライアントPCで、［ブラウザ］コントロール上のPDFファイルを表示すると、終了時に異常終了する場合があります。

  • (2001112)［タブ］コントロール、［イメージ］コントロールの［イメージ一覧ファイル名］特性に直接BMPファイルを指定する場合、以下のフラグを設定する必要があります。

[MAGIC_SPECIALS]
SpecialConvAddSlash=N

  • (2001144)数値型項目の書式で３桁区切りが有効になっている場合、「,」を含めた桁数分まで入力が可能になります。ただし、書式の桁数を超えていると項目移動ができません。

  • (2001184)選択プログラム終了後、［項目変更］ロジックユニット内に定義されたFlow()関数の戻り値が、オンラインタスクとは異なる値が返ることがあります。

  • （2001191）プッシュボタンに対しては、XPのテーマは無効になります。

  • (2001244)リッチクライアントのキャッシュパスに自動作成される環境ファイル(ユーザフォント定義ファイル、キーボード割付ファイル、論理名テーブル)の名前は、固定で設定されます。同一サーバ上で異なる環境ファイルを使用するアプリケーションを複数実行する場合には、同一の環境ファイルをマージするか、アプリケーション毎にリッチクライアントのキャッシュパスを設定して下さい。

リッチクライアント（モバイル）

  • キーボードを「ひらがな/カタカナ」に設定すると、英数字入力へのモード変更ができません。

  • （2001445）unicode特有文字は表示できません。unicode対応フォントを別途インストールする必要があります。

  • ［サブフォーム］や［タブ］コントロールが配置された画面では、実行時にソフトキーボードを表示すると、画面がリサイズされません。

  • ［タブ］コントロールを画面サイズ一杯に配置した場合、画面を横長にすると、［タブ］コントロール上のコントロールが表示されないことがあります。

Unicode

  • (2000556)MAGIC.INIの[MAGIC_SPECIALS]SpecialAnsiExpression = Y　を設定すると、Unicode型やBLOB型（［内容］特性が「U=Unicode」）の項目に対して、Unicode特有の値を更新すると、「????..」として更新されます。

開発機能

  • プログラムの公開名にDBCSや特殊文字を使用しないことを推奨します。

  • (2000238)MS-IME2002を使用した場合、uniPaaS Studioからプログラムを実行して[アクティビティモニタ]から検索画面で2バイト文字を入力したとき、Enterキーで文字を確定しないと文字が表示されない場合があります。

  • (2000316)クラス0のフォームの編集において、［テーブル］コントロールにリンクされているコントロールをテーブルの外に移動するとリンクが外れます。

  • (2000353)V9Plusで他のプログラムとデータの受け渡しを行う変数が［リンク］コマンドより後に定義されているプログラムを移行すると、リンクの［戻り値］特性に定義された変数項目が自動的に追加されるために、正しく動作しない場合があります。

  • (2000429)［データ］リポジトリで、タイトル行にカーソルを置いてAPGを実行した時、作成モードしか選択できません。

  • (2000431)平面スタイルの［コンボボックス］コントロールの背景色は36番のアプリケーション基本色で表示されます。表示色を変更したい場合は、コンボボックスのスタイルを変更するか、36番の色を変更してください。[テーブル]コントロールの子コントロールとなるコンボボックスの場合、平面スタイルでなくても36番のアプリケーション基本色で表示されます。

  • (2000462)［スタイル］特性が「Windows立体」の［タブ］コントロール上に［テーブル］コントロールをリンクさせることができません。「凸立体」に変更することでリンクすることができます。

  • (2000520)Windows Vistaの場合、フォームの［コントロール］パレットのウィンドウ枠が透過色になるため、後ろの表示が写り込みます。

  • (2000791)文字列抽出ツールは、Unicode固有文字には対応していません。

  • (2001158)コンポーネントジェネレータは、開発ライセンスがないと実行できません。

実行機能

  • アプリケーションの実行中に、アプリケーション（ECF）ファイルを更新しないでください。更新した場合の動作は保証できません。

  • (2000103)ユーザ定義関数に2バイト文字を使用した関数を定義することはできません。

  • (2000186)［入出力ファイル］テーブルの［メディア］カラムを「V=項目」、［文字セット］特性を「UTF-8」に設定すると、格納したデータが文字化けする場合があります。

  • (2000236)［プッシュボタン］コントロールに定義された項目に対する［項目変更］ロジックユニットを設定した場合、実行時にボタンを押下してもイベントは発行されません。

  • (2000286)HTTPGet関数、またはHTTPPost関数でUTF-8のデータをBLOB型のUnicodeタイプのデータで受け取ると、2バイト文字が正しく取得できません。バイナリタイプで受け取るようにしてください。

  • (2000453)［サブフォーム］コントロールを使用して、サブフォームから親ウィンドウのコントロールをクリックした場合、TaskId()関数ではサブフォームのタスクIDが返り、HandledCtrl()関数では値が返りません。

  • (2000817)並行実行のタスクから呼び出されたプログラムによる印刷出力処理でプレビューを表示した場合、［プレビュー］ウィンドウがMagicの画面の背後で表示される場合があります。

  • (2000904)Windows Vista上でMS-IME2007を使用している場合、［エディット］コントロールの［漢字入力］特性を「5」に設定しても、"半Rカナ"が有効にならないことがあります。

  • (2001094)ATOKを使用している場合、文字パレットから全角文字を選択すると、文字化けが生じる場合があります。

  • （2001197）［フローモード］特性が「A=後置」または「B=前置」に設定している処理コマンドを、［RM互換］ロジックユニット以外では実行できません。

アプリケーションサーバ機能

  • (2000309)［フォーム出力］処理コマンドで［入出力ファイル］テーブルの［メディア］カラムに「リクエスタ」、［文字セット］特性を「Unicode」に設定し、そのプログラムを他のクライアントから［コールリモート］処理コマンドで起動すると、結果ファイルはShift_JISコードで出力されます。 ［文字セット］特性がUTF-8/Shift_JISの場合は、それぞれのコードで出力されます。

バージョン管理

  • プロジェクトのバージョン管理ソフトは、Microsoft Visual SourceSafe (6.0d、あるいは 2005)、およびCVSNTをサポートしています。PVCSはサポートしておりません。バージョン管理を使用した開発を行う前に、必ずそれぞれのオンラインマニュアルをお読みください。

  • 同じプロジェクトファイルを複数のMagicエンジンで開く場合は、必ずバージョン管理機能を使用してください。使用しない場合は、開くことができません。

  • (2000405)バージョン管理でVisual SourceSafe(VSS)を使用した場合、履歴等を実行するとVSSの画面が呼び出されますが、この画面にあるヘルプボタンをクリックするとエラーが発生し、それ以降マウス操作ができなくなります。

  • (2000881)VSS 6.0dの環境でバージョン管理を利用し、「サーバから開く」を実行すると、「No project file found in selected source control project」というエラーで、プロジェクトが選択できないことがあります。この場合、VSS6.0dをSP6にアップデートして下さい。
    SP6は、以下のURLからダウンロードできます。
    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja

Oracle

  • (2000411) RAW型のカラムタイプを定義取得するとBLOB型にマッピングされますので、適宜文字型 (記憶型式：String)に変更する必要があります。

  • (2000558) BLOB型（記憶型式：Unicode Blob）の項目の内容を全角英数字（ＡＢＣ１２３など）で更新すると、文字化けが発生します。

Webサービス

プロバイダアプリケーションの注意事項

  • 公開プログラム名、およびパラメータ名には英数字と _ (アンダースコア文字)のみで先頭に数字を使用できません。

  • 異なる公開プログラム間で、同じ名前で違う型のパラメータを設定すると、正しく動作しない場合があります。

  • 入力パラメータがXMLデータの場合、パラメータをBLOB型で定義し、名前はXSDスキーマのルートと同じ名前に設定してください。

  • 入出力パラメータがXMLデータの場合、設定されたXSDファイルのエレメントの順序が、Systinetのパッケージを作成した後にアルファベット順に変更されることがあります。これにより、コンシューマに提供するスキーマとあわなくなることがあるため、あらかじめXSDのエレメントの名前をV01_xxx, V02_xxxなどの接頭辞を付加することで回避してください。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面のサービスネームスペースにはデフォルトでMAGIC.INIのオーナ名が付加されます。オーナ名にスペースや . (ドット文字)が含まれる場合、デフォルトの値では jarファイルが作成できませんので適切な値に変更する必要があります。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面の「説明」に日本語の2バイト文字を入力すると、jarファイルが作成できません。

コンシューマからWebサービスコールを実行するときの注意事項

  • ［サービス］テーブルで既存のWebサービスのWSDLを再読み込みした場合には、Magicエンジンを再起動してください。さらにそのサービスを設定したWebサービスコールを再度定義しないと正しく実行できないことがあります。

  • プロバイダにXMLデータをBLOB型で渡す場合、Shift_JISのエンコードで渡してください。

その他

  • Magic eDeveloper V10がインストールされたPCにuniPaaS Studio V1をインストールした場合、どちらかをアンインストールすると MgComCreater.dll がレジストリから削除されます。このような場合は、WindowsのRegsvr32.exeを使用して残った製品のインストールフォルダ内にあるMgComCreater.dllを登録し直してください。


参考技術情報

ここでは、Magic uniPaaS V1Plusについての参考技術情報を紹介します。

  • Windows Vista/7での制限事項

  • Windows Server 2008での制限事項

  • リッチクライアントのオンラインとの違い （Webヘルプにリンクしています）

  • Magic V10のリッチクライアントとの違い

  • Magic uniPaaS V1のリッチクライアントとの違い

  • uniPaaS V1Plus Ver 1.8との違い

  • モバイル開発での注意点

  • Magic uniPaaS for IBM i 追加情報


Windows Vista/7での制限事項

Windows VistaTM／7での留意・制限事項

Windows Vista/7上でMagic uniPaaS V1Plusを実行した場合、現在確認している留意点や制限事項は以下の通りです。

  • Magic uniPaaS V1Plusの動作は、利用するDBMSに依存しますので、各DBMSが Windows Vista/7上で動作が確認されていることが前提となります。ご利用になるDBMSの Windows Vista/7 の対応状況については、各DBMSベンダーの情報をご確認ください。

  • Windows Vista/7上では、MGPRN.HLP, SETSTYLE.HLP, WGAIJI.HLP等、*.hlp の拡張子のファイルは開くことはできません。
    参考：http://support.microsoft.com/kb/917607

  • Windows Vista/7は、Windows XPと互換性のある機能について動作確認いたしました。「Tablet PC」機能などの新機能については、未検証でありサポート対象外となります。

  • ［データベース特性］や［プログラム特性］のタブ内にあるチェックボックスのパラメータの背景が白で表示されます。

  • ［コンポーネント］リポジトリで、.NETアセンブリを新規に登録する際、［参照］タブから正しく選択できないことがあります。

  • LDAPConnect関数で、SSL経由でLDAPサーバに対して正しく接続できません。

  • Systinet Server（SOA Enablement Server）が、%ProgramFiles%（デフォルトは、C:\Program Files） フォルダ内にインストールされた場合、「管理者として実行」を選択して起動時してください。また、Webサービスインタフェースビルダを使用してインタフェースファイルを作成する場合は、Magic uniPaaSも「管理者として実行」を選択して実行してください。

Windows 7特有の制限事項

  • Windows XP Modeはサポートしていません。

JIS X 0213:2004 対応について

  • サロゲート・ペア文字（4バイトのUnicode文字）については、現在対応されておりません。

各種リンク情報

JIS X 0213:2004規格対応により文字フォント変更について　社団法人 電子情報技術産業協会
http://it.jeita.or.jp/perinfo/committee/pc/0612JISX0213-2004/index.html

JIS X 0213:2004 対応と新日本語フォント「メイリオ」について
http://www.microsoft.com/japan/windows/products/windowsvista/jp_font/default.mspx

インストール

  • 実行許可の確認

    • インストールは、Administrators グループに所属しているユーザで行ってください。

    • UAC が有効の場合、インストールプログラムの実行時に［ユーザー アカウント制御］ダイアログが表示されます。ここで［続行］ をクリックしてください。処理が継続して行われます。

  • リッチクライアント実行モジュールのインストールを行う場合、IISの以下の機能をあらかじめ有効化しておく必要があります。

Web 管理ツール

    • IIS管理コンソール

    • IIS6と互換性のある管理

World Wide Web サービス

    • HTTP 共通機能

      • 規定のドキュメント

      • 静的コンテンツ

    • アプリケーション開発機能

      • .NET拡張機能

      • ASP .NET

      • CGI

      • ISAPI フィルタ

      • ISAPI 拡張機能

    • セキュリティ

      • 要求のフィルタリング

Virtual Store

Windows Vista/7ではVirtal Storeが有効になります。Program Filesフォルダにインストールされた Magic uniPaaS をバックアップした場合、バックアップフォルダは、一般ユーザ（Usersグループ）に対して変更／書き込みの権利が割り当てられません。またバックアップされたファイルを使用してMagicエンジンを起動させた場合、環境ファイルは、仮想フォルダ（C:\Users\<ログオンユーザ>\AppData\Local\VirtualStore\Program Files\uniPaaS\<製品名>）に保存される場合があります。

64bit版 Windows 7 上で動作させる場合の留意事項

  • 64bit版のWindows 7では、WOW64（Win32互換API）上での動作に限定されます。WOW64に関する一般的な制限事項が適用される場合がありますので、詳細は以下のURLを参照してください。
    http://support.microsoft.com/kb/896456/ja

  • Magic uniPaaSは32ビットアプリケーションなので、WOW64上で実行されることになり、各DBMSのクライアントライブラリもWOW64上で動作する32ビット版のものが必要になります。Magic uniPaaSの動作は、利用しているDBMSのクライアントライブラリがWOW64での動作を保証していることが前提となりますので、各DBMSベンダーに確認してください。

  • 64ビット版のIIS7から、Magicインターネットリクエスタを実行する場合、「IISマネージャ／サーバホーム／アプリケーションプール／DefaultAppPool／詳細設定／32ビットアプリケーションの有効化」をTrueに設定する必要があります。

  • uniPaaS Studioのデフォルトのインストールフォルダは、C:\Program Files (x86)\uniPaaS\Studioですが、コンポーネント作成用のウィザードユーティリティは、"(" および ")"をフォルダ名としては指定できない文字として判断しています。このため、コンポーネントが作成できない可能性があります。コンポーネント作成を行うような場合は、（これらの文字を使用しない）インストールフォルダに変更するようにしてください。


Windows Server 2008での制限事項

Windows Server 2008での留意・制限事項

Windows Server 2008上でMagic uniPaaS V1Plusを実行した場合の留意点や制限事項は以下の通りです。

  • Magic uniPaaS V1Plusの動作は、利用するDBMSに依存しますので、各DBMSが Windows Server 2008上で動作が確認されていることが前提となります。ご利用になるDBMSの Windows Server 2008 の対応状況については、各DBMSベンダーの情報をご確認ください。

  • MRBを起動する場合、ファイアウォールの例外処理にMRBが使用するポート番号(デフォルト5215)を登録する必要があります。

  • Windows Server 2008上のプロジェクトに対してバージョン管理を行う場合、添付されているCVS NTでは正常に動作しないことがあります。Microsoft Visual Source Safeをご利用いただくようお願いいたします。

  • Systinet Server（SOA Enablement Server） を使用してWebサービス機能を利用する場合、ファイアウォールの例外処理に、Systinet Serverが使用するポート番号(デフォルト6060)を登録する必要があります。また、Systinet Serverの管理ツール(Administration Console)を実行する場合、InternetExploreの保護モードを無効にしないと、正しく動作しないことがあります。

  • Systinet Server（SOA Enablement Server）が、%ProgramFiles%（デフォルトは、C:\Program Files） フォルダ内にインストールされた場合、「管理者として実行」を選択して起動時してください。また、Webサービスインタフェースビルダを使用してインタフェースファイルを作成する場合は、Magic uniPaaSも「管理者として実行」を選択して実行してください。

  • Windows Server 2008 Standard Edition および Enterprise Edition がサポート対象となります。Web Server Edition、Itanium-Based Systems は、サポート対象外です。

64bit版 Windows Server 2008 上で動作させる場合の留意事項

  • 64bit版のWindows Server 2008では、WOW64（Win32互換API）上での動作に限定されます。WOW64に関する一般的な制限事項が適用される場合がありますので、詳細は以下のURLを参照してください。
    http://support.microsoft.com/kb/896456/ja

  • Magic uniPaaSは32ビットアプリケーションなので、WOW64上で実行されることになり、各DBMSのクライアントライブラリもWOW64上で動作する32ビット版のものが必要になります。Magic uniPaaSの動作は、利用しているDBMSのクライアントライブラリがWOW64での動作を保証していることが前提となりますので、各DBMSベンダーに確認してください。

  • 64ビット版のIIS7から、Magicインターネットリクエスタを実行する場合、「IISマネージャ／サーバホーム／アプリケーションプール／DefaultAppPool／詳細設定／32ビットアプリケーションの有効化」をTrueに設定する必要があります。

  • uniPaaS Studioのデフォルトのインストールフォルダは、C:\Program Files (x86)\uniPaaS\Studioですが、コンポーネント作成用のウィザードユーティリティは、"(" および ")"をフォルダ名としては指定できない文字として判断しています。このため、コンポーネントが作成できない可能性があります。コンポーネント作成を行うような場合は、（これらの文字を使用しない）インストールフォルダに変更するようにしてください。


Javaリッチクライアントとの違い

Magic V10のリッチクライアントとの違い

動作環境

Javaの実行環境は必要ありません。.NET Framework CLR(2.0.50727.0以上)が必要になります。

動作が異なる機能

以下の機能は、Magic V10のリッチクライアントと動作が異なります。Magic uniPaaS V1Plusで追加された機能については、新機能の説明を参照してください。

# | 内容
1 | SDIフォームの場合、ESCキーではタスクは終了できません。
2 | サブフォーム上でのタブの動作は、[タスク特性]の[タブサイクル]特性で指定できます。デフォルトは、サブフォーム内の同一レコード内での移動になります。
3 | モーダルウィンドウでタイトルに最大化、最小化ボタン、アイコンが表示されません。
4 | サブフォーム上のコントロールから親タスクのコントロールに移ると、データ書込、および［レコード後］の処理が実行されます。
5 | ［複数行編集］特性が「Yes」の［エディット］コントロールに対して、デフォルトでは改行コードの入力ができません。プログラム（［CR許可］特性）の変更が必要になります。
6 | ［コンボボックス］コントロールをデータコントロールとして定義した場合、データソースにデータがなかったり範囲内にデータがないと、［選択項目リスト］特性に定義された選択肢が表示されます。
7 | 照会モードでは、（［照会モード時修正許可］が｢No｣の場合）コンボボックスの選択肢は開きません。
8 | 削除時の確認ダイアログのデフォルトボタンは「いいえ（N）」になります。
9 | サブフォームが最初にアクティブになった場合にIsFirstRecordCycle()関数を実行すると、'FALSE'LOGが返ります。
10 | 以下の関数が変更されました： FileSize/ClientFileSize → FileInfo/ClientFileInfo FileDlg/ClientFileDlg → FileOpenDlg, FileSaveDlg / ClientFileOpenDlg, ClientFileSaveDlg DbName(番号) → DbName(番号, オプション)
11 | 最初のクライアントの実行は、http://… によって、*.publish.html または、*.applicationを実行します。
12 | バッチ処理の同時実行は、最大スレッド数まで可能です。
13 | バッチ処理中のリッチクライアントタスクのタイムアウト値は未定です。2分以上の動作が可能です。 ただし、長時間のバッチ処理を行う場合は、HTTPコネクションが接続したままになり、その間はWebサーバ資源も開放されませんので、コールリモートの非同期でバッチ処理することを推奨いたします。
14 | ［カラム］コントロールのカラムタイトルに複数行テキストを入力/表示できます。
15 | ClickOnceの仕様により、デジタル証明書が必要になります。 Magic uniPaaSが提供する証明書を使用した場合、発行元が確認できないため、実運用での利用は推奨できません。証明書は（ベリサインなどの）認証機関から取得するか、（Microsoftなどで提供されている）ツールにより作成することを推奨します。
16 | ユーザ認証を行うプロキシがある場合、ClickOnceの仕様により、統合プロキシ認証のみサポートしています。基本認証、ダイジェスト認証等はサポートしません。
17 | ［タブ］コントロールのタブにショートカットの記述(例. ...(&A)など) が有効になりません。
18 | ［プッシュボタン］コントロールの[実行元]特性を「T=フォーカス上のタスク」に設定した場合、[クリックでパーク]特性を「No」に設定する必要があります。
19 | ［プッシュボタン］コントロールの[実行元]特性を「C=コンテナタスク」に設定した場合、[パーキング可]特性を「Yes」に設定する必要があります。


uniPaaS V1との違い

Magic uniPaaS V1のリッチクライアントとの違い

動作環境

uniPaaS RichClient Serverを利用する場合のライセンスは、｢MGRIA1P1｣を指定してください。

RIA_Cacheおよびフォルダに対するエイリアス定義が不要になりました。

［ブラウザ］コントロールの［境界］特性が削除されました。

その他は、新機能の説明を参照してください。


uniPaaS V1Plus Ver 1.8との違い

Magic uniPaaS V1Plus Ver1.8との違い

Ver1.9は、Ver1.8のアップグレード対象です。既に Ver1.8がインストールされているPC上に、Ver1.9の同製品のインストールプログラムを実行した場合は、アップグレードとして動作します。ただし、以下のような点で異なりますのでご注意ください。

機能上の追加／変更内容は、新機能 を参照してください。

 | Ver1.9 | Ver1.8
MRBのポート番号（デフォルト） | 5315、5326、5336、5346 | 5215、5226、5236、5246
エイリアス名（デフォルト） リクエスタ用 アプリケーション公開用 RIAモジュール用 | uni19Scripts uni19RIAApplication （削除） ※旧バージョンのエイリアスはアップグレードも残ります。 | uni18Scripts uni18Applications uni18RIAModules
モジュール名 | mglcl19jp.dll MGrqgnrc019.dll MGrqispi019.dll MGrqcgi019.exe ※旧バージョンのファイルはアップグレード時に削除されます。 | mglcl18jp.dll MGrqgnrc018.dll MGrqispi018.dll MGrqcgi018.exe
MAGIC.INIの設定 | [MAGIC_RIA]セクションでのクライアント実行モジュールの指定は不要となりました。 |
RIAモジュールのフォルダ | RIAModulesサブフォルダの内容が常に上書きされます。リッチクライアントインタフェースビルダによって、アプリケーション毎に個別のフォルダにコピーされます。 | RIAModulesサブフォルダにuniRIA_1_8_XXXというサブフォルダが作成され、そこにインストールされます。


モバイル開発

モバイル開発での注意点

Magic uniPaaSを使用したモバイルアプリケーションの開発は、通常のRIAの開発に似ています。通常RIAとモバイルRIAの主な違いは、モバイル端末の表示領域を考慮することとタッチスクリーンやスタイル、実行方法のような予期されているユーザの経験です。

モバイル開発のパラダイム

モバイル用RIAの開発パラダイムは､Windowsのそれとほぼ同じです。ただし、以下の内容を考慮する必要があります。

環境設定

  • 開発用のPCにCompact Framework Ver2.0以上をインストールしてください。正しくインストールされないと、.NET連携機能（Magicフォーム上の.NETコントロールや［コール.NET］処理コマンド）が動作しません。

  • モバイル用アプリケーションのアセンブリをCompact Framework のものに置き換えてください。これは以下の手順で行ってください。

    1. ［コンポーネント］リポジトリを開きます。

    2. .NET Framework用のアセンブリが定義されている行にカーソルを置き、Alt+Enterを押下して［.NETアセンブリ］特性を開きます。

    3. ［パス］特性のパスをCompact Framework のパス（デフォルトは、"C:\Program Files\Microsoft.NET\SDK\CompactFramework\v2.0\Debugger\BCL"）に変更します（ファイル名は変更しないでください）。

    4. ［OK］をクリックして、ダイアログを閉じます。

    5. 同じ処理を他のアセンブルに対しても行ってください。

  • アセンブリを新規に登録する場合は、以下の手順で行ってください。

    1. ［コンポーネント］リポジトリを開きます。

    2. F4を押下して1行追加します。

    3. ［タイプ］カラムで「.」（ピリオド）を押下して、表示を「.NET」に変更します。

    4. ［名前］カラムでF5を押下して［.NETアセンブリ選択］ダイアログを開きます。

    5. ［参照］タブをクリックします。

    6. Compact Framework のパスのdllファイルを選択し、［OK］をクリックします。

    7. 同じ処理を他のアセンブルに対しても行ってください。

  • アセンブリによっては定義できないファイルがあります。この場合、［コンポーネント］リポジトリの行番号カラムに赤い×印が表示されます。

  • 同じアセンブリ(dllファイル名が同じ)の場合、.NET Framework用と Compact Framework用を共存して定義することはできません。

画面設計

  • 画面サイズ …… モバイル端末の画面は､デスクトップPCよりかなり小さく、操作はより複雑です。従って、それに応じて画面設計を行う必要があります。マルチフォームを利用することを推奨します。

  • 画面の解像度 …… モバイル端末は、機種によって解像度が異なるため、表示する各コントロールの[位置]特性を利用することを推奨します。高さ:100、幅:100に設定することで画面サイズに応じて、コントロールのサイズを変更させることができます。

  • 縦長画面の場合、以下の[フォーム特性]を目安に設定することで、画面内に収まります。

    • フォントサイズ：9

    • 幅: 40

    • 高さ: 24.5

機能設計

  • 性能 …… モバイル端末は､デスクトップPCより遅いため、クライアント側でCPUを消費するプロセスの実行は避けるようにしてください。

  • .NET機能 …… モバイル用のリッチクライアントモジュールは､.NET Compact Framework上で実行されます。.NET Compact Frameworkは.NET Framewok のサブセットであり、いくつかの機能（クラスやメソッドなど）が省略されています。詳細は、Microsoftの技術文書で確認して利用してください。

  • 機種依存性 …… 実行させるモバイル機器によってIMEなどの動作が異なる場合があります。利用する機種で事前に確認しておく必要があります。

  • タスクのネスト …… 通常のリッチクライアントタスクと同じようにタスクをネストさせることができますが、ネストを深くすると操作性が悪くなる可能性があります。

モバイル関数

Magic uniPaaSには､IsMobileClientと呼ばれる関数が含まれています。この関数は、クライアントがモバイル端末かどうかをチェックすることができます。

動的にモバイル端末用に適当なフォームを選択できるようにロジックを作成したい場合は、この関数を使用することができます。


Magic uniPaaS for IBM i 追加情報

Magic uniPaaS for IBM i Ver1.9g 追加情報

本文書では､ 弊社 Magic uniPaaS for IBM i バージョン Ver1.9g (以下、Magic uniPaaS for IBM i) に関して、マニュアルの記載事項以外の追加情報が記述されています。

動作環境

本 Magic uniPaaS for IBM i は、uniPaaS Studio / uniPaaS Client / uniPaaS Enterprise Server / uniPaaS RichClient Server の各製品とともに使用することができます。

２種類のホストライブラリが提供されています。

ホストライブラリ バージョン | 対応OS
9450-47006 （V1.3） | OS400 V5R4 / V6R1 / V7R1
9450-46012 （V1.1-a） | 9450-46012 （V1.1-a）

uniPaaS Studioのインストーラで提供されるホストライブラリは、9450-47006（V1.3）です。　V5R3環境で使用したい場合は、9450-46012（V1.1-a）をインストールしてください。　9450-46012（V1.1-a）は、Ver1.9gのuniPaaS Studioで一度インストールするか、製品CD-ROMのServers\IBM i\HOST\V5R3-V6R1に格納されています。

以下の環境で動作確認を行っています。 その他の環境については、下記のものと互換性のある場合のみ使用可能です。

ホストライブラリ バージョン | 9450-47006 （V1.3）
ホストOSバージョン | OS400 V5R4 / V6R1 / V7R1
クライアントOS バージョン | Magic uniPaaS の動作する環境
Magicバージョン | Ver 1.9g

ホストライブラリ バージョン | 9450-46012 （V1.1-a）
ホストOSバージョン | OS400 V5R3 / V6R1
クライアントOS バージョン | Magic uniPaaS の動作する環境
Magicバージョン | Ver 1.9g

また、動作環境に関する最新の情報は、弊社HPでも公開しております。

http://www.magicsoftware.co.jp/products/mgenv/dbmsunipaas1plus.htmlを参照してください。

ホストライブラリ関連の注意点

  • 開発ライセンス（D$MAGICE9）を正常に登録できた環境でも、ユーザプロファイルのCCSIDが5026を使用している場合、接続時に「Your Activation Key on AS/400 is not valid or not present You need to enter a license key. (License code:D$MAGICE9,Server:XXXXX,User:XXXXX) のエラーが表示される場合があります。その場合は、以下の手順で再度ライセンスを登録してください。

    1. ホストライブラリに対する CHANGE 権限を持つユーザ（QSECOFR など）でログオンします。

    2. ホストライブラリをカレントライブラリとします。CHGCURLIB MAGIC400 ［実行］

    3. ジョブのCCSID を 5026 に変更します。CHGJOB CCSID(5026) ［実行］

    4. EASYCLEF と入力し、再度ライセンスを登録します。

  • MGCLIENTジョブが起動、終了等を行うとメッセージ待ち行列（MAGIC400/MAGICMSGQ）にメッセージが格納されます。

メッセージ例

Client job Completed in MAGIC400/MAGIC

FROM . . : QPGMR 02/23/11 00:16:59

Client job started in MAGIC400/MAGIC

FROM . . : QPGMR 02/23/11 00:16:46

システムを長期間使用した場合、メッセージ待ち行列が満杯になり、MGCLIENTが起動しなくなる場合があります。

その場合は、以下の対応を検討してください。　（ホストライブラリがMAGIC400の場合）

定期的にメッセージをクリアーする

定期的に以下のコマンドを実行します。

CLRMSGQ MSGQ(MAGIC400/MAGICMSGQ) CLEAR(*KEEPUNANS)

メッセージが満杯時に折り返すように設定する

メッセージが満杯時に折り返すように以下のように設定します。

CHGMSGQ MSGQ(MAGIC400/MAGICMSGQ) MSGQFULL(*WRAP)

Magic uniPaaS V1からのバージョンアップ

ホストライブラリのライセンスは、Magic uniPaaS V1と同じライセンスコードです。

同じホストライブラリを使用するため、既にV1のホストライブラリがインストールされている場合は、インストールする必要がありません。

Magic uniPaaS V1.8SP1bからのバージョンアップ

特にホストライブラリを変更する必要はありませんが、変更したい場合は、現在のホストライブラリを一度削除し、再度インストールを行います。

ライセンスコードは、同一です。

ホストライブラリの削除は、以下の方法により行います。（ホストライブラリがMAGIC400の場合）

  1. ホストライブラリに対する CHANGE 権限を持つユーザ（QSECOFR など）でログオンします。

  2. ホストライブラリ以外をカレントライブラにします。

CHGCURLIB QSYS ［実行］

  3. MAGICサブシステムを終了させます。

ENDSBS SBS(MAGIC) OPTION(*IMMED) ［実行］

  4. ライブラリを削除します。

DLTLIB LIB(MAGIC400) ［実行］

制限事項および留意事項

Unicodeに関する制限事項

uniPaaS IBM i GatewayによるUnicode型項目の制御に関して、いくつかの制限事項があります。
詳細は、「Magic uniPaaS for IBM i 開発者ガイド」第4章を参照してください。

ISAMゲートウェイ

  • データ特性／SQLタブ／SQLデータベース情報にてCACHEパラメータを指定し、メインソースに指定したファイルと同じファイルをデータリンクした場合、正しくリンクできないことがあります。その場合は、同一ファイルでデータリンクを 行うファイルのみをCACHEパラメータを指定しないようにしてください。

  • ISAMファイルの[データベース特性]に「*RNGSVR=Y」を指定した場合、親子タスクの両方で、同じファイルをメインソースに指定し、かつカラム定義で範囲指定を行ったプログラムを実行すると、子タスクでファイルのオープンに失敗します。

  • ISAMファイルのキーに数値項目が含まれ、かつ[データソース特性]の[更新レコードの識別]特性に「S=位置と選択項目」または「U=位置と更新項目」を設定した場合、実行時にレコードの修正、または削除に失敗することがあります。その場合はMAGIC.INIに次の設定を行ってください。

    [MAGIC_SPECIALS]
    SpecialNegativePackedDecimalNotation=Y

  • トランザクション設定したファイルの構造を変更する場合は、事前にトランザクション設定を外して変更することをお奨めします。外さずにファイル変更を行うとファイル変換時にCommitment Control Errorが発生する場合があります。

トランザクション設定を外す方法：

    1. テーブル変換の前に'TRANSACTIONS=N'に変更します。

    2. 「変更しますか？」と聞いてきた場合は、'No'を選択します（テーブル変換は実施しません）。

    3. 5250エミュレータ上で、ジャーナル、ジャーナルレシーバを削除します（必要に応じてバックアップします）。

    4. Magic uniPaaSを再起動します。

    5. ファイル変換処理を行います。

    6. 'TRANSACTIONS=Y'に設定します。

    7. 「変更しますか？」と聞いてきた場合は、'No'を選択します（テーブル変換は実施しません）。

    8. APGを実行してジャーナルが生成されるのを確認します。

SQLゲートウェイ

  • Studioで定義取得する場合は、QSYS/QADBXREFへのアクセス権限が必要です。例えば、＊ALLOBJ特殊権限があるユーザプロファイルを使用してください。この権限がない場合、書式が正しく取得できません。

  • メインソースの[共有]特性を「N=なし」に設定したプログラムを実行してテーブルロックが発生した場合、プログラムが終了しても、テーブルに対する排他ロック、または共有ロックが解除されないため、それ以降テーブルがオープンできなくなることがあります。これは、SQLゲートウェイではコミット処理に関して、すべてのカーソルがクローズするCOMMITコマンドでなく、 COMMIT HOLDコマンドを実行していることによるものです。ロックを解除すると同時にカーソルをクローズしても構わない場合、SQLコマンドでCOMMITを実行するか、アプリケーションを再起動してください。

  • バッチタスクでトランザクションレベルがレコードの場合、BLOB項目のあるテーブルをバッチ処理すると、エラーが発生します。BLOB項目のあるデータソースをバッチ処理する場合には、[トランザクション開始]特性を「T=タスク前の前」に設定してください。


付録

  • 各種リンク情報

  • 本製品での未サポート機能

  • ベータ機能評価レポート

  • Magic uniPaaS V1Plus 使用許諾契約書

    • uniPaaS Studio あるいは Client の場合

    • uniPaaS Enterprise Server あるいは uniPaaS RichClient Server の場合


各種リンク情報

以下のリンク先にも参照してください。

MSJ のホームページ(TOPページ)

Magic uniPaaS V1Plus紹介サイト

テクニカルサポート（サポート契約のご案内）

プロフェッショナルサービス

トレーニングコース

Magic On Demand Seminar

Magicアップデートのダウンロード

RM Converterのダウンロード

Magicスキルアップセンター

XML対応帳票ソリューション「ReportsMagic」

Magic開発者のためのプログラム最適化ツール「Magic Optimizer」

パッケージソフト紹介サイト


本製品でのベータ機能

以下の機能は本製品で提供されていますが、マジックソフトウェアジャパンのサポートセンターでのサポート対象外です。ご意見、ご質問、気が付いた点などは、「ベータ評価レポート」に記入して、メールで japan_v10beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

未サポート機能一覧

  • ユーザ定義開発メニュー

  • J2EE クライアント/サーバ

  • 以下のコンポーネント ジェネレータ

    • Stored Procedure
    • UDDI Component

  • 以下のインターフェース ビルダ

    • EJB

  • ODBC ゲートウェイ

  • ISO-Visual/Logical 変換

  • PPD

  • PDF出力

  • Reports Generetor

  • 外部テストツール(WinRunner)

  • メッセージングコンポーネント


未サポート機能評価レポート

ベータ機能評価レポート

ベータ機能に関するご質問等は、マジックソフトウェアジャパンのサポートセンターではお受けいたしておりませんが、ご意見、ご質問、気が付いた点などは、下記の「ベータ 評価レポート」に記入して、メールで japan_v10beta@magicsoftware.comまでお送りください。製品の改善に反映させていただきたいと思います。

Magic uniPaaS V1Plus ベータ機能評価レポート

記入日： 年　 月 　 日

会社名：

担当者：

E-mail：

ＴＥＬ：

ＦＡＸ：

サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境

ＰＣ機種：

ＣＰＵ：

ＲＡＭ：

ＯＳ： （ ） Windows XP／（ ） Windows Vista ／（ ） Windows Server 2003／（ ） Windows Server 2008
／（ ） Windows 7 ／（ ） Windows Server 2008R2

言語：

プリンタ：

使用サーバ：

２．評価結果

対象製品： （ ）uniPaaS Studio （ ） uniPaaS Enterprise Server （ ） uniPaaS Client （ ） uniPaaS RichClient Server

製品バージョン： （ ） ※ SPxx まで含め、正確に記入してください。

該当する（ ）に＊を挿入してください。

Ａ （ ） 問題無し

Ｂ （ ） 一部支障あり

Ｃ （ ） 正常に動作しない

Ｄ （ ） インストール・起動不可

上記２でＢ，Ｃ，Ｄの場合、以下の内容をお書きください。

３． 再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

４．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なうために、極力画面のハードコピー、サンプルプログラム等の提供をお願いいたします。）

５．その他ご意見


Magic uniPaaSr V1 使用許諾契約書

Magic uniPaaS V1Plus 使用許諾契約書

Magic uniPaaS V1Plusの使用許諾契約書には、Studio あるいは Client 製品のものと、Enterprise Server あるいは RichClient Server 製品のものと2種類あります。ご購入になった製品の使用許諾契約書を参照してください。

  • uniPaaS Studio あるいは Client の場合

  • uniPaaS Enterprise Server あるいは uniPaaS RichClient Server の場合

  • Magic uniPaaS V1Plus ソフトウェアメンテナンス契約書


Magic uniPaaS V1 使用許諾契約書(Studio)

Magic uniPaaS® V1Plus 使用許諾契約書

uniPaaS Studio
uniPaaS Client

No. MSJC-12-001-1

お客様へのお願い

このパッケージに入っているソフトウェアをご購入またはご使用にあたり、本契約書を十分にお読みください。このパッケージを開封された場合には、本契約に同意されたものとみなします。
このパッケージを開封された際には、ユーザ登録を行ってください。ユーザ登録をされていない場合には、このパッケージに入っているソフトウェアに関するサポートは致しかねますので、ご了承ください。

Magic Software Enterprises社（以下「MSE」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「MSJ」という）まで書面にてご連絡いただきますようお願い致します。

1. 総則

許諾プログラムに関する全ての著作権は、MSEが保有しています。MSEはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。

2. 契約期間

本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。

3. 使用権

使用権の内容はお客様が購入された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守してください。

  • uniPaaS Studioの場合
      お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途取得しなければなりません。

  • uniPaaS Clientの場合
      お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて、又は購入したユーザ数分を特定のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途取得しなければなりません。

4.　制限

お客様は、以下の行為をしてはならないものとします。（但し、MSE による書面による同意がある場合は、この限りではありません。）

(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。

(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。

(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。

(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。

(5) ASPやSaaSあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)

5. 許諾プログラム等の複製

(1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。

(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。

(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、MSEの事前の許諾を得るものとします。

6. ＭＳＪおよびＭＳＥの保証の範囲

(1) MSJおよびMSEは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってMSJおよびMSEの唯一の保証とします。

(2) MSJおよびMSEの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。

7. 契約の解約

MSJは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。

8. 契約終了時の措置

本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。

9. 一般条項

本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。

10. 準拠法および裁判管轄

本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


Magic uniPaaS V1 使用許諾契約書(Server)

Magic uniPaaS® V1Plus 使用許諾契約書

uniPaaS Enterprise Server
uniPaaS RichClient Server

No. MSJC-12-002-2

お客様へのお願い

ソフトウェアをご購入またはご使用にあたり、本契約書を十分にお読みください。
ソフトウェアのご使用前に、ユーザ登録を行ってください。ユーザ登録をされていない場合には、このパッケージに入っているソフトウェアに関するサポートは致しかねますので、ご了承ください。

Magic Software Enterprises社（以下「MSE」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「MSJ」という）まで書面にてご連絡いただきますようお願い致します。

1. 総則

許諾プログラムに関する全ての著作権は、MSEが保有しています。MSEはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。

2. 契約期間

本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。

3. 使用権

使用権の内容はお客様が購入された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守してください。

  • uniPaaS Enterprise Server の場合

お客様は、許諾プログラムを機械読取可能な形で、コンピュータ・システムにおいてお客様が購入した合計のインスタンス数、及びスレッド数分を同時に使用すること（以下「使用権」という）ができます。

  • uniPaaS RichClient Server の場合

お客様は、許諾プログラムを機械読取可能な形で、コンピュータ・システムにおいてお客様が購入した合計のユーザ数分を同時に使用すること（以下「使用権」という）ができます。

  • uniPaaS RichClient Server for Mobile の場合

お客様は、許諾プログラムを機械読取可能な形で、コンピュータ・システムにおいてお客様が購入した合計のユーザ数分をインストールして使用すること（以下「使用権」という）ができます。

  • スタンバイ・ライセンス　オプション

お客様は、高可用性環境でスタンバイ・システムを設定するために、uniPaaS Enterprise ServerまたはuniPaaS RichClient Serverに対してスタンバイ・ライセンスを使用することができます。本番用ライセンスに障害が発生している場合にスタンバイ・ライセンスを使用することのできる制限的な権利を意味します。本番用ライセンスと同じ構成でライセンスが必要です。

4.　制限

お客様は、以下の行為をしてはならないものとします。（但し、MSE による書面による同意がある場合は、この限りではありません。）

(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。

(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。

(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。

(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。

(5) ASPやSaaSあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)

5. 許諾プログラム等の複製

(1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。

(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。

(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、MSEの事前の許諾を得るものとします。

6. MSJおよびMSEの保証の範囲

(1) MSJおよびMSEは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってMSJおよびMSEの唯一の保証とします。

(2) MSJおよびMSEの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。

7. 契約の解約

MSJは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。

8. 契約終了時の措置

本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。

9. 一般条項

本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。

10. 準拠法および裁判管轄

本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


Magic uniPaaS V1 ソフトウェアメンテナンス契約書

Magic uniPaaS® V1Plus ソフトウェア・メンテナンス契約書

uniPaaS Enterprise Server
uniPaaS RichClient Server

No. MSJC-12-003-1

お客様と、マジックソフトウェア・ジャパン株式会社（以下「MSJ」という）とは、お客様が購入される、MSJの親会社であるMagic Software Enterprises Limited（以下「MSE」という）が著作権等の知的財産権を有しMSJが日本国内の販売権を有する本件製品（後に定義する）について、以下の通りソフトウェア・メンテナンス契約（以下「本契約」という）を締結します。

第1条 （本件製品）

本契約の対象となる製品（以下、「本件製品という」）は、Magic uniPaaS V1Plus購入申込書のサイト情報（以下、「サイト」という）に記載された、お客様の同一サイトに導入される全てのuniPaaS Enterprise Server/uniPaaS RichClient Server/uniPaaS RichClient Server for Mobileとなります。

第2条 （ソフトウェア・メンテナンス）

本契約によりMSJからお客様に提供されるサービスは、第3条および第4条（以下、「ソフトウェア・メンテナンス」という）の通りです。

第3条 （メンテナンス）

MSJはお客様に対して、本件製品のプログラムの一般的に入手可能な最新バージョンもしくはアップデートモジュールを提供します。ただし、これらがMSEより提供された場合に限ります。

第4条 （サポート）

1． MSJはお客様に対して以下のサポートを提供します。

(1) 導入や使用方法に関する日常的、かつ短時間の質問に対する応答

(2) プログラム・コードに起因する障害に対するサポート

2． MSJはMagicサポートセンターのサービス提供時間中に、電子アクセスを介して、お客様のテクニカル・サポート担当者にのみサポートを提供します。

3． 本契約には以下のサポートは含まれません。

(1) アプリケーションの設計と開発に対するサポート

(2) プログラムの指定稼動環境以外の環境における本件製品の使用に関するサポート

(3) 本契約の下でMSJが責任を負わない製品に起因する障害に対するサポート

第5条 （保証）

第3条および第4条は、本契約に基づくソフトウェア・メンテナンスについての保証のすべてを規定したもので、法律上の瑕疵担保責任、商品性の保証および特定目的適合性の保証を含む全ての明示もしくは黙示の保証責任、または保証条件に代わるものとします。

第6条 （有効期間）

本契約の有効期間は、サイトに最初に導入される本件製品がMSJからお客様に出荷された日（以下、「効力発生日」という）から、１年後の同月末日（以下、「有効期間満了日」という）までとします。ただし、効力発生日が月の第1日目の場合は、効力発生日から１年後の前月末日までとします。第11条あるいは第12条の規定により本契約が終了あるいは解除されない限り、本契約は更に１年間自動更新されるものとし、それ以降も同様とします。

第7条 （ソフトウェア・メンテナンス更新日）

本契約の有効期間満了日の翌日が、サイトに最初に導入される本件製品のソフトウェア・メンテナンス更新日となります。

第8条 （契約の継続）

お客様が、本契約の継続を行わず、後日、ソフトウェア・メンテナンスの取得を希望する場合には、未契約期間の2倍の費用をMSJに支払うことにより継続することができることとします。

第9条 （追加導入）

同一サイト内に本件製品が追加導入される場合、追加導入される本件製品の最初のソフトウェア・メンテナンス更新日は、その本件製品が、MSJからお客様に出荷された日から１年後の翌月第１日目とします。ただし、出荷された日が月の第1日目である場合は、1年後の同日とします。最初に導入された本件製品のソフトウェア・メンテナンス更新日と、追加導入された本件製品のソフトウェア・メンテナンス更新日が一致しない場合は、以降の更新を、最初に導入された本件製品のソフトウェア・メンテナンス更新日に合わせるために、追加導入された本件製品のソフトウェア・メンテナンスを月単位で料金調整し、最初に導入された本件製品の更新時に合わせてお客様に請求します。

第10条 （サイト管理）

ソフトウェア・メンテナンスのライセンスを管理する単位をサイトといい、同一法人、同一敷地の管理とします。同一サイトで複数の本件製品を導入する場合は、前条により、それらのソフトウェア・メンテナンス更新日は同一日となります。

第11条 （契約の終了）

MSJが、本件製品のソフトウェア・メンテナンスを終了する場合、MSJは、事前にお客様に通知することとし、MSJは、自らの裁量により、有効期間満了日まで本件製品に対するソフトウェア・メンテナンスをお客様に対して提供するか、またはMSJに対して月割り計算した料金を返金します。

第12条 （契約の解除）

1． お客様は、MSJに文書により通知することにより本契約を解除することができます。

2． MSJは、お客様が本契約に定める事項に違反した時、またはお客様において本契約を継続しがたい重大な事由があるとMSJが認めた時は、お客様に対し、何ら事前の通知なしに直ちに本契約を解除できるものとします。

3． 本条第1項および第2項によって契約が解除された場合、MSJは支払い済みの料金を返還しません。

第13条 （協議事項）

本契約に定めのない事項あるいは本契約の履行について疑義の生じた場合は、お客様およびMSJ並びにMSJは誠意をもって協議し、解決に努力するものとします。

第14条 （合意管轄）

本契約から生ずる一切の権利義務に関する紛争については、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


Unicodeを利用する場合の注意事項

はじめに

この文書はMagic eDeveloper V10 からサポートされたUnicodeを利用する際の補足事項をまとめたものです。

プロジェクト開発

Unicode文字を設定できる箇所

開発するプロジェクトの中で設定するデータは、アプリケーション実行時に表示あるいは出力するデータ項目について、Unicode特有の文字を登録することができます。開発者のみ参照できるデータ項目については、Shift-JISコードに含まれる文字のみ登録可能です。

Unicode特有の文字を設定できる箇所

Unicode特有の文字を設定できない箇所

  • フォーム名

  • 定義式の文字データ

  • テキストコントロールの文字データ

  • ユーザメニュー名

  • ヘルプ項目のテキスト

  • モデル、データソース、プログラム等の各リポジトリ名

  • データソースの項目名

  • インデックス名

  • 外部キー名

  • 変数名、パラメータ名

  • ユーザイベント名

  • フォーム内のコントロール名

  • その他、左記以外の箇所

実行エンジンの動作

データの照合順序

Shift-JISとUnicodeは、格納される文字コードが異なりますので、それぞれをキー項目としたデータの処理順序が異なることにより、プログラムの範囲抽出処理やバッチのグループ処理に影響がでる可能性があります。
また、SQLデータベースを利用する場合は、そのデータベースマネージャ固有の機能や設定による影響があります。

文字コードを比較した場合の文字種類別の順序は次の通りです。

Shift-JIS（文字型項目)のコード順序 | Unicode(Unicode型)のコード順序
1.半角数字 2.半角英 3.半角カナ 4.全角数字 5.全角英 6.ひらがな 7.カタカナ 8.漢字 | 1.半角数字 2.半角英 3.ひらがな 4.カタカナ 5.漢字 6.全角数字 7.全角英 8.半角カナ

漢字については、個々の漢字のコード順序が異なります。 例えば、「亜」と「一」ではShift-JISとUnicodeで、次のようにコードの順序が異なります。

 | 亜 | 一 | 結果
Shift-JIS | 0x889F | 0x88EA | 亜が一より先
Unicode | U+4E9C | U+4E00 | 一が亜より先

関数

文字型項目をパラメータに持つ関数に対して、文字型項目とUnicode型項目を設定した場合の戻り値は次のようなルールがあります。

  • 文字型/Unicode型のパラメータ数を数える。(それぞれを m, n とする) ※ 文字定数の場合は、文字型/Unicode型共に+1する

  • m≠n ならば、多い方のアルゴリズムを採用

  • m=n であり、戻り値が文字型かUnicode型ならば、戻り値にあわせる。

  • m=n かつ戻り値が文字型/Unicode型以外ならば、デフォルトとして文字型とする。

  • 文字型の場合、全角文字は1文字を2でカウントしますが、Unicode型の場合、全角文字を1文字を1でカウントします。

例1. Len関数

文字列の長さを数える関数
書式：　戻り値 = Len(文字パラメータ)

  • 項目Aが文字型項目で'あ'を格納した場合、Len(RTrim(A))の戻り値は2です。

  • 項目BがUnicode型項目で'あ'を格納した場合、Len(RTrim(B))の戻り値は1です。

例2. MID関数

文字列の中から、指定された位置とサイズにあった、文字列を取得する関数
書式：　文字の戻り値 = MID(文字パラメータ, 開始位置, 文字数)

# | パラメータの型 | 戻り値の型 | 戻り値の結果
1 | 文字型 | 文字型 | バイト単位に取得
2 | 文字型 | Unicode型 | バイト単位に取得
3 | Unicode型 | 文字型 | 文字単位に取得
4 | Unicode型 | Unicode型 | 文字単位に取得
5 | 値(*1) | 文字型 | バイト単位に取得
6 | 値(*1) | Unicode型 | 文字単位に取得

*1 式に直接、'あいうえお'などの文字列を指定する場合

例3. REP関数

文字列中の位置と文字数を指定し、その部分を別の文字列に置き換える関数
書式：　文字の戻り値 = REP(文字パラメータ1, 文字パラメータ2, 位置, 文字数)

# | パラメータ1の型 | パラメータ2の型 | 戻り値の型 | 戻り値の結果
1 | 文字型 | 文字型 | 文字型 | バイト単位に取得
2 | 文字型 | 文字型 | Unicode型 | バイト単位に取得
3 | 文字型 | Unicode型 | 文字型 | バイト単位に取得
4 | 文字型 | Unicode型 | Unicode型 | 文字単位に取得
5 | Unicode型 | 文字型 | 文字型 | バイト単位に取得
6 | Unicode型 | 文字型 | Unicode型 | 文字単位に取得
7 | Unicode型 | Unicode型 | 文字型 | 文字単位に取得
8 | Unicode型 | Unicode型 | Unicode型 | 文字単位に取得
9 | 文字型 | 値(*1) | 文字型 | バイト単位に取得
10 | 文字型 | 値(*1) | Unicode型 | バイト単位に取得
11 | Unicode型 | 値(*1) | 文字型 | 文字単位に取得
12 | Unicode型 | 値(*1) | Unicode型 | 文字単位に取得
13 | 値(*1) | 文字型 | 文字型 | バイト単位に取得
14 | 値(*1) | 文字型 | Unicode型 | バイト単位に取得
15 | 値(*1) | Unicode型 | 文字型 | 文字単位に取得
16 | 値(*1) | Unicode型 | Unicode型 | 文字単位に取得

*1 式に直接、'あいうえお'などの文字列を指定する場合

その他の関数の留意事項

  • 文字型項目からUnicode型項目、またはUnicode型項目から文字型項目への代入、または項目更新処理を行う場合、内部で変換を行いますので、UnicodeFromANSI関数/UnicodeToANSI関数を使う必要はありません。
  • 現在のバージョンでは、Mail関数(MailSend/MailMsgTextなど）は、Unicode特有の文字は対応していません。

その他

  • 入出力ファイルのメディアにテキスト形式プリンタを設定した印刷処理では、Unicode特有の文字の印刷は対応していません。Unicode型データはGUI形式プリンタに設定して印刷してください。

  • メッセージコンポーネントに対して、Unicode型のパラメータを渡すことはできません。

  • フォーム入力で、UnicodeやUTF-8のファイルタイプの場合、文字型項目に入力すると文字列がカットされる場合があります。

  • フォーム出力で、ANSIのファイルタイプの場合、Unicode型項目を出力すると文字列がカットされる場合があります。

  • サロゲート・ペア文字（4バイトのUnicode文字）については、現在対応されておりません。

Unicode対応のWebアプリケーションを作成する場合

マージ機能を用いて Shift-JISに存在しないUnicode固有の文字を使う Web アプリケーションを作成する場合には、以下の点に留意してください。

  • V10では、マージテンプレートファイル、および、テンプレートに埋め込むデータに、日本語およびUnicode固有文字を使うことができます。

  • マージテンプレートファイルに、Unicode固有の文字を使う場合には、BOM (Byte Order Marker) 付きの UTF-8 で格納してください。BOMを付加しなければ、デフォルトで Shift-JIS と解釈されますので、正しい結果が得られなくなります。テンプレートにUnicode固有文字を使わない場合には、Shift-JISでも構いません。

  • 入出力ファイルテーブルでは、リクエスタを定義する際、入出力ファイル特性の「使用する文字セット」パラメータに「T=UTF-8」を指定してください。Webブラウザへ返送されるHTMLデータが UTF-8 でエンコードされます。A=Ansi あるいは O=OEM では、Shift-JISに変換されるので、Unicode 固有の文字が正しく出力されません。

  • ハイパーリンクをクリックしたり、フォームのサブミットを行った時には、WebブラウザからWebサーバへ送信されるHTTPリクエスト(GETおよびPOST)のパラメータは、UTF-8 でエンコードされてWebサーバに送信されます。文字コードを正しく解釈するために、Magicエンジン(eDevRTE.exe) と同じフォルダにある MGREQ.INI ファイルで、ConvertAlphaFromUTF8ToUnicode = Y フラグを設定してください。このフラグについては、Ver 10.1J SP1a での新機能 を参照してください。

  • ハイパーリンクで定義されたURLに、日本語やUnicode固有文字を埋め込むと、WebブラウザからWebサーバへ送信されるHTTPリクエスト(GET)に不正な文字が入ることがあります。URLにはこのような文字を避けてください。

  • フォームでサブミットするとき(POSTリクエストの場合)には、パラメータに日本語やUnicode固有の文字を使うことはできますが、アプリケーション名や公開プログラム名に使うと正しく動作しません。アプリケーション名や公開プログラム名には、半角英数字のみを使うようにしてください。

データベース固有の制限事項

MS-SQL Server

  • Unicode型/BLOB型(Unicodeタイプ)に設定したときに対応するMS-SQL Serverのカラムタイプは次の通りです。

データソースの型／内容 | データソースのサイズ | MSSQL Serverの型
Unicode型 | 1-4000 | nvarchar
Unicode型 | 4001以上 | ntext
BLOB型/Unicode | - | ntext/イメージ(*)

*SP2から記憶型式により異なります。

  • デフォルトの照合順序が設定されたデータベースでは、Unicodeに依存しないMS-SQL Serverのソート処理により、文字型項目のソート処理の結果と互換性があります。

  • 埋込SQLの入力パラメータにUnicode特有の文字を渡す場合、パラメータの先頭文字にNを付加する必要があります。
    例．select * from TESTTAB where UNICODEMOJI = N':1'

  • 文字型255桁のカラムを含むデータソースをMagicで定義し、APG実行によりテーブル作成しようとすると「SQL0604N 列の長さ、精度、または位取り属性、特殊タイプ、構造化タイプ、構造化タイプの属性、関数、あるいはタイプ・マッピング "CHAR(255)" が無効です。 SQLSTATE=42611」とエラー表示され、テーブル作成できません。(2000326)

  • 埋込SQLの入力パラメータ、およびDB SQL WHEREのパラメータにUnicode特有の文字を渡す場合、パラメータの先頭文字にNを付加する必要があります。

例．select * from TESTTAB where UNICODEMOJI = N':1'

Oracle

  • Unicode型/BLOB型(Unicodeタイプ)に設定したときに対応するOracleのカラムタイプは次の通りです。

データソースの型／内容 | データソースのサイズ | Oracleの型
Unicode型 | 1-2000 | NVARCHAR2
Unicode型 | 2001以上 | NCLOB
BLOB型/Unicode | - | NCLOB/BLOB (*)

*SP2から記憶型式により異なります。

  • SQL WHERE句に Unicode 固有の文字を文字定数として使うことはできません。

  • 埋込SQLのINOUTのパラメータが定義されたプロシージャに対して、出力パラメータにUnicode型項目を指定した場合、正しく動作しません。

  • 埋込SQLの入力パラメータにUnicode固有の文字を指定する場合、バインド変数(接頭辞にコロン(:)でなく、チルダ(~)を指定）を指定してください．この場合、パラメータを''で囲む必要はありません。

DB2 UDB

  • Unicode型/BLOB型(Unicodeタイプ)に設定したときに対応するDB2 UDBのカラムタイプは次の通りです。

データソースの型／内容 | データソースのサイズ | DB2 UDBの型 | データベースのコードセット(*1)
Unicode型 | 1-127 | GRAPHIC | UTF-8(*2)
Unicode型 | 128-16333 | VARGRAPHIC | UTF-8(*2)
Unicode型 | 16336以上 | DBCLOB | UTF-8(*2)
BLOB型/Unicode | - | DBCLOB/BLOB (*3) | IBM-943(デフォルト)

  • *1 データベース作成時に指定し、作成後に変更できません。

    *2 IBM-943に設定した場合、半角英数字、およびUnicode特有の文字が正しく格納できません。

*3 SP2から記憶型式により異なります。

  • DB2 UDB V8.2で、Unicode型項目のあるテーブルの新規作成に失敗する場合、db2cli.iniに次のパラメータ を設定してください。このファイルは通常、クライアントマシンのDB2 UDBクライアントモジュールをインストールしたフォルダに存在します。

[Common]
Graphic = 1

  • 埋込SQLのステートメントやSQL Where句は、Shift-JISの文字列でデータベースに送るため、入力パラメータにUnicode特有の文字を渡しても、正しく動作しません。

  • UTF-8に設定されたデータベースでは、文字型項目についても内部コードがUTF-8で格納されるため、次のような問題があります。

    1. ２バイト文字を最大桁数まで登録しようとすると、「SQL0302N EXECUTE またはOPENステートメント内のホスト変数の値が大きすぎます。 SQLSTATE=22001」のエラーが発生します。
    2. ソート順序がUTF-8の文字コード順になります。

Pervasive.SQL (ISAM)

  • Unicode 型項目を扱うためには、ファイルフォーマットを 7.x あるいはそれ以上にしてください。これは P.SQL の仕様制限によるものです。

  • Unicode 型項目をインデックスとした場合、正しく並ばないことがあります。これは P.SQL の問題で、「P.SQL8 SP3およびP.SQL SP2において対応されています。
    AG-TECH社のホームページ http://www.agtech.co.jp/download/update/pervasive/psqlv8s3/history.html に、以下のような情報があります： 「49474 mkde mkde Btrieve WSTRING キーで UNICODE 文字列データの並べ替え順に問題があった。」


マルチ言語環境で開発する上での注意事項

異なる言語用のWindows OS上でMagicアプリケーションを開発する場合に注意すべき内容は以下の通りです。OSは、Windows 7を前提にしています。

開発環境、実行環境共に、複数の言語環境を同時にインストールすることが可能ですが、OS言語と同一言語のみサポートします。

開発時

オブジェクトの定義名

各リポジトリ上の定義名は、基本的に英語を使用することを推奨します。それ以外の言語の文字が入力されている場合、別の言語のWindows上では、以下のように文字化けする可能性があります。

現象例：

日本語表記

  • 中国語（簡体語）Windows ： 半角カタカナが文字化けします。

  • 中国語（繁体語）Windows ： 全角のひらがな/カタカナも文字化けします。

  • タイ語/英語/スペイン語Windows ： アルファニューメリック以外は、全て文字化けします。

中国語（簡体語／繁体語)表記

  • 簡体語と繁体語では、使用する漢字が異なる場合があるため、文字化けする場合があります。また、正しく表示されていても、意味が通じない可能性があります。

  • 日本語Windows：文字によっては文字化けする場合があります。

  • タイ語/英語/スペイン語Windows ： アルファニューメリック以外は、全て文字化けします。

タイ語表記

  • 他の言語のWindowsでは、全て文字化けになります。

スペイン語表記

  • 特殊文字（ウムラウトや ?、!など）は、英語Windowsでは表示されますが、アジア系の言語のWindowsでは文字化けになります。

フォーム上のコントロールの定義名

フォーム上の特性や各コントロールの特性値は、Unicodeで登録されるため、他言語特有の文字も表示されます。

  • フォームの［フォーム名］特性

  • ［テキスト］コントロールや［チェックボックス］コントロールの［テキスト］特性

  • チョイスコントロールの［選択項目リスト］/［選択表示リスト］特性

  • ［プッシュボタン］コントロールの［書式］特性

［ヘルプ］リポジトリ

［ヘルプ］リポジトリの［テキスト］特性は、Unicodeで登録されるため、他言語特有の文字も表示されます。

［ヘルプ］リポジトリの各項目名は、他言語Windowsによって文字が化ける場合がります。

文字化けにならなくても、開発者が他言語に対する対応能力がないために表記内容を理解でない事態も想定して開発を行ってください。

日本語特有の関数

日本語版のuniPaaS Studioを使用して日本語特有の関数をプログラムに組み込んだ場合、他言語の環境ではサポートされない関数として扱われ、構文チェックでエラーになります。また、このプログラムを実行させても関数処理は動作しません。

日本語版でサポートされない特性

［入出力特性］の[PDF]特性などは日本語版ではサポート対象外のため、(MGconstw.jpnを使用した)日本語環境では、特性そのものを表示させないようにしています。他言語用の環境では、この特性が表示されますがサポート対象外となります。

DBMSの設定

RDBMSは、各言語に対応したものを使用してください。また、［DBカラム名］等DBMS側に反映される名前は、英語で指定するようにしてください。

表示データ

オンライン画面

文字型項目は、言語によって文字が化ける可能性があります。Unicode型項目は、基本的に正しく表示されます。

リッチクライアント画面

文字型項目は、言語によって文字が化ける可能性があります。また、Windowsの言語が合っていても、[動作環境]の[外部コードページ]の設定によっては、文字化けになる場合があります。Unicode型項目は、基本的に正しく表示されます。

HTMLマージ

テンプレートとなるHTMLのエンコード指定によっては正しく表示されない場合があります。この設定は、開発者の責任で行ってください。

言語の判定方法

アプリケーションが現在どの言語のWindowsで実行されているかを判断するための方法を以下に説明します。プログラム作成時の参考にしてください。

MAGIC.INIの設定内容で判断する

INIGet('ConstFile')によって出力された文字列の末尾3桁を元に以下のように判断できます。

  • eng …… 英語

  • jpn …… 日本語

  • spn …… スペイン語

  • chn …… 中国語（簡体語)

  • twn …… 中国語(繁体語)

  • thi …… タイ語

INIGet('ExternalCodePage')によって出力された文字列を元にした場合は、以下のように判断できます。

  • 1252 …… 英語/スペイン語

  • 932 …… 日本語

  • 936 …… 中国語（簡体語)

  • 950 …… 中国語(繁体語)

  • 874 …… タイ語

MAGIC.INIの設定は、Windowsの言語設定とは連動しないことを注意してください。

WindowsのAPIを呼び出す

WindowsのAPI（GetSystemDefaultLCID）を呼び出して、取得されたシステムのロケール識別子をもとに判断できます。

  • 外部コール ： '@kernel32.GetSystemDefaultLCID'

  • パラメータ ： '44' 0 数値型項目

実行すると数値型項目には以下の値が返ります。

  • 1033 …… 英語(United States)

  • 3082 …… スペイン語（Spain)

  • 1041 …… 日本語

  • 2052 …… 中国語（簡体語)

  • 1028 …… 中国語(繁体語)

  • 1054 …… タイ語

ここで取得される値は、Windowsの"Region and Language（地域と言語）"の"Format（形式）"指定に基づいた値です。設定を変更すると値も変わります。例えば、同じスペイン語圏でも、"Mexico"を選択すると"2058"が返ります。


uniPaaS 1.9g2での制限事項

Magic uniPaaS Ver1.9g2での留意・制限事項

リッチクライアント

  • (2000666)[タスク特性]の[事前読込]特性が｢Yes｣に設定されたタスクで[ビュー再表示]イベントを発行すると、チャンクサイズまでのデータしか読み込みません。ビュー再表示を行うタスクは[事前読込]特性を｢No｣に設定してください。

  • (2000729)［ウィンドウタイプ］特性が「モーダル」のウィンドウではステータス行は表示されません。ステータス行のエラーメッセージはそのタスク起動元のSDIタイプのウィンドウに表示されます。

  • (2000742)子タスクからRollback('FALSE'LOG,1)を実行しても、親タスクのロールバックはできません。

  • (2000748)パラメータを渡さないサブフォームを[タブ]コントロールに配置した場合、実行時にタブを変更しても、サブフォームのデータの変更がコミットされません。

  • (2000764)[レコード後]でリンクテーブルの項目に対して加算モードの［項目更新］処理コマンドを定義すると、リンク項目の変更時の更新処理が正常に行われないことがあります。

  • (2000812)リッチクライアントで、リンクの［戻り値］特性に親タスクの論理型変数が定義されている場合、［キャンセル］イベントによって戻り値がリセットされません。

  • (2001030)サブフォームに設定したタスク(［空のデータビュー許可］特性「Yes」）のデータビューが空の状態でも、［データビューが空］イベントが発生しません。この場合、［コール］処理コマンドでタスクを呼び出すことで対応できます。

  • (2001069)リッチクライアントで、変数項目の値を別の変数項目に代入する場合、変数の値がNULLの時、変数の［NULL計算値］特性の値が代入されます。

  • (2001076)オンラインプログラムやVer10用のリッチクライアントタスクから移行した場合、［複数行編集］特性「Yes」の［エディット］コントロールの［CR許可］特性が「No」に設定されます。このため、デフォルトでは複数行編集のコントロールに改行コードが挿入できません。

  • (2001095)Acrobat 9がインストールされたクライアントPCで、［ブラウザ］コントロール上のPDFファイルを表示すると、終了時に異常終了する場合があります。

  • (2001112)［タブ］コントロール、［イメージ］コントロールの［イメージ一覧ファイル名］特性に直接BMPファイルを指定する場合、以下のフラグを設定する必要があります。

[MAGIC_SPECIALS]
SpecialConvAddSlash=N

  • (2001144)数値型項目の書式で３桁区切りが有効になっている場合、「,」を含めた桁数分まで入力が可能になります。ただし、書式の桁数を超えていると項目移動ができません。

  • (2001184)選択プログラム終了後、［項目変更］ロジックユニット内に定義されたFlow()関数の戻り値が、オンラインタスクとは異なる値が返ることがあります。

  • （2001191）プッシュボタンに対しては、XPのテーマは無効になります。

  • (2001244)リッチクライアントのキャッシュパスに自動作成される環境ファイル(ユーザフォント定義ファイル、キーボード割付ファイル、論理名テーブル)の名前は、固定で設定されます。同一サーバ上で異なる環境ファイルを使用するアプリケーションを複数実行する場合には、同一の環境ファイルをマージするか、アプリケーション毎にリッチクライアントのキャッシュパスを設定して下さい。

リッチクライアント（モバイル）

  • キーボードを「ひらがな/カタカナ」に設定すると、英数字入力へのモード変更ができません。

  • （2001445）unicode特有文字は表示できません。unicode対応フォントを別途インストールする必要があります。

  • ［サブフォーム］や［タブ］コントロールが配置された画面では、実行時にソフトキーボードを表示すると、画面がリサイズされません。

  • ［タブ］コントロールを画面サイズ一杯に配置した場合、画面を横長にすると、［タブ］コントロール上のコントロールが表示されないことがあります。

Unicode

  • (2000556)MAGIC.INIの[MAGIC_SPECIALS]SpecialAnsiExpression = Y　を設定すると、Unicode型やBLOB型（［内容］特性が「U=Unicode」）の項目に対して、Unicode特有の値を更新すると、「????..」として更新されます。

開発機能

  • プログラムの公開名にDBCSや特殊文字を使用しないことを推奨します。

  • (2000238)MS-IME2002を使用した場合、uniPaaS Studioからプログラムを実行して[アクティビティモニタ]から検索画面で2バイト文字を入力したとき、Enterキーで文字を確定しないと文字が表示されない場合があります。

  • (2000316)クラス0のフォームの編集において、［テーブル］コントロールにリンクされているコントロールをテーブルの外に移動するとリンクが外れます。

  • (2000353)V9Plusで他のプログラムとデータの受け渡しを行う変数が［リンク］コマンドより後に定義されているプログラムを移行すると、リンクの［戻り値］特性に定義された変数項目が自動的に追加されるために、正しく動作しない場合があります。

  • (2000429)［データ］リポジトリで、タイトル行にカーソルを置いてAPGを実行した時、作成モードしか選択できません。

  • (2000431)平面スタイルの［コンボボックス］コントロールの背景色は36番のアプリケーション基本色で表示されます。表示色を変更したい場合は、コンボボックスのスタイルを変更するか、36番の色を変更してください。[テーブル]コントロールの子コントロールとなるコンボボックスの場合、平面スタイルでなくても36番のアプリケーション基本色で表示されます。

  • (2000462)［スタイル］特性が「Windows立体」の［タブ］コントロール上に［テーブル］コントロールをリンクさせることができません。「凸立体」に変更することでリンクすることができます。

  • (2000520)Windows Vistaの場合、フォームの［コントロール］パレットのウィンドウ枠が透過色になるため、後ろの表示が写り込みます。

  • (2000791)文字列抽出ツールは、Unicode固有文字には対応していません。

  • (2001158)コンポーネントジェネレータは、開発ライセンスがないと実行できません。

実行機能

  • アプリケーションの実行中に、アプリケーション（ECF）ファイルを更新しないでください。更新した場合の動作は保証できません。

  • (2000103)ユーザ定義関数に2バイト文字を使用した関数を定義することはできません。

  • (2000186)［入出力ファイル］テーブルの［メディア］カラムを「V=項目」、［文字セット］特性を「UTF-8」に設定すると、格納したデータが文字化けする場合があります。

  • (2000236)［プッシュボタン］コントロールに定義された項目に対する［項目変更］ロジックユニットを設定した場合、実行時にボタンを押下してもイベントは発行されません。

  • (2000286)HTTPGet関数、またはHTTPPost関数でUTF-8のデータをBLOB型のUnicodeタイプのデータで受け取ると、2バイト文字が正しく取得できません。バイナリタイプで受け取るようにしてください。

  • (2000453)［サブフォーム］コントロールを使用して、サブフォームから親ウィンドウのコントロールをクリックした場合、TaskId()関数ではサブフォームのタスクIDが返り、HandledCtrl()関数では値が返りません。

  • (2000817)並行実行のタスクから呼び出されたプログラムによる印刷出力処理でプレビューを表示した場合、［プレビュー］ウィンドウがMagicの画面の背後で表示される場合があります。

  • (2000904)Windows Vista上でMS-IME2007を使用している場合、［エディット］コントロールの［漢字入力］特性を「5」に設定しても、"半Rカナ"が有効にならないことがあります。

  • (2001094)ATOKを使用している場合、文字パレットから全角文字を選択すると、文字化けが生じる場合があります。

  • （2001197）［フローモード］特性が「A=後置」または「B=前置」に設定している処理コマンドを、［RM互換］ロジックユニット以外では実行できません。

アプリケーションサーバ機能

  • (2000309)［フォーム出力］処理コマンドで［入出力ファイル］テーブルの［メディア］カラムに「リクエスタ」、［文字セット］特性を「Unicode」に設定し、そのプログラムを他のクライアントから［コールリモート］処理コマンドで起動すると、結果ファイルはShift_JISコードで出力されます。 ［文字セット］特性がUTF-8/Shift_JISの場合は、それぞれのコードで出力されます。

バージョン管理

  • プロジェクトのバージョン管理ソフトは、Microsoft Visual SourceSafe (6.0d、あるいは 2005)、およびCVSNTをサポートしています。PVCSはサポートしておりません。バージョン管理を使用した開発を行う前に、必ずそれぞれのオンラインマニュアルをお読みください。

  • 同じプロジェクトファイルを複数のMagicエンジンで開く場合は、必ずバージョン管理機能を使用してください。使用しない場合は、開くことができません。

  • (2000405)バージョン管理でVisual SourceSafe(VSS)を使用した場合、履歴等を実行するとVSSの画面が呼び出されますが、この画面にあるヘルプボタンをクリックするとエラーが発生し、それ以降マウス操作ができなくなります。

  • (2000881)VSS 6.0dの環境でバージョン管理を利用し、「サーバから開く」を実行すると、「No project file found in selected source control project」というエラーで、プロジェクトが選択できないことがあります。この場合、VSS6.0dをSP6にアップデートして下さい。
    SP6は、以下のURLからダウンロードできます。
    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja

Oracle

  • (2000411) RAW型のカラムタイプを定義取得するとBLOB型にマッピングされますので、適宜文字型 (記憶型式：String)に変更する必要があります。

  • (2000558) BLOB型（記憶型式：Unicode Blob）の項目の内容を全角英数字（ＡＢＣ１２３など）で更新すると、文字化けが発生します。

Pervasive SQL

  • 外部キーが定義されたテーブルを定義取得すると、インデックステーブルにキーが定義されます。

Webサービス

プロバイダアプリケーションの注意事項

  • 公開プログラム名、およびパラメータ名には英数字と _ (アンダースコア文字)のみで先頭に数字を使用できません。

  • 異なる公開プログラム間で、同じ名前で違う型のパラメータを設定すると、正しく動作しない場合があります。

  • 入力パラメータがXMLデータの場合、パラメータをBLOB型で定義し、名前はXSDスキーマのルートと同じ名前に設定してください。

  • 入出力パラメータがXMLデータの場合、設定されたXSDファイルのエレメントの順序が、Systinetのパッケージを作成した後にアルファベット順に変更されることがあります。これにより、コンシューマに提供するスキーマとあわなくなることがあるため、あらかじめXSDのエレメントの名前をV01_xxx, V02_xxxなどの接頭辞を付加することで回避してください。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面のサービスネームスペースにはデフォルトでMAGIC.INIのオーナ名が付加されます。オーナ名にスペースや . (ドット文字)が含まれる場合、デフォルトの値では jarファイルが作成できませんので適切な値に変更する必要があります。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面の「説明」に日本語の2バイト文字を入力すると、jarファイルが作成できません。

コンシューマからWebサービスコールを実行するときの注意事項

  • ［サービス］テーブルで既存のWebサービスのWSDLを再読み込みした場合には、Magicエンジンを再起動してください。さらにそのサービスを設定したWebサービスコールを再度定義しないと正しく実行できないことがあります。

  • プロバイダにXMLデータをBLOB型で渡す場合、Shift_JISのエンコードで渡してください。

その他

  • Magic eDeveloper V10がインストールされたPCにuniPaaS Studio V1をインストールした場合、どちらかをアンインストールすると MgComCreater.dll がレジストリから削除されます。このような場合は、WindowsのRegsvr32.exeを使用して残った製品のインストールフォルダ内にあるMgComCreater.dllを登録し直してください。