Magic uniPaaS V1 追加情報

マジックソフトウェア・ジャパン株式会社
２００９年４月

Magic uniPaaS® Ver 1.5J SP1a 追加情報

  uniPaaS Studio
  uniPaaS Client
  uniPaaS Enterprise Server
  uniPaaS RichClient Server

このファイルには、Magic uniPaaS Ver 1.5J SP1a（以下 Magic uniPaaS V1、あるいは単に Magic と表記）について、マニュアルに記載されていない注意点や制限事項など重要な情報が記載されています。

内容

  • 本バージョンのご利用にあたって [image] 必ずお読みください。
  • 添付ドキュメントについて
  • サポートされているOS・DBMS
  • ソフトウェアメンテナンス [image] 必ずお読みください。
  • 修正履歴
  • 参考技術情報
  • 付録
  • 各種リンク情報
  • ベータ機能評価レポート
  • Magic uniPaaS V1 使用許諾契約書


本バージョンのご利用にあたって

インストール製品について

今回のリリースで提供されるMagic製品は、下記の通りです。

製品名

提供ライセンス

uniPaaS Studio
(開発版)

インストール時のデフォルトはデモライセンスで、最大データソース数、レコード数、プログラム数などに制限があります。弊社 UDC でユーザ登録を行い、ライセンス発行をして、ライセンス情報を取得してください。その後、ライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。

現在使用中のMagic Studio V10のライセンスファイルがそのまま利用できます。

uniPaaS Client
(実行版)

製品梱包箱のシールにライセンス情報(シリアル番号、アクティベーションキーなど)が記載されているので、インストール後にライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。

uniPaaS Enterprise Server
(サーバ版)

弊社 UDC でユーザ登録を行い、ライセンス発行をして、ライセンス情報を取得してください。その後、ライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。

uniPaaS Enterprise Serverのライセンスだけでは、リッチクライアント機能は利用できません。

uniPaaS RichClient Server
(サーバ版)

弊社 UDC でユーザ登録を行い、ライセンス発行をして、ライセンス情報を取得してください。その後、ライセンスマネージャを起動して、ライセンス登録することにより、正式製品として利用することができるようになります。

uniPaaS RichClient Serverのライセンス(MGRIA11)は、単独では使用できません。uniPaaS Enterprise Serverのライセンス（MGENT11）と組み合わせることで利用できます。

インストールとライセンス登録の詳細については、CD-ROM の Online ディレクトリに各製品ごとのインストールマニュアルがあります。ここに詳しく説明してありますので、そちらを参照してください。

ベータ機能について

本バージョンが提供する機能のうち、ベータ機能、サポート外機能とされている機能があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外ですが、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールで japan_v10beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

現バージョンでの既知の問題・制限事項

現バージョンでの既知の問題・制限事項については、修正履歴 を参照してください。

コントロールリリース版からのアップグレードについて

現在、コントロールリリース版をインストールしている場合、アップグレードに際して以下の注意点があります。

  • コントロールリリース版は、アンインストールせずMagic uniPaaS V1のインストールプログラムでアップグレードを行ってください。コントロールリリース版のレジストリ情報に不具合がありますが、アップグレードすることによってレジストリ情報を修正します。

  • リッチクライアントアプリケーションのクライアント環境は、一旦アンインストールしてから再インストールしてください。

旧バージョンからの移行について

旧バージョンで開発したアプリケーションを移行する場合の注意事項は、リファレンスヘルプの「マイグレーション」の説明を参照してください。Magic eDeveloper V10 とのリッチクライアント機能の違いについては、「Magic V10のリッチクライアントとの違い」を参照してください。

ゲートウェイ利用時の注意事項について

各DBMSに固有な新機能、留意・制限事項、および互換性についての情報は、「データベース固有の追加情報」にまとめてあります。あわせてご参照ください。

RMConverterについて

Magic V9Plus以前のアプリケーションを移行した場合、[レコードメイン]に定義されている処理コマンドは、[RM互換]ロジックユニットに定義されます。このようなプログラムは、Magic uniPaaS V1の機能が利用できない場合があり、イベントやコントロールに対応したロジックユニットに処理を移す必要があります。 [RM互換]ロジックユニットの定義内容をイベントドリブン形式に変換するユーティリティとして RMConverterを公開しています。

以下のリンク先からダウンロードしてインストールすることができます。

http://www.magicsoftware.co.jp/files/beta/uniV1/RMConverterV11/RMConverter_1.1_1.exe

RMConverterは、サポート対象外です。メッセージ表示のみ日本語化したもので、日本語に完全に対応したものではありません。ヘルプも英語で記述されています。プロジェクト名やファイル名などは、半角の英数字で指定するようにしてください。


添付ドキュメントについて

今回のリリースで提供されるドキュメントは以下の通りです。

ヘルプとReadMeは、全製品に添付されます。それ以外の技術文書は、Studio 製品にのみ添付されます。

ドキュメント名 | 形式 | 備考
Magic uniPaaS V1 ヘルプ | HTMLヘルプ (CHM) | HTML形式のリファレンスマニュアルです。PDF形式では提供されていません。
Magic uniPaaS V1 ReadMe |  | 本 ReadMe ファイルです。
Magic uniPaaSパーティショニング トラブルシューティングガイド | PDF |
インストールガイド
Magic uniPaaS コンポーネント開発 |  | Magic uniPaaSでアプリケーションを開発する上で知っていただきたい、技術情報が記載されています。
イベントドリブンアーキテクチャ
データ管理とMagic uniPaaS
インタラクティブなリッチクライアントの開発と実行
マスタリングuniPaaS
MSVSSによるバージョン管理 |  | Microsoft Visual SourceSafe を使用したMagic uniPaaS V1プロジェクトのバージョン管理の方法について解説します。
CVSによるバージョン管理 |  | CVSを使用したMagic uniPaaS V1プロジェクトのバージョン管理の方法について解説します。
移行チュートリアル |  | Magic V10以前のアプリケーションをMagic uniPaaS V1用に移行するため知っておく必要がある情報が記載されたチュートリアルです。サンプルアプリケーションを使用します。


サポートされているOS・DBMS

ここでは、Magic uniPaaS V1 のシステム要件を記します。

システム要件については、インストールガイドの第２章「セットアップ」 → 「セットアップ条件」の節にも注意事項等ありますので、ご覧ください。

Magic uniPaaS V1 サポートDBMS一覧表

DBMS | Version | Magic uniPaaS V1 Windows版
Pervasive.SQL | V9 | ○(SP1以降)
 | V10 | ○
Oracle | 9i | ○ (R2以降)
 | 10g | ○
 | 11g | ○
MS-SQL | 2005 | ○
 | 2008 | ○

凡例 … ○：動作確認済、△：制限あり、－：対象外、予定：評価予定

  • 各DBMSとも、日本語版にのみ対応しています。

  • その他の言語バージョンのDBMS製品については、DBMSベンダーが日本語版OS上で日本語データの動作保証をしている場合に限り、サポート対象となります。

uniPaaS V1 サポートOS一覧表

Windows Version | uniPaaS Studio uniPaaS Client | uniPaaS Enterprise Server uniPaaS RichClient Server
XP Professional | ○ | ×
Server 2003 (Standard, Enterprise) | ○ | ○
Vista（Business/Enterprise/Ultimate） | ○ | ×
Server 2008(Standerd/Enterprise) | ○ | ○

凡例 … ○： 動作確認済、△： 制限あり、× ： 動作保証対象外、予定： 評価予定

  • x86 (32bits) アーキテクチャのみサポートしています。Windows Server 2008のみ64ビットOSをサポートします。

  • 日本語版の Windows 製品にのみ対応しています。その他の言語バージョンでは、動作保証されていません。

WindowsVista利用時の注意事項

Windows Server 2008利用時の注意事項

その他のソフトウェア要件

用途 | ソフトウェア | 対応バージョン
バージョン管理用 | Microsoft Visual Sourcesafe | 6.0dSP6、2005
 | CVSNT | 2.0.58d
 | Jalindi Igloo | 1.03
リッチクライアント実行用 | Internet Explorer | 6.0
 | .Net Framework CLR | 2.0.50727.0以上
Webサービス | Systinet Server for Java | 6.5.2
 | JDK/JRE | 1.5

  • リッチクライアントアプリケーションをクライアントにインストールする（最初に実行させる）場合のみ、Internet Explorerが必要です。

  • ブラウザクライアント機能は、サポート対象外です。

  • Systinet Server for Java 6.5.2 および JDK/JRE 1.5.0.4 は、Magic uniPaaS製品に添付されており、Magic uniPaaSのインストーラで、これらのソフトウェアのインストールを選択することができます。Systinet Server for Javaは、バンドルされているバージョン'のみをサポートしています。

  • CVSは、バンドルされているバージョン'(CVSNT 2.0.58d) のみをサポートしています。他のバージョンについてはサポート対象外となります。

  • CVSNTの利用にあたっては、添付のオンラインドキュメント「CVSを使ったバージョン管理」に設定や注意事項等の説明がありますので、CVSを使ってバージョンコントロールを行う場合には、必ず良く読んでください。

  • チーム開発やバージョン管理を行う場合、CVSに比べMicrosoft Visual Sourcesafe の方が制限など少なく、また周辺ユーティリティも便利に使うことができます。本格的な開発を行う場合には、Microsoft Visual Sourcesafe をご利用になることをお勧めします。

  • Microsoft Visual Sourcesafe の6.0d SP6 は、以下からダウンロードできます。

http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja


ソフトウェアメンテナンス

ソフトウェア・メンテナンスについて

uniPaaS Enterprise Server V1／uniPaaS RichClient Server V1は、ソフトウェア・メンテナンス対象製品となっており、ライセンスによりソフトウェア・メンテナンス終了日が管理されています。

メンテナンス終了日を過ぎた場合の動作

Magic uniPaaS V1のモジュール作成日付が、使用ライセンスのメンテナンス終了日を過ぎている場合は、サービスパック（アップデートモジュール）の適用ができません。このような場合、以下のようなエラーが発生します。

アップグレード時

インストーラは、事前に使用されているライセンス情報をチェックします。メンテナンス終了日を過ぎている場合には、インストーラはライセンスの確認ダイアログを表示します。

ライセンスサーバのアドレスを確認の上、表示されているアドレス以外のライセンスサーバを使用している場合は、修正し、[次へ]をクリックしてください（表示内容に間違いがない場合は、[キャンセル]をクリックして終了した後、ライセンス内容を確認してください）。

再度ライセンスのチェックを行います。ここでメンテナンス終了日が超過していることが確認できた場合、以下の警告メッセージを表示してアップグレード処理を終了します

ファイアウォールがインストールされている場合、ライセンスサーバへのアクセスができない場合があります。「ライセンスサーバの扱いについて」を参考にして、事前にファイアウォールでライセンスサーバを許可するように設定してください。

Magic uniPaaS実行時

メンテナンス終了日を過ぎたライセンスを使用すると、Magic uniPaaS起動時にエラーになります。

対応方法

使用しているライセンスのメンテナンス終了日の確認方法

インストーラは使用しているライセンスのメンテナンス終了日をチエックしますが、以下の方法でインストール前に確認することが可能です。

ライセンスサーバがインストールされているPCのC:\FlexLMのLicense.datをテキストエディタで開きます。uniPaaS Enterprise ServerおよびuniPaaS RichClient Serverのスタートメニューから｢ライセンスサーバ→ライセンスファイルの表示｣を選択しても表示されます。

以下の例のような赤字の部分を確認してください。

SERVER ServerName 12ab34cd56ef TCP:744
DAEMON MAGIC C:\FlexLM\LMG.EXE

FEATURE MGENT11 MAGIC 1.000 01-jan-0 10 1234567890ABCDEF123 \
VENDOR_STRING=PT=MGENT1,C=3FFFFFF,P=S,M=0,SSL=Y,MED=30-apr-2009,BC=1234567890ABCDEF123 \
OVERDRAFT=0 DUP_GROUP=NONE ISSUER=evaluation ck=211 SN=190000001

  • ライセンス名（FEATURE XXXXXXX）

    • MGENT11 …… uniPaaS Enterprise Server/uniPaaS RichClient Server

    • MGRIA11 …… uniPaaS RichClient Server

  • メンテナンス終了日（MED=dd-mmm-yyyy）

上記の例では、Magic Enterprise Serverのライセンスで、メンテナンス終了日が2009年4月30日になっています。

使用しているライセンスのメンテナンス終了日が過ぎている場合

ソフトウェア・メンテナンス契約を更新している場合は、UDCを使用してライセンスコードの再発行を行ってください。新しいライセンスを取得したら、現在のライセンスを一旦削除した上で、再度登録し直してください。

ソフトウェア・メンテナンスの更新手続き、ライセンス発行は、サイト単位に設定しているサイト管理者が行います。

ソフトウェア・メンテナンスの更新手続きを行っていない場合は、更新手続きが必要です。更新手続は、Magic uniPaaSの購入元、又は最寄の営業所にご確認ください。

新規インストールの場合

インストール時には、ライセンス情報のチェックは行われません。

メンテナンス終了日は事前に発行されたライセンス情報で、Magic uiPaaSのモジュール作成日付はインストーラの起動時に確認することができます。


修正履歴

ここでは、Magic uniPaaS V1の修正履歴を説明します。

本バージョンでの修正内容

バージョン | 新機能 | 改善内容 | 動作変更 | 留意・制限事項
Ver1.5J SP1a |  |  |  |

ベータ機能

本バージョンでのベータ機能として指定されている機能は、「本製品でのベータ機能」をご参照ください。


uniPaaS 1.5J SP1 での新機能

Ver1.5J SP1aでの新機能

リッチクライアント

リッチクライアントの.NETサポート

リッチクライアントの実行モジュールがJavaから.NETベースに変更されました。このため現在JNLPを使用して実行している場合、RCインタフェースビルダで実行環境ファイルを作成し直す必要があります。

コントロールの追加

以下のコントロールがサポートされるようになりました

  • ライン

  • リッチエディット

  • リッチテキスト

コントロールの拡張

以下のコントロール特性がサポートされるようになりました

  • 選択プログラム

  • 起動モード

  • スタイル

  • TAB移動方向

  • 水平整列

  • [プッシュボタン]コントロールの背景色

  • [ラベル]コントロールの[テキスト]特性の式指定

  • [テーブル]コントロールの[テーブルタイトル表示]特性は、[タイトル高さ]特性に変更されました。

  • ［カラム］コントロールの［カラムタイトル］特性に複数行テキストが入力/表示できるようになりました。

処理コマンドの拡張

以下の処理コマンドの特性がサポートされるようになりました

  • フロー方向

テーブルコントロールの動作

[テーブル]コントロールは以下のように拡張されました

  • カラムソートをサポートするようになりました。レコードをソートすると、サーバに対するアクセスが発生するため注意してください。

  • カラムの順番を変更することができるようになりました、変更内容はセッションの実行中のみ有効で、終了すると初期状態に戻ります。

リッチクライアントインタフェースビルダ

RCビルダは、.NETベースに変更されました。MicrosoftのClickOnce技術に基づいたマニフェストファイルを作成するようになりました。

非インタラクティブタスク

リッチクライアントタスクは、ユーザによる操作を行うことができないリッチクライアントタスクの実行をサポートしました。これはクライアント側で実行されます。[タスク特性]の[インタラクティブ]特性のチェックを外すことで非インタラクティブになります。これにより、バッチタスクからリッチクライアントを呼び出すような処理を実現することができるようになりました。

オンラインからリッチクライアントへの移行

[ユーザアクションxx]イベント

タスクタイプを「オンライン」から「リッチクライアント」に変更すると、内部イベントの[ユーザアクションxx]イベントが、同じ名前のユーザイベントに変換されます。この動作は、[ユーザアクションxx]というユーザイベントがメインプログラムに定義されている場合のみ実行されます。

RC準備ユーティリティによって[データ特性]の[GUI表示形式]特性が[リッチクライアント形式]に、[GUI表示形式テーブル]特性が[リッチクライアント形式テーブル]にコピーされる場合にも同じように変更されます。

サブツリー

オンラインまたはバッチタスクをリッチクライアントタスクに交換すると、開発時のタスクツリー内のすべてのサブタスクがリッチクライアントタスクに変更されます。

GUIフォームのバックアップ

タスクをリッチクライアントに変更しても、GUIフォームのバックアップは保存されなくなりました。

関数

以下の関数は、サーバとクライアントの両方でサポートされるようになりました。

  • GetParam()

  • SetParam()

  • ExpCalc()

  • Rights()

以下の関数は、リッチクライアントタスクではサポートされません。

  • FileDlg() ：以下の2つの新しい関数がサポートされました。

    • ClientFileOpenDlg()

    • ClientFileSaveDlg()

  • DirDlg() は、ClientDirDlg()関数に置き換えられました。

FileDlg()/DirDlg()が使用されているMagic V10のプログラムをリポジトリ出入力で移行した場合、新しい関数に変換されないため、エラーとして扱われます。移行後に使用目的に応じた関数に手動で変更するようにしてください。

以下の関数が追加されました

  • ClientFileInfo …… ファイル情報が返る

  • ClientFileOpenDlg ……[ファイルを開く]ダイアログを開く

  • ClientFileSaveDlg ……[ファイルを保存する]ダイアログを開く

  • ClientDirDlg ……[フォルダの選択]ダイアログを開く

SDIフォームの動作の変更

リッチクライアントタスクのSDIフォームは、Escキーを押下して終了しなくなりました。これは、リッチクライアントでは、オープンし続けるMDIフレームを持っていないため、エンドユーザの意図しないアプリケーションの終了処理が発生することを防止するために変更されました。

サブフォームの動作

コントロールをクリックすることでサブフォーム/フレームから他のタスクに移動した時点でサブフォームのレコードは自動的に書き込まれます。

[循環入力]特性は、リッチクライアントでは[タブサイクル]特性に変更され、サブフォーム内の最後にパーク可能なコントロールからTab移動した場合の動作を指定することができるようになりました。

[非表示の再表示]特性が追加されました。これは、非表示の時にサブフォームが初期化されたり再表示したりするかどうかを定義するものです。これにより、サブフォームが表示されるまで再表示されないように設定できるため、パフォーマンスを改善することができます。

開発機能

[式]エディタでの関数の説明

[関数一覧]に関数の説明や構文を表示するようになりました。

関数の構文を表示するツールチップが表示され、関数やそのパラメータの概要を確認することができるようになりました。このツールチップは、関数を選択したり、記述すると自動的に表示されます。また、関数の左の括弧でCtrl+Shift+スペースを押すことでも表示されます。

色付けされた項目一覧

[項目一覧]の項目は、そのタイプ（カラム:#70/変数:#71/パラメータ:#72)に従って色分けされるようになりました。

処理コマンドのツールチップ表示

処理コマンドの(式指定ではなく直接入力された)テキスト部分がツールチップとして全て表示されるようになりました。

[サブフォーム]コントロールからのタスク作成

[サブフォーム]コントロールの[プログラム/タスク番号]特性からズームして表示させた[サブタスク一覧]から直接タスクを作成することができるようになりました。

起動プログラムへのドリルダウン

プログラムの呼び出し処理を定義した場合、定義先に簡単に移動することができるようになりました。この機能によって、現在のプログラムを抜けることなく、指定したプログラム番号に移動することができるようになります。
この機能は、プログラム番号を指定した場所でCtrl+F5を押下することで利用できます。呼び出されたプログラムに移動した後に、Ctrl+Shift+F5を押下することで元の場所に戻ることができます。
これらの機能は、[オプション]メニューにも追加されました。

Ctrl+F5を押下して起動先に移動すると、起動元の番号がスタックされプロジェクトを開いている間は維持されます。このため、起動元に戻らずに別のオブジェクトを開いた状態でCtrl+Shift+F5を押下すると、スタックされた起動元に戻る動作が発生します。

[位置]ダイアログのデザイン

[位置]ダイアログは再設計され、各設定オプションの意味がわかりやすくなりました。

[APG]ダイアログのインデックス選択

[APG]ダイアログは、実行時にインデックスが選択できるようになりました。この機能は、テーブルのレコードを参照するためにAPGを実行する際に、通常必要な機能でデフォルトインデックス以外のインデックスを使用する場合に利用します。

コントロールの[書式]特性

[データ式]の値が同じ型の別の式に変更されても、コントロールの書式は変更されないようになりました。

アプリケーションタイトルの論理名

[アプリケーション特性]の[タイトル]特性で論理名をサポートするようになりました。タイトルの内容をMagic.iniで定義することができます。

[ビュー事前読込]特性の式サポート

[ビュー事前読込]特性で、式を指定することができるようになりました。指定された式は、レコード取得前に評価されます。

並行起動でないプログラムでのソースコンテキストサポート

[メニュー特性]の[ソースコンテキスト]特性が、並行起動でないプログラムに対しても利用できるようになりました。このため、この特性に設定された値に従ってコンテキストがオープンされます。

Webサービスのエンドポイントの動的設定

Webサービスの[エンドポイント]特性の値は、Webサーバを呼び出す前に再評価されます。これによって、論理名を更新することでエンドポイントの値を変更することができるようになりました。

同じプロジェクト内でのインポート処理

旧バージョンででは、範囲を指定してプログラムを出力し、同じアプリケーションに入力した場合、同じ番号のオブジェクトを参照するようになっていました。Magic uniPaaSではこの動作が変更され、参照関係が維持された状態で入力されるようになりました。

例：A→B という参照関係を出力して入力すると、今までは　(Copy)A → B だったのが (Copy)A → (Copy)B となります。

この動作を無効にして、旧バージョンとの互換性を維持させる場合は、MAGIC.INIの[MAGIC_SPECIALS]セクションで以下のフラグを設定してください。

SpecialRelativeImport=Y

コントロール

[プッシュボタン]コントロールのパラメータ

[プッシュボタン]コントロールに、実行させる[イベント]ロジックユニットに送るパラメータを指定することができるようになりました。

ハイパーテキストスタイルの[プッシュボタン]コントロールの拡張

ハイパーテキストスタイルの[プッシュボタン]コントロールは、以下のように拡張されました

  • [水平整列]特性が有効になりました。

  • マウスカーソルがコントロール上を通過/ホバーする際の色を指定するための特性が追加されました。

[タブ]コントロールのタブ順序と可視

[タブ]コントロールに[表示レイヤリスト]特性が追加されました。この特性は、実行時に表示されるタブ内容とその順番を動的に定義することができます。

[カラムタイトル]のテキストのワードラップ

Windowsスタイルの[テーブル]コントロールの[カラムタイトル]特性のテキストは、以下のような扱いになります。

  • [垂直整列]が「上寄せ」の場合、ワードラップされます。

  • [テーブル]コントロールの[スタイル]特性が｢W=Windows｣でテキスト全体が表示できる余白がない場合、省略('...')記号がテキストの末尾に表示されます。

[照会モード時の修正許可]特性の対象コントロール

[照会モード時の修正許可]特性が[チェックボックス]と[エディット]コントロールにも追加されました。

イベント

[コントロール修正]イベント

[コントロール修正]イベントが追加され、コントロールが修正されると常にこのイベントが発行されます。これによって、キャレットがコントロールを抜ける前で、コントロールの値が変更された後に実行されるロジックを定義することが可能になります。

EditGet()関数を使用することで、変更されたコントロールの値を取得することができます。

[アプリケーションオープン]イベントのECFパラメータ

[アプリケーションオープン]イベントにオプションパラメータとして、「ECFファイル名」が追加されました。このパラメータによって、実行時にユーザの介在なしにアプリケーションの切り換えを行うことが可能になります。

ビュー再表示後のユーザソートの保持

[ビュー再表示]イベントにオプションパラメータが追加されました。このパラメータは、ユーザソート状態を維持している状態で[ビュー再表示]の実行を可能にするものです。

関数

DBName()関数の拡張

DBName()関数にパラメータが追加され、Magic uniPaaS V1上のデータソース名やデータベース名などのデータソース情報が取得できるようになりました。

移行ユーティリティも、検証リンクを使用している場合、Magic uniPaaS V1上のデータソース名を返すように変更されました。

関数の追加

  • FileInfo() 関数 ……この関数は、ファイルのシステム情報を取得することが可能です。

  • CabinetUnload() 関数 ……CabinetUnload() 関数が追加されました。この関数によって［コール公開名］処理コマンドによって呼び出されたコンポーネントをアンロードすることが可能になります。

以下の関数は、削除されました。

  • FlwMtrVars

ユーティリティ

[データ出力]ウィザードのヘッダ行指定

[データ出力]ウィザードは、テキストファイルやHTMLファイルのヘッダ行(項目名)を出力させることができるようになりました。

MRBモニタで呼び出しパスの表示

MRBモニタの機能が以下のように拡張されました

  • 呼び出したプログラム/タスクがパス形式で[リクエスタ]ウィンドウに表示されるようになりました。

  • ユーザによって変更された各表示テーブルのカラムレイアウトが保持されるようになりました。

検証リンクの移行

移行ユーティリティ（v9converter）に新しいオプション(LINKVALIDATE)が追加されました。検証リンクを照会リンクに変換した場合に、[戻り値]特性に定義する変数項目を[リンク]コマンドの前やタスクの最後に追加するかどうかを指定するものです。

デバッグ機能

読み込み専用モード時のズーム

タスクが読み込み専用モードでオープンされている状態（例えば、デバッグモードやバージョン管理中でチェックインしていない場合）でも[式]欄から[式]エディタにズームすることができるようになりました。

デバッグモード時の項目値をツールチップ表示

デバッガでは、ブレイク中に以下のオブジェクトにマウスカーソルを置くと、項目値がツールチップで表示されます。

  • [データビュー]エディタ上の項目定義行

  • [パラメータ]テーブルに定義された項目

  • [フォーム]エディタ上の項目が定義されているコントロール

実行処理

シャットダウン中に実行エンジンを終了

MRBの機能が拡張され、実行エンジンが段階的にシャットダウンしなくても、指定されたタイムアウトを越えた時点でエンジンを終了させることができるようになりました。これは、Mgrb.iniファイルの「TerminateEnginesDuringShutdown」と呼ばれる新しいキーワードを定義することで可能になります。

インターネットリクエスタのエラーのXML化

インターネットリクエスタは、XMLファイルでエラーを戻すように変更されました。Mgreq.iniファイルのDefHtmlというキーワードは、DefErrorに変更されました。

ここに、XML形式のテンプレートファイルを指定すると、このファイルにエラー情報をマージして返すことができます。

<xmlerr>
<errcode><!$MG_ErrorCode></errcode>
<errmsg><!$MG_ErrorText></errmsg>
<server><!$MG_Server></server>
<appname><!$MG_Application></appname>
<prgname><!$MG_Program></prgname>
<arguments><!$MG_Args></arguments>
<username><!$MG_User></username>
</xmlerr>

実行時の[データベースログイン]ダイアログの回避

ほとんどのエンドユーザーはデータベースの接続設定を変更する必要がないにもかかわらず、接続に失敗すると表示される[データベースログイン]ダイアログは、実行時に表示されないようになりました。

この動作を無効にして、旧バージョンとの互換性を維持させる場合は、MAGIC.INIの[MAGIC_SPECIALS]セクションで以下のフラグを設定してください。

SpecialShowDBLogin=Y

JVM位置の定義

フルパスで指定されたJVM.dllをロードするように機能が追加されました。

MAGIC.INIの[MAGIC_JAVA]セクションの[JVM_PATH]にこのパスを定義することができます。

CPUの指定

マルチCPUを搭載したH/Wで実行する場合、実行エンジンのプロセスに対するCPUを制御できるようになりました。

エンジンの起動時に指定する方法

Magic uniPaaSのインストールフォルダにあるmgreq.iniに次の指定を行います。

[REQUESTER_ENV] SpecialAffinity = 0(デフォルト)/1/2/3../Y/N

  • 0 ･･･ すべてのCPU
  • 1 ･･･ CPU0
  • 2 ･･･ CPU1
  • 3 ･･･ CPU2
  • Y ･･･ ランダム
  • N ･･･ すべてのCPU

プログラム実行中に指定する方法

［コールUDP］処理コマンドで次の関数を設定します。

mglcl015jp.SetAffinity (cpu, rc)

  • コマンド ･･･ 外部コール／U=UDP
  • 式 ･･･ mglcl015jp.SetAffinity
  • パラメータ1(数値型) ･･･ cpu: CPU番号 (0:すべてのCPU, 1:CPU0, 2:CPU1, ...)
  • パラメータ2(数値型) ･･･ rc: 戻り値 (1:成功, 0:失敗)

(参考)

現在使用しているCPU, およびシステムに存在するCPUを取得する関数

mglcl015jp.GetAffinityMask (process_affinity_mask, system_affinity_mask, rc)

  • コマンド ･･･ 外部コール／U=UDP
  • 式(関数名) ･･･ mglcl015jp.GetAffinityMask
  • パラメータ1(数値型) ･･･ process_affinity_mask: 現在のプロセスが使用するCPU
  • パラメータ2(数値型) ･･･ system_affinity_mask: システムのCPU

    • ※これらの値は、各ビットが各CPUに対応するため、次のような値が返ります。
    1:CPU0, 2:CPU1, 3:CPU0とCPU1 ... 15:4コアの全CPU
  • パラメータ3(数値型) ･･･ rc: 戻り値 (1:成功, 0:失敗)

その他

透明およびアニメーション化されたイメージのサポート

イメージの表示が可能なコントロールは、透過やアニメーション化されたGIFイメージを正しく表示させることができるようになりました。

[エラー]処理コマンドの拡張

[エラー]処理コマンドに、以下の特性が追加されました

  • タイトル …… メッセージボックスのタイトルの定義

  • イメージ ……メッセージボックスに表示されるイメージの指定

  • ボタン ……メッセージボックスに表示されるボタンタイプの選択

  • デフォルトボタン ……フォーカスがあるデフォルトボタンを指定

  • 戻り値 …… どのボタンをクリックされたかを指定

  • エラーログに追加 ……エラーログにエラーメッセージ内容を出力するかどうかの指定


uniPaaS 1.5J SP1 での改善内容

Ver1.5J SP1aでの改善内容

ここでは、Magic uniPaaS Ver1.5J SP1aでの改善内容を掲載します。

リッチクライアント

QCJ# | 内容
2000658 | [エディット]コントロールで[エラー]処理コマンドで戻ってきた直後に項目のデータが全選択されない問題
2000760 | [並行実行]特性を「Yes」に設定したプログラムを呼び出した場合、Unicode型のパラメータにUnicode特有の日本語を設定しても正しい値が渡らない問題
2000782 | サブタスクでMainLevel(1)を実行した場合の値が正しく返らないことがある問題
2000885 | ［テーブル］コントロール外に、項目が定義された［エディット］コントロールがひとつ配置されたフォームを持つオンラインタスクをリッチクライアントタスクに変換した場合、実行時に画面が表示されない場合がある問題
2000889 | ［0値表示］特性が「Yes」に設定された日付型項目において、入力されている値が全て0の場合、日付の編集時に日付区切文字が表示されない問題
2000890 | 埋込SQLタスクをサブフォームやフレームに表示させるプログラムで実行できない問題
2000892 | 数値書式にマスク文字を指定した場合、実行時に入力された値が正しく表示されない場合がある問題
2000891 | 並行実行プログラムにおいて印刷ダイアログを使用した場合、印刷後のフォーカスが呼び出し元のタスクに戻らない場合がある問題
2000658 | [エディット]コントロールで[エラー]処理コマンドで戻ってきた直後に、項目のデータが全選択されない問題
2000663 | [コールOSコマンド］処理コマンドで、*.TXT, *.DOC *.xlsなどのファイルを直接指定しても実行できない問題
2000999 | 外部キーを定義したテーブルをサブフォームに設定すると、データ登録時に参照整合性制約違反のエラーが発生することがある問題
2001061 | あるコントロールからラジオボタンの選択肢をクリックしても、即座にクリックした項目に選択されない問題
2001106 | ［タブ］コントロールの各タブにサブフォームを配置した場合、サブフォーム内コントロールの［可視］特性が初期表示のタブ以外のフォームでタブ切替した際に有効にならず、サブフォーム内のタスクにアクセスした時に有効になる問題
2001074 | 親タスクでトランザクションが開始されていない場合、実行元が「フォーカス上のタスク」のボタンをクリックすると、Magicエンジンが異常終了する問題
2001082 | グローバル変数を表示させている場合、フォーム上のグローバル変数をクリックするとフリーズする問題
2001098 | メインソース、照会リンク、書出リンクが定義されたプログラムで、メインソースの修正時に書出リンクによって新規レコードが作成されると、「レコードが失われていました」のエラーが発生する問題
2001114 | イメージデータが保存されたBLOBデータが表示されない問題
2001147 | 文字型項目の[エディット］コントロールで、末尾の全角文字の削除ができないことがある問題
2001160 | ［テーブル］コントロール上のチェックボックスがチェックされている状態で、垂直スクロールバーを下方向にクリックするとチェックが外れることがある問題
2001165 | ［修正許可］特性が「No」に設定された［エディット］コントロールに対して、拡張ウィンドウ（F6）から入力すると修正可能になる問題

実行機能

QCJ# | 内容
2001024 | ［コールCOM］処理コマンドでベクトル型(セルモデルはUnicode型)の項目を使用したときにゴミが入ることがある問題
2001117 | SQLコマンドタスクを使用した3階層のサブフォームのプログラムでマウスクリックを繰り返すと異常終了することがある問題
2001104 | ［選択モード］特性が「M=マルチ」に設定された［リスト］コントロールで、修正を行わなくても［レコード後］が実行される問題
2001092 | DataViewToTex()関数の実行時にヘッダ行が最後まで出力されないことがある問題

開発機能

QCJ# | 内容
2000832 | コンポーネント名＋ユーザイベント名が30バイトを超える場合、［事前定義ロジック］テーブルの［イベント名］カラムがすべて表示されない問題
2001120 | プログラムを開いて、ナビゲータで「親タスク作成」を実行すると異常終了する場合がある問題
2000818 | uniPaaS Studioでプロジェクトを実行した場合、メインプログラムでのRunmode（）関数の戻り値が正しく返らない問題

ゲートウェイ

QCJ# | 内容
2001129 | （MS-SQL Server）外部結合リンクを26個以上使用すると、正常に実行できない問題
2001182 | （MS-SQL Server）書式3のUnicode型のカラムを定義したデータソースに対して、SQLコマンドタスクでSELECT文を実行すると、日本語のデータが文字化けする問題
2001242 | （Oracle）外部結合リンクを26個以上使用すると、正常に実行できない問題

ユーティリティ

QCJ# | 内容
2001163 | （V9Converter）半角カタカナと全角文字が含まれたテキストコントロールが、正しく変換されない問題


uniPaaS 1.5J SP1 での制限事項

Ver1.5J SP1aでの留意・制限事項

リッチクライアント

  • (2000666)[タスク特性]の[事前読込]特性が｢Yes｣に設定されたタスクで[ビュー再表示]イベントを発行すると、チャンクサイズまでのデータしか読み込みません。ビュー再表示を行うタスクは[事前読込]特性を｢No｣に設定してください。

  • (2000714)［ウィンドウタイプ］特性が「モーダル」のタスクから「SDI」のタスクを呼び出しても、呼び出されたされたタスクはモーダルウィンドウとして動作します。

  • (2000729)［ウィンドウタイプ］特性が「モーダル」のウィンドウではステータス行は表示されません。ステータス行のエラーメッセージはそのタスク起動元のSDIタイプのウィンドウに表示されます。

  • (2000742)子タスクからRollback('FALSE'LOG,1) を実行しても、親タスクのロールバックはできません。

  • (2000748)パラメータを渡さないサブフォームを[タブ]コントロールに配置した場合、実行時にタブを変更しても、サブフォームのデータの変更がコミットされません。

  • (2000764)[レコード後]でリンクテーブルの項目に対して加算モードの［項目更新］処理コマンドを定義すると、リンク項目の変更時の更新処理が正常に行われないことがあります。

  • (2000812)リッチクライアントで、リンクの［戻り値］特性に親タスクの論理型変数が定義されている場合、［キャンセル］イベントによって戻り値がリセットされません。

  • (2001030)サブフォームに設定したタスク(［空のデータビュー許可］特性「Yes」）のデータビューが空の状態でも、［データビューが空］イベントが発生しません。この場合、［コール］処理コマンドでタスクを呼び出すことで対応できます。

  • (2001069)リッチクライアントで、変数項目の値を別の変数項目に代入する場合、変数の値がNULLの時、変数の［NULL計算値］特性の値が代入されます。

  • (2001076)オンラインプログラムやVer10用のリッチクライアントタスクから移行した場合、［複数行編集］特性「Yes」の［エディット］コントロールの［CR許可］特性が「No」に設定されます。このため、デフォルトでは複数行編集のコントロールに改行コードが挿入できません。

  • (2001095)Acrobat 9がインストールされたクライアントPCで、［ブラウザ］コントロール上のPDFファイルを表示すると、終了時に異常終了する場合があります。

  • (2001112)［タブ］コントロール、［イメージ］コントロールの［イメージ一覧ファイル名］特性に直接BMPファイルを指定する場合、以下のフラグを設定する必要があります。

[MAGIC_SPECIALS]
SpecialConvAddSlash=N

  • (2001115)［リッチエディット］コントロールのデータを編集する際、色とフォントの設定はできません。

  • (2001134)MAGIC.INIに以下のフラグを設定した場合、実行時に大量のデータを読み込むと異常終了する場合があります。

[MAGIC_SPECIALS]
CompressBrowserXML=Y
SecureBrowserClient=Y

  • (2001143)［リンク］コマンドの［位置付］特性に指定した項目に対して、一旦データ修正を行ってからキャンセルし、更に再修正を行うと、［項目変更］ロジックユニットが実行されません。

  • (2001144)数値型項目の書式で３桁区切りが有効になっている場合、「,」を含めた桁数分まで入力が可能になります。ただし、書式の桁数を超えていると項目移動ができません。

  • （2001179)データソースのカラムで書式の［0値表示］が「Yes」に設定されておりかつ、デフォル値の継承解除している数値型のモデルを使用している場合、サブフォームが登録モードの時、［0値表示］が機能せず「0」で表示されます。

  • （2001180）日付型項目が定義されたコントロールの［水平整列］特性を「センタリング」にしても、機能しません。

  • (2001184)選択プログラム終了後、［項目変更］ロジックユニット内に定義されたFlow()関数の戻り値が、オンラインタスクとは異なる値が返ることがあります。

  • （2001186）［ブロックwhile］処理コマンド内にバッチ処理が定義されている場合、［ブロック］処理コマンドの後に定義されている処理コマンドが、１回以上実行されてしまいます。

  • （2001191）プッシュボタンに対しては、XPのテーマは無効になります。

  • （2001198）WinBox関数の第2パラメータにX、Yを指定した場合、正しく機能しません。

  • （2001200）日付型項目の値を削除して、［強制終了］欄が「E=編集」のユーザイベントを実行すると、日付が「2000/01/01」になります。

  • (2001244)リッチクライアントのキャッシュパスに自動作成される環境ファイル(ユーザフォント定義ファイル、ユーザ色定義ファイル、キーボード割付ファイル、論理名テーブル)の名前は、固定で設定されます。同一サーバ上で異なる環境ファイルを使用するアプリケーションを複数実行する場合には、同一の環境ファイルをマージするか、アプリケーション毎にリッチクライアントのキャッシュパスとキャッシュエイリアスを設定して下さい。

Unicode

  • (2000556)MAGIC.INIの[MAGIC_SPECIALS]SpecialAnsiExpression = Y　を設定すると、Unicode型やBLOB型（［内容］特性が「U=Unicode」）の項目に対して、Unicode特有の値を更新すると、「????..」として更新されます。

開発機能

  • (2000238)MS-IME2002を使用した場合、uniPaaS Studioからプログラムを実行して[アクティビティモニタ]から検索画面で2バイト文字を入力したとき、Enterキーで文字を確定しないと文字が表示されない場合があります。

  • (2000316)クラス0のフォームの編集において、［テーブル］コントロールにリンクされているコントロールをテーブルの外に移動するとリンクが外れます。

  • (2000353)V9Plusで他のプログラムとデータの受け渡しを行う変数が［リンク］コマンドより後に定義されているプログラムを移行すると、リンクの［戻り値］特性に定義された変数項目が自動的に追加されるために、正しく動作しない場合があります。

  • (2000429)［データ］リポジトリで、タイトル行にカーソルを置いてAPGを実行した時、作成モードしか選択できません。

  • (2000431)平面スタイルの［コンボボックス］コントロールの背景色は36番のアプリケーション基本色で表示されます。表示色を変更したい場合は、コンボボックスのスタイルを変更するか、36番の色を変更してください。[テーブル]コントロールの子コントロールとなるコンボボックスの場合、平面スタイルでなくても36番のアプリケーション基本色で表示されます。

  • (2000462)［スタイル］特性が「Windows立体」の［タブ］コントロール上に［テーブル］コントロールをリンクさせることができません。「凸立体」に変更することでリンクすることができます。

  • (2000520)Windows Vistaの場合、フォームの［コントロール］パレットのウィンドウ枠が透過色になるため、後ろの表示が写り込みます。

  • (2000791)文字列抽出ツールは、Unicode固有文字には対応していません。

  • (2001152)［ユーザアクションxx］イベントを設定したプッシュボタンが定義されたアプリケーションに対して、リッチクライアント準備ユーティリティを実行し、ユーザアクションに関するダイアログで「No」を選択すると、エンジンが異常終了する場合があります。

  • (2001158)コンポーネントジェネレータは、開発ライセンスがないと実行できません。

実行機能

  • アプリケーションの実行中に、アプリケーション（ECF）ファイルを更新しないでください。更新した場合の動作は保証できません。

  • (2000103)ユーザ定義関数に2バイト文字を使用した関数を定義することはできません。

  • (2000186)［入出力ファイル］テーブルの［メディア］カラムを「V=項目」、［文字セット］特性を「UTF-8」に設定すると、格納したデータが文字化けする場合があります。

  • (2000236)［プッシュボタン］コントロールに定義された項目に対する［項目変更］ロジックユニットを設定した場合、実行時にボタンを押下してもイベントは発行されません。

  • (2000286)HTTPGet関数、またはHTTPPost関数でUTF-8のデータをBLOB型のUnicodeタイプのデータで受け取ると、2バイト文字が正しく取得できません。バイナリタイプで受け取るようにしてください。

  • (2000453)［サブフォーム］コントロールを使用して、サブフォームから親ウィンドウのコントロールをクリックした場合、TaskId()関数ではサブフォームのタスクIDが返り、HandledCtrl()関数では値が返りません。

  • (2000817)並行実行のタスクから呼び出されたプログラムによる印刷出力処理でプレビューを表示した場合、［プレビュー］ウィンドウがMagicの画面の背後で表示される場合があります。

  • (2000904)Windows Vista上でMS-IME2007を使用している場合、［エディット］コントロールの［漢字入力］特性を「5」に設定しても、"半Rカナ"が有効にならないことがあります。

  • (2001094)ATOKを使用している場合、文字パレットから全角文字を選択すると、文字化けが生じる場合があります。

  • (2001189)コマンドラインファイルを付加してMagic uniPaaSを起動した場合、論理名のWorkingDirが正しく設定されません。

  • （2001197）［フローモード］特性が「A=後置」または「B=前置」に設定している処理コマンドを、［RM互換］ロジックユニット以外では実行できません。

アプリケーションサーバ機能

  • (2000309)［フォーム出力］処理コマンドで［入出力ファイル］テーブルの［メディア］カラムに「リクエスタ」、［文字セット］特性を「Unicode」に設定し、そのプログラムを他のクライアントから［コールリモート］処理コマンドで起動すると、結果ファイルはShift_JISコードで出力されます。 ［文字セット］特性がUTF-8/Shift_JISの場合は、それぞれのコードで出力されます。

バージョン管理

  • プロジェクトのバージョン管理ソフトは、Microsoft Visual SourceSafe (6.0d、あるいは 2005)、およびCVSNTをサポートしています。PVCSはサポートしておりません。バージョン管理を使用した開発を行う前に、必ずそれぞれのオンラインマニュアルをお読みください。

  • 同じプロジェクトファイルを複数のMagicエンジンで開く場合は、必ずバージョン管理機能を使用してください。使用しない場合は、開くことができません。

  • (2000405)バージョン管理でVisual SourceSafe(VSS)を使用した場合、履歴等を実行するとVSSの画面が呼び出されますが、この画面にあるヘルプボタンをクリックするとエラーが発生し、それ以降マウス操作ができなくなります。

  • (2000881)VSS 6.0dの環境でバージョン管理を利用し、「サーバから開く」を実行すると、「No project file found in selected source control project」というエラーで、プロジェクトが選択できないことがあります。この場合、VSS6.0dをSP6にアップデートして下さい。
    SP6は、以下のURLからダウンロードできます。
    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=ja

Oracle

  • (2000411) RAW型のカラムタイプを定義取得するとBLOB型にマッピングされますので、適宜文字型 (記憶型式：String)に変更する必要があります。

  • (2000558) BLOB型（記憶型式：Unicode Blob）の項目の内容を全角英数字（ＡＢＣ１２３など）で更新すると、文字化けが発生します。

Webサービス

プロバイダアプリケーションの注意事項

  • 公開プログラム名、およびパラメータ名には英数字と _ (アンダースコア文字)のみで先頭に数字を使用できません。

  • 異なる公開プログラム間で、同じ名前で違う型のパラメータを設定すると、正しく動作しない場合があります。

  • 入力パラメータがXMLデータの場合、パラメータをBLOB型で定義し、名前はXSDスキーマのルートと同じ名前に設定してください。

  • 入出力パラメータがXMLデータの場合、設定されたXSDファイルのエレメントの順序が、Systinetのパッケージを作成した後にアルファベット順に変更されることがあります。これにより、コンシューマに提供するスキーマとあわなくなることがあるため、あらかじめXSDのエレメントの名前をV01_xxx, V02_xxxなどの接頭辞を付加することで回避してください。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面のサービスネームスペースにはデフォルトでMAGIC.INIのオーナ名が付加されます。オーナ名にスペースや . (ドット文字)が含まれる場合、デフォルトの値では jarファイルが作成できませんので適切な値に変更する必要があります。

  • Webサービスインタフェースビルダでパッケージ(jarファイル)を作成する時、「Webサービスの詳細」画面の「説明」に日本語の2バイト文字を入力すると、jarファイルが作成できません。

コンシューマからWebサービスコールを実行するときの注意事項

  • ［サービス］テーブルで既存のWebサービスのWSDLを再読み込みした場合には、Magicエンジンを再起動してください。さらにそのサービスを設定したWebサービスコールを再度定義しないと正しく実行できないことがあります。

  • プロバイダにXMLデータをBLOB型で渡す場合、Shift_JISのエンコードで渡してください。

その他

  • ブラウザクライアント機能は、サポート対象外です。

  • Magic eDeveloper V10がインストールされたPCにuniPaaS Studio V1をインストールした場合、どちらかをアンインストールすると MgComCreater.dll がレジストリから削除されます。このような場合は、WindowsのRegsvr32.exeを使用して残った製品のインストールフォルダ内にあるMgComCreater.dllを登録し直してください。


参考技術情報

ここでは、Magic uniPaaS V1 についての参考技術情報を紹介します。

  • Windows Vistaでの制限事項

  • Windows Server 2008での制限事項

  • リッチクライアントのオンラインとの違い

  • Magic V10のリッチクライアントとの違い


Vistaでの制限事項

Windows VistaTMでの留意・制限事項

Windows Vista上でMagic uniPaaS V1を実行した場合の留意点や制限事項は以下の通りです。

  • Windows Vista上では、MGPRN.HLP, SETSTYLE.HLP, WGAIJI.HLP等、*.hlp の拡張子のファイルは開くことはできません。
    参考：http://support.microsoft.com/kb/917607

  • UACが有効になっていると、Administrator権限のあるユーザでログオンされていても、管理者権限でのみ実行できるコマンド(regsvr32.exeなど) はOSコマンドから実行できません。

  • Windows Vistaは、Windows2000/XPとの互換レベルで動作確認したものです。「Tablet PC」機能などのVistaでの新機能については、未検証でありサポート対象外となります。

JIS X 0213:2004 対応について

  • サロゲート・ペア文字（4バイトのUnicode文字）については、現在対応されておりません。

各種リンク情報

JIS X 0213:2004規格対応により文字フォント変更について　社団法人 電子情報技術産業協会
http://it.jeita.or.jp/perinfo/committee/pc/0612JISX0213-2004/index.html

JIS X 0213:2004 対応と新日本語フォント「メイリオ」について
http://www.microsoft.com/japan/windows/products/windowsvista/jp_font/default.mspx

ブラウザクライアント

  • (2000469)Windows Vista上のWebブラウザからブラウザクライアントモジュールのインストールプログラム（DotNetMsi.msi）が自動で実行されないため、自動インストールを行うことはできません．Supportディレクトリ上にあるファイルをクリックして手動でインストールを行う必要があります。

  • (2000470)ブラウザクライアントで、CJK統合漢字拡張B面の字(丈の旧字体など)が正しく格納できません。またそのコードで格納されたデータを読み込むと、Webブラウザでエラーが発生します。

  • 公開名に日本語（全角／半角カタカナ）が含まれている場合、実行できません。

インストール

  • 実行許可の確認

    • インストールは、Administrators グループに所属しているユーザで行ってください。

    • UAC が有効の場合、インストールプログラムの実行時に［ユーザー アカウント制御］ダイアログが表示されます。ここで［続行］ をクリックしてください。処理が継続して行われます。

  • ブラウザクライアント／リッチクライアント実行モジュールのインストールを行う場合、IISの以下の機能をあらかじめ有効化しておく必要があります。

Web 管理ツール

    • IIS管理コンソール

World Wide Web サービス

    • HTTP 共通機能

      • 規定のドキュメント

      • 静的コンテンツ

    • アプリケーション開発機能

      • .NET拡張機能

      • ASP .NET

      • CGI

      • ISAPI フィルタ

      • ISAPI 拡張機能

    • セキュリティ

      • 要求のフィルタリング

ユーティリティ

  • (2000487)リモートデバッガを有効にして実行版を起動すると、終了時にOSからのエラーダイアログが表示されることがあります。


Windows Server 2008での制限事項

Windows Server 2008での留意・制限事項

Windows Server 2008上でMagic uniPaaS V1を実行した場合の留意点や制限事項は以下の通りです。

  • Magic uniPaaS V1の動作は、利用するDBMSに依存しますので、各DBMSが Windows Server 2008上で動作が確認されていることが前提となります。ご利用になるDBMSの Windows Server 2008 の対応状況については、各DBMSベンダーの情報をご確認ください。

  • uniPaaS Enterprise Server またはuniPaaS RichClient Server のインストール時にFlexLMを同時にインストールすると、FlexLMはスタートメニュー／スタートアップのショートカットによって実行されるように なります。この場合、複数のマシンからリモートログオンした際に多重起動されることがありますので、このショートカットは削除し、タスクスケジューラに同 じコマンドを登録することで対応していただきますようお願いいたします。
     コマンドラインでタスクスケジューラに登録するには、Administratorから次のようなコマンドで可能になります。(実際には、1行のコマンドとして実行してください）

schtasks /Create /S LOCALHOST /RU SYSTEM /SC ONSTART /TN FlexLM /TR "C:\FlexLM\LMGRD.EXE -app -c C:\FlexLM\license.dat -l C:\FlexLM\lmlog.txt" /F

  • リッチクライアントアプリケーション、またはマージ出力のインターネットアプリケーションを実行する場合、IIS7上でMagicインターネットリクエスタを動作させるために、次のような設定が必要になります。
      (1) 「IISマネージャーのサーバホーム/ISPIおよびCGIの制限」のリストにmgrqispi015.dllを登録し、あわせて「拡張パスの実行を許可する」をチェックする。
      (2) 「uni15Scripts(エイリアス)/ハンドラマッピング」で「ISAPI-dll」に対する「機能アクセス許可の編集」で実行を有効にする。
    ※mgrqcgi015.exeを使用する場合も同様の設定を行います。

  • MRBを起動する場合、ファイアウォールの例外処理にMRBが使用するポート番号(デフォルト4000)を登録する必要があります。

  • Windows Server 2008上のプロジェクトに対してバージョン管理を行う場合、添付されているCVS NTでは正常に動作しないことがあります。Microsoft Visual Source Safeをご利用いただくようお願いいたします。

  • Systinet Server を使用してWebサービス機能を利用する場合、ファイアウォールの例外処理に、Systinet Serverが使用するポート番号(デフォルト6060)を登録する必要があります。また、Systinet Serverの管理ツール(Administration Console)を実行する場合、InternetExploreの保護モードを無効にしないと、正しく動作しないことがあります。

  • Windows Server 2008 Standard Edition および Enterprise Edition がサポート対象となります。Web Server Edition、Itanium-Based Systems は、サポート対象外です。

64bit版 Windows Server 2008 上で動作させる場合の留意事項

  • 64bit版としてサポートするOSは、Windows Server 2008 のみです。また、WOW64（Win32互換API）上での動作に限定されます。WOW64に関する一般的な制限事項が適用される場合がありますので、詳細は以下のURLを参照してください。
    http://support.microsoft.com/kb/896456/ja

  • 64ビット版のIIS7から、Magicインターネットリクエスタを実行する場合、「IISマネージャ／サーバホーム／アプリケーションプール／DefaultAppPool／詳細設定／32ビットアプリケーションの有効化」をTrueに設定する必要があります。


リッチクライアントの制限事項

リッチクライアントのオンラインとの違い

動作環境

uniPaaS RichClient Serverのライセンス(MGRIA11)のみでは、リッチクライアントタスクを呼び出すことができません。uniPaaS Enterprise Serverのライセンス(MGENT11)が同じライセンスファイルに定義されている場合のみ利用できます。その際、Magic uniPaaS側のライセンスは、"MGENT11"を指定してください。

ライセンスのスレッド数は、[動作環境]の[最大並行ユーザ数]に定義された値がMagicエンジンの起動時に消費されます。[最大並行ユーザ数]が｢0｣かライセンス上のユーザ数を越えている場合は、ライセンスのユーザ数分が消費されます。

動作が異なる機能

以下の機能は、オンラインタスクと動作が異なります。またこれ以外でも、インターネット環境を利用して実行する特性上、動作が異なる場合があります。

# | 内容 | 対応
1 | 数値項目の入力時の最初のキャレット位置が右側になります。（オンラインプログラムでは左側。） |
2 | ESCキーではタスクは終了できません。 | Windowの×ボタンをクリックするか、[終了]イベントを発行するボタンを定義してください。
3 | [タスク特性]の[循環入力]特性が[タブサイクル]特性になります。 | サブフォーム/フレームに定義されたタスクで利用します。
4 | サブフォームタスクの[タスク前]／[タスク後]の実行フローが異なります。 |
5 | [トランザクションモード]特性のオプション |
6 | [リッチエディット]コントロール上のデータの書式が変更できません。 |
7 | コンボボックスの選択肢が多い場合、選択リストのモニタの表示枠を越えて表示されます。 | [コントロール特性／表示行数]に適切な行数を設定します。
8 | 高速モードで実行される場合、［コントロール］検証ロジックユニットは、項目の更新の有無にかかわらず常に評価されます。 |

サポートされない機能

以下の機能は、現在リッチクライアントアプリケーションではサポートされていません。

これ以外でも、リッチクライアントアプリケーションは、処理内容によってサーバ側またはクライアント側のどちらかでしか処理されない場合があるため、設定箇所によっては定義できない（関数などの）オブジェクトがあります。詳細は、『インタラクティブなリッチクライアントの開発と実行』を参照してください。

タスク/ロジック定義

#

内容

対応

1

[RM互換]ロジックユニット

[イベント]ロジックユニットに移動します。

2

バッチタスクからの呼び出し

バッチタスクを非インタラクティブなリッチクライアントに変換することで起動できます。

3

照会モード位置付け

4

実行時のオプションメニュー（範囲、位置付、ソート、インデックス変更）

6

日本語のプロジェクト名

半角英数字のプロジェクト名を定義します。

9

[入出力ファイル]テーブル

データの入出力処理は、専用のバッチタスクで対応するようにします。

10

[タスク特性]の以下のオプション

  • タスク常駐

  • レコード削除

  • ウィンドウ再表示

  • ウィンドウ表示

  • ウィンドウ消去

  • キャッシュ範囲

  • ロック方式

  • 位置付

  • 範囲

  • インデックス変更

  • ソート

  • 入出力ファイル

  • インデックス最適化

  • 照会モード位置付

  • データ出力

以下のデータ型

  • ActiveX型

  • OLE型

以下のコントロール

  • （テキスト／グループ以外の）スタティック

  • スライダ

  • OLE

以下の処理コマンド

  • コールCOM

  • フォーム

［コール］処理コマンドの以下の特性

  • フォーム

  • コンテキストID

［イベント実行］処理コマンドの以下の特性

  • 出力先コンテキスト名

［コールOSコマンド］処理コマンドの以下の特性

  • 表示

  • ウェイト（[実行]特性が｢クライアント｣の場合）

フォーム/コントロール

#

内容

対応

1

[テーブル]コントロールでのマルチマーキング

2

内部形式/Windows形式のヘルプ

URLによるヘルプ、またはツールチップ、自動ヘルプに変更します。

3

ドラッグ＆ドロップ

4

以下のフォーム特性

  • ウィンドウリストに表示

  • 寸法単位（｢ダイアログ｣固定）

  • フォーム状態ID

  • ドロップ許可

  • パレット最適化

  • 分割

  • 位置

フォームの分割は、[リッチクライアントフレーム]フォームを利用して実現可能です。

5

[エディット]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スクロールバーの表示

  • スタイル

  • 境界スタイル

  • 垂直整列

7

[ラベル]コントロール（GUI表示フォームの[テキスト]コントロール）の以下の特性

  • RTF許可

  • スタティックタイプ

  • ドラッグ許可

  • ドロップ許可

  • 境界スタイル

  • 線種

  • 線幅

8

[プッシュボタン]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

9

[コンボボックス]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スタイル

  • 境界スタイル

  • 垂直整列

11

[リストボックス]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • 選択モード（｢シングル｣固定）

  • スタイル

  • 境界スタイル

  • 水平整列

12

[ラジオボタン]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スタイル（｢平面｣と｢凹立体｣のみ）

  • 複数行

  • 境界スタイル

13

[イメージ]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スタイル

  • 境界スタイル

  • イメージ効果

表可能なイメージファイルは、BMP/DIB/EMF/GIF/ICO/JIF/JPG/PNG/RLE/TIFF/WMFです。

14

[チェックボックス]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スタイル（｢平面｣と｢凹立体｣のみ）

  • 複数行

  • 境界スタイル

15

[グループ]コントロールの以下の特性

  • スタティックタイプ

  • ドラッグ許可

  • ドロップ許可

  • スタイル

  • 境界スタイル

  • 垂直整列

  • 水平整列

  • 線種

  • 線幅

16

[タブ]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スタイル

  • 垂直整列

  • タブラベル位置（｢上｣と｢下｣のみ）

17

[テーブル]コントロールの以下の特性

  • ドラッグ許可

  • ドロップ許可

  • スタイル

  • 境界スタイル→ 境界

  • 下辺位置

  • 最終区切線

  • ウィンドウ内テーブル

以下のコントロールは、[テーブル]コントロールに配置できません。

  • ラジオボタン

  • グループ

  • タブ

  • リストボックス

  • サブフォーム

18

[カラム]コントロールの以下の特性

  • 上境界線

  • 右境界線

  • カラムのマーキング

19

[サブフォーム]コントロールの以下の特性

  • 境界スタイル→ 境界

関数

以下の関数は利用できません。また、リッチクライアントでのみ有効な関数もあります。詳細は、『インタラクティブなリッチクライアントの開発と実行』を参照してください。

  • Blob2Req

  • CleftMDI

  • ClientCertificateAdd/ClientCertificateDiscard

  • COM関数

  • Counter

  • CTop/CTopMDI

  • CtrlHWND

  • CurrPosition

  • DateFormat

  • Drag&Drop関数

  • EOF/EOP

  • File2Req

  • GetNextRecNum

  • HitZOrder

  • IOCurr

  • KbGet/KbPut

  • Line

  • MarkedTextSet

  • MDate

  • マルチマーク関数

  • MnuAdd/MnuRemove/MnuReset

  • Page

  • RqHTTPHeader

  • SetContextFocus

  • SNMPNotify

  • SplitterOffset

  • SubformExecMode

  • Text

  • TransMode

  • UDF関数

  • Variant関数

  • WinHelp/WinHWND

  • WsProviderAttachmentAdd/Get

  • XML関数

内部イベント

以下の内部イベントは利用できません。「ユーザアクション」は、ユーザイベントに変更する必要があります。詳細は、『インタラクティブなリッチクライアントの開発と実行』を参照してください。

  • OSｺﾏﾝﾄﾞ

  • MAGIC情報

  • ｱﾌﾟﾘｹｰｼｮﾝを開く

  • ｲﾝﾃﾞｯｸｽ

  • ｵﾌﾞｼﾞｪｸﾄの挿入

  • ｿｰﾄ

  • ﾃﾞｰﾀ出力

  • ﾄﾞﾗｯｸﾞ開始

  • ﾄﾞﾛｯﾌﾟ

  • ﾉｰﾄﾞ縮小

  • ﾉｰﾄﾞ名を編集

  • ﾉｰﾄﾞ展開

  • ﾏｰｸを反転

  • ﾏｰｸ/ﾏｰｸ解除

  • ﾏｰｸを全て解除

  • ﾏﾙﾁﾏｰｷﾝｸﾞで次ﾍﾟｰｼﾞ

  • ﾏﾙﾁﾏｰｷﾝｸﾞで次行

  • ﾏﾙﾁﾏｰｷﾝｸﾞで前ﾍﾟｰｼﾞ

  • ﾏﾙﾁﾏｰｷﾝｸﾞで前行

  • ﾕｰｻﾞｱｸｼｮﾝ

  • 子ﾉｰﾄﾞ作成

  • 全て削除

  • 再表示

  • 開始値

  • 終了値

  • 位置付／次候補

  • 位置付

  • 全てﾏｰｸ

  • 次ﾍﾟｰｼﾞにﾏｰｸ

  • 前ﾍﾟｰｼﾞにﾏｰｸ

  • 項目先頭までﾏｰｸ

  • 最後までﾏｰｸ

  • 先頭までﾏｰｸ

  • 次行でﾏｰｸ

  • 前行でﾏｰｸ

  • 親のﾉｰﾄﾞに移動

  • 出力ﾀﾞｲｱﾛｸﾞ 次へ

  • 出力ﾀﾞｲｱﾛｸﾞ 戻る

  • 照会

  • 範囲

  • 入出力ﾌｧｲﾙ

  • 子のﾉｰﾄﾞに移動

  • 次のﾉｰﾄﾞに移動

  • 前のﾉｰﾄﾞに移動

その他

  • ActiveDirectory認証は利用できません。LDAP認証を使用してActive Directoryサーバへの認証を行うようにしてください。


Javaリッチクライアントとの違い

Magic V10のリッチクライアントとの違い

動作環境

Javaの実行環境は必要ありません。.NET Framework CLR(2.0.50727.0以上)が必要になります。

uniPaaS RichClient Serverの場合、MGENT11とMGRIA11のライセンスをライセンスサーバに登録する必要があります。Magic uniPaaS側の[ライセンス名]には、"MGENT11"を指定します。

クライアント実行モジュールは、Magic.iniの[MAGIC_RIA]セクションにフォルダ名で指定されます。フォルダ名は、バージョンアップによって変更される場合があります。

動作が異なる機能

以下の機能は、Magic V10のリッチクライアントと動作が異なります。Magic uniPaaS V1で追加された機能については、新機能の説明を参照してください。

# | 内容
1 | SDIフォームの場合、ESCキーではタスクは終了できません。
2 | サブフォーム上でのタブの動作は、[タスク特性]の[タブサイクル]特性で指定できます。デフォルトは、サブフォーム内の同一レコード内での移動になります。
3 | モーダルウィンドウでタイトルに最大化、最小化ボタン、アイコンが表示されません。
4 | サブフォーム上のコントロールから親タスクのコントロールに移ると、データ書込、および［レコード後］の処理が実行されます。
5 | ［複数行編集］特性が「Yes」の［エディット］コントロールに対して、デフォルトでは改行コードの入力ができません。プログラム（［CR許可］特性）の変更が必要になります。
6 | ［コンボボックス］コントロールをデータコントロールとして定義した場合、データソースにデータがなかったり範囲内にデータがないと、空の選択肢が表示されます。
7 | ［有効］特性が「No」に設定された［エディット］コントロールを表示した場合、背景がグレーになります（V10では、背景は白）。
8 | 背景色が透過指定されている［テキスト］コントロール(a)を背景色が透過指定されていないコントロール(b)の上に配置した場合、(a)の背景色は(b)の背景色になります（V10では、フォームの色）。
9 | 照会モードでは、コンボボックスの選択肢は開きません。
10 | 削除時の確認ダイアログのデフォルトボタンは「No」になります。
11 | サブフォームが最初にアクティブになった場合にIsFirstRecordCycle()関数を実行すると、'FALSE'LOGが返ります。
12 | 以下の関数が変更されました： FileSize/ClientFileSize → FileInfo/ClientFileInfo FileDlg/ClientFileDlg → FileOpenDlg, FileSaveDlg / ClientFileOpenDlg, ClientFileSaveDlg DbName(番号) → DbName(番号, オプション)
13 | 最初のクライアントの実行は、http://… によって、*.publish.html または、*.applicationを実行します。
14 | バッチ処理の同時実行は、最大スレッド数まで可能です。
15 | バッチ処理中のリッチクライアントタスクのタイムアウト値は未定です。2分以上の動作が可能です。 ただし、長時間のバッチ処理を行う場合は、HTTPコネクションが接続したままになり、その間はWebサーバ資源も開放されませんので、コールリモートの非同期でバッチ処理することを推奨いたします。
16 | ［カラム］コントロールのカラムタイトルに複数行テキストを入力/表示できます。
17 | ClickOnceの仕様により、デジタル証明書が必要になります。 Magic uniPaaSが提供する証明書を使用した場合、発行元が確認できないため、実運用での利用は推奨できません。証明書は（ベリサインなどの）認証機関から取得するか、（Microsoftなどで提供されている）ツールにより作成することを推奨します。
18 | ClickOnceの仕様により、統合プロキシ認証のみサポートしています。基本認証、ダイジェスト認証等はサポートしません。
19 | ［タブ］コントロールのタブにショートカットの記述(例. ...(&A)など) が有効になりません。
20 | ［プッシュボタン］コントロールの[実行元]特性を「T=フォーカス上のタスク」に設定した場合、[クリックでパーク]特性を「No」に設定する必要があります。
21 | ［プッシュボタン］コントロールの[実行元]特性を「C=コンテナタスク」に設定した場合、[パーキング可]特性を「Yes」に設定する必要があります。


付録

  • 各種リンク情報
  • 本製品でのベータ機能
  • ベータ機能評価レポート
  • Magic uniPaaS V1 使用許諾契約書
    • uniPaaS Studio あるいは Client の場合
    • uniPaaS Enterprise Server の場合


各種リンク情報

以下のリンク先にも参照してください。

MSJ のホームページ(TOPページ)

テクニカルサポート（サポート契約のご案内）

プロフェッショナルサービス

トレーニングコース

Magicアップデートのダウンロード

Magicスキルアップセンター

連載 Magic V10リッチクライアント

山下博士のMagic実践活用講座

XML対応帳票ソリューション「ReportsMagic」

Magic開発者のためのプログラム最適化ツール「Magic Optimizer」

パッケージソフト紹介サイト


本製品でのベータ機能

以下の機能は本製品で提供されていますが、日本語版ではベータ機能扱いです。 これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外ですが、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールで japan_v10beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

ベータ機能一覧

  • ブラウザクライアント

  • ユーザ定義開発メニュー

  • J2EE クライアント

  • J2EE サーバ

  • 以下のコンポーネント ジェネレータ

    • ストアド プロシージャ
    • UDDI Component

  • 以下のインターフェース ビルダ

    • EJB

  • DDF Maker

  • ODBC ゲートウェイ

  • 以下のメッセージングコンポーネント

    • JMS
    • Websphere MQ


ベータ版評価レポートのお願い

ベータ機能評価レポート

ベータ機能に関するご質問等は、マジックソフトウェアジャパンのサポートセンターではお受けいたしておりませんが、ご意見、ご質問、気が付いた点などは、下記の「ベータ 機能評価レポート」に記入して、メールで japan_v10beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。

Magic uniPaaS V1 ベータ機能評価レポート

記入日： 年　 月 　 日

会社名：

担当者：

E-mail：

ＴＥＬ：

ＦＡＸ：

サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境

ＰＣ機種：

ＣＰＵ：

ＲＡＭ：

ＯＳ： （ ） Windows XP／（ ） Windows Vista ／（ ） Windows Server 2003／（ ） Windows Server 2008

プリンタ：

使用サーバ：

２．評価結果

対象製品： （ ）uniPaaS Studio （ ） uniPaaS Enterprise Server （ ） uniPaaS Client （ ） uniPaaS RichClient Server

製品バージョン： （ ） ※ SPxx まで含め、正確に記入してください。

該当する（ ）に＊を挿入してください。

Ａ （ ） 問題無し

Ｂ （ ） 一部支障あり

Ｃ （ ） 正常に動作しない

Ｄ （ ） インストール・起動不可

上記２でＢ，Ｃ，Ｄの場合、以下の内容をお書きください。

３． 再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

４．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なうために、極力画面のハードコピー、サンプルプログラム等の提供をお願いいたします。）

５．その他ご意見


Magic uniPaaSr V1 使用許諾契約書

Magic uniPaaS V1 使用許諾契約書

Magic uniPaaS V1の使用許諾契約書には、Studio あるいは Client 製品のものと、Enterprise Server あるいは RichClient Server 製品のものと2種類あります。ご購入になった製品の使用許諾契約書を参照してください。

  • uniPaaS Studio あるいは Client の場合
  • uniPaaS Enterprise Server あるいは uniPaaS RichClient Server の場合
  • Magic uniPaaS V1 ソフトウェアメンテナンス契約書


Magic uniPaaS V1 使用許諾契約書(Studio)

Magic uniPaaS® V1 使用許諾契約書

uniPaaS Studio
uniPaaS Client

No. MSJC-11-001-1

お客様へのお願い

このパッケージに入っているソフトウェアをご購入またはご使用にあたり、本契約書を十分にお読みください。このパッケージを開封された場合には、本契約に同意されたものとみなします。
このパッケージを開封された際には、ユーザ登録を行ってください。ユーザ登録をされていない場合には、このパッケージに入っているソフトウェアに関するサポートは致しかねますので、ご了承ください。

Magic Software Enterprises社（以下「MSE」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「MSJ」という）まで書面にてご連絡いただきますようお願い致します。

1. 総則

許諾プログラムに関する全ての著作権は、MSEが保有しています。MSEはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。

2. 契約期間

本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。

3. 使用権

使用権の内容はお客様が購入された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守してください。

  • uniPaaS Studioの場合
      お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途取得しなければなりません。

  • uniPaaS Clientの場合
      お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて、又は購入したユーザ数分を特定のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途取得しなければなりません。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途取得しなければなりません。

4.　制限

お客様は、以下の行為をしてはならないものとします。（但し、MSE による書面による同意がある場合は、この限りではありません。）

(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。

(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。

(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。

(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。

(5) ASPやSaaSあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)

5. 許諾プログラム等の複製

(1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。

(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。

(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、MSEの事前の許諾を得るものとします。

6. ＭＳＪおよびＭＳＥの保証の範囲

(1) MSJおよびMSEは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってMSJおよびMSEの唯一の保証とします。

(2) MSJおよびMSEの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。

7. 契約の解約

MSJは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。

8. 契約終了時の措置

本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。

9. 一般条項

本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。

10. 準拠法および裁判管轄

本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


Magic uniPaaS V1 使用許諾契約書(Server)

Magic uniPaaS® V1 使用許諾契約書

uniPaaS Enterprise Server
uniPaaS RichClient Server

No. MSJC-11-002-2

お客様へのお願い

ソフトウェアをご購入またはご使用にあたり、本契約書を十分にお読みください。
ソフトウェアのご使用前に、ユーザ登録を行ってください。ユーザ登録をされていない場合には、このパッケージに入っているソフトウェアに関するサポートは致しかねますので、ご了承ください。

Magic Software Enterprises社（以下「MSE」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「MSJ」という）まで書面にてご連絡いただきますようお願い致します。

1. 総則

許諾プログラムに関する全ての著作権は、MSEが保有しています。MSEはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。

2. 契約期間

本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。

3. 使用権

使用権の内容はお客様が購入された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守してください。

  • uniPaaS Enterprise Server の場合

お客様は、許諾プログラムを機械読取可能な形で、コンピュータ・システムにおいてお客様が購入した合計のインスタンス数、及びスレッド数分を同時に使用すること（以下「使用権」という）ができます。

  • uniPaaS RichClient Server の場合

お客様は、許諾プログラムを機械読取可能な形で、コンピュータ・システムにおいてお客様が購入した合計のユーザ数分を同時に使用すること（以下「使用権」という）ができます。

  • スタンバイ・ライセンス　オプション

お客様は、高可用性環境でスタンバイ・システムを設定するために、uniPaaS Enterprise ServerまたはuniPaaS RichClient Serverに対してスタンバイ・ライセンスを使用することができます。本番用ライセンスに障害が発生している場合にスタンバイ・ライセンスを使用することのできる制限的な権利を意味します。本番用ライセンスと同じ構成でライセンスが必要です。

4.　制限

お客様は、以下の行為をしてはならないものとします。（但し、MSE による書面による同意がある場合は、この限りではありません。）

(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。

(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。

(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。

(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。

(5) ASPやSaaSあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)

5. 許諾プログラム等の複製

(1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。

(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。

(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、MSEの事前の許諾を得るものとします。

6. MSJおよびMSEの保証の範囲

(1) MSJおよびMSEは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってMSJおよびMSEの唯一の保証とします。

(2) MSJおよびMSEの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。

7. 契約の解約

MSJは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。

8. 契約終了時の措置

本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。

9. 一般条項

本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。

10. 準拠法および裁判管轄

本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


Magic uniPaaS® V1 ソフトウェア・メンテナンス契約書

uniPaaS Enterprise Server
uniPaaS RichClient Server

No. MSJC-11-003-1

お客様と、マジックソフトウェア・ジャパン株式会社（以下「MSJ」という）とは、お客様が購入される、MSJの親会社であるMagic Software Enterprises Limited（以下「MSE」という）が著作権等の知的財産権を有しMSJが日本国内の販売権を有する本件製品（後に定義する）について、以下の通りソフトウェア・メンテナンス契約（以下「本契約」という）を締結します。

第1条 （本件製品）

本契約の対象となる製品（以下、「本件製品という」）は、Magic uniPaaS V1購入申込書のサイト情報（以下、「サイト」という）に記載された、お客様の同一サイトに導入される全てのuniPaaS Enterprise Server V1/uniPaaS RichClient Serverとなります。

第2条 （ソフトウェア・メンテナンス）

本契約によりMSJからお客様に提供されるサービスは、第3条および第4条（以下、「ソフトウェア・メンテナンス」という）の通りです。

第3条 （メンテナンス）

MSJはお客様に対して、本件製品のプログラムの一般的に入手可能な最新バージョンもしくはアップデートモジュールを提供します。ただし、これらがMSEより提供された場合に限ります。

第4条 （サポート）

1． MSJはお客様に対して以下のサポートを提供します。

(1) 導入や使用方法に関する日常的、かつ短時間の質問に対する応答

(2) プログラム・コードに起因する障害に対するサポート

2． MSJはMagicサポートセンターのサービス提供時間中に、電子アクセスを介して、お客様のテクニカル・サポート担当者にのみサポートを提供します。

3． 本契約には以下のサポートは含まれません。

(1) アプリケーションの設計と開発に対するサポート

(2) プログラムの指定稼動環境以外の環境における本件製品の使用に関するサポート

(3) 本契約の下でMSJが責任を負わない製品に起因する障害に対するサポート

第5条 （保証）

第3条および第4条は、本契約に基づくソフトウェア・メンテナンスについての保証のすべてを規定したもので、法律上の瑕疵担保責任、商品性の保証および特定目的適合性の保証を含む全ての明示もしくは黙示の保証責任、または保証条件に代わるものとします。

第6条 （有効期間）

本契約の有効期間は、サイトに最初に導入される本件製品がMSJからお客様に出荷された日（以下、「効力発生日」という）から、１年後の同月末日（以下、「有効期間満了日」という）までとします。ただし、効力発生日が月の第1日目の場合は、効力発生日から１年後の前月末日までとします。第11条あるいは第12条の規定により本契約が終了あるいは解除されない限り、本契約は更に１年間自動更新されるものとし、それ以降も同様とします。

第7条 （ソフトウェア・メンテナンス更新日）

本契約の有効期間満了日の翌日が、サイトに最初に導入される本件製品のソフトウェア・メンテナンス更新日となります。

第8条 （契約の継続）

お客様が、本契約の継続を行わず、後日、ソフトウェア・メンテナンスの取得を希望する場合には、未契約期間の2倍の費用をMSJに支払うことにより継続することができることとします。

第9条 （追加導入）

同一サイト内に本件製品が追加導入される場合、追加導入される本件製品の最初のソフトウェア・メンテナンス更新日は、その本件製品が、MSJからお客様に出荷された日から１年後の翌月第１日目とします。ただし、出荷された日が月の第1日目である場合は、1年後の同日とします。最初に導入された本件製品のソフトウェア・メンテナンス更新日と、追加導入された本件製品のソフトウェア・メンテナンス更新日が一致しない場合は、以降の更新を、最初に導入された本件製品のソフトウェア・メンテナンス更新日に合わせるために、追加導入された本件製品のソフトウェア・メンテナンスを月単位で料金調整し、最初に導入された本件製品の更新時に合わせてお客様に請求します。

第10条 （サイト管理）

ソフトウェア・メンテナンスのライセンスを管理する単位をサイトといい、同一法人、同一敷地の管理とします。同一サイトで複数の本件製品を導入する場合は、前条により、それらのソフトウェア・メンテナンス更新日は同一日となります。

第11条 （契約の終了）

MSJが、本件製品のソフトウェア・メンテナンスを終了する場合、MSJは、事前にお客様に通知することとし、MSJは、自らの裁量により、有効期間満了日まで本件製品に対するソフトウェア・メンテナンスをお客様に対して提供するか、またはMSJに対して月割り計算した料金を返金します。

第12条 （契約の解除）

1． お客様は、MSJに文書により通知することにより本契約を解除することができます。

2． MSJは、お客様が本契約に定める事項に違反した時、またはお客様において本契約を継続しがたい重大な事由があるとMSJが認めた時は、お客様に対し、何ら事前の通知なしに直ちに本契約を解除できるものとします。

3． 本条第1項および第2項によって契約が解除された場合、MSJは支払い済みの料金を返還しません。

第13条 （協議事項）

本契約に定めのない事項あるいは本契約の履行について疑義の生じた場合は、お客様およびMSJ並びにMSJは誠意をもって協議し、解決に努力するものとします。

第14条 （合意管轄）

本契約から生ずる一切の権利義務に関する紛争については、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


Unicodeを利用する場合の注意事項

はじめに

この文書はMagic eDeveloper V10 からサポートされたUnicodeを利用する際の補足事項をまとめたものです。

プロジェクト開発

Unicode文字を設定できる箇所

開発するプロジェクトの中で設定するデータは、アプリケーション実行時に表示あるいは出力するデータ項目について、Unicode特有の文字を登録することができます。開発者のみ参照できるデータ項目については、Shift-JISコードに含まれる文字のみ登録可能です。

Unicode特有の文字を設定できる箇所

Unicode特有の文字を設定できない箇所

  • フォーム名

  • 定義式の文字データ

  • テキストコントロールの文字データ

  • ユーザメニュー名

  • ヘルプ項目のテキスト

  • モデル、データソース、プログラム等の各リポジトリ名

  • データソースの項目名

  • インデックス名

  • 外部キー名

  • 変数名、パラメータ名

  • ユーザイベント名

  • フォーム内のコントロール名

  • その他、左記以外の箇所

実行エンジンの動作

データの照合順序

Shift-JISとUnicodeは、格納される文字コードが異なりますので、それぞれをキー項目としたデータの処理順序が異なることにより、プログラムの範囲抽出処理やバッチのグループ処理に影響がでる可能性があります。
また、SQLデータベースを利用する場合は、そのデータベースマネージャ固有の機能や設定による影響があります。

文字コードを比較した場合の文字種類別の順序は次の通りです。

Shift-JIS（文字型項目)のコード順序 | Unicode(Unicode型)のコード順序
1.半角数字 2.半角英 3.半角カナ 4.全角数字 5.全角英 6.ひらがな 7.カタカナ 8.漢字 | 1.半角数字 2.半角英 3.ひらがな 4.カタカナ 5.漢字 6.全角数字 7.全角英 8.半角カナ

漢字については、個々の漢字のコード順序が異なります。 例えば、「亜」と「一」ではShift-JISとUnicodeで、次のようにコードの順序が異なります。

 | 亜 | 一 | 結果
Shift-JIS | 0x889F | 0x88EA | 亜が一より先
Unicode | U+4E9C | U+4E00 | 一が亜より先

関数

文字型項目をパラメータに持つ関数に対して、文字型項目とUnicode型項目を設定した場合の戻り値は次のようなルールがあります。

  • 文字型/Unicode型のパラメータ数を数える。(それぞれを m, n とする) ※ 文字定数の場合は、文字型/Unicode型共に+1する

  • m≠n ならば、多い方のアルゴリズムを採用

  • m=n であり、戻り値が文字型かUnicode型ならば、戻り値にあわせる。

  • m=n かつ戻り値が文字型/Unicode型以外ならば、デフォルトとして文字型とする。

  • 文字型の場合、全角文字は1文字を2でカウントしますが、Unicode型の場合、全角文字を1文字を1でカウントします。

例1. Len関数

文字列の長さを数える関数
書式：　戻り値 = Len(文字パラメータ)

  • 項目Aが文字型項目で'あ'を格納した場合、Len(RTrim(A))の戻り値は2です。

  • 項目BがUnicode型項目で'あ'を格納した場合、Len(RTrim(B))の戻り値は1です。

例2. MID関数

文字列の中から、指定された位置とサイズにあった、文字列を取得する関数
書式：　文字の戻り値 = MID(文字パラメータ, 開始位置, 文字数)

# | パラメータの型 | 戻り値の型 | 戻り値の結果
1 | 文字型 | 文字型 | バイト単位に取得
2 | 文字型 | Unicode型 | バイト単位に取得
3 | Unicode型 | 文字型 | 文字単位に取得
4 | Unicode型 | Unicode型 | 文字単位に取得
5 | 値(*1) | 文字型 | バイト単位に取得
6 | 値(*1) | Unicode型 | 文字単位に取得

*1 式に直接、'あいうえお'などの文字列を指定する場合

例3. REP関数

文字列中の位置と文字数を指定し、その部分を別の文字列に置き換える関数
書式：　文字の戻り値 = REP(文字パラメータ1, 文字パラメータ2, 位置, 文字数)

# | パラメータ1の型 | パラメータ2の型 | 戻り値の型 | 戻り値の結果
1 | 文字型 | 文字型 | 文字型 | バイト単位に取得
2 | 文字型 | 文字型 | Unicode型 | バイト単位に取得
3 | 文字型 | Unicode型 | 文字型 | バイト単位に取得
4 | 文字型 | Unicode型 | Unicode型 | 文字単位に取得
5 | Unicode型 | 文字型 | 文字型 | バイト単位に取得
6 | Unicode型 | 文字型 | Unicode型 | 文字単位に取得
7 | Unicode型 | Unicode型 | 文字型 | 文字単位に取得
8 | Unicode型 | Unicode型 | Unicode型 | 文字単位に取得
9 | 文字型 | 値(*1) | 文字型 | バイト単位に取得
10 | 文字型 | 値(*1) | Unicode型 | バイト単位に取得
11 | Unicode型 | 値(*1) | 文字型 | 文字単位に取得
12 | Unicode型 | 値(*1) | Unicode型 | 文字単位に取得
13 | 値(*1) | 文字型 | 文字型 | バイト単位に取得
14 | 値(*1) | 文字型 | Unicode型 | バイト単位に取得
15 | 値(*1) | Unicode型 | 文字型 | 文字単位に取得
16 | 値(*1) | Unicode型 | Unicode型 | 文字単位に取得

*1 式に直接、'あいうえお'などの文字列を指定する場合

その他の関数の留意事項

  • 文字型項目からUnicode型項目、またはUnicode型項目から文字型項目への代入、または項目更新処理を行う場合、内部で変換を行いますので、UnicodeFromANSI関数/UnicodeToANSI関数を使う必要はありません。
  • 現在のバージョンでは、Mail関数(MailSend/MailMsgTextなど）は、Unicode特有の文字は対応していません。

その他

  • 入出力ファイルのメディアにテキスト形式プリンタを設定した印刷処理では、Unicode特有の文字の印刷は対応していません。Unicode型データはGUI形式プリンタに設定して印刷してください。

  • メッセージコンポーネントに対して、Unicode型のパラメータを渡すことはできません。

  • フォーム入力で、UnicodeやUTF-8のファイルタイプの場合、文字型項目に入力すると文字列がカットされる場合があります。

  • フォーム出力で、ANSIのファイルタイプの場合、Unicode型項目を出力すると文字列がカットされる場合があります。

  • サロゲート・ペア文字（4バイトのUnicode文字）については、現在対応されておりません。

Unicode対応のWebアプリケーションを作成する場合

マージ機能を用いて Shift-JISに存在しないUnicode固有の文字を使う Web アプリケーションを作成する場合には、以下の点に留意してください。

  • V10では、マージテンプレートファイル、および、テンプレートに埋め込むデータに、日本語およびUnicode固有文字を使うことができます。

  • マージテンプレートファイルに、Unicode固有の文字を使う場合には、BOM (Byte Order Marker) 付きの UTF-8 で格納してください。BOMを付加しなければ、デフォルトで Shift-JIS と解釈されますので、正しい結果が得られなくなります。テンプレートにUnicode固有文字を使わない場合には、Shift-JISでも構いません。

  • 入出力ファイルテーブルでは、リクエスタを定義する際、入出力ファイル特性の「使用する文字セット」パラメータに「T=UTF-8」を指定してください。Webブラウザへ返送されるHTMLデータが UTF-8 でエンコードされます。A=Ansi あるいは O=OEM では、Shift-JISに変換されるので、Unicode 固有の文字が正しく出力されません。

  • ハイパーリンクをクリックしたり、フォームのサブミットを行った時には、WebブラウザからWebサーバへ送信されるHTTPリクエスト(GETおよびPOST)のパラメータは、UTF-8 でエンコードされてWebサーバに送信されます。文字コードを正しく解釈するために、Magicエンジン(eDevRTE.exe) と同じフォルダにある MGREQ.INI ファイルで、ConvertAlphaFromUTF8ToUnicode = Y フラグを設定してください。このフラグについては、Ver 10.1J SP1a での新機能 を参照してください。

  • ハイパーリンクで定義されたURLに、日本語やUnicode固有文字を埋め込むと、WebブラウザからWebサーバへ送信されるHTTPリクエスト(GET)に不正な文字が入ることがあります。URLにはこのような文字を避けてください。

  • フォームでサブミットするとき(POSTリクエストの場合)には、パラメータに日本語やUnicode固有の文字を使うことはできますが、アプリケーション名や公開プログラム名に使うと正しく動作しません。アプリケーション名や公開プログラム名には、半角英数字のみを使うようにしてください。

データベース固有の制限事項

MS-SQL Server

  • Unicode型/BLOB型(Unicodeタイプ)に設定したときに対応するMS-SQL Serverのカラムタイプは次の通りです。

データソースの型／内容 | データソースのサイズ | MSSQL Serverの型
Unicode型 | 1-4000 | nvarchar
Unicode型 | 4001以上 | ntext
BLOB型/Unicode | - | ntext/イメージ(*)

*SP2から記憶型式により異なります。

  • デフォルトの照合順序が設定されたデータベースでは、Unicodeに依存しないMS-SQL Serverのソート処理により、文字型項目のソート処理の結果と互換性があります。

  • 埋込SQLの入力パラメータにUnicode特有の文字を渡す場合、パラメータの先頭文字にNを付加する必要があります。
    例．select * from TESTTAB where UNICODEMOJI = N':1'

  • 文字型255桁のカラムを含むデータソースをMagicで定義し、APG実行によりテーブル作成しようとすると「SQL0604N 列の長さ、精度、または位取り属性、特殊タイプ、構造化タイプ、構造化タイプの属性、関数、あるいはタイプ・マッピング "CHAR(255)" が無効です。 SQLSTATE=42611」とエラー表示され、テーブル作成できません。(2000326)

  • 埋込SQLの入力パラメータ、およびDB SQL WHEREのパラメータにUnicode特有の文字を渡す場合、パラメータの先頭文字にNを付加する必要があります。

例．select * from TESTTAB where UNICODEMOJI = N':1'

Oracle

  • Unicode型/BLOB型(Unicodeタイプ)に設定したときに対応するOracleのカラムタイプは次の通りです。

データソースの型／内容 | データソースのサイズ | Oracleの型
Unicode型 | 1-2000 | NVARCHAR2
Unicode型 | 2001以上 | NCLOB
BLOB型/Unicode | - | NCLOB/BLOB (*)

*SP2から記憶型式により異なります。

  • SQL WHERE句に Unicode 固有の文字を文字定数として使うことはできません。

  • 埋込SQLのINOUTのパラメータが定義されたプロシージャに対して、出力パラメータにUnicode型項目を指定した場合、正しく動作しません。

  • 埋込SQLの入力パラメータにUnicode固有の文字を指定する場合、バインド変数(接頭辞にコロン(:)でなく、チルダ(~)を指定）を指定してください．この場合、パラメータを''で囲む必要はありません。

DB2 UDB

  • Unicode型/BLOB型(Unicodeタイプ)に設定したときに対応するDB2 UDBのカラムタイプは次の通りです。

データソースの型／内容 | データソースのサイズ | DB2 UDBの型 | データベースのコードセット(*1)
Unicode型 | 1-127 | GRAPHIC | UTF-8(*2)
Unicode型 | 128-16333 | VARGRAPHIC | UTF-8(*2)
Unicode型 | 16336以上 | DBCLOB | UTF-8(*2)
BLOB型/Unicode | - | DBCLOB/BLOB (*3) | IBM-943(デフォルト)

    *1 データベース作成時に指定し、作成後に変更できません。

    *2 IBM-943に設定した場合、半角英数字、およびUnicode特有の文字が正しく格納できません。

*3 SP2から記憶型式により異なります。

  • DB2 UDB V8.2で、Unicode型項目のあるテーブルの新規作成に失敗する場合、db2cli.iniに次のパラメータ を設定してください。このファイルは通常、クライアントマシンのDB2 UDBクライアントモジュールをインストールしたフォルダに存在します。

[Common]
Graphic = 1

  • 埋込SQLのステートメントやSQL Where句は、Shift-JISの文字列でデータベースに送るため、入力パラメータにUnicode特有の文字を渡しても、正しく動作しません。

  • UTF-8に設定されたデータベースでは、文字型項目についても内部コードがUTF-8で格納されるため、次のような問題があります。

    1. ２バイト文字を最大桁数まで登録しようとすると、「SQL0302N EXECUTE またはOPENステートメント内のホスト変数の値が大きすぎます。 SQLSTATE=22001」のエラーが発生します。
    2. ソート順序がUTF-8の文字コード順になります。

Pervasive.SQL (ISAM)

  • Unicode 型項目を扱うためには、ファイルフォーマットを 7.x あるいはそれ以上にしてください。これは P.SQL の仕様制限によるものです。

  • Unicode 型項目をインデックスとした場合、正しく並ばないことがあります。これは P.SQL の問題で、「P.SQL8 SP3およびP.SQL SP2において対応されています。
    AG-TECH社のホームページ http://www.agtech.co.jp/download/update/pervasive/psqlv8s3/history.html に、以下のような情報があります： 「49474 mkde mkde Btrieve WSTRING キーで UNICODE 文字列データの並べ替え順に問題があった。」