ReportsMagic Ver1.3b 追加情報

マジックソフトウェア・ジャパン
株式会社２００８年１１月

ReportsMagic Version1.3b 追加情報

RMDesigner
RMViewer

本文書には､ReportsMagic Verison1.3b として提供されたプログラム に関して、マニュアルの記載事項以外の追加情報が記述されています。

  • 本バージョンのご利用にあたって [image] 　ご使用前に必ずお読みください。
  • サンプルフォーム、アプリケーション （RMDesigner）
  • サンプルフォーム、アプリケーション（RMViewer Web版／RichClient版）
  • V1.3bの新機能
  • V1.3bの改善・変更内容
  • 制限事項及び留意事項
  • 修正履歴
    V1.3aの新機能
    V1.3aの改善・変更内容
    V1.3の新機能
    V1.3の改善・変更内容
    V1.1の新機能
    V1.1の改善・変更内容
    V1.0Bの新機能
    V1.0Bの改善・変更内容
    V1.0Aの改善・変更内容
  • 参考技術情報
  • 付録
    各種リンク情報
    ベータ版評価レポートのお願い
    製品構成
    動作環境
    ＦＡＱ
    使用許諾契約

本バージョンのご利用にあたって

ベータ版、体験版をご利用になったお客様に

ベータ版、体験版から製品版に移行する場合には、以下の点にご留意ください。

  • 本製品版をインストールするにあたりましては、ベータ版、体験版のモジュールが残って思わぬ悪影響を与えることを避けるため、ベータ版、体験版のアンインストールを行い、ファイル等の設定を完全に削除してください。
  • ベータ版、体験版で作成したフォームデータは、製品版で使用することはできません。

RMViewer（ActiveX)のアップデート

メンテナンス処理、アップグレード処理で RMViewer（ActiveX)の再登録を実行した場合、「RMViewer体験版のご案内」、「RMViewerCtl.ocx の DllRegisterServerは成功しました」等のダイアログが表示される場合があります。その場合は、Enterを入力してそのまま継続してください。

過去のバージョンとの互換性

RMDesignerで作成されるフォームは、バージョン番号により管理されています。
基本的にフォームファイルは、上位互換性を持ちますが、下位互換性はサポートされていません。 旧フォームファイルを開き、書込みを行うと自動的に新バージョンへ移行しますので、事前にバックアップすることをお薦めいたします。

旧バージョンのフォームの移行

RMDesignerで旧バージョンのフォームを読み込むと自動的に、最新バージョンのフォームへ移行されます。
以下のようなダイアログが表示されます。

フォームの上位互換

フォームの上位互換は以下のようになっています。

 |  | フォームをオープンするRMViewerのバージョン
 |  | V1.0 | V1.1 | V1.2 | V1.3 | V1.3a/V1.3b
フォームが作成されたバージョン | V1.0 | ○ | ○ | ○ | × | ×
 | V1.1 | × | ○ | ○ | × | ×
 | V1.2 | × | × | ○ | × | ×
 | V1.3 | × | × | × | ○ | ○
 | V1.3a/V1.3b | × | × | × | × | ○

RMViewer V1.3bは、V1.3aとフォーム バージョンが同一です。RMViewer V1.3bは、V1.3、V1.3a/V1.3bのフォームのみサポートされ ます。

 |  | フォームをオープンするRMDesignerのバージョン
 |  | V1.0 | V1.1 | V1.2 | V1.3 | V1.3a/V1.3b
フォームが作成されたバージョン | V1.0 | ○ | ○ | ○ | △※1 | △※1
 | V1.1 | × | ○ | ○ | △※1 | △※1
 | V1.2 | × | × | ○ | △※1 | △※1
 | V1.3 | × | × | × | ○ | △※1
 | V1.3a/V1.3b | × | × | × | × | ○

※1：旧フォームを開くことは可能ですが、旧バージョンのフォームを修正することはできません。　新バージョンへ移行する必要があります。

Windows Vistaでのインストール及び実行について

Windows Vista にReportsMagic をインストール及び実行する場合、以下の点に注意してください。

実行許可の確認
インストールは、Administrators グループに所属しているユーザで行ってください。
UAC が有効の場合、インストールプログラムの実行時に［ユーザー アカウント制御］ダイアログが表示されます。ここで［続行］ をクリックしてください。処理が継続して行われます。

ベータ機能／ご意見、要望事項について

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外となります。
又、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールにて japan_v10beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

サンプルフォーム、アプリケーション（RMDesigner）

各種サンプルフォーム、及びMagicアプリケーションが提供されています。

RMDesigner での確認

  • RMDesigner.exe を起動し 該当のフォームを開き、ツール／テストでサンプルデータを選択します。
サンプルフォーム | フォーム名 C:\ReportsMagic\ RMdataV13\ | サンプルデータ C:\ReportsMagic\ RMdataV13\ | 備考
家族構成 （マルチデータフォーム） | EmpfamilyCsv.rfr | EmpfamilyCsv.csv | CSV形式
 | EmpfamilyCsvhead.rfr | EmpfamilyCsvhead.csv EmpfamilyCsvheadUTF-8.csv EmpfamilyCsvheadUTF-8BOM.csv EmpfamilyCsvheadUTF-16BOM.csv EmpfamilyCsvheadUTF-16BOMBig.csv | CSVヘッダー付き形式 文字コードパターン ・SJIS ・UTF-8 ・UTF-8BOM付き ・UTF-16 ・UTF-16ビッグエンディアン
 | EmpfamilydbFORM.rfr | EmpfamilydbForm.dat | dbFORM形式
 | EmpfamilyXml.rfr | Empfamily.xml EmpfamilyUTF-8BOM.xml EmpfamilyUTF-16BOM.xml EmpfamilyUTF-16BOMBig.xml | XML形式 文字コードパターン ・SJIS ・UTF-8 ・UTF-16 ・UTF-16ビッグエンディアン
家族構成一覧 | EmpfamilyList.rfr | EmpfamilyList.xml | XML形式 レイヤ関数使用
勘定科目名 （dbFORMからの移行） | HIKAKU.ｒｆｒ | HIKAKU.dat | dbFORMのフォームを読み込んで作成したものです。
 | HIKAKU.FRM | HIKAKU.dat | オリジナルのdbFORMのフォームです。新規フォームを作成し、「ファイル／dbFORM読み込み 」で 読み込むことができます。その後、「ツール／帳票設定」のデータ形式をdbFORM形式にして、確認します。
複合文書 | Fukugo.rfr （Fukugo.rff） | Fukugo.xml | 納品書、請求書、納品受領書の複合文書です。
複数ページ | Fukusu.rfr （Fukusu.rfc） （Fukusu.rff） | Fukusu.xml Fukusu100.xml/Fukusu500.xml/ Fukusu1000.xml/Fukusu1740.xml （Fukusu.xmc） | 暗黙の改ページのサンプルです。
複数テーブル | MtblFukusu.rfr | MtblFukusu.xml | 複数テーブルのサンプルです。
 | MtblFukusu2.rfr | MtblFukusu2.xml
バーコード | バーコード.rfr | バーコード.xml | バーコードの一覧表です。
イメージ | イメージ.rfr | イメージ.xml | イメージ処理のサンプルです。
ヒサゴ GB1101-納品書 (罫線無） | GB1101-納品書(罫線無）.rfr | GB1101納品書.xml | ヒサゴ GB1101-納品書(罫線無） プレプリントへの印刷を想定。納品書のイメージをスキャナー読み込みし、項目の位置合わせをしています。
ヒサゴ GB1101-納品書 (罫線有） | GB1101-納品書(罫線有）.rfr | GB1101納品書.xml | ヒサゴ GB1101-納品書(罫線有） ヒサゴのフォーマットに合わせて罫線等をReportsMagicで作成しています。
扶養控除等申告書 | 扶養控除等申告書（H18).rfr | 扶養控除等申告書（H18).xml |
保険料控除等申告書 | 保険料控除等申告書(H17).rfr | 保険料控除等申告書(H17).xml |
ブレーク処理 納品書 | BrNouhin1.rfr | BrNouhin.xml | 納品書ブレーク処理 ブレーク項目 ・日付、伝票番号
 | BrNouhin2.rfr | BrNouhin.xml | 納品書ブレーク処理 1レコード 複数行表示レイアウト ブレーク項目 ・日付、伝票番号
演算子処理 | 演算子処理.rfr | 演算子処理.xml | 演算子処理
言語変換 | EmpfamilyXml.rfr | Empfamily.xml | 言語変換ファイル「家族構成English.mls」を使用します。 日本語が英語になります。 RMDesigner.exeのツール／テストでは確認できません。サンプルのメニューがらRMViewerを起動して確認します。
文字列ライン | SetTextLine.rfr SetTextLineP.rfr | SetTextLine.xml | 文字列ライン指定関数（SetTextLine）のサンプル SetTextLine.rfrとSetTextLineP.rfrの違いはフォントが異なるのみです。

圧縮暗号化のファイル（xmc、csc、rff）は、RMViewerで確認します。

  • RMDesigner－サンプルのメニューをクリックして起動してください。
メニュー | フォーム名 RMdataV13\ | 備考
Magic V10の起動 |  | Magic eDeveloper V10起動
Magicの起動 |  | Magic eDeveloper V9Plus起動
バーコード | バーコード.rfr | XML形式 A4縦 RMViewer.exe起動
ヒサゴGB1101-納品書(罫線無） | GB1101-納品書(罫線有）.rfr | XML形式 A4縦 RMViewer.exe起動
ヒサゴGB1101-納品書(罫線有） | GB1101-納品書(罫線無）.rfr | XML形式 A4縦 RMViewer.exe起動
演算子処理 | 演算子処理.rfr | XML形式 A4縦 RMViewer.exe起動
家族構成 | EmpfamilyXml.rfr | XML形式 A4縦 RMViewer.exe起動
家族構成.HTML | EmpfamilyXml.rfr | XML形式 A4縦 ブラウザ起動
家族構成-言語変換 | EmpfamilyXml.rfr | XML形式 A4縦 RMViewer.exe起動
納品書-１レコード複数行表示 | BrNouhin2.rfr | XML形式 A4縦 RMViewer.exe起動
納品書-ブレーク処理 | BrNouhin1.rfr | XML形式 A4縦 RMViewer.exe起動
扶養控除等申告書 | 扶養控除等申告書（H18).rfr | XML形式 A4縦 RMViewer.exe起動
複合文書 | Fukugo.rfr | XML形式 A4縦 RMViewer.exe起動
複合文書.HTML | Fukugo.rfr | XML形式 A4縦 ブラウザ起動
複数テーブル | MtblFukusu.rfr | XML形式 A4縦 RMViewer.exe起動
複数ページ | Fukusu.rfr | XML形式 A4縦 RMViewer.exe起動
複数ページ.HTML | Fukusu.rfr | XML形式 A4縦 ブラウザ起動
複数ページ－大量 | Fukusu.rfr | XML形式 A4縦 RMViewer.exe起動 大量ページのサンプルでRMViewer.のマルチスレッドの動作を確認できます。
保険料控除等申告書 | 保険料控除等申告書(H17).rfr | XML形式 A4縦 RMViewer.exe起動

RMDesignerで添付しているRMViewerは体験版です。

HTMLの場合、フォーム、印刷データのパスをドライブ指定で記述していますが、URLに変更することも可能です。
ただし、運用時には、RMViewerライセンスに注意が必要です。　ライセンス等の製品構成に関しては、こちらを確認してください。

●例
<param name="RfrFile" value="http://localhost/ReportsMagic/RMdataV11/EmpfamilyXml.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/RMdataV11/Empfamily.xml">
<param name="ToolBar" value="on">

Magicと連携したサンプル

Ｃ／Ｓ（Ｖ１０／Ｖ９Plsu）

家族構成のXMLフォーム（EmpfamilyXml.rfr）を使用したサンプルアプリケーションです。
プログラムリポジトリの「ReportsMagic サンプル-メイン」をＦ７で実行してください。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
Magic Viewer ActiveX | Magicから ActiveX 呼び出しで、RMViewerを実行します。
Magic Viewer EXE | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。
Magic Viewer EXE Cmd | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。 RMViewerコマンドライン実行関数を使用しています。
HTML Viewer | ブラウザから、RMViewerを実行します。 表示用のHTML（家族構成.htm）を生成し、オープンします。
RMCompSec | 圧縮・フラットファイルを作成します。

  • サンプルアプリケーションは、V10.1SP4b、及びV9.4 SP6bで開発されています。
  • 「Magic Viewer EXE」、「Magic Viewer EXE Cmd」に印刷範囲指定のパラメータが追加されました。 指定する場合は、プレビュー表示をNoにします。

リッチクライアント（Ｖ１０）

リッチクライアントのサンプルが追加されました。
プログラムリポジトリの「ReportsMagic サンプル-メイン」　公開名(RMMain）をＦ７で実行します。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
RC Viewer ActiveX | リッチクライアントのブラウザコントロールでRMViewer（ActiveX）を実行します。
RC Viewer EXE(http) | リッチクライアントから RMExeViewer.exe使用してRMViewer.exeを実行します。
大量印刷 | 大量印刷デモです。 フラットファイルを使用した方法とPDFを使用した方法が提供されています。 ①フラットファイル生成後、ブラウザコントロール（RMViewer）表示 ②RMViewerからPDF出力後、ブラウザコントロール（PDF Reader）表示

サンプルプログラムは、 理解をしやすいように構造をシンプルにしていますが、実務で使用するには以下のような考量が必要です。

  • マルチユーザに関しては、対応していません。 (印刷データ、HTML名、プリンタ名等）
  • 大量印刷の印刷用データ(XML)は固定データです。 （動的に生成はしていません）
    100、500、1000、1740ページ、（Fukusu100.xml、Fukusu500.xml、Fukusu1000.xml、Fukusu1740.xml）が準備されています。
  • PDF出力をリッチクライアントタスクで実行しています。
    大量印刷のような長時間のバッチ処理が想定される場合は、バッチタスク（並行実行、又はMagic Enterprise Serverによりコールリモート）で処理する必要があります。
    （リッチクライアントタスクでは、Javaの仕様により２分間で終了しなければエラーとなります。）

V10リッチクライアントの環境設定

V10 リッチクライアントのサンプルを使用する場合に設定します。

  • PDF出力には、「PDFファイルを出力するソフト」が別途必要になります。
    PDFは、決められたフォルダ内に自動出力でき、PDF生成後に結果表示をしない機能が必要です。　（テスト的に手作業でフォルダ指定等を行うようにすれば可能です。）
    事前にPDF出力フォルダを作成してください。（デフォルトは、C:\PDF）
    又、PDFのプリンタ名を設定します。
  • 論理名を必要に応じて修正します。

C:\Program Files\ReportsMagic\RMDesigner\Sample\MagicV10\RMini.ini

/[MAGIC_LOGICAL_NAMES]RM_URLRoot = *http://localhost/ReportsMagic13Sample/	←仮想ディレクトリ名
/[MAGIC_LOGICAL_NAMES]RM_ExePass = *C:\PROGRA~1\REPORT~1\RMDESI~1		←RMExeViewer.exe格納フォルダパス（最後に\は不要）
/[MAGIC_LOGICAL_NAMES]RM_PDF = *C:\PDF\				←PDF出力フォルダ名
/[MAGIC_LOGICAL_NAMES]RM_PDFPrinterName = SkyPDF Pro Driver	←PDF出力プリンタ名

サンプルフォーム（RMViewer Web版／RichClient版）

RMViewer Web版、RichClient版のサンプル

インストーラは、IIS環境がある場合、IISの仮想ディレクトリの設定を行います。

RMDesignerのサンプルのHTML（ブラウザ）のデモは、ファイルアクセスで行っています。

製品 | URL
RMViewer Web版 | http://ホスト名/ReportsMagic13/ReportsMagicWeb.html
RMViewer RichClient版 | http://ホスト名/ReportsMagic13/ReportsMagicRC.html

  • RichClient版には、RMViewer exe版のダウンロードが提供されています。
  • IE 6以上でないと動作しない場合があります。


ReportsMagic Ver1.3b 修正履歴

V1.3bの新機能

関数の拡張
元号年　書式の対応
RMDesignerの拡張
RMViewerの拡張

関数の拡張

文字列ライン指定関数

関数名：@SetTextLine ( 線種, 線種, 色テーブル番号)
機能：文字列の上に線を引く
引数：
      形状（0：取消線, 1：二重取消線, 2：アンダーライン, 3：囲み線, 4：角各囲み)
      線種（0：実線, 1：破線, 2：点線, 3：一点鎖線, 4：二点鎖線）
      色テーブル番号（0～70） （0の場合は文字色、塗潰し指定は無効）

(例)
@SetTextLine ( 0, 0, 2)

  • フォントの情報を元に、線幅、線位置を自動計算しますので、フォントによっては異なる場合があります。
  • 文字の回転には対応していません。

元号年　書式の対応

元号年の書式が拡張されました。　これにより元号記号が無い元号年の表記が可能になりました。

指示記号 | 機能 | 例
ＧＧ | 元号年 | YY年MM月 ⇒ 08年07月 GG年MM月 ⇒ 20年07月

必ず2桁で指定してください。

RMDesignerの拡張

XML不正時のエラーログ出力

XML形式印刷データの場合に、XMLが不正の場合、ログ出力するようになりました。
開発時にXMLの不具合により正しく印刷されない場合の原因分析に役立ちます。

RMDesignerの ツール－テストの時のみ有効です。

●rmerror.logの例

※ライン12行のカラム11の/fieldを示しています。　エラー発生場所によっては、Line番号がテーブル区切になったりします。
＜正常なXML＞
0123456789101234567890
04 __<PrintData>
05 ____<report form="EmpfamilyXml.rfr">
06 ______<form no="1">
07 ________<field tag="会社名">
08 __________<value>マジックソフトウェア・ジャパン株式会社</value>
09 ________</field>
10 ________<field tag="社員番号">
11 __________<value>11</value>
12 ________</field> 		＜不正なXML＞
0123456789101234567890
04 __<PrintData>
05 ____<report form="EmpfamilyXml.rfr">
06 ______<form no="1">
07 ________<field tag="会社名">
08 __________<value>マジックソフトウェア・ジャパン株式会社</value>
09 ________</field>
10 ←社員番号のfield tagの欠落
11 __________<value>11</value>
12 ________</field>

コピー＆ペーストの改善

通常、コピー＆ペーストを行うと右下にペーストされますが、ペース位置が拡張されました。

キー操作 | ペースト位置
Ｃｔｒｌ＋V | 右下
Ｃｔｒｌ＋Alt＋V | 下（右移動しない）
Ｃｔｒｌ＋Shift＋V | 右（下移動しない）

サンプルプログラム

リッチクライアントのサンプルプログラムが追加されました。

RMViewerの拡張

ActiveX起動オプションの互換性向上

RMViewer起動オプションとActiveX起動オプションのパラメータ仕様が異なるため、ActiveXを拡張して両方のパラメータで動作するようにしました。

プロパティ一覧 | 内容
Thumbnail | サムネール表示 （'on','off' 又は、'y','n'）
ToolBar | ツールバー表示 （'on','off' 又は、'y','n'）

用紙サイズ，用紙の向き，給紙方法

プリンタ名の指定が拡張されて用紙サイズ，用紙の向き，給紙方法が指定できるようになりました。

プリンタ名(/用紙サイズ，用紙の向き，給紙方法(，用紙の長さ，用紙の幅) )（/垂直オフセット，水平オフセット）

用紙サイズでユーザ定義を指定した場合のみ用紙の長さ，用紙の幅が指定可能です。

（例）
/prn=EPSON LP-9400
/prn=EPSON LP-9400/A4 210 × 297 mm，縦，用紙ﾄﾚｲ
/prn=EPSON LP-9400/，，用紙ｶｾｯﾄ1
/prn=EPSON LP-9400/ﾕｰｻﾞｰ定義ｻｲｽﾞ，，，2000，1000

※省略した場合は、各プリンタのデフォルト値となります。

  • 「 起動オプションの一覧」は、こちら を「RMViewer ActiveX起動オプション」は、こちらを確認してください。
  • プリンタ名、用紙サイズ、用紙の向き、給紙方法の名称で’/’が含まれる場合には、’\/’と指定してください。

オフセット指定

ReportsMagicは、プリンタの印刷可能領域を考量して印刷するので、原則印刷位置がずれることはありません。　しかし、プリンタのハード的劣化等により印刷位置がずれた場合、オフセット指定により印刷位置を補正することが可能になります。

プリンタ名(/用紙サイズ，用紙の向き，給紙方法(，用紙の長さ，用紙の幅) )（/垂直オフセット，水平オフセット）

垂直オフセット，水平オフセットは、-99～+99　（±9.9mm）で指定可能です。

（例）
/prn=EPSON LP-9400//-12,+34 　上へ1.2mm、右へ3.5mm
/prn=EPSON LP-9400/A4 210 × 297 mm，縦，用紙ﾄﾚｲ/-12,+34　上へ1.2mm、右へ3.5mm

印刷可能領域を超える補正を行うと超えた部分は印刷されません。

RMViewer起動用DLL

VER1.3用にRMViewer実行関数(Execute)　が拡張されました。

  • Ver1.3 RMViewer実行関数(Execute)
      構文……定義式：RMViewer.Execute131
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）　用紙サイズ、用紙の向き、給紙方法 、オフセットが指定できるようになりました。
    プリンタ名(/用紙サイズ，用紙の向き，給紙方法(，用紙の長さ，用紙の幅) )（/垂直オフセット，水平オフセット）
      ④RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型）
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示）
      ⑨拡大率（文字型）　　　（‘10～500’、‘i’、‘w’、‘a’、‘p’）
      ⑩ページレイアウト（文字型） 　（1,2,3）
      ⑪サムネール表示 （文字型）　（'y' または 'n'で指定）
      ⑫メニューバー表示 （文字型） （'y' または 'n'で指定）
      ⑬ツールバー表示 （文字型）　（'y' または 'n'で指定）
      ⑭ステータスバー表示 （'y' または 'n'で指定）
      ⑮言語変換ファイル名（文字型）
      ⑯レイヤ表示の指定 （文字型） レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定（1234567SOV）
      ⑰印刷範囲指定（文字型）
      ⑱実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑲エラーメッセージ（文字型）

RMViewer exe版ダウンロード形式インストーラ

RMViewer RichClient版で提供されている「RMViewer exe版ダウンロード形式インストーラ」は、インストール後に以下の環境変数をセットするようになりました。

システム環境変数名

内容

RMVIEWER_HOME

RMViewerのインストールフォルダパス

  • RMViewer.exeのインストールフォルダがクライアント毎に異なる場合、RMExeViewer.exeの起動パスを取得することが可能になります。
    リッチクライアント上の環境変数は、ClientOSEnvGet関数で取得可能です。
    (例）C:\PROGRA~1\REPORT~1\RMDESI~1
    最後に\は含まれません。

  • 環境変数への反映は、インストール後に再起動が必要です。

V1.3bの改善・変更内容

RMDesigner

  • テーブルのプロパティで列数を変更しても、列サイズをリサイズしないようにしました。 リサイズしたい場合は、RMDesigner.iniで、下記のパラメータを追加してください。
    [General-Summary]
    TableResize=Y
  • 項目の項目書式の値を大きく設定した場合、書式表示で、項目の書式内容が文字化けする件に対応しました。

データ連携

  • CSV形式でダブルクオートのエスケープ処理が正しく動作しない件に対応しました。
    （例）”あ,””う”⇒あ,””う　と認識される。　正しくは、あ,”う
  • CSV形式でブレーク処理を設定すると、不要なブレークタイトルが入る場合がある件に対応しました。

データ項目ウインドウ

  • データ項目ウインドウのXMLテンプレート出力で複数のテーブルがある場合、一番行数が多いテーブルを最後に出力するようになりました。
  • データ項目ウインドウのXMLテンプレート出力で同じデータ項目名が複数存在している場合、１つの項目のみを出力するようになりました。
  • データ項目ウィンドウのテーンプレート出力で生成したテンプレートファイルの改行は、コードLF(0x0a)のみでしたが、CR(0x0d)、LF(0x0a)で出力するように変更されました。ただし、 旧バージョンで生成したLFのみのテンプレートでも動作としては問題はありません。

その他

  • RMCompSec01.dllからRMCompSec05.DLLをRMCompSec.dllの起動したフォルダからロードできるようになりました。
  • 項目書式を文字の255バイト以上に設定すると、書式のサンプル表示する文字化けする件に対応しました。
  • 複数行の文字列を文字ピッチを0で、縮小して全体出力した場合、下寄せ、センタリングの位置がずれる件に対応しました。
  • 横文字で文字ピッチを文字幅より大きく設定している場合、水平均等すると、枠からはみ出して表示される件に対応しました。
  • 文字拡大率を100%より大きく、文字ピッチを0に設定している場合、枠からはみ出して表示される件に対応しました。
  • 文字幅拡大率を100%より大きく設定している場合、センタリング、下寄せに設定していると、位置がずれて表示される場合がある件に対応しました。
  • 縦文字の場合、半角文字の文字ピッチが無効になる件に対応しました。
  • 縦文字で文字ピッチの文字幅拡大率を100%より大きく設定すると、行ピッチが広く表示される件に対応しました。
  • 二重線で実線以外の場合、上下の線種パターンがずれる件に対応しました。

RMViewer

  • サムネ－ル表示でサムネ－ル画面クリック時に、右表示が１ページだけ表示される場合がある件に対応しました。
  • サムネ－ル表示－連続２ページで、右側ページの表示枠が表示されない場合があるのに対応しました。
  • ActiveX版でサムネイル及び、ツールバーの設定を'off''にしても表示される件に対応しました。
  • ActiveX版でMLSのパス指定でhttpが有効にならない件に対応しました。
  • RMViewer Web版のRMViewer.exeで、ファイルオープンダイアログからhttp形式でオープンできない件に対応しました。
  • 帳票設定でプリンタを指定している場合、プリンタ名が同じでも、出力先が異なるとエラーになり印刷できない件に対応しました。
  • 言語変換ファイルを指定してRMViewerを起動するとクラッシュする場合がある件に対応しました。
  • Active-X版で複数HTMLを起動すると、不定期にクラッシュする件に対応しました。
  • 大量ページを印刷すると、不定期にデータが欠ける件に対応しました。
  • プレビュー表示で、暗黙改ページが数ページ表示すると、クラッシュ件に対応しました。

マニュアル（Readme)の主な変更

  • RMViewer 起動オプション
  • RMViewer ActiveX起動オプション
  • RMViewer exe版－ActiveX版　起動オプション 比較
  • RMViewer exe版　プリンタ名の指定
  • CSV（Comma-Separated Values）
  • バーコード
  • 製品構成
  • 動作環境
  • ＦＡＱ


ReportsMagic Ver1.3b 追加情報

制限事項及び留意事項

イメージ

  • スタティックなイメージ読み込みは、イメージ形式によっては実際のイメージと異なる表示になる場合があります。
  • イメージをデータ項目として使用する場合、サポートしているイメージ形式は以下の種類です。
    BMP、PNG、JPEG
  • イメージのデータ項目の場合、イメージデータのサイズ比率を維持したままで、コントロール上に収まるように拡大/縮小します。

印刷

  • Windowsのプリンタドライバを使用しての印刷のみをサポートしています。
  • プリンタの内蔵フォントで印刷した場合には、ReportsMagicで表示されているフォントと印刷されるフォントが異なる場合があります。
    その場合は、プリンタのプロパティのフォントの設定をプリンタ内臓のフォントから TrueType フォントに変更します。TrueType フォントを使用する設定はプリンタの種類によって異なりますので、お使いのプリンタのマニュアルをご覧ください。

dbFORM

  • dbFORMのフォームを読み込んだ場合、若干フォームイメージが異なる場合があります。
  • dbFORMのフォームを読み込んだ場合、データや罫線等の一部がスキャナレイヤに割りあたっている場合があります。その場合は、他のレイヤに変更してください。　尚、デフォルトではスキャナレイヤは「選択不可」になっていますので、一度「選択可」にしてください。
  • 文字単位のフォント指定、属性指定は、できません。
  • 文字の囲み、傍点、袋文字、影付き、立体、下付、上付はサポートされていません。
  • バーコードはサポートされていません。
  • 縦書きの場合、１バイト文字は縦書きになりません。
       dbFORM形式は、既存フォームの移行を主目的としており、ReportsMagicの新機能サポート、今後の機能拡張の計画はありません。
既存フォームを取り込んだあとは、CSV、XML形式に移行されることを推奨いたします。

データ連携

  • テーブルの連結には、対応していません。
  • 複数テーブルの場合、暗黙の改ページはサポートされません。　明示的な改ページで作成します。
  • 複数テーブルの場合、テーブルの行数分の印刷データが存在しない場合は、空白のダミーデータを作成してください。
  • 複数テーブルの場合、異なる行数のテーブルを組合わせる場合は、行数が多いテーブルが最後になるように印刷データを生成してください。

データ項目ウインドウ

  • データ項目ウインドウを表示している状態で、フォーム上のデータ項目を削除しても、データ項目ウインドウには反映されません。その場合は、データ項目ウインドウの再表示を実行してください。
  • フォームに割り付けたデータ項目のプロパティを開いて項目名を変更した場合、新規に変更した項目が追加されます。 以前のデータ項目は、データ項目削除ダイアログで削除することができます。

その他

  • 外字を使用する場合は、実行するPCに事前に外字を登録しておく必要があります。
  • 文字列を固定幅フォント－文字ピッチ０の状態で使用すると、解像度の異なるコンピュータで表示イメージが異なる場合があります。その場合は、文字ピッチを指定するようにしてください。
  • 縦文字を指定した場合、フォントは@が付いた縦書き用フォントを選択してください。縦書用フォントで無い場合は@MSゴシックを使用します。
  • テーブルをネストして使用することは出来ません。
  • フォーム作成時に稀に画面にゴミが表示される場合があります。　その場合は。再表示(Ｆ５）を行ってください。
  • Magic eDeveloper V10で「ReportsMagicアプリケーションウイザード」は、サポートされていません。
  • マルチフォーム（複合帳票）で異なる用紙サイズを組合わせることは、サポートされていません。

バーコード

  • 各バーコードの仕様に合わせたサイズになるようにフォームを調整してください。
  • プリンタ、用紙、リーダ、トナーの濃度などの組み合わせにより正しく読み取れない場合があるので、実際に使用される環境で十分テストを行うようにしてください。
  • 郵便カスタマーバーコードの詳細情報は、参考技術情報を参照してください。、

RMViewer

  • RMViewer（ActiveX)をMagicのバッチタスクで印刷することは出来ません。バッチタスクで印刷する場合は、RMViewer（EXE)を使用してください。

Unicode

  • サロゲート・ペア文字（4バイトのUnicode文字）については、対応していません。

既知の不具合

  • 図形のプロパティの座標でX,Y座標を変更後、基準点を変更した場合、 X,Y座標が変更前の座標で座標変換されている。
  • 図形のプロパティでは幅と高さを0に設定し、適用すると、以降、 幅と高さを0以外の設定しても幅と高さが0の状態で表示されてしまう。
  • テーブルのエディットで、フォント名やサイズ等の状態表示ができない。


ReportsMagic Ver1.3 修正履歴

V1.3aの新機能

RMViewer RC版
圧縮、解凍化（RMCompSec.DLL）のマルチスレッド対応
圧縮、解凍化（RMCompSec.DLL）のMLS対応
Flatファイル保存機能
関数の追加
RichClient用RMViewer起動EXE
サムネールの操作性向上
RMViewerの拡張

RMViewer RichClient版

Magic RichClient Server 用のRMViewerとして RMViewer RichClient版の製品が追加されます。
従来のRMViewer と異なり、C/S（ファイルパス）、Web（http）の両方のアクセスをサポートします。
これにより、Magicリッチクライアント環境でオンラインにおいても、RMViewerを使用することが可能になります。

 | ライセンス | アクセス | 圧縮、解凍化 | RMViewer exe版 ダウンロード形式インストーラ
RMViewer C/S版 | 同時ユーザ数 | ファイルパス | シングルスレッド | －
RMViewer Web版 | サーバ | Http | マルチスレッド | －
RMViewer RichClient版 | 同時ユーザ数 | ファイルパス＆Http | マルチスレッド | 提供されます。

※ReportsMagicの製品構成は、こちらを参照してください。

RMViewer exe版ダウンロード形式インストーラ

Webサーバから、ダウンロードしてクライアントPCにインストールするインストーラが提供されます。　RMViewer C/S版 のイメージに近いものですが、ライセンス登録が必要なく、ファイルパス、及びHttpアクセスの両方をサポートします。

インストーラの分離

従来は、C/S版、Web版は、同じインストーラを使用していましたが、V1.3aからは以下のように分離 されるようになります。
・RMViewer C/S版
・RMViewer Web版
・RMViewer RichClient版
RMViewer Web版、RMViewer RichClient版では、Webサーバ（IIS)の設定 も行います。

圧縮、解凍化（RMCompSec.DLL）のマルチスレッド対応

圧縮、解凍化（RMCompSec.DLL）がマルチスレッド対応になりました。これにより、Magic Enterprise Server、Magic RichClient Serverのマルチスレッド環境で使用することが可能になります。

マルチスレッド環境で使用するには、RMCompSec.RMCS_Initのパラメータに以下を指定しします。

/MultiThread=Y

構文 定義式: RMCompSec.RMCS_Init
パラメータ
パラメータ (入力引数:文字型)
戻り値 (戻り値:数値型)
エラーメッセージ (戻り値:文字型)

  • RMViewer Web版、RMViewer RichClient版でのみ使用することができます。RMViewer C/S版（Magic Client）の環境では、指定してもシングルスレッドとして動作します。
  • RMCompSec.DLLのエラーコード一覧が更新されています。　詳細は、参考技術情報を参照してください。

使用DLL

  • RMCompSec.dll、RMCompSec01.dll～RMCompSec05.dll

圧縮、解凍化（RMCompSec.DLL）のMLS対応

圧縮、解凍化（RMCompSec.DLL）で言語変換ファイル（MLS）も含めることが出来るようになりました。

構文 定義式: RMCompSec.RMCS_Encode2
パラメータ
①フォームファイルパス （入力引数，文字型）
②印刷データファイルパス （入力引数、文字型）
③言語変換ファイルパス （入力引数、文字型）
④圧縮・暗号化ファイルパス （入力引数、文字型）
⑤オプション （入力引数、文字型）
   0：RFC作成
   1：XMC作成
   2：CSC作成
   3：RFF作成指示
⑥パスワードオプション （入力引数、文字型）
   0：フォームファイルのパスワードを使用
   1：無し
   2：個別指定 （次項のパスワードで指定）
⑦パスワード （入力引数、文字型）
⑧戻り値 （戻り値、数値型）
   0:正常終了 負付きの数値型３桁で返します。
⑨エラーメッセージ（戻り値：文字型）

  • RMCompSec.DLLのエラーコード一覧が更新されています。　詳細は、参考技術情報を参照してください。

Flatファイル保存機能

RMViewerでFlatファイルを保存することが可能になりました。
有効にするには、帳票設定／実行時設定で「Flatファイル保存」有効にしておく必要があります。

関数の追加

レイヤ指定関数

関数名：@layer(レイヤ)
機能：レイヤの表示/非表示の制御を行います。
      明示的改ページでのみ使用可能です。
      １ページ内で複数回設定された場合は最後に設定されたものが有効になります。
引数：レイヤ1～7、スキャナ、OLE、オーバレイの順番で指定("1234567SOV")します。
      '0':指定レイヤを表示しない
      '1':指定レイヤを表示する
      '-':指定レイヤをデフォルトのまま
(例)
@layer("110-------")

RichClient用RMViewer起動EXE

Magic RichClientのクライアント側でOSコマンドでRMViewerを起動するためのＥＸＥ（RMExeViewer.exe）が提供されています。
RMViewerの戻り値も取得することが可能です。

インストール
RMViewer exe版ダウンロード形式インストーラでインストールします。

起動パラメータ
RMExeViewer [Viewer実行ディレクトリ] [Viewer実行パラメータ：省略可] [ウェイト：(Y/N デフォルト:Y) [エラーメッセージ表示：省略可(Y/N デフォルト:N)]

エラーメッセージ表示は、Debug用のオプションでバックグランド印刷時（dsp=n）でも戻り値を表示することが出来ます。

例：

RMExeViewer "C:\Program Files\ReportsMagic\RMViewerRC" "" N Y

RMExeViewer "C:\Program Files\ReportsMagic\RMViewerRC" "/pagelayout=2 /thumbnail=y"

RMExeViewer "C:\Program Files\ReportsMagic\RMViewerRC" "/rfr=Scripts\sample\RMdataV13\Fukusu.rfr /rdata=Scripts\sample\RMdataV13\Fukusu.xml"

RMExeViewer "C:\Program Files\ReportsMagic\RMViewerRC" "/rfr=C:\Progra~1\ReportsMagic\RMViewerRC\Scripts\sample\RMdataV13\Fukusu.rfr /rdata=C:\Progra~1\ReportsMagic\RMViewerRC\Scripts\sample\RMdataV13\Fukusu.xml"

RMExeViewer "C:\Program Files\ReportsMagic\RMViewerRC" "/rfr=http://localhost/ReportsMagic13/sample/RMdataV13/Fukusu.rfr /rdata=http://localhost/ReportsMagic13/sample/RMdataV13/Fukusu.xml"

サムネールの操作性向上

  • 右表示エリアの表示領域が表示枠（赤）で表示、クリックで移動可能
  • ページ番号の表示

RMViewerの拡張

起動オプションの一覧

表示方法 | 内 容
フォームファイルの指定 | /rfr=フォームファイル名
印刷データファイルの指定 | /rdata=データファイル名
プレビュー表示 | /dsp=[y|n] ‘y’ ･････プレビュー表示をします。 ‘n’ ･････プレビュー表示を行わず、すぐにバックグラウンドで印刷を開始します。
プリンタ名の指定 | /prn= …… 実行時に印刷プリンタを指定することが可能です。
拡大率の指定 | /zoom= ‘10～500’の数字、または‘i’、‘w’、‘a’または ‘p’を指定します。 10から500の数字 ･････ 拡大率を表します。100が通常の倍率です。 ‘i’ ･････ 基準倍率表示（デフォルト） ‘w’ ･････ ウインドウの描画領域幅にページの横幅を合わせます。 ‘p’ ･････ ページ全体を表示します。（デフォルト） ウインドウの描画領域の縦幅にページの縦幅を合わせます。 ‘a’ ･････ 全画面表示を行います。
ページレイアウトの指定 | /pagelayout= 1,2,3のいずれかを指定します。 ‘1’ ･････1ページ表示を行います。（デフォルト） ‘2’ ･････連続１ページ表示を行います。 ‘3’ ･････連続２ページ表示を行います。
サムネール表示の指定 | /thumbnail= ‘y’ または ‘n’ を指定します。 ‘ｙ’ ･････サムネール表示を行います。 ‘n’ ･････サムネール表示を行いません。（デフォルト）
メニューバー表示の指定 | /menubar= ‘y’ または ‘n’を指定します。 ‘ｙ’ ･････メニューバーを表示します。（デフォルト） ‘n’ ･････メニューバーを表示しません。
ツールバー表示の指定 | /toolbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ツールバーを表示します。（デフォルト） ‘n’ ･････ツールバーを表示しません。
ステータスバー表示の指定 | /statusbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ステータスバーを表示します。（デフォルト） ‘n’ ･････ステータスバーを表示しません。
言語変換ファイルの指定 | /mls=パス名 （例）RMViewer.exe /rfr=XXX.RFF /dsp=y /mls=XXXX.MLS
レイヤ表示の指定 | /layer=レイヤパラメータ を指定します。 レイヤパラメータ： レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定します。（1234567SOV） 0：非表示、1：表示、－：デフォルトのまま （例）RMViewer.exe /rfr=XXX.RFF /dsp=y /layer=1011100--- レイヤ１、３，４，５：表示、レイヤ２、６，７：非表示、スキャナ、OLE、オーバレイ：デフォルト表示
印刷範囲指定 | /page=[開始ページ]-[終了ページ] （例） /page=5 5ページのみ /page=5- 5ページから最終ページ ※プレビュー表示がNoで無ければ有効になりません。

「帳票設定」のRMViewer初期オープンモードよりも、起動オプションの方が優先されます。

RMViewer起動用DLL

VER1.3用にRMViewer実行関数(Execute)　が拡張されました。

  • Ver1.3 RMViewer実行関数(Execute)
      構文……定義式：RMViewer.Execute131
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型）
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示）
      ⑨拡大率（文字型）　　　（‘10～500’、‘i’、‘w’、‘a’、‘p’）
      ⑩ページレイアウト（文字型） 　（1,2,3）
      ⑪サムネール表示 （文字型）　（'y' または 'n'で指定）
      ⑫メニューバー表示 （文字型） （'y' または 'n'で指定）
      ⑬ツールバー表示 （文字型）　（'y' または 'n'で指定）
      ⑭ステータスバー表示 （'y' または 'n'で指定）
      ⑮言語変換ファイル名（文字型）
      ⑯レイヤ表示の指定 （文字型） レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定（1234567SOV）
      ⑰印刷範囲指定（文字型）
      ⑱実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑲エラーメッセージ（文字型）

V1.3aの改善・変更内容

RMDesigner

  • 「FLATファイルとして保存」でＦＬＡＴファイルが生成できない件に対応しました。

データ連携

  •

その他

  •

RMViewer

  • @tpage関数を使用した場合、バックグランド印刷では、総ページが最終ページしか印字されない件に対応しました。
  • Active-X版の場合、サムネイルの項目が項目名で表示される不具合に対応しました。
  • バックグランド印刷の場合の出力処理のパフォーマンスを改善しました。
  • FLATファイルオープン時。パスワード入力ダイアログで「キャンセル」をクリックしても即終了しない件に対応しました。
  • 旧バージョンで作成したFLATファイルが読めない件に対応しました。
  • 「プレビュー表示」なしの場合の印刷パフォーマンスを改善しました。
  • URL指定指定のイメージファイルが表示しない件に対応しました。（RMViewer C/S版は無効）

マニュアルの変更

  • RMCompSec.DLLのエラーコード一覧
  • RMViewer 起動用DLL－RMViewer.DLLのエラーコード一覧


ReportsMagic Ver1.3 修正履歴

V1.3の新機能

状態表示・変更機能
Unicode対応
フォームバージョンの移行
ブレイク処理
関数の追加
１レコード複数行出力
言語変換機能
その他の拡張
RMViewerの拡張

 状態表示・変更機能

Microsoft Wordのようにオブジェクトを選択（マウスでクリック）した場合、そのオブジェクトの状態を表示するようになりました。（以前は、新規作成時のデフォルト値を表示）
また、複数のオブジェクトを選択した状態でアイコンを操作すると対象オブジェクトの全てが変更することができます。

Unicode対応

Unicodeに対応しました。

対応文字コード

対象データ | 対応文字コード
フォームデータ | Unicode（UTF-16) 旧フォームを移行するとSJISからUnicodeへ変換します。
印刷データ |  SJIS（デフォルト）  UTF-8  UTF-16  UTF-16-ビッグエンディアン
起動パラメータ | SJIS

注意：サロゲート・ペア文字（4バイトのUnicode文字）については、対応していません。

印刷データの文字コードの識別方法

フォーム形式 | 識別方法
XML形式 | 印刷データのXMLのencoding=で指定します。 <?xml version="1.0" encoding="utf-8"?>
CSV形式 | ① フォーム－「帳票設定」で、デフォルト文字コードで指定します。 ② 印刷データのBOMで指定する。（①よりも優先します。）
dbFORM形式 | Unicodeはサポートされません。

BOM

文字コード | BOM (Byte Order Mark) HEX
UTF-8 | ef bb bf
UTF-16 | ff fe
UTF-16-ビッグエンディアン | fe ff

デフォルトの「文字コード」の指定

フォーム－「帳票設定」でデフォルトの「文字コード」を指定します。

フォームバージョンの移行

旧バージョンのフォーム

従来のように旧バージョンのフォームを読み込むと自動的に、最新バージョンのフォームへ移行されます。
以下のようなダイアログが表示されます。

フォームの上位互換

フォームの上位互換は以下のようになっています。

 | RMViewerのバージョン
作成されたバージョン | V1.0 | V1.1 | V1.2 | V1.3
V1.0 | ○ | ○ | ○ | ×
V1.1 | × | ○ | ○ | ×
V1.2 | × | × | ○ | ×
V1.3 | × | × | × | ○

RMViewer V1.3 は、V1.3のフォームしかサポートされません。

 | RMDesignerのバージョン
作成されたバージョン | V1.0 | V1.1 | V1.2 | V1.3
V1.0 | ○ | ○ | ○ | △※1
V1.1 | × | ○ | ○ | △※1
V1.2 | × | × | ○ | △※1
V1.3 | × | × | × | ○

※1：旧フォームを開くことは可能ですが、旧バージョンのフォームを修正することはできません。　新バージョンへ移行する必要があります。

ブレイク処理

ブレイク処理が定義できるようになりました。

ブレイク項目の定義

テーブルの各データ項目のブレイクキーを使用して、ブレイク項目を設定します。
最大４レベルまで指定できます。

ブレイク時表示は、ブレイクしたときに表示するタイトルを指定します。

ブレイクした時のタイトルを指定します。

ブレイク時の処理の定義

各データ項目毎にブレイク時の処理内容を指定します。

ページブレイク：

ブレイク表示 | 内容
空白 | ブレイクしても改ページしません。
Key | ブレイク時に改ページします。

ブレイク時表示：ブレイク時のブレイク表示内容を指定します。

ブレイク時表示 | 内容
表示なし | 表示しません。
タイトル | ブレイク項目の定義で定義したタイトルを表示します。
集計値 | ブレイク毎の集計値を表示します。

  • ブレイクの設定は、帳票１ページで一つのテーブルでしか設定できません。

データ項目ウインドウの拡張

データ項目ウインドウが拡張され、ブレイク、ブレイク表示、オペランド等が表示されるようになりました。
又、項目名をダブルクリックすることにより容易に各プロパティが表示できます。

関数の追加

条件

関数名：@if ( 条件 ，真の処理 ，偽の処理 )
機能：条件により、返す内容を変える
引数：条件 、条件分岐のための比較式など。
    条件が真の時、真の処理を行う。
    条件が偽の時、偽の処理を行う。

条件：データ項目名、固定値、演算子を用いて条件を記述します。データ項目名は”'”で囲みます。

(例)
@if ( '社員番号' > 1000，@SetTextColor ( 5)，@SetTextColor (6))

文字色指定

関数名：@SetTextColor ( 色テーブル番号)
機能：文字の色を指定する。関数を指定したデータ項目でのみ有効となる。
-1を指定すると非表示となります。

フォント指定

関数名：@SetTextFont ( フォントテーブル番号)
機能：文字のフォントを指定する。関数を指定したデータ項目でのみ有効となる。

演算子

作成されたバージョン | 演算子 | 内容 | 備考
算術演算子 | + | 加算 |
 | - | 減算 |
 | * | 乗算 |
 | / | 除算 |
 | MOD | 剰余 |
 | ^ | 指数 |
論理演算子 | = | 等しい |
 | <> | 等しくない |
 | < | 未満 |
 | <= | 以下 |
 | > | より大きい |
 | >= | 以上 |
 | NOT | 否定 |
 | AND | 論理積 |
 | OR | 論理和 |
特殊演算子 （ブレイク処理の中でのみ有効です） | @max | 最大値 | @max ( データ項目，処理区分) 処理区分： （1:ページ内,2:先頭から現在のページまで) (例) @max（’数量’，１）
 | @min | 最小値 | @min( データ項目，処理区分) 処理区分： （1:ページ内,2:先頭から現在のページまで) (例) @min（’数量’，１）
 | @ave | 平均値 | @ave ( データ項目，処理区分) 処理区分： （1:ページ内,2:先頭から現在のページまで) (例) @ave（’数量’，１）
 | @sum | 合計値 | @sum ( データ項目，処理区分) 処理区分： （1:ページ内,2:先頭から現在のページまで) (例) @sum（’数量’，１）

演算 に於ける有効桁数は、15桁です。

数値の四捨五入

関数名：@Round(数値,整数部桁数,小数部桁数)
機能：数値の一部を取り出し、その結果を四捨五入します。
引数：
・数値 … 処理の対象となる数値
・整数部桁数 … 取り出したい桁の整数の桁数を指定します。指定した数の桁は、小数点から左に向かって取り出されます。
・小数部桁数 … 取り出したい桁の少数の桁数を指定します。指定した数の桁は、小数点から右に向かって取り出されます。
戻り値：数値…取り出される小数部で一番右の次の桁が四捨五入され、その結果が返ります。

例：@Round(345.995,2,2)
46.00 が返ります。

数値の抽出（範囲外は切り捨て）

関数名：@Fix(数値,整数部桁数,小数部桁数)
機能：数値（実数または整数）を指定し、その一部を切り取ります。
引数：
・数値 …処理対象の数値
・整数部桁数 …指定した数値の整数部で切り取り後の桁数を指定します。整数部の場合、切り取りは左側から行われます。
・小数部桁数 …指定した数値の小数部で切り取り後の桁数を指定します。小数部の場合、切り取りは右側から行われます。
戻り値：数値

例：
@Fix(12345.6789,3,3)　345.678 が返ります。

IF( @Fix(M,2,0)=99,N+1,N)　数値M がチェックされ、M の整数部で右側の2 桁が99であった場合、N が1だけ増加します。

１レコード複数行出力

テーブルの１レコード（明細）において、複数行の出力がサポートされました。

テーブルの編集

何も選択していない状況でメニューの「Table」をクリックし、編集したいテーブル内の項目をクリックします。

テーブル内の各項目を編集します。

テーブル内の各項目を区切る縦罫線は、「縦罫線表示なし」をクリックすることにより表示しなくなります。
以下の例では、日付、伝票番号間の罫線表示がされなくなります。

言語変換機能

言語変換機能がサポートされました。
フォームの固定情報の文字列をRMViewerまたは、RMDesignerのテスト時に言語変換ファイルに沿って変換する機能です。
これにより、フォームを変更しなくても、複数の言語変換ファイルを使用することにより、複数の言語、またはユーザ毎のフォームを作成することが可能になります。

言語変換ファイル作成

  1. 変換元ファイル（テキストファイル）を次の形式で作成します。
  • １項目につき２行
  • 各行は（CR/LF）が終端
  • ２行目は、１行目の変換テキスト
    １行の最大長は1024文字
  2. メニューのツール／言語変換ファイル作成を起動します。

言語変換ファイル（MLS)を作成します。

  • ＜入力ファイル名＞は、1 で作成した変換元ファイルの名前です。
  • ＜出力ファイル名＞は、作成する言語変換ファイルの名前です。
    このファイルを［言語］テーブルの「変換ファイル」として選択します。
  • ＜文字コード＞は、元のテキストファイルのコードページを指定します。

RMDesignerでの言語変換ファイルの指定

テストを実行する場合の言語を選択します。

  1. メニューのツール／言語一覧を起動します。

  2. 作成した言語、言語変換ファイルを設定します。

編集、追加、削除を使用して言語変換ファイルのパスを設定します。

  3. デフォルト言語を設定します。　TEST実行時に使用されます。

空白、または言語一覧で設定した言語名を設定します。　空白にした場合は、無変換を意味します。

言語一覧の設定は、iniファイル（RmDesigner.ini）に格納されます。
他のPC環境に移行する場合は、言語一覧から再度登録するか、RmDesigner.iniのRM_LANGUAGEセクションをコピーします。
（例）
[RM_LANGUAGE]
DefaultLanguage=
Eng=C:\ReportsMagic\家族構成English.mls

RMViewerでの言語変換の実行

言語変換ファイルは、RMViewerの起動パラメータで指定します。
詳細は、RMViewerの拡張を参照してください。

その他の拡張

RMViewerの拡張

起動オプションの一覧

表示方法 | 内 容
フォームファイルの指定 | /rfr=フォームファイル名
印刷データファイルの指定 | /rdata=データファイル名
プレビュー表示 | /dsp=[y|n] ‘y’ ･････プレビュー表示をします。 ‘n’ ･････プレビュー表示を行わず、すぐにバックグラウンドで印刷を開始します。
プリンタ名の指定 | /prn= …… 実行時に印刷プリンタを指定することが可能です。
拡大率の指定 | /zoom= ‘10～500’の数字、または‘i’、‘w’、‘a’または ‘p’を指定します。 10から500の数字 ･････ 拡大率を表します。100が通常の倍率です。 ‘i’ ･････ 基準倍率表示（デフォルト） ‘w’ ･････ ウインドウの描画領域幅にページの横幅を合わせます。 ‘p’ ･････ ページ全体を表示します。（デフォルト） ウインドウの描画領域の縦幅にページの縦幅を合わせます。 ‘a’ ･････ 全画面表示を行います。
ページレイアウトの指定 | /pagelayout= 1,2,3のいずれかを指定します。 ‘1’ ･････1ページ表示を行います。（デフォルト） ‘2’ ･････連続１ページ表示を行います。 ‘3’ ･････連続２ページ表示を行います。
サムネール表示の指定 | /thumbnail= ‘y’ または ‘n’ を指定します。 ‘ｙ’ ･････サムネール表示を行います。 ‘n’ ･････サムネール表示を行いません。（デフォルト）
メニューバー表示の指定 | /menubar= ‘y’ または ‘n’を指定します。 ‘ｙ’ ･････メニューバーを表示します。（デフォルト） ‘n’ ･････メニューバーを表示しません。
ツールバー表示の指定 | /toolbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ツールバーを表示します。（デフォルト） ‘n’ ･････ツールバーを表示しません。
ステータスバー表示の指定 | /statusbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ステータスバーを表示します。（デフォルト） ‘n’ ･････ステータスバーを表示しません。
言語変換ファイルの指定 | /mls=パス名 （例）RMViewer.exe /rfr=XXX.RFF /dsp=y /mls=XXXX.MLS
レイヤ表示の指定 | /layer=レイヤパラメータ を指定します。 レイヤパラメータ： レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定します。（1234567SOV） 0：非表示、1：表示、－：デフォルトのまま （例）RMViewer.exe /rfr=XXX.RFF /dsp=y /layer=1011100--- レイヤ１、３，４，５：表示、レイヤ２、６，７：非表示、スキャナ、OLE、オーバレイ：デフォルト表示

「帳票設定」のRMViewer初期オープンモードよりも、起動オプションの方が優先されます。

RMViewer ActiveX　機能拡張

RMViewer ActiveX　プロパティ一覧

プロパティ一覧 | 内 容
Copy | コピー数
PageLayout | ページレイアウト番号
PrinterName | プリンタ名
RDataFile | 印刷データファイル名
RfrFile | フォームファイル名
Zoom | 拡大率（'10-500','i','w','a','p'）
Thumbnail | サムネール表示 （'on','off'）
ToolBar | ツールバー表示 （'on','off'）
Mls | 言語変換ファイル名
Layer | レイヤ表示

Beta1では、サポートされていません。

RMViewer ActiveX　メソッド一覧

メソッド一覧 | 内 容
AboutBox | RMViewer バージョン情報
OnThumbnail | サムネール表示
OnToolBar | ツールバー表示
PageFirst | 先頭ページ
PageLast | 最終ページ
PageLayout1 | ページレイアウトの指定 1ページ表示
PageLayout2 | ページレイアウトの指定 連続１ページ表示
PageLayout3 | ページレイアウトの指定 連続２ページ表示
PageNext | 次ページ
PagePre | 前ページ
PageSelect | 印刷範囲の指定
PrintData | 印刷
ZoomAll | 拡大率：ページ全体を表示
ZoomAllWidth | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
ZoomBase（ZoomTop） | 拡大率：基準倍率表示
ZoomFulll | 拡大率：全画面表示
ZoomIn | 拡大率：拡大
ZoomOut | 拡大率：縮小

RMViewer起動用DLL

VER1.3用にRMViewer実行関数(Execute)　が拡張されました。

  • Ver1.3 RMViewer実行関数(Execute)
      構文……定義式：RMViewer.Execute130
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型）
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示）
      ⑨拡大率（文字型）　　　（‘10～500’、‘i’、‘w’、‘a’、‘p’）
      ⑩ページレイアウト（文字型） 　（1,2,3）
      ⑪サムネール表示 （文字型）　（'y' または 'n'で指定）
      ⑫メニューバー表示 （文字型） （'y' または 'n'で指定）
      ⑬ツールバー表示 （文字型）　（'y' または 'n'で指定）
      ⑭ステータスバー表示 （'y' または 'n'で指定）
      ⑮言語変換ファイル名（文字型）
      ⑯レイヤ表示の指定 （文字型） レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定（1234567SOV）
      ⑰実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑱エラーメッセージ（文字型）

Beta1では、サポートされていません。

V1.3の改善・変更内容

RMDesigner

  • 新規でテーブルを作成した場合、データ項目ウィンドウに反映されない件に対応しました。　データ項目ウインドウへの更新にはテーブルで使用している全データ項目(項目名)を定義しておく必要があります。
  • ヘッダー無しCSV形式で、データ項目ウィンドウにおいてCSVファイルを読み込むと、末尾の項目名が2重に表示される件に対応しました。
  • グリッド設定で、入力点が1/3、1/4の時、グリッドとずれてしまう件に対応しました。
  • 図形の線において、幅最大化、幅最小化（高さ最大化、高さ最小化）が正しく機能しない件に対応しました。
  • RMDesignerの印字位置がRMViewerと異なる件に対応しました。
  • フォームを開いた直後にキー操作でコントロールの移動ができない件に対応しました。
  • 既存のフォームでテーブルコントロールのサイズを変えると、列の間隔が均一になってしまう件に対応しました。
  • 新規フォームでデータ項目ウィンドウからフォーム上にドラックした後、色番号やフォント番号を設定すると異常終了する件に対応しました。
  • フォームに登録しているプリンタが、Windowsに登録していない場合、帳票設定のプリンタ設定を実行すると異常終了する件に対応しました。
  • 新規にテーブルを作成後、データ項目ウィンドウを開くと、ゴミが表示される件に対応しました。
  • 下記の図形のプロパティで座標指定できるようにしました。
    テキスト、項目、楕円弧、イメージ、括弧、バーコード、テーブル
  • 直線、連続線の図形のプロパティで、幅または、高さを0に設定しても無効になる不具合に対応しました。
  • ページ情報編集でオーバレイページの「編集」でタイトル、印刷順の修正ができない不具合に対応しました。
  • 単体選択（マウスでクリック）した場合、Ctrl+Shift+右クリックで次候補（マウスでクリック範囲内で次の図形）選択するようにしました。

データ連携

  • XML形式で、フォーム番号やテーブルのレコード番号に空白があっても表示されるようになりました。
  • 文字型で書式を使用している場合、データ項目の最後の文字が半角カタカナの場合、最後の1文字が表示されない件に対応しました。
  • 小数点付の数値型書式で機能指示記号「Z」が指定されている場合、データが0の場合に小数点部分が空白にならない件に対応しました。
  • 数値項目で負数データの先頭がスペースの場合0になる不具合に対応しました。
  • 文字列、項目でエディット枠に文字列が収まらない場合、センタリングや右寄せを設定しても左寄せになる不具合に対応しました。

その他

  • 文字列で、プロポーショナルフォント、「縮小して全体を出力」の場合、テスト表示／印刷ビューアでは正しく表示されるが印刷すると縮小されない件に対応しました。
  • 文字列の均等割付で、文字列に全角データと半角スペースが混在した場合に文字列の最後に余白ができる件に対応しました。
  • バーコードEAN128に誤差があり、バーコードリーダで正しく読めない場合がある件に対応しました。
  • テキストや項目の文字サイズによっては、「縮小して全体を出力」を設定してもはみ出して表示される件に対応しました。
  • 帳票設定で余白を設定している場合、RMViewerで設定した余白値で印刷されない件に対応しました。

RMViewer

  • サムネイル表示で、テーブル表示に不正な行が表示されマウスのクリック等で再表示すると正しい行数が表示される件に対応しました。
  • Viewer起動時にパラメータでフォームとデータファイルを指定して実行すると@date(),@time()が印刷されない件に対応しました。


ReportsMagic Ver1.1 修正履歴

V1.1の新機能

バーコード
記憶型式対応
 書式対応
フォーム移行
その他の拡張
RMViewerの拡張
ReportsMagicアプリケーションウイザード
圧縮及び暗号化、フラットファイル対応
ベータ機能

バーコード

  • CODE39及びNW-7、ITFは、チェックディジットの有無が指定できるようになりました。
  • EAN128が追加されました。
    旧バージョンでもCODE128を利用することにより対応可能でしたが、CODEC, FUNC1を自動的に追加するようにしバーコード化したいデータのみで対応できるようなりました。
  • QRコードに対応しました。
    コード種別はモデル2にのみ対応しています。（モデル1、及びマイクロQRコードには対応していません。）
    詳細は、RMDesignerリファレンスマニュアル（図形の描画－バーコードの描画）を参照してください。

記憶型式対応

データ型

旧バージョンでは、種類と表現していました。　固定データ、データ項目、ページ番号、日付、時刻のデータ型に分類されて管理されるようになりました。

記憶型式

Magicと同様に記憶型式がサポートされるようになりました。

詳細は、RMDesignerリファレンスマニュアル（帳票ツールの概要－フォームファイルの設計）を参照してください。

dbFORM形式では、データ型は固定データとデータ項目のみ、記憶形式はサポートされません。

書式対応

Magicと同様に書式がサポートされるようになりました。 項目書式の記述方法は、基本的にMagicと互換です。

詳細は、RMDesignerリファレンスマニュアル（帳票ツールの概要－フォームファイルの設計）を参照してください。

dbFORM形式で書式は、サポートされません。

オペランド

  • 実行する関数を指定します。　従来は文字列の項目TAGで記述していました。

フォーム移行

旧バージョンのフォームを読み込むと自動的に、最新バージョンのフォームへ移行されます。
以下は、移行内容についての詳細です。

事前に旧フォームをバックアップされることをお奨めいたします。

データ型の対応
＜CSV形式、ヘッダ付きCSV形式、XML形式＞

旧フォームデータ | データ型 | 記憶型式 | 書式 | オペランド
項目TAGが空白 | 固定データ | 文字 | 書式は未設定（空白） |
項目TAGが非空白 | データ項目 | 文字 | 書式は未設定（空白） |
項目TAGが@page(X) | ページ番号 | 数字 | NNNN | @page(X)をコピー

書式 未設定（空白）は、V1.0Xと互換動作となります。

＜dbFORM形式＞

旧フォームデータ | データ型 | 記憶型式 | 書式 | オペランド
項目名に%%が無い | 固定データ | 文字 | 書式は未設定（空白） |
項目名に%%がある | データ項目 | 文字 | 書式は未設定（空白） |

項目名の統合

  • 旧バージョンでは、固定データ／可変（データ）項目を「項目TAG」の有無で判断していましたが、データ型のサポートにより不要になりました。　従って、旧バージョンの「項目名」、「項目TAG」は、「項目名」に統合されました。 この場合、項目名と項目TAGの内容が異なる場合には、項目名が削除されますので、ご注意ください。
データフォーム形式 | データ型
項目XML ヘッダー無しCSV ヘッダー付きCSV | 「項目TAG」を「項目名」にコピーし、旧バージョンの「項目名」は廃棄。
dbFORM | 「項目名」をそのままコピーします。 旧バージョンの「項目TAG」は廃棄。

その他の拡張

グリット設定の拡張

  • 縦・横の個別指定ができるようになりました。
  • 表示単位にCPI/LPIが追加されました。

グリット設定のフォーム格納

グリット設定で設定した情報をフォームファイルに格納するようになりました。
フォームを開いた場合は、フォーム格納時のグリット情報を元にグリット表示を行います。

レイヤ情報のフォーム格納、レイヤ情報の入力

  • レイヤ設定で設定した情報をフォームファイルに格納するようになりました。フォームを開いた場合は、フォーム格納時のレイヤ設定情報を元にレイヤを設定します。
  • レイヤ１～７は、レイヤに関するコメントを記入することが出来るようになりました。レイヤ画面を表示し、直接記入します。
  • 不可視のレイヤは、RMViewerでは表示されません。

基本色定義

Magicと同様に基本色定義がサポートされました。
これによりフォーム内の各種の色指定を一元管理することが可能になります。
詳細は、RMDesignerリファレンスマニュアル（図形の描画－はじめに 基本設定）を参照してください。

フォント定義

Magicと同様にフォント定義がサポートされました。
これによりフォーム内の各種フォント指定を一元管理することが可能になります。
詳細は、RMDesignerリファレンスマニュアル（図形の描画－はじめに 基本設定）を参照してください。

テーブルの罫線機能の拡張

テーブルの罫線の色指定、外枠罫線は、四隅に対して角丸め有無の指定ができるようになりました。

テーブルのプロパティの拡張

テーブル－各列データ項目の見出し、列データの一般、文字列、データ項目プロパティを切り替えて設定できるようになりました。

テーブルのプロパティで表示できる最大項目数は96個まです。　それ以上存在する場合は、テーブル上で個別に定義します。

テーブルの行、列の挿入、削除、移動

各行、列の追加、削除、移動が可能になりました。
詳細は、RMDesignerリファレンスマニュアル（図形の編集－テーブルの編集）を参照してください。

角丸四角の拡張

角丸四角は、四隅に対して角丸め有無の指定ができるようになりました。

非表示項目の指定

データ項目に対して、項目の非表示を指定できるようになりました。
CSV形式でページブレイクの項目を、非表示にしたい場合等に使用することが出来ます。
dbFORM形式では、サポートされません。

関数追加

  • @date()
    現在の日付を取得する。表示方法は書式に従う。
  • @time()
    現在の時刻を取得する。 表示方法は書式に従う。

RMDesignerアイコンの追加

  • 基本色定義
  • フォント定義
  • 縦文字列、横文字列　固定データ用　（従来の縦文字列、横文字列は、データ項目用）
  • OLE　新規オブジェクトの挿入
  • ライン整合
  • 領域移動
  • 交点間削除

    ツールバーのパレット桁のデフォルトは３に変更しました。

帳票設定－用紙指定

フォームの用紙設定を個別に行えるようになりました。
「帳票設定」のプリンタ設定の方式とは異なり、プリンタドライバを特定しないで作成することが出来ます。
開発／実行の印刷するプリンタ環境が異なることが想定される場合は、こちらの方法で作成することを推奨します。

以下の情報を設定することが可能です。

  • 用紙サイズ
  • 用紙向き
  • 余白 フォーム作成時のデフォルトプリンタの情報がセットされますが、変更することが可能です。
  • プリンタ設定の「リセット」を行えるようになりました。

RMViewer初期オープンモード

RMViewerでフォームをオープンした時の各種動作を指定できるようになりました。
「帳票設定」画面の「実行時設定」タブで指定します。

  • サムネール表示
  • ページレイアウト
    ・ 単一ページ
    ・ 連続ページ
    ・ 連続２ページ
  • 起動ページ番号
  • 拡大率
    ・ 倍率指定表示
    ・ 基準画面表示（デフォルト）
    ・ 全体表示
    ・ 描画領域の横幅に合わせる
    ・ 全画面表示
  • メニューバー非表示
  • ツールバー非表示
  • ステータスバー非表示

プレ印刷用紙の印刷時にスキャナレイヤの印刷が可能なように拡張されました。

  • プレ印刷用紙に印刷する（スキャナレイヤは印刷しない）

RMViewerの拡張

表示方法の拡張

  • メニューバー、及びアイコンが追加され以下の表示が可能になりました。

表示方法 | 内 容
領域指定拡大 | 拡大率：領域を指定して拡大表示
基準倍率表示 | 拡大率：基準倍率で表示します。(既存機能：アイコンが変更されました）
用紙全体表示 | 拡大率：ページ全体が表示できる倍率で表示
幅に合わせる | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
全画面表示 | 拡大率：ウインドウを最大化して表示
ページ番号表示 | 表示しているページの番号、総ページ番号が表示します。ページ番号を入力することによりページへジャンプすることが出来ます。
サムネール表示 | サムネールを表示するペインを左側に作成し、サムネール表示
単一ページ表示 | ページレイアウト：従来の表示方法で、一度に文書の1 ページ分だけを表示（既存機能）
連続ページ | ページレイアウト：ページを縦に続けて表示
連続２ページ | ページレイアウト：２ページを横に並べて、縦に続けて表示

起動オプションの追加

表示方法 | 内 容
フォームファイルの指定 | /rfr=フォームファイル名
印刷データファイルの指定 | /rdata=データファイル名
プレビュー表示 | /dsp=[y|n] ‘y’ ･････プレビュー表示をします。 ‘n’ ･････プレビュー表示を行わず、すぐにバックグラウンドで印刷を開始します。
プリンタ名の指定 | /prn= …… 実行時に印刷プリンタを指定することが可能です。
拡大率の指定 | /zoom= ‘10～500’の数字、または‘i’、‘w’、‘a’または ‘p’を指定します。 10から500の数字 ･････ 拡大率を表します。100が通常の倍率です。 ‘i’ ･････ 基準倍率表示（デフォルト） ‘w’ ･････ ウインドウの描画領域幅にページの横幅を合わせます。 ‘p’ ･････ ページ全体を表示します。（デフォルト） ウインドウの描画領域の縦幅にページの縦幅を合わせます。 ‘a’ ･････ 全画面表示を行います。
ページレイアウトの指定 | /pagelayout= 1,2,3のいずれかを指定します。 ‘1’ ･････1ページ表示を行います。（デフォルト） ‘2’ ･････連続１ページ表示を行います。 ‘3’ ･････連続２ページ表示を行います。
サムネール表示の指定 | /thumbnail= ‘y’ または ‘n’ を指定します。 ‘ｙ’ ･････サムネール表示を行います。 ‘n’ ･････サムネール表示を行いません。（デフォルト）
メニューバー表示の指定 | /menubar= ‘y’ または ‘n’を指定します。 ‘ｙ’ ･････メニューバーを表示します。（デフォルト） ‘n’ ･････メニューバーを表示しません。
ツールバー表示の指定 | /toolbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ツールバーを表示します。（デフォルト） ‘n’ ･････ツールバーを表示しません。
ステータスバー表示の指定 | /statusbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ステータスバーを表示します。（デフォルト） ‘n’ ･････ステータスバーを表示しません。

「帳票設定」のRMViewer初期オープンモードよりも、起動オプションの方が優先されます。

RMViewer ActiveX　機能拡張

RMViewer ActiveX　プロパティ一覧

プロパティ一覧 | 内 容
Copy | コピー数
PageLayout | ページレイアウト番号
PrinterName | プリンタ名
RDataFile | 印刷データファイル名
RfrFile | フォームファイル名
Zoom | 拡大率（'10-500','i','w','a','p'）
Thumbnail | サムネール表示 （'on','off'）
ToolBar | ツールバー表示 （'on','off'）

RMViewer ActiveX　メソッド一覧

メソッド一覧 | 内 容
AboutBox | RMViewer バージョン情報
OnThumbnail | サムネール表示
OnToolBar | ツールバー表示
PageFirst | 先頭ページ
PageLast | 最終ページ
PageLayout1 | ページレイアウトの指定 1ページ表示
PageLayout2 | ページレイアウトの指定 連続１ページ表示
PageLayout3 | ページレイアウトの指定 連続２ページ表示
PageNext | 次ページ
PagePre | 前ページ
PageSelect | 印刷範囲の指定
PrintData | 印刷
ZoomAll | 拡大率：ページ全体を表示
ZoomAllWidth | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
ZoomBase（ZoomTop） | 拡大率：基準倍率表示
ZoomFulll | 拡大率：全画面表示
ZoomIn | 拡大率：拡大
ZoomOut | 拡大率：縮小

RMViewer起動用DLL

VER1.1用にRMViewer実行関数(Execute)　が拡張されました。

  • Ver1.1 RMViewer実行関数(Execute)
      構文……定義式：RMViewer.Execute110
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型）
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示）
      ⑨拡大率（文字型）　　　（‘10～500’、‘i’、‘w’、‘a’、‘p’）
      ⑩ページレイアウト（文字型） 　（1,2,3）
      ⑪サムネール表示 （文字型）　（'y' または 'n'で指定）
      ⑫メニューバー表示 （文字型） （'y' または 'n'で指定）
      ⑬ツールバー表示 （文字型）　（'y' または 'n'で指定）
      ⑭ステータスバー表示 （'y' または 'n'で指定）
      ⑮実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑯エラーメッセージ（文字型）

コマンドラインで起動できるRMVieweコマンドライン実行関数(.CommandLine)　が追加されました。
  • RMViewerコマンドライン実行関数（CommandLine）
      構文……定義式：RMViewer.CommandLine
      バラメータ……
      ①RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ②コマンドライン（文字型）
      ③ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ④実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑤エラーメッセージ（文字型）

    ＜コマンドラインの例＞
    /rfr=C:\ReportsMagic\RMdataV11\EmpfamilyXml.rfr /rdata=C:\ReportsMagic\RMdataV11\Empfamily.xml
    /dsp=y /copy=1 /status=y /zoom=i /pagelayout=0 /thumbnail=n /menubar=y /toolbar=y /statusbar=y

RMViewer プレビューパフォーマンス向上

RMViewerをマルチスレッドにすることにより、プレビューのパフォーマンスを向上しました。
プレビュー用中間データ処理と表示処理をマルチスレッド化し、中間データ処理の途中でもプレビュー表示することが出来るようになりました。

  • ページ関数
    フォーム上で指定されているページ関数は、未決定状態の場合があります。その場合は、#で表示されます。
    （例）　001／###　 ###は総ページ数
  • RMViewer上のページ番号表示
    総ページ数は処理済のページ数が表示されます。　最終ページまで処理されていない場合は、総ページ数の最後に#が追加されます。
    （例）　1／18#　　→　確定後 1／1740
  • 印刷処理は、中間データが確定したタイミングで印刷を行います。

dbFORM形式では、サポートされません。

ReportsMagicアプリケーションウイザード

ReportsMagic用のアプリケーションウイザードが提供されています。

以下の機能が提供されています。

  • 印刷用データ作成プログラムの自動生成（XML形式、ヘッダー付きCSV形式）
  • マージ用テンプレートファイルの自動生成

詳細は、RMDesignerリファレンスマニュアル（アプリケーションウイザード）を参照してください。

圧縮及び暗号化、フラットファイル対応

フォームファイル、印刷データの圧縮及び暗号化、及びフラットファイルをサポートします。
フラットファイルは、フォームデータ＋印刷データを圧縮及び暗号化処理したファイルです。

拡張子の定義
圧縮＋暗号化及びフラットファイルは、拡張子により識別されます。

表示方法 | 標準 | 圧縮＋暗号化 | 備考
フォームファイル | RFR | RFC |
印刷データ ＸＭＬ | ＸＭＬ | XMC |
印刷データ ＣＳＶ | ＣＳＶ | CSC |
印刷データ dbFORM | 任意 | － | dbFROM形式は、圧縮＋暗号化、フラットファイル化はサポートされません。
フラットファイル | － | RFF | フラットファイルの指定は、フォームファイル名（/rfr=）で指定します。

動的イメージデータは、圧縮の対象となりません。従って、異なる環境でイメージデータを使用する場合、事前にイメージデータを準備しておく必要があります。

パスワード

RMViewer.exe起動時に、圧縮＋暗号化ファイルを指定する場合には、コマンドラインでパスワードを指定することが可能です。コマンドラインで指定していない場合は、パスワード入力のダイアログが表示されま す。

（例）
RMViewer.exe /rfr=XXX.RFC:password /rdata=XXX.XMC:password /dsp=y
RMViewer.exe /rfr=XXX.RFF:password

  • フォームファイル、印刷データファイル共に、圧縮＋暗号化ファイルを使用する場合には、パスワードが２つ必要となります。
  • 圧縮時にパスワード設定を行っていない場合は、パスワード入力は表示されません。

RMDesignerでのFLATファイル作成

RMDesigner上で、フラットファイルを生成することが可能です。
フォームを開いた状態で、メニューバー［ファイル］－［FLATファイルとして保存］をクリックし、印刷データファイル名、保存ファイル名を指定して保存を行います。

パスワードは、帳票設定のパスワードを使用します。

圧縮・暗号化用DLL

圧縮・暗号化、フラットファイル化のためのDLLが提供されています。
Magicのコールコマンド—ユーザPRCを使用して圧縮・暗号化、フラットファイル化を処理することが出来ます。

詳細は、RMDesignerリファレンスマニュアル（フラットファイルとセキュリティ－圧縮・暗号化DLL）を参照してください。

ベータ機能

  • 無し。

V1.1の改善・変更内容

イメージ

  • RMDesigner上でフォームにイメージを貼り付けた場合、固定項目の場合はイメージを表示しますが、データ項目の場合は、文字列と同様に枠、項目名等を表示するようになりました。

バーコード

  • RMDesigner上でフォームにバーコードを貼り付けた場合、固定項目の場合はバーコードを表示しますが、データ項目の場合は、文字列と同様に枠、項目名等を表示するようになりました。

dbFORM

  • dbFORM形式で、シーケンス番号が飛んだ場合、印刷データとして認識しない件に対応しました。
    （例）
    フォーム
      %%1-1 %%1-2 %%1-4 %%1-5 　←%%1-3が無い
    データ
      "1-1","1-2","1-4","1-5",[TAB][FF]
    結果　V1.0Bまで
      "1-1"　"1-2"　" "　" "　　←%%1-2以降が表示されない
      改ページ
    結果　V1.0C
      "1-1"　"1-2"　"1-4"　"1-5"
      改ページ
  • dbFORM形式で、親番号のみの場合、TABコードで親番号が更新されてしまう件に対応しました。
    （例）
    フォーム
      %%1 %%2 %%3
    データ
      "1",[TAB],"2","3"[FF]
    結果　V1.0Bまで
      "1"　" "　"2" ←"2"が次項目にずれる
      改ページ
      " "　" "　" "
      改ページ
    結果　V1.0C
      "1"　"2"　"3"
      改ページ
  • dbFORM形式で、親子番号で、TABコードがないのに、子を終了して親番号が更新されてしまう件に対応しました。
    （例）
    フォーム
      %%1-1　%%1-2　%%1-3　　%%2-1　%%2-2　%%2-3
    データ
      "1-1","1-2","1-3","1-4","1-5",[TAB],"2-1","2-2","2-3","2-4","2-5",[TAB][FF]
                                        ←"1-4" "1-5" "2-4" "2-5"の項目が、フォーム項目よりも多い
    結果　V1.0Bまで
      "1-1"　"1-2"　"1-3"　　" "　" "　" "　　　←"2-1"以降がずれる
      改ページ
      "2-2"　"2-3"　"2-4"　　" "　" "　" "
      改ページ
    結果　V1.0C
      "1-1"　"1-2"　"1-3" "2-1"　"2-2"　"2-3"
      改ページ
  • dbFORM形式で、FFコードがなくても、フォームに配置された項目よりデータが多い場合、動的に改ページ後、データが欠落する件に対応しました。
    (例)
    フォーム
      %%1 %%2 %%3
    テータ
      "1", "2", "3", "4", "5"[FF]　　←"4" "5"の項目が、フォーム項目よりも多い
    結果　V1.0Bまで
      "1" "2" "3"
      改ページ
      "5" " " " "　　　　　　　　　　 ←"4"が欠落
      改ページ
    結果　V1.0C
      "1" "2" "3"
      改ページ
      "4" "5" " "
      改ページ

    フォーム
      %%1-1 %%1-2 %%2-1 %%2-2
    テータ
      "1-1" "1-2" [TAB] "2-1" "2-2" [TAB] "3-1" "3-2" [TAB][FF]　←"3-1" "3-2"の項目が、フォーム項目よりも多い
    結果　V1.0Bまで
      "1-1" "1-2" 　"2-1" "2-2"
      改ページ
      "3-2" " " 　" " " "　　　←"3-1"が欠落
      改ページ
    結果　V1.0C
      "1-1" "1-2" 　"2-1" "2-2"
      改ページ
      "3-1" "3-2" 　" " " "
      改ページ

データ連携

  • XML形式の場合、テーブルに１行もデータが無い場合にそのページ全体が表示されなくなる件に対応しました。
  • 可変データ項目で、データが1024バイトを超えると表示が文字化けする件に対応しました。
  • データ項目の文字枠連結に対応しました。

データ項目ウインドウ

  • ［ファイルを開く］機能では、フォームに対するデータ形式のファイル（例：XML）のみが読み込めるようになっていましたが、どの形式のファイルでも読み込めるようになりました。
  • 新規に複数の項目を挿入した後、画面更新を行うと、項目タグ名(NewItem)が重複してしまうため、挿入した項目が１つしか表示されない件に対応しました。
    また、テーブルタグをフォーム上に配置した後は、テーブルタグに新規に項目タグを挿入できなくなります。
  • フォーム上に複数テーブルでXMLテンプレートを作成後、MagicからXML出力する際に、「テンプレートファイルエラー：タグ名が重複しています。....」のエラーが発生する件に対応しました。
  • XMLテンプレート出力で、複数フォームでも対応できるようにMagic用TAGにページ番号が付加されるようになりました。
    （例）(!$MG_会社名)　→　(!$MG_1_会社名)
  • XMLテンプレート出力で、暗黙改ページ（ページ番号X.X）は出力しないようにしました。
  • XMLテンプレート出力で、LF（0x0a)、半角スペース(0x20）が入るようになりました。CR（0x0d）は含まれません。
  • データ項目の表示順番を↑↓で変更してもフォームファイルに格納されるようになりました。
  • フォームに割りついていないデータ項目も、フォームファイルに格納できるようになりました。
  • フォーム上でデータ項目を削除した場合、フォーム書き込み時、データ項目ウインドウの表示時に、データ項目ウインドウから削除するか確認するダイアログを表示するようになりました。
  • データ項目ウインドウからデータ項目をドラッグ&ドロップしフォームに貼り付けた場合、グリッド位置にドロップされない件に対応しました。

その他

  • 帳票設定－「データファイルのパス」は、サポートされなくなりました。
  • テーブル属性の「同じデータが続くときに横線省略」 は、サポートされなくなりました。
  • テーブルは、文字列検索・文字列置換の対象になりません。
  • ファイル-最近使ったファイルは、RMDesignerを一旦終了するとクリアされる件に対応しました。
  • RMViewer.DLLのエラー番号を3桁に統一しました。
    -61702　→　-321 印刷ｼﾞｮﾌﾞを開始できませんでした。
  • バーコード出力時にエラーが発生した場合は、「バーコードエラー：エラー番号」と出力されるようになりました。

RMViewer

  • フォーム「帳票設定」で指定したプリンタ名が32バイトよりも長い場合、設定された用紙サイズがビューアに反映されず、使用するプリンタのデフォルト用紙サイズになる件に対応しました。
  • RMViewer　EXE版にて、フォームに貼り付けたオブジェクトをプレビューして印刷すると貼り付けたオブジェクトが印刷されない場合がある件に対応しました。
  • RMViewer　ActiveX版で、メソッドのオブジェクト一覧で基準中心表示は、ZoomTopよりZoomBaseに変更になりました。ZoomTopでも動作しますが、極力ZoomBaseに変更してください。
  • ActiveX版の場合、 ホイールマウスが動作しない件に対応しました。


ReportsMagic Ver1.0B 修正履歴

V1.0Bの新機能

イメージ
  • イメージをデータ項目として使用する場合、イメージ形式としてJPEGに対応しました。

RMViewer

各種コマンドパラメータが拡張されました。

  • 印刷中表示画面の表示・非表示の指定(コマンドパラメータ指定)
    /status=[y/n]
    y:表示（デフォｒント）
    N:非表示
  • 印刷部数の指定(コマンドパラメータ指定)
    /copy=[部数]

RMViewer起動用DLL

  • Ver1.0～Ver1.0A RMViewer実行関数(ExecuteO)
      構文……定義式：RMViewer.ExecuteO
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （’y’ または ‘n’で指定）
      ⑥ウェイトを指定します。（文字型） （’y’ または ‘n’で指定）
      ⑦実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑧エラーメッセージ（文字型）

  • Ver1.0B RMViewer実行関数(Execute)　　　　　　　 ＜Ver1.0Bで拡張された定義式＞
      構文……定義式：RMViewer.Execute
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型） ※Ver1.0Bで追加されたパラメータ
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示） ※Ver1.0Bで追加されたパラメータ
      ⑨実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑩エラーメッセージ（文字型）

Ver1.0B RMViewer起動パラメータの機能拡張に伴い、RMViewer起動用DLLのパラメータも拡張されました。これにより、V1.0～V1.0AでRMViewer実行関数(Execute)を使用したMagicアプリケーションは、コールユーザPRC実行後に「ユーザー関数、またはユーザープロシジャの引数の数が合っていません。」のエラーが発生 するようになります。
  その場合は、Magicアプリケーションの定義式RMViewer.ExecuteをRMViewer.ExecuteOに変更します。テキスト検索、テキスト置換を使用すると容易に移行することが可能です。
  Magicアプリケーションを変更せずに使用したい場合は、Ver1.0～Ver1.0A用のRMViewer起動用DLLを使用することにより可能です。ただし、拡張された機能を使用することが出来ません。今後の拡張にも対応することが出来なくなる為、移行することをお奨めいたします。
今後パラメータ仕様が変更（拡張）される場合は、定義名の追加等により、Magicアプリケーションの互換性が維持できるように考慮いたします。

RMViererCtrl(ActiveX）

  • プリンタ名をパラメータで指定
    CallCom
    プロパティ：PrinterName
    パラメータ値：[プリンタ名]

    HTMLでの指定：
    <param name="PrinterName" value="[プリンタ名]"

  • 印刷部数を指定する
    CallCom
    プロパティ：Copy
    パラメータ値：[部数(文字列)]

    HTMLでの指定：
    <param name="Copy" value="[部数]"

  • ページ指定の対応
    CallCom
    プロパティ：PageSelect
    パラメータ値：なし

V1.0Bの改善・変更内容

RMDesigner

  • カウントアップ複写を行った場合、項目名、項目タグがカウントアップされない件に対応しました。
  • テスト表示で複数ページ表示した場合、先頭ページ/最終ページのボタンがアクティブにならない件に対応しました。
  • 文字列で塗りつぶしを指定した場合は、文字枠全体を塗りつぶすようになりました。
  • テーブルで背景色を指定したとき、無条件に横罫線が出力される件に対応しました。

データ連携

  • dbFORM形式で、項目の「テキストの折り返し」が有効にならない件に対応しました。
    「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
    「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

    dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。
    従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。
  • dbFORM形式で全タグに差込データを設定していない状態で「ＦＦ」で出力した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • XML形式で全タグに差込データを設定していない状態で明示的改ページを実施した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • CSV形式で、Key指定が無い場合には、1レコードが1ページと認識できずに、最後のレコードのみが出力される件に対応しました。

データ項目ウインドウ

  • データ項目ウインドウで一旦項目を削除すると、再びデータを読み込んでも再定義されない件に対応しました。

その他

  • 文字列属性の「テキストの長さに合わせてフォントサイズを調節」は、「縮小して全体を出力」に変更されました。
    従来は、表示領域に格納できる最大フォントサイズを計算して表示していましたが、指定されたフォントサイズ、文字ピッチで表示領域に出力できない場合のみ、フォントサイズ 、文字ピッチを小さくして全体を 出力するようになりました。
    複数行はサポートしていません。「テキストの折りかえし」を指定しても無視されます。
  • フォームを上書き保存をするとファイルサイズが２倍近く大きくなる件に対応しました。
  • シュートカットが変更されました。詳細は、参考技術情報を参照してください。

RMViewer

  • 複数ページを表示した場合、先頭ページ/最終ページ/指定ページが有効にならない件に対応しました。
  • 複数ページを表示した状態で印刷を実行すると常に最終ページが表示されていましたが、印刷を開始したページが表示されるようになりました。
  • フォーム「帳票設定」で指定した用紙サイズや給紙方法が反映されない場合がある件に対応しました。


ReportsMagic Ver1.0A 修正履歴

V1.0Aの改善・変更内容

dbFORM

  • dbFORMフォームの読込で、項目にアンダーバーが付く件に対応しました。
  • dbFORMフォームの読込で、横倍角に対応しました。
  • dbFORM形式でイメージデータが表示されない件に対応しました。
    文字列／データ項目名の最後の文字を I にします。　例：％％１７－４Ｉ

データ連携

  • CSV形式で、印刷データにシングルバイトの"が含まれると正しくデータ認識できない件に対応しました。
    シングルバイトの"を含めたい場合は、""と表現します。
  • XML形式で、印刷データに、シングルバイトの"や、&quot;が含まれると正しくデータ認識できない件に対応しました。

その他

  • 「テスト実行」を行うと、フォームの項目名が実データに更新される場合がある件に対応しました。
  • スタティック（固定）文字列は、枠を表示をしないようにしました。
  • バーコードのデータが不正な場合は、「バーコードエラー」と表示するようになりました。
  • 文字列でテキストに下線を指定した場合、スペース部分は下線が引かれない件に対応しました。

RMViewer

  • フォームファイルをオープンし印刷データ取り込み前は、項目データが項目タグ名や、サンプルが表示されている件に対応しました。


ReportsMagic 参考技術情報

参考技術情報

ここでは、ReportsMagic についての参考技術情報を紹介します。

  • RMViewer 起動オプション
  • RMViewer ActiveX起動オプション
  • RMViewer exe版－ActiveX版　起動オプション 比較
  • RMViewer exe版　プリンタ名の指定
  • RMViewer C/S版とWeb版のアクセス
  • ショートカットキー一覧
  • 「帳票設定」で指定した用紙サイズ、給紙方法や部数の対応
  • RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について
  • 文字列の出力可能範囲について
  • XML形式で文字列の前に半角スペースは有効にならない
  • 「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」
  • データ連携－データ形式の違い
  • RMCompSec.DLLのエラーコード一覧
  • RMViewer 起動用DLL-RMViewer.DLLのエラーコード一覧
  • CSV（Comma-Separated Values）
  • バーコード

RMViewer 起動オプション

表示方法

内　容
フォームファイルの指定

/rfr=フォームファイル名

印刷データファイルの指定

/rdata=データファイル名

プレビュー表示

/dsp=[y|n]
  ‘y’ ･････プレビュー表示をします。
  ‘n’ ･････プレビュー表示を行わず、すぐにバックグラウンドで印刷を開始します。

プリンタ名の指定

/prn= …… 実行時に印刷プリンタを指定することが可能です。

プリンタ名(/用紙サイズ，用紙の向き，給紙方法(，用紙の長さ，用紙の幅) )（/垂直オフセット，水平オフセット）

用紙の長さ，用紙の幅は、用紙サイズでユーザ定義を指定した場合のみ有効です。

（例）
/prn=EPSON LP-9400
/prn=EPSON LP-9400/A4 210 × 297 mm，縦，用紙ﾄﾚｲ
/prn=EPSON LP-9400/，，用紙ｶｾｯﾄ1
/prn=EPSON LP-9400/ﾕｰｻﾞｰ定義ｻｲｽﾞ，，，2000，1000

※省略した場合は、各プリンタのデフォルト値

垂直オフセット，水平オフセットは、-99～+99　（±9.9mm）で指定可能
（例）
/prn=EPSON LP-9400//-12,+34 　上へ1.2mm、右へ3.5mm
/prn=EPSON LP-9400/A4 210 × 297 mm，縦，用紙ﾄﾚｲ/-12,+34　上へ1.2mm、右へ3.5mm
拡大率の指定

/zoom= ‘10～500’の数字、または‘i’、‘w’、‘a’または ‘p’を指定します。
   10から500の数字　･････ 拡大率を表します。100が通常の倍率です。
  ‘i’　 ･････ 基準倍率表示（デフォルト）
  ‘w’　 ･････ ウインドウの描画領域幅にページの横幅を合わせます。
  ‘p’ 　 ･････ ページ全体を表示します。（デフォルト）
                ウインドウの描画領域の縦幅にページの縦幅を合わせます。
  ‘a’ 　 ･････ 全画面表示を行います。

ページレイアウトの指定

/pagelayout= 1,2,3のいずれかを指定します。
  ‘1’　 ･････1ページ表示を行います。（デフォルト）
  ‘2’ 　 ･････連続１ページ表示を行います。
  ‘3’　 ･････連続２ページ表示を行います。

サムネール表示の指定

/thumbnail= ‘y’ または ‘n’ を指定します。
  ‘ｙ’　 ･････サムネール表示を行います。
‘n’　 ･････サムネール表示を行いません。（デフォルト）

メニューバー表示の指定

/menubar= ‘y’ または ‘n’を指定します。
   ‘ｙ’　 ･････メニューバーを表示します。（デフォルト）
   ‘n’　 ･････メニューバーを表示しません。

ツールバー表示の指定

/toolbar= ‘y’ または ‘n’ を指定します。
   ‘y’　 ･････ツールバーを表示します。（デフォルト）
   ‘n’　 ･････ツールバーを表示しません。

ステータスバー表示の指定

/statusbar= ‘y’ または ‘n’ を指定します。
    ‘y’　 ･････ステータスバーを表示します。（デフォルト）
    ‘n’　 ･････ステータスバーを表示しません。

印刷部数の指定

/copy=コピー数
  （1～各プリンタの有効部数を指定します）

言語変換ファイルの指定

/mls=パス名

（例）
RMViewer.exe /rfr=XXX.RFF /dsp=y /mls=XXXX.MLS

レイヤ表示の指定

/layer=レイヤパラメータ を指定します。
レイヤパラメータ：
レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定します。（1234567SOV）
0：非表示、1：表示、－：デフォルトのまま

（例）
RMViewer.exe /rfr=XXX.RFF /dsp=y /layer=1011100---
レイヤ１、３，４，５：表示、レイヤ２、６，７：非表示、スキャナ、OLE、オーバレイ：デフォルト表示

印刷範囲指定

/page=[開始ページ]-[終了ページ]
（例）
/page=5　　　5ページのみ
/page=5- 5ページから最終ページ
※プレビュー表示がNoで無ければ有効になりません。

「帳票設定」のRMViewer初期オープンモードよりも、起動オプションの方が優先されます。

RMViewer ActiveX起動オプション

プロパティ一覧 | 内 容
Copy | コピー数 (1～各プリンタの有効枚数を指定)
PageLayout | ページレイアウト番号 ‘1’(1ページ表示), ‘2’(連続1ページ表示),‘3’(連続2ページ表示)のいずれかを指定。
PrinterName | プリンタ名(/用紙サイズ，用紙の向き， 給紙方法(，用紙の長さ，用紙の幅) )（/垂直オフセット，水平オフセット） 用紙の長さ，用紙の幅は、用紙サイズでユーザ定義を指定した場合のみ有効です。
RDataFile | 印刷データファイル名
RfrFile | フォームファイル名
Zoom | 拡大率 （'10-500'(倍率指定), 'i'(基準倍率), 'w'(ウインドウ領域幅にページ横幅を合わせる), 'p'(ページ全体を表示), 'a'(全画面表示)）
Thumbnail | サムネール表示 （'on','off' 又は、'y','n'）
ToolBar | ツールバー表示 （'on','off' 又は、'y','n'））
Mls | 言語変換ファイル名 言語変換ファイルの指定
Layer | レイヤ表示

メソッド一覧 | 内 容
AboutBox | RMViewer バージョン情報
OnThumbnail | サムネール表示
OnToolBar | ツールバー表示
PageFirst | 先頭ページ
PageLast | 最終ページ
PageLayout1 | ページレイアウトの指定 1ページ表示
PageLayout2 | ページレイアウトの指定 連続１ページ表示
PageLayout3 | ページレイアウトの指定 連続２ページ表示
PageNext | 次ページ
PagePre | 前ページ
PageSelect | 印刷範囲の指定
PrintData | 印刷
ZoomAll | 拡大率：ページ全体を表示
ZoomAllWidth | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
ZoomBase | 拡大率：基準倍率表示
ZoomFulll | 拡大率：全画面表示
ZoomIn | 拡大率：拡大
ZoomOut | 拡大率：縮小

RMViewer exe版－ActiveX版　起動オプション比較

表示方法 | RMViewer exe版 | ActiveX版
フォームファイルの指定 | ○ | ○
印刷データファイルの指定 | ○ | ○
プレビュー表示 （バックグランド印刷） | ○ | －
プリンタ名の指定 | ○ | ○
拡大率の指定 | ○ | ○
ページレイアウトの指定 | ○ | ○
サムネール表示の指定 | ○ | ○
メニューバー表示の指定 | ○ | －
ツールバー表示の指定 | ○ | ○
ステータスバー表示の指定 | ○ | －
印刷部数の指定 | ○ | ○
言語変換ファイルの指定 | ○ | ○
レイヤ表示の指定 | ○ | ○
印刷範囲指定 | ○ | －

ActiveX版では、バックグランド印刷はサポートされません。

RMViewer exe版　プリンタ名の指定

  • プリンタ名に空白がある場合は、”(ダブルコーテーション)で括って下さい。
  • RMExeViewer.exe で、プリンタ名に空白がある場合は、\”を使用します。
    （例）/prn=\"EPSON LP-9400\"
  • ネットワークプリンタに印刷する場合は、UNCの記述で記載します。
    （例）\\サーバ名\EPSON LP-9400
  • 設定できるプリンタ名は、RMDesigner／RMViewerのファイル／印刷のプリンタ名で確認できます。

RMViewer C/S版とWeb版のアクセス

RMViewer C/S版とWeb版は、フォームファイル、印刷データファイルに対するアクセス方法が異なります。
C/S版の場合は、ファイルパス指定、Web版の場合は、httpでの指定になります。

  • RMViewer C/S （ファイルアクセス）
種類 | 起動例
RMViewer.exe | RMViewer.exe /rfr=sample.rfr /rdata=sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
  • RMViewer Web 　（Httpアクセス）
種類 起動例
RMViewer.exe RMViewer.exe /rfr=http://localhost/ReportsMagic/sample.rfr
/rdata=http://localhost/ReportsMagic/sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="http://localhost/ReportsMagic/sample.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>

起動オプションの詳細は、RMViewer 起動オプション、RMViewer ActiveX起動オプション－プロパティ一覧を参照してください。

ショートカットキー一覧
RMDesigner

分類 | 動作 | ショートカットキー
ファイル | 新規作成 | Ctrl + N
 | 開く | Ctrl + O
 | 閉じる | Ctrl + W
 | 上書き保存 | Ctrl + S
 | 名前を付けて保存 | Ctrl + Shift + S
 | ﾌﾟﾘﾝﾀの設定 | Ctrl + Shift + P
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
編集 | 元に戻す | Ctrl + Z
 | 切り取り | Ctrl + X
 | ｺﾋﾟｰ | Ctrl + C
 | 貼り付け | Ctrl + V
 | 消去 | Del
 | すべて選択 | Ctrl + A
 | 文字列検索 | Ctrl + F
 | 文字列置換 | Ctrl + H
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 指定ページ | Alt + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ｳｨﾝﾄﾞｳ | 並べて表示 | Ctrl + Shift + K
 | 重ねて表示 | Ctrl + Shift + J
テーブル | 項目選択 | Ctrl+E
ﾍﾙﾌﾟ | RMDesignerのヘルプ | F1

RMViewer

分類 | 動作 | ショートカットキー
ファイル | 開く | Ctrl + O
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 幅に合わせる | Ctrl + 2
 | 全画面表示 | Ctrl + 3
 | 指定ページ | Ctrl + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ﾍﾙﾌﾟ | RMViewerのヘルプ | F1

RMViewer ActiveX版（RMViewerCtrl.ocx）では、ショートカットキーは対応していません。

「帳票設定」で指定した用紙サイズ、給紙方法や部数の対応

RMDesignerの「帳票設定」で指定した用紙サイズや給紙方法は、RMViewerで以下の様に対応しています。
デバイスモードのコピーは、フォーム上に登録しているプリンタと一致するプリンタがある場合のみ行います。

  • 用紙サイズ：
    フォーム上に登録しているプリンタと一致するプリンタがある場合には、フォームの用紙サイズに設定します。
    一致するプリンタがない場合には、もっとも近い用紙サイズにします。
  • 用紙方向：
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
  • 給紙方法：
    フォーム上に登録しているプリンタと一致するプリンタがある場合のみ反映します。
    一致するプリンタが無い場合には、デフォルトの給紙方法にしています。
  • 部数
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
    プリンタ毎に部数の制限があります。この場合は、プリンタの仕様ににより部数が設定されます。

RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について

RMViewer ActiveX版（RMViewerCtrl.ocx）を使用するには、事前に使用するPCのシステムにActiveX登録を行う必要があります。

●RMDesignerの場合
RMDesignerには、RMViewerの体験版が添付されていますが、ライセンス登録プログラム（RMLicense.exe ）を実施してもActiveXは登録されません。
インストールしたフォルダ上のバッチファイルにより、登録、及び解除を行うことが出来ます。

Addregsvr32.bat | RMViewerCtrl.ocxの登録を行います。
DELregsvr32.bat | RMViewerCtrl.ocxの登録を解除します。

●RMViewerの場合

ライセンス登録プログラム（RMLicense.exe ）によりライセンスの登録を行うことにより、ActiveXを登録します。
すでにシステムに登録済みの場合、確認のダイアログが表示されます。

  • RMViewerを、複数PCにインストールしている場合は、登録を実行したPCのRMViewer.exe、RMViewerCtrl.ocx をコピーし、 上記のバッチプログラムを使用することにより登録、または更新することが可能です。　更新の場合は、　DELregsvr32.bat、Addregsvr32.batを実行 します。

●ブラウザ－ActiveXの自動ダウンロード

HTMLファイルに以下の記述を追加すること自動ダウンロードを行うことが可能です。

<html>
<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/RMViewerCtrl.ocx#version=1,0,0,1"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\RMdata\\EmpfamilyXml.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\RMdata\\EmpfamilyMagic.xml">
<param name="ToolBar" value="on">
</object>
</html>

※ActiveXのバージョン番号
ユーザー環境にあるバージョンが CODEBASE の指定よりも古い場合は、CODEBASE で指定した場所から、新しいバージョンの ActiveＸ RMViewer を自動的に ダウンロードおよびインストールさせることができます。
モジュールを更新したい場合は、3番目のバージョン番号を変化させます。（例）version=1,0,0,1→version=1,0,１,1

文字列の出力可能範囲について

V1.0Bより文字列の出力可能範囲が厳密に制御されるようになりました。
文字列枠は、内部余白により制御されており、出力する文字列が文字列枠の範囲を超えた文字は、出力されません。

dbFORM形式は、項目の「テキストの折り返し」により出力方式が異なります。
「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。

XML形式で文字列の前に半角スペースは有効にならない

XML形式で文字列で文字列の前に半角スペースを入れると無視される場合があります。
これは、XMLの仕様で前後の半角スペースは、取り除かれる為です。
（例）　<value>△△ＡＢＣＤＥＦ△△</value>　→　ＡＢＣＤＥＦ　　△は、半角スペース

これを回避するには、XMLに以下を追加します。

<ReportsMagic version="1.0" xml:space="preserve">

後ろの半角スペースを有効にしたい場合は、書式を未設定（空白）にします。（V1.0X互換）

「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」

ブラウザ上でRMViewerを使用した場合、表示される場合があります。

これはWindows XPのサービスパック2（SP2）のセキュリティ強化に伴って表示されるようになったメッセージでWebページからユーザのコンピュータ上のスクリプトやActiveXコントロールが実行されようとしたときに表示されます。

情報バーをクリックして、ブロックされているコンテンツを許可することは可能ですが、表示するたびに入力が必要になります。以下の操作をすることで、確認画面が表示されなくなります。

▼操作手順
メニュー［ツール］－［インターネットオプション］をクリック
  ↓
［インターネットオプション］ダイアログ－［詳細設定］タブをクリック
  ↓
［設定］－［セキュリティ］欄の、
［マイコンピュータのファイルでのアクティブコンテンツの実行を許可する］チェックをOnにする
  ↓
［インターネットオプション］ダイアログ－［OK］ボタンをクリック

データ連携－データ形式の違い

 | dbFORM | CSV | ヘッダー付き CSV | XML
TAG名ルール | %%数字２階層まで | %%数字 | 任意 | 任意
テーブル | なし テーブル構造の認識は無い | １個 | １個 | 複数可能※２
明示的改ページ | データ内で指定 （ＦＦ） | キー指定 | キー指定 | データ内で指定
暗黙的改ページ | × | ○ キー指定が無い場合は、１レコード毎に改ページ | ○ キー指定が無い場合は、１レコード毎に改ページ | ○
マルチフォーム ※1 | × | △ 暗黙的改ページの場合のみ可能 | △ 暗黙的改ページの場合のみ可能 | ○ データ内で指定 （XML フォーム番号）
マージテンプレート作成支援 | × | × | × | ○
備考 | dbFORMの互換機能を重視した形式です。 今後の拡張予定はありません。ヘッダー付きCSV、XML形式への移行をお奨めいたします。 | データ格納率が高いため、大量印刷の場合に有利です。 | データ格納率が高いため、大量印刷の場合に有利です。 CSV形式に比べて、TAG名を自由に管理できるため、メンテナンス性は向上します。 | マルチフォームをサポートした最も高度なフォーム形式です。 ReportsMagicのデフォルトのフォーム形式です。 CSV形式に比べるとデータ量が大きくなる傾向があります。
  • ※１：ひとつの帳票データで複数のフォームを使用する形態。例えば、１ページ目は納品書、２ページ目は請求書、３ページ目は納品受領書のような形態。
  • ※２：複数テーブル
    ・テーブルのネストは、サポートされません。
    ・暗黙の改ページは、サポートされません。　明示的改ページを使用します。
    ・ブレイク処理は、サポートされません。

RMCompSec.DLLのエラーコード一覧

エラー番号 | ステータスメッセージ
0 | 正常に終了しました。
-1 | 初期処理に失敗しました。
-2 | 終了処理に失敗しました。
-11 | 引数に誤りがあります。
-12 | ファイルオープンに失敗しました。
-13 | ファイル入出力に失敗しました。
-14 | 圧縮処理に失敗しました。
-15 | 暗号化処理に失敗しました。
-16 | フォームファイルからパスワード抽出に失敗しました。
-17 | バックグランドでは動作しません。
-18 | 圧縮・暗号化処理が実行できませんでした。 （初期処理をしていないか、モジュールが破損していて圧縮・暗号化処理が実行できない場合）
-19 | メモリ不足です。
-20 | モジュールロードに失敗しました。

RMViewer 起動用DLL-RMViewer.DLLのエラーコード一覧

エラー番号 | ステータスメッセージ
0 | 正常に終了しました。
-1 | RMViewerが実行できませんでした。
-2 | ステータスファイルが作成できません。
-3 | RMViewerは実行中です。
-4 | パラメータが不正です。
-100 | OLE の初期化に失敗しました。 OLE ﾗｲﾌﾞﾗﾘのﾊﾞｰｼﾞｮﾝが正しいことを確認してください。
-170 | データ形式が違います。
-202 | DIB が大きすぎます。
-247 | [ファイル名]を読み込むことができません。
-249 | 文書が使用中です。
-250 | ファイルのオープンに失敗しました。
-252 | ファイルの読み込みに失敗しました。
-257 | パスワードが一致しません。
-266 | CoInitialize 失敗!
-284 | データ形式が違います。
-287 | 一致するタグがありません。
-295 | ヘルプファイルが見つかりません。
-301 | 指定したプリンタが登録されていません。
-302 | 指定したフォームファイルが存在しません。
-303 | 指定したデータファイルが存在しません。
-305 | ライセンス情報が不正です。
-306 | 使用期限を越えました。
-307 | 現在のライセンスでは、認可されていないアクセス方式です。
-308 | サポートされていないバージョンのフォームです。#[フォームバージョン]
-321 | 印刷ジョブを開始できませんでした。
-322 | XXXXX:パラメータが不正です。
-331 | リソース不足です。
-332 | 指定したオフセット値は無効です。

CSV（Comma-Separated Values）

CSV（Comma-Separated Values）は、いくつかのフィールド（項目）をコンマ「,」で区切ったテキストデータおよびテキストファイルです。

（例）
"MSJ","11","山田太郎","山田花子","35","妻" データイメージ（　MSJ 11 山田太郎 山田花子 35 妻）

フィールドは、ダブルクォート「"」 で囲んでも囲まなくても良いです。
（例）
MSJ,11,山田太郎,山田一郎,8,長男 上の例と同じ

フィールドがコンマ、ダブルクォート、改行を含む場合は、かならずダブルクォートで囲みます。　また、フィールドに含まれるダブルクォートは2つ並べてエスケープします。
（例）
"MSJ","11,111","""山田太郎""","""山田花子""",35,"妻" データイメージ（　MSJ 11,111 "山田太郎" "山田花子" 35 妻）

バーコード

郵便カスタマバーコード

ReportsMagicには、郵便カスタマバーコードの「郵便番号」、「住所表示番号」のみを渡します。（最大20桁）

（例）10000131-3-2-503

カスタマバーコードに必要な文字情報の抜き出しから生成までの処理概要
住所を町域名までの住所Aと町域名以降の住所Bに分割します。

東京都千代田区霞が関1丁目3番2号　郵便プラザ503室
住所

東京都千代田区霞が関
住所A
町域名までの住所(郵便番号)

1丁目3番2号　郵便プラザ503室
住所B
町域名以降の住所(住所表示番号)

町域までの住所に郵便番号を設定します。

町域名以降の住所(住所表示番号)からバーコードとして必要な文字情報(住所表示番号)を抜き出します。

100-0013
(郵便番号)

1-3-2-503
(住所表示番号)

前記の郵便番号と住所表示番号を連結してカスタマバーコードの情報とします。

[カスタマバーコードの情報]

1000013
郵便番号
(注1)

1-3-2-503
住所表示番号

(注1)バーコードの情報を生成するときは、郵便番号の3～4けた目間のハイフンを省きます。

前記のカスタマバーコードの情報にチェックデジット、スタートコード、ストップコードを付加してカスタマバーコードを生成します。

(注2)「CC4」は、住所表示番号部分が13けたに満たない場合に充足する制御コードです。　13桁に不足した場合は、ReportsMagicが自動的に付加します 。
(注3)「チェックデジット9」は、ReportsMagicが自動的に付加します。

  • 詳細は、日本郵政の郵便番号・バーコードマニュアルを参照してください。
    http://www.post.japanpost.jp/zipcode/zipmanual/index.htm
  • バーコードの端から端までが64mm～88mmの範囲になるようにします。


各種リンク情報

以下のリンク先にも参照してください。

MSJ のホームページ(TOPページ)

テクニカルサポート（サポート契約のご案内）

プロフェッショナルサービス

トレーニングコース

Magicアップデートのダウンロード

Magicスキルアップセンター

連載 Magic V10リッチクライアント

山下博士のMagic実践活用講座

XML対応帳票ソリューション「ReportsMagic」

Magic開発者のためのプログラム最適化ツール「Magic Optimizer」

パッケージソフト紹介サイト


ベータ版評価レポートのお願い

ベータ機能－評価レポートのお願い

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外です。
又、ご意見、ご質問、気が付いた点などは、下記の「ベータ評価レポート」に記入して、メールで japan_v10beta@magicsoftware.com までお送りください。
お送りいただいたレポートは、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

ReportsMagic V1.3b ベータ機能評価レポート

記入日： ２００８年　　 月　 日
会社名：
担当者：
E-mail：
ＴＥＬ：
ＦＡＸ：
サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境
ＰＣ機種：
ＣＰＵ：
ＲＡＭ：
ＯＳ： （ ）Windows98／（ ）Windows2000（SP： ）／（ ）WindowsXP／（ ）Windows2003／（ ）WindowsVista
ＩＭＥ：
ビデオカード：
使用ブラウザ：（ ）IE5.5 （SP： )、　（ ） IE6（SP： ）

２．不具合の場合

不具合を確認した場合は、こちらに記入してください。 該当する（ ）に＊を挿入してください。

Ａ （ ） 一部支障あり
Ｂ （ ） 正常に動作しない
Ｃ （ ） インストール・起動不可

２．１．再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

２．２．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なう
ために、極力画面のハードコピー、フォームデータ、サンプルプログラム等の提供をお願い
いた します。　異常終了するような場合は、ワトソン博士のログ の提供もお願いいたします。）

３．要望事項
機能追加、改善要望等がありましたら、こちらに記入してください。
（できるだけ詳細にお書きください。）

４．その他ご意見

以上


ReportsMagic製品構成

製品構成
RMDesignerのライセンスについて
RMViewer C/Sのライセンスについて
RMViewer Web版のライセンスについて
RMViewer RichClient 版のライセンスについて
 WTS(Windows Terminal Server)、Citrix Presentation Server で使用する場合の注意点

ReportsMagic は、大きく分けて、印刷フォームを作成するRMDesignerと印刷結果を表示（ビューワ）、印刷するRMViewerの２種類の製品から構成されます。

製品構成

製品名 | ライセンス | 備考
RMDesigner | １ユーザ | インストールベース RMViewer体験版付き
RMDesigner エンタープライズパック | ５ユーザ | インストールベース 開発用RMViewer C/S ５ユーザ付き
RMViewer C/S版 | １～ | 同時アクセスユーザ数 通常、Magic Clientと同一ユーザ数を購入 アクセス方式（ファイルアクセス）
RMViewer Web版 | サーバ | サーバ単位※1 アクセス方式（Hｔｔｐアクセス）
RMViewer RichClient版 | ユーザ | Magicリッチクライアント（Magic RichClient Server）用※2 Magicリッチクライアントと同一ユーザ数を購入 アクセス方式（ファイルアクセス、Hｔｔｐアクセスの両方） クライアント用のRMViewer exeインストーラ提供※3
 | サーバ | Magicリッチクライアント（Magic RichClient Server）用※2 サーバ単位※1 アクセス方式（ファイルアクセス、Hｔｔｐアクセスの両方） クライアント用のRMViewer exeインストーラ提供※3
  • ※1：CPU数や使用ユーザー数に依存しません。 1サーバへのインストールです。（RMViewer配布目的）
    ただし、ReportsMagicの印刷データ生成、圧縮／解凍化の為にMagicサーバ（Magic Application Server、Magic Enterprise Server、Magic RichClient Server）にインストールする場合は、別サーバに１台のみインストールすることが可能です。 複数のWebサーバ、複数のMagicサーバを使用する場合は、累計したサーバライセンスが必要です。
  • ※2：Magic Client と組合わせて使用することは出来ません。
  • ※3：WebサーバからダウンロードしてクライアントPCにRMViewer exe版をインストールするものです。 単独で動作しますが、Magicリッチクライアントのシステム範囲のみで使用可能です。

各製品の機能比較

 |  | RMDesigner | RMViewer C/S | RMViewer Web | RMViewer RichClient
 |  |  |  |  | ユーザ | サーバ
印刷フォーム作成機能 |  | ○ |  |  |  |
RMViewer 実装方式 | EXE |  | ○ | △※1 | ○ | ○
 | ActiveX |  | ○ | ○ | ○ | ○
RMViewer アクセス方式 | ファイル |  | ○ |  | ○ | ○
 | http |  |  | ○ | ○ | ○
圧縮／暗号化DLL |  | シングルスレッド | シングルスレッド | マルチスレッド | マルチスレッド | マルチスレッド
RMViewer exe ダウンロード形式インストーラ |  |  |  |  | ○※2 | ○※2
ライセンス |  | 特定のPC1台のみ | 同時ユーザ数 | サーバ | 同時ユーザ数 | サーバ

※1：メンテナンス用としてWebサーバ上でのみ使用可能なExe版が提供されています。
※2：Magic Client と組合せて使用することは出来ません。

RMDesignerのライセンスについて

RMDesignerのライセンスは、以下のようになります。

  • RMDesignerのライセンスは、特定のPC1台にのみインストール可能で、かつ、同時に1人のユーザのみが利用可能です。
  • エンタープライズパックは、5ユーザのライセンスがパックされた製品です。　特定のPCの 5台にインストール可能です。
  • RMViewer体験版が添付されています。　エンタープライズパックの場合は、開発目的で使用できるRMViewer C/S 5ユーザが提供されています。
  • インストール直後は、制限つきの体験版として動作します。ユーザ登録センターへ申請手続きを行い、正式ライセンスの Activation Keyを入手し、ライセンスをインストールすることによって、制限なしの正式版として動作します。

RMViewer C/Sのライセンスについて

RMViewer C/S のライセンスは、以下のようになります。

  • RMViewer C/Sのライセンスは、同時アクセスユーザ数となり、Magic Clientと同一ユーザ数を購入します。　Magic Clientによって、同時アクセスの制御を行います。
  • RMViewer exe版、ActiveX版を使用可能です。
  • アクセス方法は、ファイルアクセスのみサポートされます。
  • インストール直後は、制限つきの体験版として動作します。ユーザ登録センターへ申請手続きを行い、正式ライセンスの Activation Keyを入手し、ライセンスをインストールすることによって、制限なしの正式版として動作します。
  • 複数ユーザ版のインストールは、ファイルサーバ上にRMViewerをインストールし、各クライアントで共有することが可能です。

RMViewer Web版のライセンスについて

RMViewer Web版 のライセンスは、以下のようになります。

  • RMViewer Web版のライセンスは、サーバライセンスです。 CPU数や使用ユーザ数に依存しません。 1サーバへのインストールです。（RMViewer配布目的）
    ただし、ReportsMagicの圧縮／暗号化の為にMagicサーバ（Magic Application Server、Magic Enterprise Server、Magic RichClient Server）にインストールする場合は、別サーバに１台のみインストールすることが可能です。 複数のWebサーバ、複数のMagicサーバを使用する場合は、累計したサーバライセンスが必要です。

※上記の例は、RMViewer ActiveX配布用に1台のWeb サーバ、圧縮処理の為に2台のMagic Enterprise Serverを使用しています。　RMViewer Web版は、2サーバ分のライセンスが必要です。

  • RMViewer ActiveX版を使用可能です。　ただし、メンテナンス用としてWebサーバ上でのみ使用可能なRMViewer Exe版が提供されています。
  • アクセス方法は、Httpアクセスのみサポートされます。

RMViewer RichClient 版のライセンスについて

RMViewer RichClient 版 のライセンスは、以下のようになります。

  • Magicリッチクライアント（Magic RichClient Server）用のRMViewerです。　Magic Client と組合せて使用することは出来ません。
  • RMViewer RichClient 版のライセンスは、同時アクセスユーザ数と、サーバライセンスの二種類があります。
    一般的にユーザ数が少ない構成の場合は、同時アクセスユーザ数が、ユーザ数が多い場合は、サーバライセンスの方が安価な構成になります。
  • 同時アクセスユーザ数の場合は、Magicリッチクライアントと同じユーザ数を購入します。
  • サーバライセンスの場合、CPU数や使用ユーザ数に依存しません。 1サーバへのインストールです。
    ただし、ReportsMagicの圧縮／暗号化の為にMagicサーバ（Magic Application Server、Magic Enterprise Server、Magic RichClient Server）にインストールする場合は、別サーバに１台のみインストールすることが可能です。 複数のWebサーバ、複数のMagicサーバを使用する場合は、累計したサーバライセンスが必要です。

※上記の例は、RMViewer ActiveX/EXE配布用配布用に1台のWebサーバ、圧縮／暗号化処理の為に2台のMagic Enterprise Serverを使用しています。　サーバライセンスの場合は、RMViewer RichClient版は、２サーバ分のライセンスが必要です。

  • RMViewer ｅｘｅ版、ActiveX版を使用可能です。　exe版は、クライアントにダウンロードしてインストールするインストーラが提供されています。
  • アクセス方法は、ファイルアクセス、Httpアクセスの両方をサポートします。
  • クライアント上でRMViewer ｅｘｅ版を起動することが可能です。

WTS(Windows Terminal Server)、Citrix Presentation Server で使用する場合の注意点

  • 接続して使用する可能なクライアント台数分のライセンス（RMDesigner、RMViewer）の購入が必要になります。
  • Magicサポートセンターでは、WTS、Citrix Presentation Server（MetaFrame）に関する問い合わせは、サポート対象外となります。
  • 詳細は、最寄の弊社営業所へお問い合わせください。


動作環境

ReportsMagic 動作環境

製品 | 対応環境
RMDesigner | Windows 2000／XP／2003／Vista
RMViewer | Windows 98 SE Windows 2000／XP／2003／Vista ブラウザ InternetExplorer 5.5(SP2)以上
Magic eDeveloper 対応 | ActiveX組込 V9Plus/V10 Exe起動 V9/V9Plus/V10

注意事項

  • プロセッサは、Intel x86アーキテクチャ、およびその互換プロセッサのみサポートしています。


ReportsMagic FAQ

製品体系・製品概要について

  • ReportsMagicの製品概要は？

  • Magicで開発された印刷プログラムの帳票フォーム（テキスト形式、GUI形式）をReportsMagicに自動移行するのですか？

  • 印刷データのフォームは、どのような形式があるのですか？

  • ReportsMagicがDBを直接アクセスすることはできないのですか？

  • インターネット環境で使用可能ですか？

  • フラットファイルとは何ですか？

動作環境

  • ReportsMagicの動作環境は？

  • Windows Vista対応は？

  • Windows x64には対応していますか？

ReportsMagicライセンス関連

  • ReportsMagicのライセンス概要はどのようになっていますか？

  • RMDesigner：一人の開発者が、複数のPCで開発を行っています。　RMDesigner １ユーザを複数のPCにインストールすることはできますか？

  • RMViewer C/S版 ：Magic Client とRMViewer C/Sを組合せて使用する場合、何ユーザを購入すればよいですか？

  • RMViewer Web版 ：RMViewer exe版は、どのように使用するのでしょうか？

  • RMViewer RichClient版：RMViewer RichClient版を C/Sシステムで使用することは可能ですか？

  • Magicリッチクライアント（RIA）環境で、RMViewer Web版を使用することは可能でしょうか？

  • Magic eDeveloper以外で開発されたシステムでReportsMagicを使用することは可能ですか？　又、その場合のライセンスはどのようになりますか？

  • ReportsMagic－サイト単位で使用するライセンス形態、またはパッケージで使用するライセンス形態等の、ライセンス形態はありますか？

  • コールド・スタンバイでの使用する場合は、ライセンスはどうなりますか？

インストール関連

  • クライアント側には何をインストールしますか？

  • RMViewer C/Sの複数ユーザ版は、どのようにしてインストールするのですか？

  • RMViewer Web版、RMViewer RichClient版は、どのようにインストールするのですか？

  • RMViewer RichClient版で提供されている、RMViewer exe版はどのようにインストールするのですか？

ReportsMagic の製品仕様

  • Unicodeは、サポートされていますか？

  • 外字は使用できますか？

  • どのようなプリンタ（例えば、ドットインパクトプリンタ）でも印刷可能ですか？

  • RMViewerでプレビューしないで、バックグランド印刷することは可能でしょうか？

  • RMViewer RichClient版で、 RMViewer ActiveX版とRMViewer exe版の違いは、どのような点が異なるのでしょうか？

  • ReportsMagicとPDFの違いは、どのような点ですか？

  • バーコードは、どのような種類をサポートしていますか？

  • 圧縮・暗号化は、印刷フォーム、印刷データ単位で可能ですか？

サポート・サービス

  • インストール、導入教育、帳票設計支援等のサービスはありますか？

  • テクニカルサポートはどうなりますか？

製品体系・製品概要について

Ｑ | ReportsMagicの製品概要は？
Ａ | 「ReportsMagicの製品構成」をご確認ください。
 | Totop
Ｑ | Magicで開発された印刷プログラムの帳票フォーム（テキスト形式、GUI形式）をReportsMagicに自動移行するのですか？
Ａ | いいえ。 お客様がReportsMagicの仕様に合わせて新規にプログラムを開発する必要があります。 RMDesigner で印刷フォームを作成します。 Magicで印刷用の印刷データを生成（XML、CSV出力）し、RMViewerで印刷フォーム、印刷データを読込んで印刷します。
 | Totop
Ｑ | 印刷データのフォームは、どのような形式があるのですか？
Ａ | XML形式、CSV形式、ヘッダー付きCSV形式、dbFORM形式があります。 XML形式は、推奨の形式です。 高度な印刷フォームに対応可能です。 CSV形式、ヘッダー付きCSV形式は、単純な帳票に適しており、データ格納率は高いのが特徴です。 dbFORM形式は、DOSの帳票ツールであるdbFORM移行用に準備されたものです。
 | Totop
Ｑ | ReportsMagicがDBを直接アクセスすることはできないのですか？
Ａ | 出来ません。
 | Totop
Ｑ | インターネット環境で使用可能ですか？
Ａ | はい。 ReportsMagicで使用する印刷フォーム、印刷データと同一ものを、C/S環境、Web環境で使用することが可能です。
 | Totop
Ｑ | フラットファイルとは何ですか？
Ａ | ReportsMagicの印刷フォームと印刷データを1つファイルに統合したものです。 PDFのように一つのファイルで構成されます。 従って、RMViewer exe版がインストールされている環境では、ダブルクリックで開くことが可能です。
 | Totop

動作環境

Ｑ | ReportsMagicの動作環境は？
Ａ | 「ReportsMagicの動作環境」をご確認ください。
 | Totop
Ｑ | Windows Vista対応は？
Ａ | ReportsMagic Ver1.3でWindows Vistaに対応しました。 ただし、周辺ソフトウェアに関しては、各ベンダの対応状況をご確認ください。
 | Totop
Ｑ | Windows x64には対応していますか？
Ａ | 対応していません。 WOW64環境では、基本的に動作すると考えられますが、未検証です。使用される場合は、お客様の責任の範囲でご使用後ください。
 | Totop

ReportsMagicライセンス関連

Ｑ | ReportsMagicのライセンス概要はどのようになっていますか？
Ａ | 「ReportsMagicの製品構成」をご確認ください。
 | Totop
Ｑ | RMDesigner：一人の開発者が、複数のPCで開発を行っています。 RMDesigner １ユーザを複数のPCにインストールすることはできますか？
Ａ | 出来ません。 RMDesignerはインストールベースのライセンスです。 １ユーザを複数のPCにインストールすることは出来ません。
 | Totop
Ｑ | RMViewer C/S版 ：Magic Client とRMViewer C/Sを組合せて使用する場合、何ユーザを購入すればよいですか？
Ａ | Magic Clientと同数のユーザ数を購入してください。 Magic Clientは、バージョンによりライセンス管理方法が異なりますので詳細は、各バージョンの製品構成を参照してください。
 | Totop
Ｑ | RMViewer Web版 ：RMViewer exe版は、どのように使用するのでしょうか？
Ａ | メンテナンス用としてWebサーバ上でのみ使用可能です。 クライアント上での使用はできません。 又、印刷フォーム、印刷データへのアクセスはhttpのみ可能です。
 | Totop
Ｑ | RMViewer RichClient版：RMViewer RichClient版を C/Sシステムで使用することは可能ですか？
Ａ | 出来ません。 RMViewer RichClient版は、Magicリッチクライアントでのみ使用できるものです。 C/Sシステム、Magicリッチクライアントの両方を混在して使用する場合は、両方のライセンスが必要です。
 | Totop
Ｑ | Magicリッチクライアント（RIA）環境で、RMViewer Web版を使用することは可能でしょうか？
Ａ | 可能です。 ただし、ブラウザコントロール（ブラウザ機能）のみでしか使用できません。 RMViewer exeを使用したバックグランド印刷、ファイルアクセス、オフラインでの印刷等は対応出来ません。 システム要件に柔軟に対応可能なRMViewer RichClient版を使用されることをお奨めいたします。
 | Totop
Ｑ | Magic eDeveloper以外で開発されたシステムでReportsMagicを使用することは可能ですか？ 又、その場合のライセンスはどのようになりますか？
Ａ | ReportsMagicは、Magic eDeveloper で使用する印刷ソリューションとして設計されています。 技術的には他の言語（VB .NET、Javaなど）でも使用することは可能ですが、正式な動作検証を行っていません。 サポート範囲外となります。 使用される場合は、事前に動作検証を行い、お客様の責任の範囲でご使用ください。 その場合、ライセンスに関しては、ReportsMagicのライセンスを守る必要があります。 RMViewer C/Sの場合は、インストールベースライセンスとなります。 RMViewer RichClient版は、ご使用できません。
 | Totop
Ｑ | ReportsMagic－サイト単位で使用するライセンス形態、またはパッケージで使用するライセンス形態等の、ライセンス形態はありますか？
Ａ | 最寄の営業所にご確認ください。
 | Totop
Ｑ | コールド・スタンバイでの使用する場合は、ライセンスはどうなりますか？
Ａ | MViewerを圧縮／暗号化処理の為にMagicサーバ（Magic Application Server、Magic Enterprise Server、Magic RichClient Server）にインストールした場合、可用性向上のためにコールド・スタンバイやホット・スタンバイが必要になる場合があります。 コールド・スタンバイは、ソフトウェア使用許諾書の許諾プログラム等の複製の (1) で記載されている「バックアップを目的とする複製」とみなし、ライセンスの追加購入の必要はありません。
 | Totop

インストール関連

Ｑ | クライアント側には何をインストールしますか？
Ａ | 運用環境により異なります。 C/S環境（RMViewer C/S） ・クライアント側にRMViewer Exe／RMViewer ActiveＸをインストールします。 Web環境、RichClient環境 ・クライアント側にブラウザを使用してRMViewer ActiveＸをアドオンします。 ・RichClient版では、RMViewer exe版をダウンロードしてインストールすることも可能です。
 | Totop
Ｑ | RMViewer C/Sの複数ユーザ版は、どのようにしてインストールするのですか？
Ａ | 複数ユーザ版は、ファイルサーバ（共有フォルダ）にRMViewer をインストールし、各クライアントで「環境設定」を行います。環境設定を行うことにより、共有フォルダへのショートカット作成や、各クライアントPCへのRMViewer－ActiveXの登録を実施します。
 | Totop
Ｑ | RMViewer Web版、RMViewer RichClient版は、どのようにインストールするのですか？
Ａ | Webサーバ（ＩＩＳ）があるWindows Server環境上でインストールを行います。 又、別PC上にあるMagic Enterprise Serverや、Magic RichClient Serverで圧縮／暗号化DLLを使用する場合には、同様にインストールします。
 | Totop
Ｑ | RMViewer RichClient版で提供されている、RMViewer exe版はどのようにインストールするのですか？
Ａ | Webサーバからダウンロードして各クライアントにインストールを行います。 RMViewer C/S版とほぼ同一仕様ですが、以下が異なります。 ・ファイルアクセス、HTTPアクセスの両方が可能 ・ライセンス登録を行う必要がない。（ライセンス登録済みのモジュールを提供） ・クライアント上のRMViewer exe版の起動用コマンドの提供
 | Totop

ReportsMagic の製品仕様

Ｑ | Unicodeは、サポートされていますか？
Ａ はい。　Ver1.3よりサポートされました。
フォームデータは、Unicodeで格納されています。（旧バージョンのフォームを移行すると自動的にコンバートします）
印刷データは、SJIS（デフォルト）、UTF-8、UTF-16、UTF-16-ビッグエンディアンに対応しています。
サロゲート・ペア文字（4バイトのUnicode文字）については、対応していません。

Totop
Ｑ | 外字は使用できますか？
Ａ | 実行するPCに事前に外字を登録しておく必要があります。

Totop
Ｑ | どのようなプリンタ（例えば、ドットインパクトプリンタ）でも印刷可能ですか？
Ａ | Windows対応のプリンタドライバが用意されていれば、印刷可能です。

Totop
Ｑ | RMViewerでプレビューしないで、バックグランド印刷することは可能でしょうか？
Ａ RMViewer exe版では、起動パラメータで指定することが可能です。
RMViewer ActiveX版では、出来ません。
又、出力先のプリンターを指定することも可能です。

Totop
Ｑ | RMViewer RichClient版で、 RMViewer ActiveX版とRMViewer exe版の違いは、どのような点が異なるのでしょうか？
Ａ
 | RMViewer ActiveX版 | RMViewer exe版
Magicのプログラム | ブラウザコントロール（Webブラウザの機能） | OSコマンドを使用 RMViewer起動用のコマンドが提供されています。
インストール | ブラウザのプラグイン | インストーラをダウンロードしてインストールする
バックグランド印刷 | 不可 | 可能
オフライン | 不可 | Flatファイルをクライアント上にダウンロードしていれば、ダブルクリックで開くことが可能

Totop
Ｑ | ReportsMagicとPDFの違いは、どのような点ですか？
Ａ
 | ReportsMagic | PDF
[ライセンス] ビューワ | 有償 | 無償
[ライセンス] Flat/PDFファイル作成 | ビューワに含まれます | 有償
Flat/PDFファイル 生成処理のスピード | ◎（速い） | △（やや遅い）
Flat/PDFファイル ファイルサイズ | ◎（小さい） | △（やや大きい）
Flat/PDFファイル フォント組込み（外字） | × ※事前にクライアントにインストールする必要があります。 | ○
Flat/PDFファイル 動的イメージ組込み | × ※圧縮しない場合は可能 | ○
表示までの速度 | ◎（速い） | ○（ある程度は速い）
Magicプログラム構造 | 印刷データ（XML／CSV)出力 | Magicの印刷プログラム
印刷フォーム作成 | RMDesigner | Magicのフォーム ※通常はMagicの帳票フォーム（テキスト形式、GUI形式）を使用しますが、ReportsMagicからPDFを生成することも可能です。

※弊社の比較によるものです。

Totop
Ｑ | バーコードは、どのような種類をサポートしていますか？
Ａ 以下のバーコードに対応しています。

【一次元コード】
JAN13、JAN8、ITF、NW7、CODE39、 CODE128、UPC(E)
郵便カスタマバーコード、EAN128

【二次元コード】
QRコード

Totop
Ｑ | 圧縮・暗号化は、印刷フォーム、印刷データ単位で可能ですか？
Ａ 印刷フォーム形式別に、印刷フォーム、印刷データ、及びフラットファイルの単位に圧縮・暗号化が可能です。
これにより、印刷フォームは事前にクライアント側に配布しておき圧縮・暗号化した印刷データのみを配布する方法や、フラットファイル化して同時に配布する等、色々なシステム要件に対応可能です。

ReportsMagicファイル拡張子
ファイル | 標準拡張子 | 圧縮+暗号化 拡張子
フォームファイル | RFR | RFC
印刷データ-XML | XML | XMC
印刷データ-CSV | CSV | CSC
フラットファイル |  | RFF

Totop

サポート・サービス

Ｑ | インストール、導入教育、帳票設計支援等のサービスはありますか？
Ａ | ReportsMagicは、シンプルな設計になっていますので、現在通常のメニューとしては用意しておりません。 お客様のご要望に幅広くご対応できるプロフェッショナルサービスもご用意しておりますので最寄の営業所にご確認ください。
 | Totop
Ｑ | テクニカルサポートはどうなりますか？
Ａ | Magicサポート（有償）で対応します。 インシデントによりテクニカルなご質問に回答します。 詳細は、「サポート契約のご案内」をご確認ください。
 | Totop


Magic Software Japan K.K - Magic eDeveloper Plus Ver9.40J SP1 ベータ版 （Windows版）

ReportsMagic 使用許諾契約書

MSJC-RM002

本ソフトウェアモジュールを利用するにあたっては、下記の事項を良く理解し、合意した上でご利用ください。万一合意できない場合には、本ソフトウェアモジュールをご利用になることはできません。

マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）まで書面にてご連絡いただきますようお願い致します。

1. | 総則
   許諾プログラムに関する全ての著作権は、ＭＳＪが保有しています。ＭＳＪはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。
2. | 契約期間
   本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。
3. | 使用権
   使用権の内容はお客様が購入又は入手された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守して下さい。
・RMDesignerの場合
  お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－C/Sの場合
  お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－Webの場合
  お客様は、許諾プログラムを機械読取可能な形で、サーバ単位で使用することができます。
・RMViewer－RichClientの場合
    お客様は、許諾プログラムを機械読取可能な形で、サーバ単位又は、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。ユーザ数の場合は、Magic RichClient Server と同じユーザ数分の使用権をＭＳＪより取得しなければなりません。Magic RichClient Serverのシステムのみで使用することができます。
・体験版の場合
  お客様は、試用目的でだけ許諾プログラムを使用することができます。許諾プログラム、及び許諾プログラムを利用して開発したモジュールを営利目的に使用することはできません。
4. | 制限
   お客様は、以下の行為をしてはならないものとします。（但し、MSJによる書面による同意がある場合は、この限りではありません。）
(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。
(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。
(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。
(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。
(5) ＡＳＰやＳａａＳあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)
5. | 許諾プログラム等の複製
   (1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。
(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。
(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、ＭＳＪの事前の許諾を得るものとします。
6. | ＭＳＪの保証の範囲
   (1) ＭＳＪは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってＭＳＪの唯一の保証とします。
(2) ＭＳＪの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。
7. | 契約の解約
   ＭＳＪは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。
8. | 契約終了時の措置
   本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。
9. | 一般条項
   本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。
10. | 準拠法および裁判管轄
   本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


ワトソン博士のログのとり方

目次

  1. ワトソン博士とは？
  2. ワトソン博士を使ってログを取るための準備
  3. プログラムがクラッシュする場合のダイアログ
  4. プログラムがハングアップする場合の処置
  5. ワトソン博士が出力したログとクラッシュダンプファイルの送付
  6. 参考情報
    • クラッシュ ダンプ ファイルを作成しないようにする方法
    • より詳しい説明

1. ワトソン博士とは？

ワトソン博士(Dr. Watson)というのは、Microsoft社が提供するWindowsアプリケーションのためのデバッグ用ツールです。ワトソン博士をあらかじめデフォルトのデバッガとして登録しておけば、Windows上で動作するアプリケーションが異常終了した場合に、その時点での各種内部状態の記録(ログ)を作成し、保存します。アプリケーションの開発者はそのログをもとにして異常終了した状態を解析し、デバッグすることができます。

ここでは、ワトソン博士の設定方法、できるログファイル等について基本的なことをごく簡単に説明します。

2. ワトソン博士を使ってログを取るための準備

STEP 1. ワトソン博士をデバッガとして設定する

最初に、ワトソン博士をシステムで使うデフォルトのデバッガとして登録しなければなりません。これには、コマンドプロンプト(DOS窓)で、

drwtsn32 -i

とタイプすることによりなされます。このコマンドは、Administrator 権限のあるユーザだけでしか実行できません。

登録をいったん行うと、この設定はレジストリに書き込まれますので、マシンを再起動しても、再度実行する必要はありません。

登録に成功すると、下図のようなダイアログが表示されます。

STEP 2. ワトソン博士の設定を確認する

次に、ワトソン博士の設定を確認します。コマンドプロンプトから、今度は引数なしで

drwtsn32

を実行すると、次のような設定ダイアログが表示されます。

このうち、「ログファイルパス」は、ログファイルを保存しておくディレクトリ名を指定し、デフォルトでは「c:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson」などになっていますが、Windowsのバージョンにより違う場合があるので、確認して記録しておいてください。

ここに記録されるログファイルには、異常終了した時点でのメモリやレジスターの内部状態などの基本的な情報がテキスト形式で記録されます。

ログファイルに記録されているものだけでは情報不足で、異常終了時のプログラムのメモリの状態全部がデバッグに必要になることがあります。ワトソン博士では、これを「クラッシュダンプファイル」と呼び、設定ダイアログの「クラッシュダンプファイルの作成」にチェックが入っている場合に、「クラッシュダンプ」で指定されたディレクトリに作成します。

クラッシュダンプファイルはデバッグに極めて有効ですので、問題解決の時にはこれが取られるように、「クラッシュダンプファイルの作成」にチェックをしておいてください。

ただし、このファイルはプロセスのメモリ空間全体と付随情報を保存するので、サイズが非常に大きくなりがちです。たとえば、Magic のエンジンが異常終了した場合には、数十MBのサイズになります。このため、クラッシュダンプファイルの作成は問題解決に必要な場合に限り、普通は取らないようにチェックをはずしておくのが良いでしょう。

以上で、ワトソン博士の設定は終了です。実際にプログラムを動かしてテストを開始してください。

3. プログラムが異常終了する場合のダイアログ

プログラムの実行中に、アクセス違反、ハンドルされない例外などが発生してプロセスが異常終了したら、次のようなエラーダイアログが表示されます。ここのボタンが「キャンセル」になっている間は、ログファイルを作成中ですので、ボタンを押さないでください。クラッシュダンプファイルを作成する設定になっていると、このダイアログのボタンが「キャンセル」から「OK」に変わるまで、1分程度の時間がかかることがあります。

ボタンが「キャンセル」から「OK」に変わったら、ログファイルおよびクラッシュダンプファイルの作成は完了したので、OKを押してください。

4. プログラムがハングアップする場合の処置

プログラムの実行時に、異常終了はしないものの、プロセスが反応しなくなることもよくあります。この場合、無限ループに陥り、CPUを100%近く消費してしまっている場合もありますし、逆に、何かの待ち状態が続くようになってしまって、CPUが0%であることもあります。

いずれの場合にも、プログラムを強制終了させる必要がありますが、これには主に2つの方法があります。

  1. タスクマネージャからプロセスを強制終了させる方法
  2. ワトソン博士を使ってプロセスを強制終了させる方法

ここでは、ワトソン博士を使ってプロセスを強制終了させる方法について説明します。ワトソン博士を使って強制終了させることにより、タスクマネージャでは終了させられないサービスのプロセスを終了させることもでき、また、異常終了の場合と同様なログとクラッシュダンプファイルを取得することもできます。

STEP 1. プロセスIDを識別する

タスクマネージャなどで、ハングアップしているプロセス(強制終了させたいプロセス)のプロセスIDを識別します。

無限ループになっている場合には、「CPU」欄の値が 99 など、ほぼ100に近い数値になっているものがそれです(System Idle Process というのがありますが、これは無視してください。これは、本当の意味でのプロセスではなく、CPU負荷がほぼ0%の時には、System Idle Processの「CPU」が99近くになっています)。

逆に、永遠の待ち状態になっている場合には、時間が経ってもCPUの値とかメモリ使用量とかが変動しないので、判別することができます。通常活動を行っているプロセスは、時間とともにこれらの値が変動します。

STEP 2. drwtsn32.exe を実行する

プロセスIDが取得できたら、コマンドプロンプトから次のコマンドを実行します。ここで、pid は、STEP 1で取得したプロセスIDです。

drwtsn32 -p pid

このコマンドを実行すると、「プログラムのクラッシュする場合のダイアログ」で示したのと同様のダイアログが表示されます。クラッシュダンプファイルを採取する場合には、ボタンの表示が「OK」になるまで待ってください。クラッシュダンプファイルを採取する必要がない場合には、「キャンセル」ボタンを押して構いません。

5. ワトソン博士が出力したログとクラッシュダンプファイルの送付

STEP 1. ログファイルとクラッシュダンプファイルの送付

ワトソン博士の出力したログファイル (drwtsn32.log) は、ダイアログで設定されたディレクトリに保存されています。このファイルをコピーして、適当な形式(LZH、ZIPなど)で圧縮し、サポートセンターへお送りください。サイズが大きくなるので、圧縮しても大きすぎる場合には、CD-Rなどにコピーしてください。

[注意] ログファイル drwtsn32.log は、異常終了のあるたびに追加書き込みされ、サイズがだんだん増えてきますので、適宜削除してください。一方、クラッシュダンプファイル user.dmp は異常終了のあるたびに上書きされますので、必要ならば、別名に変更するなどして保存しておいてください。

STEP 2. モジュールの DIR の結果の送付

モジュールのバージョンを正確に把握するため、Magicをインストールしたディレクトリで、下図のように、dir コマンドを使って Magic関係のモジュールのタイムスタンプ、サイズなどを取得し、その結果を適当なファイルに格納して、上記のログファイル等と一緒にサポートセンターへお送りください。

[参考] dir コマンドの結果(上図で modules.txt の中身)は、次のようなものです。これは例ですので、Magicのバージョン等により結果が異なります。

ドライブ D のボリューム ラベルは S359897D001 です
 ボリューム シリアル番号は 488B-6C1C です

 D:\Program Files\Magic\Development のディレクトリ

2002/11/19  13:22               49,220 MGActDir.dll
2002/12/10  20:18              204,713 MGBC930_03AJ.cab
2002/11/25  13:45               97,522 MGBC930_03AJ.js
2002/12/10  20:19              203,714 MGBC930_03AJS.cab
2002/12/10  20:19              204,454 MGBC930_03AJS_FW01.cab
2002/12/10  20:19              204,678 MGBC930_03AJ_FW01.cab
2002/12/10  20:07               97,460 MGBC930_03AJ_FW01.js
2002/11/19  16:16               19,401 MGBCCOM9.cab
2002/12/03  19:27              225,345 MGddf.dll
2002/12/03  19:31              225,347 MGddf2k.dll
2000/03/16  01:34                2,206 mgedit.jpg
2002/12/13  14:31                  121 mgflwmtr.log
2002/12/11  18:34            5,726,274 MGgenw.exe
2002/12/03  19:35               86,084 MGlcl9jp.dll
2002/12/03  17:38              118,851 MGmerge.dll
1999/01/06  11:41                  435 MGPRN.CNT
1999/06/18  10:08              110,592 MGPRN.EXE
2001/05/24  08:38              319,218 MGPRN.HLP
2002/12/13  14:18                  625 mgrb.ini
2002/05/11  09:04                  822 mgreq.ini
2002/12/03  17:29              548,931 MGresrc.dll
2002/12/11  18:34            3,584,066 MGrntw.exe
2002/12/05  15:26              102,468 MGrqcmdl.exe
2002/12/03  19:35              667,718 MGrqgnrc93.dll
2002/12/03  19:21               98,374 MGrqhttp93.dll
2002/12/03  19:20              217,155 MGrqmrb.exe
2002/12/03  19:35              352,324 MGrqsoap.dll
1999/04/21  00:19              253,952 MGVAR.ocx
2000/02/28  17:56                2,672 mgvcr.jpg
2002/11/19  13:34              143,426 MG_ocx.dll
              30 個のファイル          13,868,168 バイト

 D:\Program Files\Magic\Development\EJB のディレクトリ

2002/07/24  09:07               31,886 mgejbgnrc.jar
               1 個のファイル              31,886 バイト

 D:\Program Files\Magic\Development\Gateways のディレクトリ

2002/12/05  15:26              331,842 MGbtrv.dll
2002/12/05  15:26              319,556 MGmemory.dll
2002/12/05  15:26              331,842 MGpv2k.dll
               3 個のファイル             983,240 バイト

 D:\Program Files\Magic\Development\Magic9Demo\HTML_Pages のディレクトリ

2001/02/16  12:23                  240 mg_vcr.gif
               1 個のファイル                 240 バイト

 D:\Program Files\Magic\Development\Support のディレクトリ

2002/12/03  10:47              759,085 mgconstw.eng
2002/12/05  16:59              759,033 mgconstw.jp2
2002/12/05  16:58              759,032 mgconstw.jpn
2002/09/26  11:39                8,467 MGHELPW.CNT
2002/12/10  16:08            3,114,135 MGHELPW.HLP
               5 個のファイル           5,399,752 バイト

     ファイルの総数:
              40 個のファイル          20,283,286 バイト
               0 個のディレクトリ     328,677,376 バイトの空き領域

6. 参考情報

6.1. クラッシュ ダンプ ファイルを作成しないようにする方法

問題解決の時には、クラッシュダンプファイルは非常に有効なので、できるだけ取るようにしていただきたいと思いますが、問題の調査が終わり、通常の運用に戻った場合には、クラッシュダンプファイルは作成する必要がありませんので、次のステップでクラッシュダンプファイルを作成しないように設定を変更します。

STEP 1. ワトソン博士の設定ダイアログを起動する

Administrator 権限のあるユーザだけでログインし、コマンドプロンプト(DOS窓)で、引数なしで

drwtsn32

を実行します。するとワトソン博士の設定ダイアログが出てきます。

STEP 2. 「クラッシュダンプファイルを作成する」のチェックをはずす

設定ダイアログの中で、「クラッシュダンプファイルの作成(T)」のチェックボックスをはずします。すると、「クラッシュ ダンプ (P)」の欄が無効化されます。これで「OK」ボタンを押すと、以後、万一プログラムが異常終了しても、比較的サイズの小さいログだけが作成され、クラッシュダンプファイルは作成されなくなります。

この設定はレジストリに書き込まれますので、マシンを再起動しても、再度実行する必要はありません。

6.2. より詳しい説明

ワトソン博士の使い方の詳細については、コマンドプロンプトで

drwtsn32

を実行させると、ワトソン博士の設定ダイアログが出てくるので、「ヘルプ」ボタンを押してワトソン博士のヘルプを読んでください。