ReportsMagic Ver1.1 追加情報

マジックソフトウェア・ジャパン
株式会社２００５年12月

ReportsMagic Version1.1 追加情報

本文書には､ReportsMagic Verison1.1 として提供されたプログラム に関して、マニュアルの記載事項以外の追加情報が記述されています。

  • 本バージョンのご利用にあたって
  • 動作環境
  • サンプルフォーム、アプリケーション
  • 修正履歴
    V1.1の新機能
    V1.1の改善・変更内容
    V1.0Bの新機能
    V1.0Bの改善・変更内容
    V1.0Aの改善・変更内容
  • 制限事項及び留意事項
  • 参考技術情報
  • ベータ版評価レポートのお願い
  • 使用許諾契約

本バージョンのご利用にあたって

ベータ版、体験版をご利用になったお客様に

ベータ版、体験版から製品版に移行する場合には、以下の点にご留意ください。

  • 本製品版をインストールするにあたりましては、ベータ版、体験版のモジュールが残って思わぬ悪影響を与えることを避けるため、ベータ版、体験版のアンインストールを行い、ファイル等の設定を完全に削除してください。
  • ベータ版、体験版で作成したフォームデータは、製品版で使用することはできません。

RMViewer（ActiveX)のアップデート

メンテナンス処理、アップグレード処理で RMViewer（ActiveX)の再登録を実行した場合、「RMViewer体験版のご案内」、「RMViewerCtl.ocx の DllRegisterServerは成功しました」等のダイアログが表示される場合があります。その場合は、Enterを入力してそのまま継続してください。

過去のバージョンとの互換性

RMDesignerで作成されるフォームは、バージョン番号により管理されています。
基本的にフォームファイルは、上位互換性を持ちますが、下位互換性はサポートされていません。 旧フォームファイルを開き、書込みを行うと自動的に新バージョンへ移行しますので、事前にバックアップすることをお薦めいたします。

フォームバージョンの読み込み対応一覧

 | 旧バージョンのフォームファイル | 新バージョンのフォームファイル
RMDesigner 旧バージョン | ○ | ×
RMViewer 旧バージョン | ○ | ×
RMDesigner 新バージョン | ○ 変更・保存すると新バージョンの形式となる | ○
RMViewer 新バージョン | △ 新バージョンの仕様変更等により一部互換性が維持できない場合もあります。旧バージョンのフォームファイルを新バージョン に移行することお奨めいたします。 | ○

フォームバージョン一覧

ReportsMagicバージョン | フォームバージョン番号
V1.0、V1.0A、V1.0B | 5
V1.1 | 10

ベータ機能／ご意見、要望事項について

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外となります。
又、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールにて japan_v9beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

動作環境

  • RMDesigner

    Windows 2000／XP／2003
  • RMViewer

    Windows | 98 SE／2000／XP／2003
    ブラウザ | Internet Explorer 5.5 SP2以上
    Magic（ActiveX)組込み | V9Plus
    Magic　exe起動 | V8、V9、V9Plus

サンプルフォーム、アプリケーション

各種サンプルフォーム、及びMagicアプリケーションが提供されています。

V1.0からのサンプル フォーム、アプリケーションの主な変更点

  • 全フォーム：データ項目の記憶型式、書式、基本色番号、フォント番号の対応
  • RMViewer初期オープンモードの設定（サムネール表示、連続ページ、他）
  • バーコードサンプルの更新（EAN128、QRコードの追加）
  • ヒサゴ　GB1101-納品書(罫線有り、無し）の追加
  • 扶養控除等申告書、保険料控除等申告書の追加
  • サンプルアプリケーション：RMViewer.exe起動拡張の対応
  • サンプルアプリケーション：圧縮・フラットファイルの作成の追加

RMDesigner での確認

  • RMDesigner.exe を起動し 該当のフォームを開き、ツール／テストでサンプルデータを選択します。
サンプルフォーム | フォーム名 C:\ReportsMagic\ RMdataV11\ | サンプルデータ C:\ReportsMagic\ RMdataV11\ | 備考
家族構成 （マルチデータフォーム） | EmpfamilyCsv.rfr | EmpfamilyCsv.csv | CSV形式
 | EmpfamilyCsvhead.rfr | EmpfamilyCsvhead.csv | CSVヘッダー付き形式
 | EmpfamilydbFORM.rfr | EmpfamilydbForm.dat | dbFORM形式
 | EmpfamilyXml.rfr | Empfamily.xml | XML形式
勘定科目名 （dbFORM） | HIKAKU.ｒｆｒ | HIKAKU.dat | dbFORMのフォームを読み込んで作成したものです。
 | HIKAKU.FRM | HIKAKU.dat | オリジナルのdbFORMのフォームです。新規フォームを作成し、「ファイル／dbFORM読み込み 」で 読み込むことができます。その後、「ツール／帳票設定」のデータ形式をdbFORM形式にして、確認します。
複合文書 | Fukugo.rfr （Fukugo.rff） | Fukugo.xml | 納品書、請求書、納品受領書の複合文書です。
複数ページ | Fukusu.rfr （Fukusu.rfc） （Fukusu.rff） | Fukusu.xml 大量Fukusu.xml （Fukusu.xmc） | 暗黙の改ページのサンプルです。
バーコード | バーコード.rfr | バーコード.xml | バーコードの一覧表です。
イメージ | イメージ.rfr | イメージ.xml | イメージ処理のサンプルです。
ヒサゴ GB1101-納品書 (罫線無） | GB1101-納品書(罫線無）.rfr | GB1101納品書.xml | ヒサゴ GB1101-納品書(罫線無） プレプリントへの印刷を想定。納品書のイメージをスキャナー読み込みし、項目の位置合わせをしています。
ヒサゴ GB1101-納品書 (罫線有） | GB1101-納品書(罫線有）.rfr | GB1101納品書.xml | ヒサゴ GB1101-納品書(罫線有） ヒサゴのフォーマットに合わせて罫線等をReportsMagicで作成しています。
扶養控除等申告書 | 扶養控除等申告書（H18).rfr | 扶養控除等申告書（H18).xml |
保険料控除等申告書 | 保険料控除等申告書(H17).rfr | 保険料控除等申告書(H17).xml |

RMViewerでの確認

  • RMDesigner－サンプルのメニューをクリックして起動してください。
メニュー | サンプルフォーム | 備考
家族構成 | 家族構成 | XML形式 A4縦 RMViewer.exe起動
家族構成.HTML | 家族構成 | XML形式 A4縦 ブラウザ起動
複合文書 | 複合文書 | XML形式 A4縦 RMViewer.exe起動
複合文書.HTML | 複合文書 | XML形式 A4縦 ブラウザ起動
複数ページ | 複数ページ | XML形式 A4縦 RMViewer.exe起動
複数ページ－大量 | 複数ページ | XML形式 A4縦 RMViewer.exe起動 大量ページのサンプルでRMViewer.のマルチスレッドの動作を確認できます。
複数ページ.HTML | 複数ページ | XML形式 A4縦 ブラウザ起動
バーコード | バーコード | XML形式 A4縦 RMViewer.exe起動
ヒサゴGB1101-納品書(罫線有） | ヒサゴGB1101-納品書(罫線有 | XML形式 A4縦 RMViewer.exe起動
ヒサゴGB1101-納品書(罫線無） | ヒサゴGB1101-納品書(罫線無） | XML形式 A4縦 RMViewer.exe起動
扶養控除等申告書 | 扶養控除等申告書 | XML形式 A4縦 RMViewer.exe起動
保険料控除等申告書 | 保険料控除等申告書 | XML形式 A4縦 RMViewer.exe起動

RMDesignerで添付しているRMViewerは体験版です。

HTMLの場合、フォーム、印刷データのパスをドライブ指定で記述していますが、URLに変更することも可能です。

●例
<param name="RfrFile" value="http://localhost/ReportsMagic/RMdataV11/EmpfamilyXml.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/RMdataV11/Empfamily.xml">
<param name="ToolBar" value="on">

Magicと連携したサンプル

家族構成のXMLフォーム（EmpfamilyXml.rfr）を使用したサンプルアプリケーションです。
プログラムリポジトリの「ReportsMagic サンプル-メイン」をＦ７で実行してください。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
Magic Viewer ActiveX | Magicから ActiveX 呼び出しで、RMViewerを実行します。
Magic Viewer EXE | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。
Magic Viewer EXE Cmd | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。 RMViewerコマンドライン実行関数を使用しています。
HTML Viewer | ブラウザから、RMViewerを実行します。 表示用のHTML（家族構成.htm）を生成し、オープンします。
RMCompSec | 圧縮・フラットファイルを作成します。

サンプルアプリケーションは、V9.4 SP3で開発されています。


ReportsMagic Ver1.1 修正履歴

V1.1の新機能

バーコード
記憶型式対応
 書式対応
フォーム移行
その他の拡張
RMViewerの拡張
ReportsMagicアプリケーションウイザード
圧縮及び暗号化、フラットファイル対応
ベータ機能

バーコード

  • CODE39及びNW-7、ITFは、チェックディジットの有無が指定できるようになりました。
  • EAN128が追加されました。
    旧バージョンでもCODE128を利用することにより対応可能でしたが、CODEC, FUNC1を自動的に追加するようにしバーコード化したいデータのみで対応できるようなりました。
  • QRコードに対応しました。
    コード種別はモデル2にのみ対応しています。（モデル1、及びマイクロQRコードには対応していません。）
    詳細は、RMDesignerリファレンスマニュアル（図形の描画－バーコードの描画）を参照してください。

記憶型式対応

データ型

旧バージョンでは、種類と表現していました。　固定データ、データ項目、ページ番号、日付、時刻のデータ型に分類されて管理されるようになりました。

記憶型式

Magicと同様に記憶型式がサポートされるようになりました。

詳細は、RMDesignerリファレンスマニュアル（帳票ツールの概要－フォームファイルの設計）を参照してください。

dbFORM形式では、データ型は固定データとデータ項目のみ、記憶形式はサポートされません。

書式対応

Magicと同様に書式がサポートされるようになりました。 項目書式の記述方法は、基本的にMagicと互換です。

詳細は、RMDesignerリファレンスマニュアル（帳票ツールの概要－フォームファイルの設計）を参照してください。

dbFORM形式で書式は、サポートされません。

オペランド

  • 実行する関数を指定します。　従来は文字列の項目TAGで記述していました。

フォーム移行

旧バージョンのフォームを読み込むと自動的に、最新バージョンのフォームへ移行されます。
以下は、移行内容についての詳細です。

事前に旧フォームをバックアップされることをお奨めいたします。

データ型の対応
＜CSV形式、ヘッダ付きCSV形式、XML形式＞

旧フォームデータ | データ型 | 記憶型式 | 書式 | オペランド
項目TAGが空白 | 固定データ | 文字 | 書式は未設定（空白） |
項目TAGが非空白 | データ項目 | 文字 | 書式は未設定（空白） |
項目TAGが@page(X) | ページ番号 | 数字 | NNNN | @page(X)をコピー

書式 未設定（空白）は、V1.0Xと互換動作となります。

＜dbFORM形式＞

旧フォームデータ | データ型 | 記憶型式 | 書式 | オペランド
項目名に%%が無い | 固定データ | 文字 | 書式は未設定（空白） |
項目名に%%がある | データ項目 | 文字 | 書式は未設定（空白） |

項目名の統合

  • 旧バージョンでは、固定データ／可変（データ）項目を「項目TAG」の有無で判断していましたが、データ型のサポートにより不要になりました。　従って、旧バージョンの「項目名」、「項目TAG」は、「項目名」に統合されました。 この場合、項目名と項目TAGの内容が異なる場合には、項目名が削除されますので、ご注意ください。
データフォーム形式 | データ型
項目XML ヘッダー無しCSV ヘッダー付きCSV | 「項目TAG」を「項目名」にコピーし、旧バージョンの「項目名」は廃棄。
dbFORM | 「項目名」をそのままコピーします。 旧バージョンの「項目TAG」は廃棄。

その他の拡張

グリット設定の拡張

  • 縦・横の個別指定ができるようになりました。
  • 表示単位にCPI/LPIが追加されました。

グリット設定のフォーム格納

グリット設定で設定した情報をフォームファイルに格納するようになりました。
フォームを開いた場合は、フォーム格納時のグリット情報を元にグリット表示を行います。

レイヤ情報のフォーム格納、レイヤ情報の入力

  • レイヤ設定で設定した情報をフォームファイルに格納するようになりました。フォームを開いた場合は、フォーム格納時のレイヤ設定情報を元にレイヤを設定します。
  • レイヤ１～７は、レイヤに関するコメントを記入することが出来るようになりました。レイヤ画面を表示し、直接記入します。
  • 不可視のレイヤは、RMViewerでは表示されません。

基本色定義

Magicと同様に基本色定義がサポートされました。
これによりフォーム内の各種の色指定を一元管理することが可能になります。
詳細は、RMDesignerリファレンスマニュアル（図形の描画－はじめに 基本設定）を参照してください。

フォント定義

Magicと同様にフォント定義がサポートされました。
これによりフォーム内の各種フォント指定を一元管理することが可能になります。
詳細は、RMDesignerリファレンスマニュアル（図形の描画－はじめに 基本設定）を参照してください。

テーブルの罫線機能の拡張

テーブルの罫線の色指定、外枠罫線は、四隅に対して角丸め有無の指定ができるようになりました。

テーブルのプロパティの拡張

テーブル－各列データ項目の見出し、列データの一般、文字列、データ項目プロパティを切り替えて設定できるようになりました。

テーブルのプロパティで表示できる最大項目数は96個まです。　それ以上存在する場合は、テーブル上で個別に定義します。

テーブルの行、列の挿入、削除、移動

各行、列の追加、削除、移動が可能になりました。
詳細は、RMDesignerリファレンスマニュアル（図形の編集－テーブルの編集）を参照してください。

角丸四角の拡張

角丸四角は、四隅に対して角丸め有無の指定ができるようになりました。

非表示項目の指定

データ項目に対して、項目の非表示を指定できるようになりました。
CSV形式でページブレイクの項目を、非表示にしたい場合等に使用することが出来ます。
dbFORM形式では、サポートされません。

関数追加

  • @date()
    現在の日付を取得する。表示方法は書式に従う。
  • @time()
    現在の時刻を取得する。 表示方法は書式に従う。

RMDesignerアイコンの追加

  • 基本色定義
  • フォント定義
  • 縦文字列、横文字列　固定データ用　（従来の縦文字列、横文字列は、データ項目用）
  • OLE　新規オブジェクトの挿入
  • ライン整合
  • 領域移動
  • 交点間削除

    ツールバーのパレット桁のデフォルトは３に変更しました。

帳票設定－用紙指定

フォームの用紙設定を個別に行えるようになりました。
「帳票設定」のプリンタ設定の方式とは異なり、プリンタードライバを特定しないで作成することが出来ます。
開発／実行の印刷するプリンター環境が異なることが想定される場合は、こちらの方法で作成することを推奨します。

以下の情報を設定することが可能です。

  • 用紙サイズ
  • 用紙向き
  • 余白 フォーム作成時のデフォルトプリンターの情報がセットされますが、変更することが可能です。
  • プリンタ設定の「リセット」を行えるようになりました。

RMViewer初期オープンモード

RMViewerでフォームをオープンした時の各種動作を指定できるようになりました。
「帳票設定」画面の「実行時設定」タブで指定します。

  • サムネール表示
  • ページレイアウト
    ・ 単一ページ
    ・ 連続ページ
    ・ 連続２ページ
  • 起動ページ番号
  • 拡大率
    ・ 倍率指定表示
    ・ 基準画面表示（デフォルト）
    ・ 全体表示
    ・ 描画領域の横幅に合わせる
    ・ 全画面表示
  • メニューバー非表示
  • ツールバー非表示
  • ステータスバー非表示

プレ印刷用紙の印刷時にスキャナレイヤの印刷が可能なように拡張されました。

  • プレ印刷用紙に印刷する（スキャナレイヤは印刷しない）

RMViewerの拡張

表示方法の拡張

  • メニューバー、及びアイコンが追加され以下の表示が可能になりました。

表示方法 | 内 容
領域指定拡大 | 拡大率：領域を指定して拡大表示
基準倍率表示 | 拡大率：基準倍率で表示します。(既存機能：アイコンが変更されました）
用紙全体表示 | 拡大率：ページ全体が表示できる倍率で表示
幅に合わせる | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
全画面表示 | 拡大率：ウインドウを最大化して表示
ページ番号表示 | 表示しているページの番号、総ページ番号が表示します。ページ番号を入力することによりページへジャンプすることが出来ます。
サムネール表示 | サムネールを表示するペインを左側に作成し、サムネール表示
単一ページ表示 | ページレイアウト：従来の表示方法で、一度に文書の1 ページ分だけを表示（既存機能）
連続ページ | ページレイアウト：ページを縦に続けて表示
連続２ページ | ページレイアウト：２ページを横に並べて、縦に続けて表示

起動オプションの追加

表示方法 | 内 容
フォームファイルの指定 | /rfr=フォームファイル名
印刷データファイルの指定 | /rdata=データファイル名
プレビュー表示 | /dsp=[y|n] ‘y’ ･････プレビュー表示をします。 ‘n’ ･････プレビュー表示を行わず、すぐにバックグラウンドで印刷を開始します。
プリンタ名の指定 | /prn= …… 実行時に印刷プリンタを指定することが可能です。
拡大率の指定 | /zoom= ‘10～500’の数字、または‘i’、‘w’、‘a’または ‘p’を指定します。 10から500の数字 ･････ 拡大率を表します。100が通常の倍率です。 ‘i’ ･････ 基準倍率表示（デフォルト） ‘w’ ･････ ウインドウの描画領域幅にページの横幅を合わせます。 ‘p’ ･････ ページ全体を表示します。（デフォルト） ウインドウの描画領域の縦幅にページの縦幅を合わせます。 ‘a’ ･････ 全画面表示を行います。
ページレイアウトの指定 | /pagelayout= 1,2,3のいずれかを指定します。 ‘1’ ･････1ページ表示を行います。（デフォルト） ‘2’ ･････連続１ページ表示を行います。 ‘3’ ･････連続２ページ表示を行います。
サムネール表示の指定 | /thumbnail= ‘y’ または ‘n’ を指定します。 ‘ｙ’ ･････サムネール表示を行います。 ‘n’ ･････サムネール表示を行いません。（デフォルト）
メニューバー表示の指定 | /menubar= ‘y’ または ‘n’を指定します。 ‘ｙ’ ･････メニューバーを表示します。（デフォルト） ‘n’ ･････メニューバーを表示しません。
ツールバー表示の指定 | /toolbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ツールバーを表示します。（デフォルト） ‘n’ ･････ツールバーを表示しません。
ステータスバー表示の指定 | /statusbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ステータスバーを表示します。（デフォルト） ‘n’ ･････ステータスバーを表示しません。

「帳票設定」のRMViewer初期オープンモードよりも、起動オプションの方が優先されます。

RMViewer ActiveX　機能拡張

RMViewer ActiveX　プロパティ一覧

プロパティ一覧 | 内 容
Copy | コピー数
PageLayout | ページレイアウト番号
PrinterName | プリンター名
RDataFile | 印刷データファイル名
RfrFile | フォームファイル名
Zoom | 拡大率（'10-500','i','w','a','p'）
Thumbnail | サムネール表示 （'on','off'）
ToolBar | ツールバー表示 （'on','off'）

RMViewer ActiveX　メソッド一覧

メソッド一覧 | 内 容
AboutBox | RMViewer バージョン情報
OnThumbnail | サムネール表示
OnToolBar | ツールバー表示
PageFirst | 先頭ページ
PageLast | 最終ページ
PageLayout1 | ページレイアウトの指定 1ページ表示
PageLayout2 | ページレイアウトの指定 連続１ページ表示
PageLayout3 | ページレイアウトの指定 連続２ページ表示
PageNext | 次ページ
PagePre | 前ページ
PageSelect | 印刷範囲の指定
PrintData | 印刷
ZoomAll | 拡大率：ページ全体を表示
ZoomAllWidth | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
ZoomBase（ZoomTop） | 拡大率：基準倍率表示
ZoomFulll | 拡大率：全画面表示
ZoomIn | 拡大率：拡大
ZoomOut | 拡大率：縮小

RMViewer起動用DLL

VER1.1用にRMViewer実行関数(Execute)　が拡張されました。

  • Ver1.1 RMViewer実行関数(Execute)
      構文……定義式：RMViewer.Execute110
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型）
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示）
      ⑨拡大率（文字型）　　　（‘10～500’、‘i’、‘w’、‘a’、‘p’）
      ⑩ページレイアウト（文字型） 　（1,2,3）
      ⑪サムネール表示 （文字型）　（'y' または 'n'で指定）
      ⑫メニューバー表示 （文字型） （'y' または 'n'で指定）
      ⑬ツールバー表示 （文字型）　（'y' または 'n'で指定）
      ⑭ステータスバー表示 （'y' または 'n'で指定）
      ⑮実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑯エラーメッセージ（文字型）

コマンドラインで起動できるRMVieweコマンドライン実行関数(.CommandLine)　が追加されました。
  • RMViewerコマンドライン実行関数（CommandLine）
      構文……定義式：RMViewer.CommandLine
      バラメータ……
      ①RMViewerの実行フォルダ。（文字型）　指定がない場合には、カレントフォルダーになります。
      ②コマンドライン（文字型）
      ③ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ④実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑤エラーメッセージ（文字型）

    ＜コマンドラインの例＞
    /rfr=C:\ReportsMagic\RMdataV11\EmpfamilyXml.rfr /rdata=C:\ReportsMagic\RMdataV11\Empfamily.xml
    /dsp=y /copy=1 /status=y /zoom=i /pagelayout=0 /thumbnail=n /menubar=y /toolbar=y /statusbar=y

RMViewer プレビューパフォーマンス向上

RMViewerをマルチスレッドにすることにより、プレビューのパフォーマンスを向上しました。
プレビュー用中間データ処理と表示処理をマルチスレッド化し、中間データ処理の途中でもプレビュー表示することが出来るようになりました。

  • ページ関数
    フォーム上で指定されているページ関数は、未決定状態の場合があります。その場合は、#で表示されます。
    （例）　001／###　 ###は総ページ数
  • RMViewer上のページ番号表示
    総ページ数は処理済のページ数が表示されます。　最終ページまで処理されていない場合は、総ページ数の最後に#が追加されます。
    （例）　1／18#　　→　確定後 1／1740
  • 印刷処理は、中間データが確定したタイミングで印刷を行います。

dbFORM形式では、サポートされません。

ReportsMagicアプリケーションウイザード

ReportsMagic用のアプリケーションウイザードが提供されています。

以下の機能が提供されています。

  • 印刷用データ作成プログラムの自動生成（XML形式、ヘッダー付きCSV形式）
  • マージ用テンプレートファイルの自動生成

詳細は、RMDesignerリファレンスマニュアル（アプリケーションウイザード）を参照してください。

圧縮及び暗号化、フラットファイル対応

フォームファイル、印刷データの圧縮及び暗号化、及びフラットファイルをサポートします。
フラットファイルは、フォームデータ＋印刷データを圧縮及び暗号化処理したファイルです。

拡張子の定義
圧縮＋暗号化及びフラットファイルは、拡張子により識別されます。

表示方法 | 標準 | 圧縮＋暗号化 | 備考
フォームファイル | RFR | RFC |
印刷データ ＸＭＬ | ＸＭＬ | XMC |
印刷データ ＣＳＶ | ＣＳＶ | CSC |
印刷データ dbFORM | 任意 | － | dbFROM形式は、圧縮＋暗号化、フラットファイル化はサポートされません。
フラットファイル | － | RFF | フラットファイルの指定は、フォームファイル名（/rfr=）で指定します。

動的イメージデータは、圧縮の対象となりません。従って、異なる環境でイメージデータを使用する場合、事前にイメージデータを準備しておく必要があります。

パスワード

RMViewer.exe起動時に、圧縮＋暗号化ファイルを指定する場合には、コマンドラインでパスワードを指定することが可能です。コマンドラインで指定していない場合は、パスワード入力のダイアログが表示されま す。

（例）
RMViewer.exe /rfr=XXX.RFC:password /rdata=XXX.XMC:password /dsp=y
RMViewer.exe /rfr=XXX.RFF:password

  • フォームファイル、印刷データファイル共に、圧縮＋暗号化ファイルを使用する場合には、パスワードが２つ必要となります。
  • 圧縮時にパスワード設定を行っていない場合は、パスワード入力は表示されません。

RMDesignerでのFLATファイル作成

RMDesigner上で、フラットファイルを生成することが可能です。
フォームを開いた状態で、メニューバー［ファイル］－［FLATファイルとして保存］をクリックし、印刷データファイル名、保存ファイル名を指定して保存を行います。

パスワードは、帳票設定のパスワードを使用します。

圧縮・暗号化用DLL

圧縮・暗号化、フラットファイル化のためのDLLが提供されています。
Magicのコールコマンド—ユーザPRCを使用して圧縮・暗号化、フラットファイル化を処理することが出来ます。

詳細は、RMDesignerリファレンスマニュアル（フラットファイルとセキュリティ－圧縮・暗号化DLL）を参照してください。

ベータ機能

  • 無し。

V1.1の改善・変更内容

イメージ

  • RMDesigner上でフォームにイメージを貼り付けた場合、固定項目の場合はイメージを表示しますが、データ項目の場合は、文字列と同様に枠、項目名等を表示するようになりました。

バーコード

  • RMDesigner上でフォームにバーコードを貼り付けた場合、固定項目の場合はバーコードを表示しますが、データ項目の場合は、文字列と同様に枠、項目名等を表示するようになりました。

dbFORM

  • dbFORM形式で、シーケンス番号が飛んだ場合、印刷データとして認識しない件に対応しました。
    （例）
    フォーム
      %%1-1 %%1-2 %%1-4 %%1-5 　←%%1-3が無い
    データ
      "1-1","1-2","1-4","1-5",[TAB][FF]
    結果　V1.0Bまで
      "1-1"　"1-2"　" "　" "　　←%%1-2以降が表示されない
      改ページ
    結果　V1.0C
      "1-1"　"1-2"　"1-4"　"1-5"
      改ページ
  • dbFORM形式で、親番号のみの場合、TABコードで親番号が更新されてしまう件に対応しました。
    （例）
    フォーム
      %%1 %%2 %%3
    データ
      "1",[TAB],"2","3"[FF]
    結果　V1.0Bまで
      "1"　" "　"2" ←"2"が次項目にずれる
      改ページ
      " "　" "　" "
      改ページ
    結果　V1.0C
      "1"　"2"　"3"
      改ページ
  • dbFORM形式で、親子番号で、TABコードがないのに、子を終了して親番号が更新されてしまう件に対応しました。
    （例）
    フォーム
      %%1-1　%%1-2　%%1-3　　%%2-1　%%2-2　%%2-3
    データ
      "1-1","1-2","1-3","1-4","1-5",[TAB],"2-1","2-2","2-3","2-4","2-5",[TAB][FF]
                                        ←"1-4" "1-5" "2-4" "2-5"の項目が、フォーム項目よりも多い
    結果　V1.0Bまで
      "1-1"　"1-2"　"1-3"　　" "　" "　" "　　　←"2-1"以降がずれる
      改ページ
      "2-2"　"2-3"　"2-4"　　" "　" "　" "
      改ページ
    結果　V1.0C
      "1-1"　"1-2"　"1-3" "2-1"　"2-2"　"2-3"
      改ページ
  • dbFORM形式で、FFコードがなくても、フォームに配置された項目よりデータが多い場合、動的に改ページ後、データが欠落する件に対応しました。
    (例)
    フォーム
      %%1 %%2 %%3
    テータ
      "1", "2", "3", "4", "5"[FF]　　←"4" "5"の項目が、フォーム項目よりも多い
    結果　V1.0Bまで
      "1" "2" "3"
      改ページ
      "5" " " " "　　　　　　　　　　 ←"4"が欠落
      改ページ
    結果　V1.0C
      "1" "2" "3"
      改ページ
      "4" "5" " "
      改ページ

    フォーム
      %%1-1 %%1-2 %%2-1 %%2-2
    テータ
      "1-1" "1-2" [TAB] "2-1" "2-2" [TAB] "3-1" "3-2" [TAB][FF]　←"3-1" "3-2"の項目が、フォーム項目よりも多い
    結果　V1.0Bまで
      "1-1" "1-2" 　"2-1" "2-2"
      改ページ
      "3-2" " " 　" " " "　　　←"3-1"が欠落
      改ページ
    結果　V1.0C
      "1-1" "1-2" 　"2-1" "2-2"
      改ページ
      "3-1" "3-2" 　" " " "
      改ページ

データ連携

  • XML形式の場合、テーブルに１行もデータが無い場合にそのページ全体が表示されなくなる件に対応しました。
  • 可変データ項目で、データが1024バイトを超えると表示が文字化けする件に対応しました。
  • データ項目の文字枠連結に対応しました。

データ項目ウインドウ

  • ［ファイルを開く］機能では、フォームに対するデータ形式のファイル（例：XML）のみが読み込めるようになっていましたが、どの形式のファイルでも読み込めるようになりました。
  • 新規に複数の項目を挿入した後、画面更新を行うと、項目タグ名(NewItem)が重複してしまうため、挿入した項目が１つしか表示されない件に対応しました。
    また、テーブルタグをフォーム上に配置した後は、テーブルタグに新規に項目タグを挿入できなくなります。
  • フォーム上に複数テーブルでXMLテンプレートを作成後、MagicからXML出力する際に、「テンプレートファイルエラー：タグ名が重複しています。....」のエラーが発生する件に対応しました。
  • XMLテンプレート出力で、複数フォームでも対応できるようにMagic用TAGにページ番号が付加されるようになりました。
    （例）(!$MG_会社名)　→　(!$MG_1_会社名)
  • XMLテンプレート出力で、暗黙改ページ（ページ番号X.X）は出力しないようにしました。
  • XMLテンプレート出力で、LF（0x0a)、半角スペース(0x20）が入るようになりました。CR（0x0d）は含まれません。
  • データ項目の表示順番を↑↓で変更してもフォームファイルに格納されるようになりました。
  • フォームに割りついていないデータ項目も、フォームファイルに格納できるようになりました。
  • フォーム上でデータ項目を削除した場合、フォーム書き込み時、データ項目ウインドウの表示時に、データ項目ウインドウから削除するか確認するダイアログを表示するようになりました。
  • データ項目ウインドウからデータ項目をドラッグ&ドロップしフォームに貼り付けた場合、グリッド位置にドロップされない件に対応しました。

その他

  • 帳票設定－「データファイルのパス」は、サポートされなくなりました。
  • テーブル属性の「同じデータが続くときに横線省略」 は、サポートされなくなりました。
  • テーブルは、文字列検索・文字列置換の対象になりません。
  • ファイル-最近使ったファイルは、RMDesignerを一旦終了するとクリアされる件に対応しました。
  • RMViewer.DLLのエラー番号を3桁に統一しました。
    -61702　→　-321 印刷ｼﾞｮﾌﾞを開始できませんでした。
  • バーコード出力時にエラーが発生した場合は、「バーコードエラー：エラー番号」と出力されるようになりました。

RMViewer

  • フォーム「帳票設定」で指定したプリンタ名が32バイトよりも長い場合、設定された用紙サイズがビューアに反映されず、使用するプリンタのデフォルト用紙サイズになる件に対応しました。
  • RMViewer　EXE版にて、フォームに貼り付けたオブジェクトをプレビューして印刷すると貼り付けたオブジェクトが印刷されない場合がある件に対応しました。
  • RMViewer　ActiveX版で、メソッドのオブジェクト一覧で基準中心表示は、ZoomTopよりZoomBaseに変更になりました。ZoomTopでも動作しますが、極力ZoomBaseに変更してください。
  • ActiveX版の場合、 ホイールマウスが動作しない件に対応しました。


ReportsMagic Ver1.0B 修正履歴

V1.0Bの新機能

イメージ
  • イメージをデータ項目として使用する場合、イメージ形式としてJPEGに対応しました。

RMViewer

各種コマンドパラメータが拡張されました。

  • 印刷中表示画面の表示・非表示の指定(コマンドパラメータ指定)
    /status=[y/n]
    y:表示（デフォｒント）
    N:非表示
  • 印刷部数の指定(コマンドパラメータ指定)
    /copy=[部数]

RMViewer起動用DLL

  • Ver1.0～Ver1.0A RMViewer実行関数(ExecuteO)
      構文……定義式：RMViewer.ExecuteO
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （’y’ または ‘n’で指定）
      ⑥ウェイトを指定します。（文字型） （’y’ または ‘n’で指定）
      ⑦実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑧エラーメッセージ（文字型）

  • Ver1.0B RMViewer実行関数(Execute)　　　　　　　 ＜Ver1.0Bで拡張された定義式＞
      構文……定義式：RMViewer.Execute
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型） ※Ver1.0Bで追加されたパラメータ
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示） ※Ver1.0Bで追加されたパラメータ
      ⑨実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑩エラーメッセージ（文字型）

Ver1.0B RMViewer起動パラメータの機能拡張に伴い、RMViewer起動用DLLのパラメータも拡張されました。これにより、V1.0～V1.0AでRMViewer実行関数(Execute)を使用したMagicアプリケーションは、コールユーザPRC実行後に「ユーザー関数、またはユーザープロシジャの引数の数が合っていません。」のエラーが発生 するようになります。
  その場合は、Magicアプリケーションの定義式RMViewer.ExecuteをRMViewer.ExecuteOに変更します。テキスト検索、テキスト置換を使用すると容易に移行することが可能です。
  Magicアプリケーションを変更せずに使用したい場合は、Ver1.0～Ver1.0A用のRMViewer起動用DLLを使用することにより可能です。ただし、拡張された機能を使用することが出来ません。今後の拡張にも対応することが出来なくなる為、移行することをお奨めいたします。
今後パラメータ仕様が変更（拡張）される場合は、定義名の追加等により、Magicアプリケーションの互換性が維持できるように考慮いたします。

RMViererCtrl(ActiveX）

  • プリンタ名をパラメータで指定
    CallCom
    プロパティ：PrinterName
    パラメータ値：[プリンタ名]

    HTMLでの指定：
    <param name="PrinterName" value="[プリンタ名]"

  • 印刷部数を指定する
    CallCom
    プロパティ：Copy
    パラメータ値：[部数(文字列)]

    HTMLでの指定：
    <param name="Copy" value="[部数]"

  • ページ指定の対応
    CallCom
    プロパティ：PageSelect
    パラメータ値：なし

V1.0Bの改善・変更内容

RMDesigner

  • カウントアップ複写を行った場合、項目名、項目タグがカウントアップされない件に対応しました。
  • テスト表示で複数ページ表示した場合、先頭ページ/最終ページのボタンがアクティブにならない件に対応しました。
  • 文字列で塗りつぶしを指定した場合は、文字枠全体を塗りつぶすようになりました。
  • テーブルで背景色を指定したとき、無条件に横罫線が出力される件に対応しました。

データ連携

  • dbFORM形式で、項目の「テキストの折り返し」が有効にならない件に対応しました。
    「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
    「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

    dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。
    従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。
  • dbFORM形式で全タグに差込データを設定していない状態で「ＦＦ」で出力した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • XML形式で全タグに差込データを設定していない状態で明示的改ページを実施した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • CSV形式で、Key指定が無い場合には、1レコードが1ページと認識できずに、最後のレコードのみが出力される件に対応しました。

データ項目ウインドウ

  • データ項目ウインドウで一旦項目を削除すると、再びデータを読み込んでも再定義されない件に対応しました。

その他

  • 文字列属性の「テキストの長さに合わせてフォントサイズを調節」は、「縮小して全体を出力」に変更されました。
    従来は、表示領域に格納できる最大フォントサイズを計算して表示していましたが、指定されたフォントサイズ、文字ピッチで表示領域に出力できない場合のみ、フォントサイズ 、文字ピッチを小さくして全体を 出力するようになりました。
    複数行はサポートしていません。「テキストの折りかえし」を指定しても無視されます。
  • フォームを上書き保存をするとファイルサイズが２倍近く大きくなる件に対応しました。
  • シュートカットが変更されました。詳細は、参考技術情報を参照してください。

RMViewer

  • 複数ページを表示した場合、先頭ページ/最終ページ/指定ページが有効にならない件に対応しました。
  • 複数ページを表示した状態で印刷を実行すると常に最終ページが表示されていましたが、印刷を開始したページが表示されるようになりました。
  • フォーム「帳票設定」で指定した用紙サイズや給紙方法が反映されない場合がある件に対応しました。


ReportsMagic Ver1.0A 修正履歴

V1.0Aの改善・変更内容

dbFORM

  • dbFORMフォームの読込で、項目にアンダーバーが付く件に対応しました。
  • dbFORMフォームの読込で、横倍角に対応しました。
  • dbFORM形式でイメージデータが表示されない件に対応しました。
    文字列／データ項目名の最後の文字を I にします。　例：％％１７－４Ｉ

データ連携

  • CSV形式で、印刷データにシングルバイトの"が含まれると正しくデータ認識できない件に対応しました。
    シングルバイトの"を含めたい場合は、""と表現します。
  • XML形式で、印刷データに、シングルバイトの"や、&quot;が含まれると正しくデータ認識できない件に対応しました。

その他

  • 「テスト実行」を行うと、フォームの項目名が実データに更新される場合がある件に対応しました。
  • スタティック（固定）文字列は、枠を表示をしないようにしました。
  • バーコードのデータが不正な場合は、「バーコードエラー」と表示するようになりました。
  • 文字列でテキストに下線を指定した場合、スペース部分は下線が引かれない件に対応しました。

RMViewer

  • フォームファイルをオープンし印刷データ取り込み前は、項目データが項目タグ名や、サンプルが表示されている件に対応しました。


ReportsMagic Ver1.0B Beta1 追加情報

制限事項及び留意事項

イメージ

  • スタティックなイメージ読み込みは、イメージ形式によっては実際のイメージと異なる表示になる場合があります。
  • イメージをデータ項目として使用する場合、サポートしているイメージ形式は以下の種類です。
    BMP、PNG、JPEG
  • イメージのデータ項目の場合、イメージデータのサイズ比率を維持したままで、コントロール上に収まるように拡大/縮小します。

印刷

  • Windowsのプリンタドライバを使用しての印刷のみをサポートしています。

dbFORM

  • dbFORMのフォームを読み込んだ場合、若干フォームイメージが異なる場合があります。
  • 文字単位のフォント指定、属性指定は、できません。
  • 文字の囲み、傍点、袋文字、影付き、立体、下付、上付はサポートされていません。
  • 縦書きの場合、１バイト文字は縦書きになりません。

データ連携

  • テーブルの連結には、対応していません。

データ項目ウインドウ

  • データ項目ウインドウを表示している状態で、フォーム上のデータ項目を削除しても、データ項目ウインドウには反映されません。その場合は、データ項目ウインドウの再表示を実行してください。
  • フォームに割り付けたデータ項目のプロパティを開いて項目名を変更した場合、新規に変更した項目が追加されます。 以前のデータ項目は、データ項目削除ダイアログで削除することができます。

その他

  • 使用できる文字コードは、シフトJISのみです。
  • 外字を使用する場合は、実行するPCに事前に外字を登録しておく必要があります。
  • 文字列を固定幅フォント－文字ピッチ０の状態で使用すると、解像度の異なるコンピュータで表示イメージが異なる場合があります。その場合は、文字ピッチを指定するようにしてください。
  • 縦文字を指定した場合、フォントは@が付いた縦書き用フォントを選択してください。縦書用フォントで無い場合は@MSゴシックを使用します。
  • テーブルをネストして使用することは出来ません。
  • フォーム作成時に稀に画面にゴミが表示される場合があります。　その場合は。再表示(Ｆ５）を行ってください。

RMViewer

  • RMViewer（ActiveX)をMagicのバッチタスクで印刷することは出来ません。バッチタスクで印刷する場合は、RMViewer（EXE)を使用してください。


ReportsMagic 参考技術情報

参考技術情報

ここでは、ReportsMagic についての参考技術情報を紹介します。

  • RMViewer C/S版とWeb版のアクセス
  • ショートカットキー一覧
  • 「帳票設定」で指定した用紙サイズ、給紙方法や部数の対応
  • RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について
  • 文字列の出力可能範囲について
  • XML形式で文字列の前に半角スペースは有効にならない
  • 「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」
  • データ連携－データ形式の違い

RMViewer C/S版とWeb版のアクセス

RMViewer C/S版とWeb版は、フォームファイル、印刷データファイルに対するアクセス方法が異なります。
C/S版の場合は、ファイルパス指定、Web版の場合は、httpでの指定になります。

  • RMViewer C/S
種類 | 起動例
RMViewer.exe | RMViewer.exe /rfr=sample.rfr /rdata=sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\sample.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>
  • RMViewer Web
種類 起動例
RMViewer.exe RMViewer.exe /rfr=http://localhost/ReportsMagic/sample.rfr
/rdata=http://localhost/ReportsMagic/sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="http://localhost/ReportsMagic/sample.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>

ショートカットキー一覧
RMDesigner

分類 | 動作 | ショートカットキー
ファイル | 新規作成 | Ctrl + N
 | 開く | Ctrl + O
 | 閉じる | Ctrl + W
 | 上書き保存 | Ctrl + S
 | 名前を付けて保存 | Ctrl + Shift + S
 | ﾌﾟﾘﾝﾀの設定 | Ctrl + Shift + P
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
編集 | 元に戻す | Ctrl + Z
 | 切り取り | Ctrl + X
 | ｺﾋﾟｰ | Ctrl + C
 | 貼り付け | Ctrl + V
 | 消去 | Del
 | すべて選択 | Ctrl + A
 | 文字列検索 | Ctrl + F
 | 文字列置換 | Ctrl + H
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 指定ページ | Alt + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ｳｨﾝﾄﾞｳ | 並べて表示 | Ctrl + Shift + K
 | 重ねて表示 | Ctrl + Shift + J
ﾍﾙﾌﾟ | RMDesignerのヘルプ | F1

RMViewer

分類 | 動作 | ショートカットキー
ファイル | 開く | Ctrl + O
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 幅に合わせる | Ctrl + 2
 | 全画面表示 | Ctrl + 3
 | 指定ページ | Ctrl + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ﾍﾙﾌﾟ | RMViewerのヘルプ | F1

RMViewer ActiveX版（RMViewerCtrl.ocx）では、ショートカットキーは対応していません。

「帳票設定」で指定した用紙サイズ、給紙方法や部数の対応

RMDesignerの「帳票設定」で指定した用紙サイズや給紙方法は、RMViewerで以下の様に対応しています。
デバイスモードのコピーは、フォーム上に登録しているプリンタと一致するプリンタがある場合のみ行います。

  • 用紙サイズ：
    フォーム上に登録しているプリンタと一致するプリンタがある場合には、フォームの用紙サイズに設定します。
    一致するプリンタがない場合には、もっとも近い用紙サイズにします。
  • 用紙方向：
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
  • 給紙方法：
    フォーム上に登録しているプリンタと一致するプリンタがある場合のみ反映します。
    一致するプリンタが無い場合には、デフォルトの給紙方法にしています。
  • 部数
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
    プリンタ毎に部数の制限があります。この場合は、プリンタの仕様ににより部数が設定されます。

RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について

RMViewer ActiveX版（RMViewerCtrl.ocx）を使用するには、事前に使用するPCのシステムにActiveX登録を行う必要があります。

●RMDesignerの場合
RMDesignerには、RMViewerの体験版が添付されていますが、ライセンス登録プログラム（RMLicense.exe ）を実施してもActiveXは登録されません。
インストールしたフォルダ上のバッチファイルにより、登録、及び解除を行うことが出来ます。

Addregsvr32.bat | RMViewerCtrl.ocxの登録を行います。
DELregsvr32.bat | RMViewerCtrl.ocxの登録を解除します。

●RMViewerの場合

ライセンス登録プログラム（RMLicense.exe ）によりライセンスの登録を行うことにより、ActiveXを登録します。
すでにシステムに登録済みの場合、確認のダイアログが表示されます。

  • RMViewerを、複数PCにインストールしている場合は、登録を実行したPCのRMViewer.exe、RMViewerCtrl.ocx をコピーし、 上記のバッチプログラムを使用することにより登録、または更新することが可能です。　更新の場合は、　DELregsvr32.bat、Addregsvr32.batを実行 します。

●ブラウザ－ActiveXの自動ダウンロード

HTMLファイルに以下の記述を追加すること自動ダウンロードを行うことが可能です。

<html>
<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/RMViewerCtrl.ocx#version=1,0,0,1"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\RMdata\\EmpfamilyXml.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\RMdata\\EmpfamilyMagic.xml">
<param name="ToolBar" value="on">
</object>
</html>

文字列の出力可能範囲について

V1.0Bより文字列の出力可能範囲が厳密に制御されるようになりました。
文字列枠は、内部余白により制御されており、出力する文字列が文字列枠の範囲を超えた文字は、出力されません。

dbFORM形式は、項目の「テキストの折り返し」により出力方式が異なります。
「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。

XML形式で文字列の前に半角スペースは有効にならない

XML形式で文字列で文字列の前に半角スペースを入れると無視される場合があります。
これは、XMLの仕様で前後の半角スペースは、取り除かれる為です。
（例）　<value>△△ＡＢＣＤＥＦ△△</value>　→　ＡＢＣＤＥＦ　　△は、半角スペース

これを回避するには、XMLに以下を追加します。

<ReportsMagic version="1.0" xml:space="preserve">

後ろの半角スペースを有効にしたい場合は、書式を未設定（空白）にします。（V1.0X互換）

「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」

ブラウザ上でRMViewerを使用した場合、表示される場合があります。

これはWindows XPのサービスパック2（SP2）のセキュリティ強化に伴って表示されるようになったメッセージでWebページからユーザのコンピュータ上のスクリプトやActiveXコントロールが実行されようとしたときに表示されます。

情報バーをクリックして、ブロックされているコンテンツを許可することは可能ですが、表示するたびに入力が必要になります。以下の操作をすることで、確認画面が表示されなくなります。

▼操作手順
メニュー［ツール］－［インターネットオプション］をクリック
  ↓
［インターネットオプション］ダイアログ－［詳細設定］タブをクリック
  ↓
［設定］－［セキュリティ］欄の、
［マイコンピュータのファイルでのアクティブコンテンツの実行を許可する］チェックをOnにする
  ↓
［インターネットオプション］ダイアログ－［OK］ボタンをクリック

データ連携－データ形式の違い

 | dbFORM | CSV | ヘッダー付き CSV | XML
TAG名ルール | %%数字２階層まで | %%数字 | 任意 | 任意
テーブル | なし テーブル構造の認識は無い | １個 | １個 | 複数可能 （ネストはできません）
明示的改ページ | データ内で指定 （ＦＦ） | キー指定 | キー指定 | データ内で指定
暗黙的改ページ | × | ○ キー指定が無い場合は、１レコード毎に改ページ | ○ キー指定が無い場合は、１レコード毎に改ページ | ○
マルチフォーム ※1 | × | △ 暗黙的改ページの場合のみ可能 | △ 暗黙的改ページの場合のみ可能 | ○ データ内で指定 （XML フォーム番号）
マージテンプレート作成支援 | × | × | × | ○
備考 | dbFORMの互換機能を重視した形式です。 今後の拡張予定はありません。ヘッダー付きCSV、XML形式への移行をお奨めいたします。 | データ格納率が高いため、大量印刷の場合に有利です。 | データ格納率が高いため、大量印刷の場合に有利です。 CSV形式に比べて、TAG名を自由に管理できるため、メンテナンス性は向上します。 | マルチフォームをサポートした最も高度なフォーム形式です。 ReportsMagicのデフォルトのフォーム形式です。 CSV形式に比べるとデータ量が大きくなる傾向があります。
  • ※１：ひとつの帳票データで複数のフォームを使用する形態。例えば、１ページ目は納品書、２ページ目は請求書、３ページ目は納品受領書のような形態。


ベータ版評価レポートのお願い

ベータ機能－評価レポートのお願い

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外です。
又、ご意見、ご質問、気が付いた点などは、下記の「ベータ評価レポート」に記入して、メールで japan_v9beta@magicsoftware.com までお送りください。
お送りいただいたレポートは、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

ReportsMagic V1.1 ベータ機能評価レポート

記入日： ２００５年　　 月　 日
会社名：
担当者：
E-mail：
ＴＥＬ：
ＦＡＸ：
サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境
ＰＣ機種：
ＣＰＵ：
ＲＡＭ：
ＯＳ： （ ）Windows98／（ ）Windows2000（SP： ）／（ ）WindowsXP／（ ）Windows2003
ＩＭＥ：
ビデオカード：
使用ブラウザ：（ ）IE5.5 （SP： )、　（ ） IE6（SP： ）

２．不具合の場合

不具合を確認した場合は、こちらに記入してください。 該当する（ ）に＊を挿入してください。

Ａ （ ） 一部支障あり
Ｂ （ ） 正常に動作しない
Ｃ （ ） インストール・起動不可

２．１．再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

２．２．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なう
ために、極力画面のハードコピー、フォームデータ、サンプルプログラム等の提供をお願い
いた します。）

３．要望事項
機能追加、改善要望等がありましたら、こちらに記入してください。
 （できるだけ詳細にお書きください。）

４．その他ご意見

以上


Magic Software Japan K.K - Magic eDeveloper Plus Ver9.40J SP1 ベータ版 （Windows版）

ReportsMagic 使用許諾契約書

本ソフトウェアモジュールを利用するにあたっては、下記の事項を良く理解し、合意した上でご利用ください。万一合意できない場合には、本ソフトウェアモジュールをご利用になることはできません。

マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）とお客様（以下「お客様」という）は、「ReportsMagic ベータ版」としてMSJ社より提供されるソフトウェア・プログラム（以下「許諾プログラム」という）及びドキュメント（マニュアルなど）について以下の通り合意しました。

1. | 総則
   許諾プログラムに関する全ての著作権は、Magic Software Enterprises社、ＭＳＪまたは許諾プログラムに関して正当な権限を有する第三者が保有しています。 ＭＳＪはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的な使用権を付与します。
2. | 契約期間
   本契約は、お客様が許諾プログラムを取得した時から発効し、または第７条の規定により解約されるまで有効とします。
3. | 使用権
   (1)使用権の内容はお客様が購入又は入手された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守して下さい。
・RMDesignerの場合
お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－C/Sの場合
お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－Webの場合
お客様は、許諾プログラムを機械読取可能な形で、Webサーバ単位で使用することができます。
・体験版の場合
お客様は、試用目的でだけ許諾プログラムを使用することができます。許諾プログラム、及び許諾プログラムを利用して開発したモジュールを営利目的に使用することはできません。
(2)お客様は、ＭＳＪの書面による同意を得なければ、使用権を第三者に対して譲渡、移転、または再使用権の設定を行うことはできません。このパッケージの同封物の一部もしくは全部、並びに許諾プログラムの内容の一部もしくは全部を第三者に譲渡または移転してはなりません。
(3)お客様は、許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルしないことに同意します。
4. | ＭＳＪの保証の範囲
   (1)ＭＳＪは、許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。
(2)ＭＳＪは、お客様の許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。
5. | ソフトウェア・メンテナンスについて
   各プログラム使用権にはソフトウェア・メンテナンスが含まれています。許諾プログラムの使用権に含まれるソフトウェア・メンテナンスは、ＭＳＪ より提供され、「ReportsMagicソフトウェア・メンテナンス」といいます。
ReportsMagic ソフトウェア・メンテナンスは、効力発生日に開始し、１年後の同月末日に終了します。ただし、効力発生日が月の第1日目の場合は、取得日から１年後の前月末日に終了します。
許諾プログラム使用権に対するReportsMagicソフトウェア・メンテナンスの有効期間においては、
①ＭＳＪはお客様に対して、ご契約された全てのプログラムの一般的に入手可能な最新バージョンもしくはアップデートモジュールを提供し、その使用を許諾します。ただし、これらが提供された場合に限ります。
②ＭＳＪはお客様に対して以下のサポートを提供します。
ⅰ)導入や使用方法に関する日常的、かつ短時間の質問に対する応答
ⅱ)プログラム・コードに起因する障害に対するサポート
③ＭＳＪはMagicサポートセンターのサービス提供時間中に、電子アクセス（使用可能な場合）または電話を介して、お客様の情報システム部門のテクニカル・サポート担当者にのみサポートを提供します。マジックソリューションパートナー（MSP）経由で購入したお客様は、MSP経由での対応となります。
④ReportsMagicソフトウェア・メンテナンスには以下のサポートは含まれません。
ⅰ)アプリケーションの設計と開発に対するサポート
ⅱ)プログラムの指定稼動環境以外の環境における当該プログラムの使用に関するサポート
ⅲ)本契約書の下でMSJが責任を負わない製品に起因する障害に対するサポート
上記は、ReportsMagicソフトウェア・メンテナンスについての保証のすべてを規定したもので、法律上の瑕疵担保責任、商品性の保証および特定目的適合性の保証を含む全ての明示もしくは黙示の保証責任、または保証条件に代わるものとします
(2) 一年毎のソフトウェア・メンテナンスの更新
「ソフトウェア・メンテナンス更新日」とは、本契約書の効力発生日から1年後の翌月第1日目をいいます。ただし、効力発生日が月の第１日目である場合には、１年後の同日が最初の「ソフトウェア・メンテナンス更新日」になります。お客様は追加料金を支払うことにより期間満了となるソフトウェア・メンテナンスを継続することができます｡この時、ソフトウェア・メンテナンス更新日も自動的に１年延長されます。お客様が、かかる継続を希望する場合には、(1) MSJが、お客様からの継続の注文(注文書等) を現行の有効期間満了日より前までに受領すること、また(2) 次に続く有効期間分のソフトウェア・メンテナンスの請求書受領日より30 日以内に支払いを行うことが必要です。お客様が、プログラム使用権のうち、すべてあるいは特定のものについてソフトウェア・メンテナンスの継続を行わず、後日、かかるプログラム使用権のいずれかについてソフトウェア・メンテナンスの取得を希望する場合には、お客様は、未契約期間の費用を支払うことにより継続することが可能です。
ＭＳＪが、必要に応じ、特定のプログラムに対してソフトウェア・メンテナンスの提供を中止した場合は、お客様は以下のことについて了解するものとします。
1) ＭＳＪは、当該プログラムに対してはソフトウェア・メンテナンスの更新を提供しません。
2) 上記中止のお知らせの前にお客様がそのプログラム使用権のソフトウェア・メンテナンスを更新した場合には、ＭＳＪは、自らの裁量により、更新済み契約の終了まで、当該プログラム使用権についてソフトウェア・メンテナンスをお客様に対して継続して提供するか、またはお客様に対して月割り計算した料金を返金します。
6. | 契約の解約
   ＭＳＪは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。
7. | 契約終了時の措置
   本契約が第6条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。
8. | 一般条項
   本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。
9. | 裁判管轄
   本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


ReportsMagic Ver1.0A 修正履歴

CHM ファイルのトピックが表示できない問題

セキュリティ更新プログラム のインストール後、 ダウンロードしたCHMファイルのトピックが表示できない場合があります。
（注意：このページも表示できなくなります。）

対応方法

  • 方法①： ネットワーク共有フォルダにある場合は、ローカルコンピュータにコピーする。共有フォルダで使用したい場合は、方法④を実施する。
  • 方法②： CHMファイルを開くときに、「セキュリティファイルの警告」が出る場合は、「この種類のファイルであれば常に警告する」のチェックを外す。
  • 方法③： CHMファイルのプロパティで、「ブロックの解除」が表示されている場合は、ボタンを押す。
  • 方法④： レジストリエントリを修正する。　HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions　を開く。
    DWORD値でMaxAllowedZone を作成し値のデータを「１」にする。
    値は、0～４の範囲があり、数が大きいほどセキュリティが緩くなります。
    警告     : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。セキュリティに関しても自己責任で行ってください。

参考情報

  • セキュリティ更新プログラム MS05-026 またはセキュリティ更新プログラム MS05-001 のインストール後、一部の Web サイトで特定の HTML ヘルプ機能を使用できなくなることがある
    http://support.microsoft.com/default.aspx?scid=kb;ja;892675
  • セキュリティ更新プログラム 896358 のインストール後、ダウンロードした CHM ファイルを開けない http://support.microsoft.com/default.aspx?scid=kb;ja;902225
  • Windows Server 2003 Service Pack 1、セキュリティ更新プログラム MS05-026 または MS04-023 のインストール後、InfoTech プロトコルを使用する一部の Web アプリケーションが使用できなくなる
    http://support.microsoft.com/default.aspx?scid=kb;ja;896054