ReportsMagic Ver1.0B 追加情報

マジックソフトウェア・ジャパン
株式会社２００５年６月

ReportsMagic Version1.0B 追加情報

本文書には､ReportsMagic として提供されたプログラム に関して、マニュアルの記載事項以外の追加情報が記述されています。

  • 本バージョンのご利用にあたって
  • 動作環境
  • サンプルフォーム、アプリケーション
  • 修正履歴
  • 制限事項及び留意事項
  • 参考技術情報
  • ベータ版評価レポートのお願い
  • 使用許諾契約

本バージョンのご利用にあたって

ベータ版、体験版をご利用になったお客様に

ベータ版、体験版から製品版に移行する場合には、以下の点にご留意ください。

  • 本製品版をインストールするにあたりましては、ベータ版、体験版のモジュールが残って思わぬ悪影響を与えることを避けるため、ベータ版、体験版のアンインストールを行い、ファイル等の設定を完全に削除してください。
  • ベータ版、体験版で作成したフォームデータは、製品版で使用することはできません。

RMViewer（ActiveX)のアップデート

メンテナンス処理、アップグレード処理で RMViewer（ActiveX)の再登録を実行した場合、「RMViewer体験版のご案内」、「RMViewerCtl.ocx の DllRegisterServerは成功しました」等のダイアログが表示される場合があります。その場合は、Enterを入力してそのまま継続してください。

ベータ機能／ご意見、要望事項について

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外となります。又、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールにて japan_v9beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

動作環境及

  • RMDesigner

    Windows 2000／XP／2003
  • RMViewer

    Windows | 98 SE／2000／XP／2003
    ブラウザ | Internet Explorer 5.5 SP2以上
    Magic（ActiveX)組込み | V9Plus
    Magic　exe起動 | V8、V9、V9Plus

サンプルフォーム、アプリケーション

RMDesignerのインストール時にサンプルプログラムのインストール選択している場合は、サンプルフォーム、及びMagicアプリケーションがインストールされます。

RMDesigner での確認

  • RMDesigner で RMDesigner\Sample\RMdata上の各フォームを開き、ツール／テストでサンプルデータを選択します。
サンプルフォーム | フォーム名 | サンプルデータ | 備考
家族構成 （マルチデータフォーム） | EmpfamilyCsv.rfr | EmpfamilyCsv.csv | CSV形式
 | EmpfamilyCsvhead.rfr | EmpfamilyCsvhead.csv | CSVヘッダー付き形式
 | EmpfamilydbFORM.rfr | EmpfamilydbForm.dat | dbFORM形式
 | EmpfamilyXml.rfr | Empfamily.xml | XML形式
勘定科目名 （dbFORM） | HIKAKU.ｒｆｒ | HIKAKU.dat | dbFORMのフォームを読み込んで作成したものです。
 | HIKAKU.FRM | HIKAKU.dat | オリジナルのdbFORMのフォームです。新規フォームを作成し、「ファイル／dbFORM読み込み 」で 読み込むことができます。その後、「ツール／帳票設定」のデータ形式をdbFORM形式にして、確認します。
複合文書 | Fukugo.rfr | Fukugo.xml | 納品書、請求書、納品受領書の複合文書です。
バーコード | バーコード.rfr | バーコード.xml | バーコードの一覧表です。
イメージ | イメージ.rfr | イメージ.xml | イメージ処理のサンプルです。
複数ページ | Fukusu.rfr | Fukusu.xml | 暗黙の改ページのサンプルです。

RMViewerでの確認

  • RMDesigner－サンプルのメニューをクリックして起動してください。
メニュー | サンプルフォーム | 起動方法
家族構成.HTML | 家族構成 | ブラウザ起動
家族構成 | 家族構成 | RMViewer.exe起動
複合文書.HTML | 複合文書 | ブラウザ起動
複合文書 | 複合文書 | RMViewer.exe起動
複数ページ.HTML | 複数ページ | ブラウザ起動
複数ページ | 複数ページ | RMViewer.exe起動

RMDesignerで添付しているRMViewerは体験版です。

HTMLの場合、フォーム、印刷データのパスをドライブ指定で記述していますが、URLに変更することも可能です。

●例
<param name="RfrFile" value="http://localhost/ReportsMagic/EmpfamilyXml.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/Empfamily.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　　　←プリンタ名を指定したい場合
<param name="Copy" value="3">　　　　　　　　　　　　 ←印刷部数を指定したい場合

Magicと連携したサンプル

家族構成のXMLフォーム（EmpfamilyXml.rfr）を使用したサンプルアプリケーションです。
RMDesigner－サンプルの「Magic起動」のメニューをクリックして起動してください。
プログラムリポジトリの「ReportsMagic サンプル-メイン」をＦ７で実行してください。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
Magic Viewer ActiveX | Magicから ActiveX 呼び出しで、RMViewerを実行します。
Magic Viewer EXE | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。
HTML Viewer | ブラウザから、RMViewerを実行します。 表示用のHTML（家族構成.htm）を生成し、オープンします。


ReportsMagic Ver1.0B 修正履歴

V1.0Bの新機能

イメージ
  • イメージをデータ項目として使用する場合、イメージ形式としてJPEGに対応しました。

RMViewer

各種コマンドパラメータが拡張されました。

  • 印刷中表示画面の表示・非表示の指定(コマンドパラメータ指定)
    /status=[y/n]
    y:表示（デフォｒント）
    N:非表示
  • 印刷部数の指定(コマンドパラメータ指定)
    /copy=[部数]

RMViererCtrl(ActiveX）

  • プリンタ名をパラメータで指定
    CallCom
    プロパティ：PrinterName
    パラメータ値：[プリンタ名]

    HTMLでの指定：
    <param name="PrinterName" value="[プリンタ名]"

  • 印刷部数を指定する
    CallCom
    プロパティ：Copy
    パラメータ値：[部数(文字列)]

    HTMLでの指定：
    <param name="Copy" value="[部数]"

  • ページ指定の対応
    CallCom
    プロパティ：PageSelect
    パラメータ値：なし

V1.0Bの改善・変更内容

RMDesigner

  • カウントアップ複写を行った場合、項目名、項目タグがカウントアップされない件に対応しました。
  • テスト表示で複数ページ表示した場合、先頭ページ/最終ページのボタンがアクティブにならない件に対応しました。
  • 文字列で塗りつぶしを指定した場合は、文字枠全体を塗りつぶすようになりました。
  • テーブルで背景色を指定したとき、無条件に横罫線が出力される件に対応しました。

データ連携

  • dbFORM形式で、項目の「テキストの折り返し」が有効にならない件に対応しました。
    「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
    「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

    dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。
    従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。
  • dbFORM形式で全タグに差込データを設定していない状態で「ＦＦ」で出力した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • XML形式で全タグに差込データを設定していない状態で明示的改ページを実施した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • CSV形式で、Key指定が無い場合には、1レコードが1ページと認識できずに、最後のレコードのみが出力される件に対応しました。

データ項目ウインドウ

  • データ項目ウインドウで一旦項目を削除すると、再びデータを読み込んでも再定義されない件に対応しました。

その他

  • 文字列属性の「テキストの長さに合わせてフォントサイズを調節」は、「縮小して全体を出力」に変更されました。
    従来は、表示領域に格納できる最大フォントサイズを計算して表示していましたが、指定されたフォントサイズ、文字ピッチで表示領域に出力できない場合のみ、フォントサイズ 、文字ピッチを小さくして全体を 出力するようになりました。
    複数行はサポートしていません。「テキストの折りかえし」を指定しても無視されます。
  • フォームを上書き保存をするとファイルサイズが２倍近く大きくなる件に対応しました。
  • シュートカットが変更されました。詳細は、参考技術情報を参照してください。

RMViewer

  • 複数ページを表示した場合、先頭ページ/最終ページ/指定ページが有効にならない件に対応しました。
  • 複数ページを表示した状態で印刷を実行すると常に最終ページが表示されていましたが、印刷を開始したページが表示されるようになりました。
  • フォーム「帳票設定」で指定した用紙サイズや給紙方法が反映されない場合がある件に対応しました。


ReportsMagic Ver1.0A 修正履歴

V1.0Aの改善・変更内容

dbFORM

  • dbFORMフォームの読込で、項目にアンダーバーが付く件に対応しました。
  • dbFORMフォームの読込で、横倍角に対応しました。
  • dbFORM形式でイメージデータが表示されない件に対応しました。
    文字列／データ項目名の最後の文字を I にします。　例：％％１７－４Ｉ

データ連携

  • CSV形式で、印刷データにシングルバイトの"が含まれると正しくデータ認識できない件に対応しました。
    シングルバイトの"を含めたい場合は、""と表現します。
  • XML形式で、印刷データに、シングルバイトの"や、&quot;が含まれると正しくデータ認識できない件に対応しました。

その他

  • 「テスト実行」を行うと、フォームの項目名が実データに更新される場合がある件に対応しました。
  • スタテック（固定）文字列は、枠を表示をしないようにしました。
  • バーコードのデータが不正な場合は、「バーコードエラー」と表示するようになりました。
  • 文字列でテキストに下線を指定した場合、スペース部分は下線が引かれない件に対応しました。

RMViewer

  • フォームファイルをオープンし印刷データ取り込み前は、項目データが項目タグ名や、サンプルが表示されている件に対応しました。


ReportsMagic Ver1.0B Beta1 追加情報

制限事項及び留意事項

イメージ

  • スタティクなイメージ読み込みは、イメージ形式によっては実際のイメージと異なる表示になる場合があります。
  • イメージをデータ項目として使用する場合、サポートしているイメージ形式は以下の種類です。
    BMP、PNG、JPEG
  • イメージのデータ項目の場合、イメージデータのサイズ比率を維持したままで、コントロール上に収まるように拡大/縮小します。

印刷

  • Windowsのプリンタドライバを使用しての印刷のみをサポートしています。

dbFORM

  • dbFORMのフォームを読み込んだ場合、若干フォームイメージが異なる場合があります。
  • 文字単位のフォント指定、属性指定は、できません。
  • 文字の囲み、傍点、袋文字、影付き、立体、下付、上付はサポートされていません。
  • 縦書きの場合、１バイト文字は縦書きになりません。

データ連携

  • 項目書式は将来の拡張のために用意されているもので、現在は未使用です。使用しないでください。
  • データ項目の文字枠連結には、対応していません。

データ項目ウインドウ

  • データ項目ウインドウを表示している状態で、フォーム上のデータ項目を削除しても、データ項目ウインドウには反映されません。その場合は、データ項目ウインドウの再表示を実行してください。
  • データ項目ウインドウにデータ項目が存在してもフォームに割りついていない項目は、フォームを格納しても保存されません。
  • フォームに割り付けたデータ項目のプロパティを開いて項目TAGを変更した場合、以前のデータ項目は残り、新規に変更した項目が追加されます。

その他

  • 使用できる文字コードは、シフトJISのみです。
  • 外字を使用する場合は、実行するPCに事前に外字を登録しておく必要があります。
  • 文字列を固定幅フォント－文字ピッチ０の状態で使用すると、解像度の異なるコンピュータで表示イメージが異なる場合があります。その場合は、文字ピッチを指定するようにしてください。
  • テーブル属性の「同じデータが続くときに横線省略」 は対応していません。
  • 縦文字を指定した場合、フォントは@が付いた縦書き用フォントを選択してください。縦書用フォントで無い場合は@MSゴシックを使用します。
  • グリット設定、レイヤの可視、選択可の情報は、フォームファイルには格納されません。
  • テーブルをネストして使用することは出来ません。

RMViewer

  • RMViewer（ActiveX)をMagicのバッチタスクで印刷することは出来ません。バッチタスクで印刷する場合は、RMViewer（EXE)を使用してください。


ReportsMagic 参考技術情報

参考技術情報

ここでは、ReportsMagic についての参考技術情報を紹介します。

  • RMViewer C/S版とWeb版のアクセス
  • ショートカットキー一覧
  • 「帳票設定」で指定した用紙サイズや給紙方法の対応
  • RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について
  • 文字列の出力可能範囲について
  • 「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」
  • データ連携－データ形式の違い

RMViewer C/S版とWeb版のアクセス

RMViewer C/S版とWeb版は、フォームファイル、印刷データファイルに対するアクセス方法が異なります。
C/S版の場合は、ファイルパス指定、Web版の場合は、httpでの指定になります。

  • RMViewer C/S
種類 | 起動例
RMViewer.exe | RMViewer.exe /rfr=sample.rfr /rdata=sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\sample.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>
  • RMViewer Web
種類 起動例
RMViewer.exe RMViewer.exe /rfr=http://localhost/ReportsMagic/sample.rfr
/rdata=http://localhost/ReportsMagic/sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="http://localhost/ReportsMagic/sample.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>

ショートカットキー一覧
RMDesigner

分類 | 動作 | ショートカットキー
ファイル | 新規作成 | Ctrl + N
 | 開く | Ctrl + O
 | 閉じる | Ctrl + W
 | 上書き保存 | Ctrl + S
 | 名前を付けて保存 | Ctrl + Shift + S
 | ﾌﾟﾘﾝﾀの設定 | Ctrl + Shift + P
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
編集 | 元に戻す | Ctrl + Z
 | 切り取り | Ctrl + X
 | ｺﾋﾟｰ | Ctrl + C
 | 貼り付け | Ctrl + V
 | 消去 | Del
 | すべて選択 | Ctrl + A
 | 文字列検索 | Ctrl + F
 | 文字列置換 | Ctrl + H
 | ジャンプ－指定ページ | Alt + N
 | ジャンプ－前ページ | Ctrl + ←
 | ジャンプ－次ページ | Ctrl + →
 | ジャンプ－先頭ページ | Ctrl + Shift + PgUp
 | ジャンプ－最終ページ | Ctrl + Shift + PgDn
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
ｳｨﾝﾄﾞｳ | 並べて表示 | Ctrl + Shift + K
 | 重ねて表示 | Ctrl + Shift + J
ﾍﾙﾌﾟ | RMDesignerのヘルプ | F1

RMViewer

分類 | 動作 | ショートカットキー
ファイル | 開く | Ctrl + O
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 指定ページ | Alt + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ﾍﾙﾌﾟ | RMViewerのヘルプ | F1

RMViewer ActiveX版（RMViewerCtrl.ocx）では、ショートカットキーは対応していません。

「帳票設定」で指定した用紙サイズや給紙方法の対応

RMDesignerの「帳票設定」で指定した用紙サイズや給紙方法は、RMViewerで以下の様に対応しています。
デバイスモードのコピーは、フォーム上に登録しているプリンタと一致するプリンタがある場合のみ行います。

  • 用紙サイズ：
    フォーム上に登録しているプリンタと一致するプリンタがある場合には、フォームの用紙サイズに設定します。
    一致するプリンタがない場合には、もっとも近い用紙サイズにします。
  • 用紙方向：
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
  • 給紙方法：
    フォーム上に登録しているプリンタと一致するプリンタがある場合のみ反映します。
    一致するプリンタが無い場合には、デフォルトの給紙方法にしています。

RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について

RMViewer ActiveX版（RMViewerCtrl.ocx）を使用するには、事前に使用するPCのシステムにActiveX登録を行う必要があります。

●RMDesignerの場合
RMDesignerには、RMViewerの体験版が添付されていますが、ライセンス登録プログラム（RMLicense.exe ）を実施してもActiveXは登録されません。
インストールしたフォルダ上のバッチファイルにより、登録、及び解除を行うことが出来ます。

Addregsvr32.bat | RMViewerCtrl.ocxの登録を行います。
DELregsvr32.bat | RMViewerCtrl.ocxの登録を解除します。

●RMViewerの場合

ライセンス登録プログラム（RMLicense.exe ）によりライセンスの登録を行うことにより、ActiveXを登録します。
すでにシステムに登録済みの場合、確認のダイアログが表示されます。

  • RMViewerを、複数PCにインストールしている場合は、登録を実行したPCのRMViewer.exe、RMViewerCtrl.ocx をコピーし、 上記のバッチプログラムを使用することにより登録、または更新することが可能です。　更新の場合は、　DELregsvr32.bat、Addregsvr32.batを実行 します。

●ブラウザ－ActiveXの自動ダウンロード

HTMLファイルに以下の記述を追加すること自動ダウンロードを行うことが可能です。

<html>
<object classid="clsid:AAA3475B-DC7E-4C29-A719-08407FA18945" id="RMViewer"
codebase="http://localhost/RMViewerCtrl.ocx#version=1,0,0,1"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\RMdata\\EmpfamilyXml.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\RMdata\\EmpfamilyMagic.xml">
<param name="ToolBar" value="on">
</object>
</html>

文字列の出力可能範囲について

V1.0Bより文字列の出力可能範囲が厳密に制御されるようになりました。
文字列枠は、内部余白により制御されており、出力する文字列が文字列枠の範囲を超えた文字は、出力されません。

dbFORM形式は、項目の「テキストの折り返し」により出力方式が異なります。
「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。

「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」

ブラウザ上でRMViewerを使用した場合、表示される場合があります。

これはWindows XPのサービスパック2（SP2）のセキュリティ強化に伴って表示されるようになったメッセージでWebページからユーザのコンピュータ上のスクリプトやActiveXコントロールが実行されようとしたときに表示されます。

情報バーをクリックして、ブロックされているコンテンツを許可することは可能ですが、表示するたびに入力が必要になります。以下の操作をすることで、確認画面が表示されなくなります。

▼操作手順
メニュー［ツール］－［インターネットオプション］をクリック
  ↓
［インターネットオプション］ダイアログ－［詳細設定］タブをクリック
  ↓
［設定］－［セキュリティ］欄の、
［マイコンピュータのファイルでのアクティブコンテンツの実行を許可する］チェックをOnにする
  ↓
［インターネットオプション］ダイアログ－［OK］ボタンをクリック

データ連携－データ形式の違い

 | dbFORM | CSV | ヘッダー付き CSV | XML
TAG名ルール | %%数字２階層まで | %%数字 | 任意 | 任意
テーブル | なし テーブル構造の認識は無い | １個 | １個 | 複数可能 （ネストはできません）
明示的改ページ | データ内で指定 （ＦＦ） | キー指定 | キー指定 | データ内で指定
暗黙的改ページ | × | ○ キー指定が無い場合は、１レコード毎に改ページ | ○ キー指定が無い場合は、１レコード毎に改ページ | ○
マルチフォーム ※1 | × | △ 暗黙的改ページの場合のみ可能 | △ 暗黙的改ページの場合のみ可能 | ○ データ内で指定 （XML フォーム番号）
マージテンプレート作成支援 | × | × | × | ○
備考 | dbFORMの互換機能を重視した形式です。 今後の拡張予定はありません。ヘッダー付きCSV、XML形式への移行をお奨めいたします。 | データ格納率が高いため、大量印刷の場合に有利です。 | データ格納率が高いため、大量印刷の場合に有利です。 CSV形式に比べて、TAG名を自由に管理できるため、メンテナンス性は向上します。 | マルチフォームをサポートした最も高度なフォーム形式です。 ReportsMagicのデフォルトのフォーム形式です。 CSV形式に比べるとデータ量が大きくなる傾向があります。
  • ※１：ひとつの帳票データで複数のフォームを使用する形態。例えば、１ページ目は納品書、２ページ目は請求書、３ページ目は納品受領書のような形態。


ベータ版評価レポートのお願い

本ベータ版は製品出荷前に機能、安定性などの評価のために公開されているもので、マジックソフトウェアジャパンのサポートセンターでのサポート対象外です。
ベータ版についてのご意見、ご質問、気が付いた点などは、下記の「ベータ評価レポート」に記入して、メールで japan_v9beta@magicsoftware.com までお送りください。
製品の改善に反映させていただきたいと思います。

ReportsMagic V1.0B 評価レポート

記入日： ２００５年６ 月　 日
会社名：
担当者：
E-mail：
ＴＥＬ：
ＦＡＸ：
サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境
ＰＣ機種：
ＣＰＵ：
ＲＡＭ：
ＯＳ： （ ）Windows98／（ ）Windows2000（SP： ）／（ ）WindowsXP／（ ）Windows2003
ＩＭＥ：
ビデオカード：
使用ブラウザ：（ ）IE5.5 （SP： )、　（ ） IE6（SP： ）

２．不具合の場合

不具合を確認した場合は、こちらに記入してください。 該当する（ ）に＊を挿入してください。

Ａ （ ） 一部支障あり
Ｂ （ ） 正常に動作しない
Ｃ （ ） インストール・起動不可

２．１．再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

２．２．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なう
ために、極力画面のハードコピー、フォームデータ、サンプルプログラム等の提供をお願い
いた します。）

３．要望事項
機能追加、改善要望等がありましたら、こちらに記入してください。
 （できるだけ詳細にお書きください。）

４．その他ご意見

以上


Magic Software Japan K.K - Magic eDeveloper Plus Ver9.40J SP1 ベータ版 （Windows版）

ReportsMagic 使用許諾契約書

本ソフトウェアモジュールを利用するにあたっては、下記の事項を良く理解し、合意した上でご利用ください。万一合意できない場合には、本ソフトウェアモジュールをご利用になることはできません。

マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）とお客様（以下「お客様」という）は、「ReportsMagic ベータ版」としてMSJ社より提供されるソフトウェア・プログラム（以下「許諾プログラム」という）及びドキュメント（マニュアルなど）について以下の通り合意しました。

1. | 総則
   許諾プログラムに関する全ての著作権は、Magic Software Enterprises社、ＭＳＪまたは許諾プログラムに関して正当な権限を有する第三者が保有しています。 ＭＳＪはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的な使用権を付与します。
2. | 契約期間
   本契約は、お客様が許諾プログラムを取得した時から発効し、または第７条の規定により解約されるまで有効とします。
3. | 使用権
   (1)使用権の内容はお客様が購入又は入手された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守して下さい。
・RMDesignerの場合
お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－C/Sの場合
お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－Webの場合
お客様は、許諾プログラムを機械読取可能な形で、Webサーバ単位で使用することができます。
・体験版の場合
お客様は、試用目的でだけ許諾プログラムを使用することができます。許諾プログラム、及び許諾プログラムを利用して開発したモジュールを営利目的に使用することはできません。
(2)お客様は、ＭＳＪの書面による同意を得なければ、使用権を第三者に対して譲渡、移転、または再使用権の設定を行うことはできません。このパッケージの同封物の一部もしくは全部、並びに許諾プログラムの内容の一部もしくは全部を第三者に譲渡または移転してはなりません。
(3)お客様は、許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルしないことに同意します。
4. | ＭＳＪの保証の範囲
   (1)ＭＳＪは、許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。
(2)ＭＳＪは、お客様の許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。
5. | ソフトウェア・メンテナンスについて
   各プログラム使用権にはソフトウェア・メンテナンスが含まれています。許諾プログラムの使用権に含まれるソフトウェア・メンテナンスは、ＭＳＪ より提供され、「ReportsMagicソフトウェア・メンテナンス」といいます。
ReportsMagic ソフトウェア・メンテナンスは、効力発生日に開始し、１年後の同月末日に終了します。ただし、効力発生日が月の第1日目の場合は、取得日から１年後の前月末日に終了します。
許諾プログラム使用権に対するReportsMagicソフトウェア・メンテナンスの有効期間においては、
①ＭＳＪはお客様に対して、ご契約された全てのプログラムの一般的に入手可能な最新バージョンもしくはアップデートモジュールを提供し、その使用を許諾します。ただし、これらが提供された場合に限ります。
②ＭＳＪはお客様に対して以下のサポートを提供します。
ⅰ)導入や使用方法に関する日常的、かつ短時間の質問に対する応答
ⅱ)プログラム・コードに起因する障害に対するサポート
③ＭＳＪはMagicサポートセンターのサービス提供時間中に、電子アクセス（使用可能な場合）または電話を介して、お客様の情報システム部門のテクニカル・サポート担当者にのみサポートを提供します。マジックソリューションパートナー（MSP）経由で購入したお客様は、MSP経由での対応となります。
④ReportsMagicソフトウェア・メンテナンスには以下のサポートは含まれません。
ⅰ)アプリケーションの設計と開発に対するサポート
ⅱ)プログラムの指定稼動環境以外の環境における当該プログラムの使用に関するサポート
ⅲ)本契約書の下でMSJが責任を負わない製品に起因する障害に対するサポート
上記は、ReportsMagicソフトウェア・メンテナンスについての保証のすべてを規定したもので、法律上の瑕疵担保責任、商品性の保証および特定目的適合性の保証を含む全ての明示もしくは黙示の保証責任、または保証条件に代わるものとします
(2) 一年毎のソフトウェア・メンテナンスの更新
「ソフトウェア・メンテナンス更新日」とは、本契約書の効力発生日から1年後の翌月第1日目をいいます。ただし、効力発生日が月の第１日目である場合には、１年後の同日が最初の「ソフトウェア・メンテナンス更新日」になります。お客様は追加料金を支払うことにより期間満了となるソフトウェア・メンテナンスを継続することができます｡この時、ソフトウェア・メンテナンス更新日も自動的に１年延長されます。お客様が、かかる継続を希望する場合には、(1) MSJが、お客様からの継続の注文(注文書等) を現行の有効期間満了日より前までに受領すること、また(2) 次に続く有効期間分のソフトウェア・メンテナンスの請求書受領日より30 日以内に支払いを行うことが必要です。お客様が、プログラム使用権のうち、すべてあるいは特定のものについてソフトウェア・メンテナンスの継続を行わず、後日、かかるプログラム使用権のいずれかについてソフトウェア・メンテナンスの取得を希望する場合には、お客様は、未契約期間の費用を支払うことにより継続することが可能です。
ＭＳＪが、必要に応じ、特定のプログラムに対してソフトウェア・メンテナンスの提供を中止した場合は、お客様は以下のことについて了解するものとします。
1) ＭＳＪは、当該プログラムに対してはソフトウェア・メンテナンスの更新を提供しません。
2) 上記中止のお知らせの前にお客様がそのプログラム使用権のソフトウェア・メンテナンスを更新した場合には、ＭＳＪは、自らの裁量により、更新済み契約の終了まで、当該プログラム使用権についてソフトウェア・メンテナンスをお客様に対して継続して提供するか、またはお客様に対して月割り計算した料金を返金します。
6. | 契約の解約
   ＭＳＪは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。
7. | 契約終了時の措置
   本契約が第6条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。
8. | 一般条項
   本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。
9. | 裁判管轄
   本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


ReportsMagic Ver1.0A 修正履歴

CHM ファイルのトピックが表示できない問題

セキュリティ更新プログラム のインストール後、 ダウンロードしたCHMファイルのトピックが表示できない場合があります。
（注意：このページも表示できなくなります。）

対応方法

  • 方法①： ネットワーク共有フォルダにある場合は、ローカルコンピュータにコピーする。共有フォルダで使用したい場合は、方法④を実施する。
  • 方法②： CHMファイルを開くときに、「セキュリティファイルの警告」が出る場合は、「この種類のファイルであれば常に警告する」のチェックを外す。
  • 方法③： CHMファイルのプロパティで、「ブロックの解除」が表示されている場合は、ボタンを押す。
  • 方法④： レジストリエントリを修正する。　HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions　を開く。
    DWORD値でMaxAllowedZone を作成し値のデータを「１」にする。
    値は、0～４の範囲があり、数が大きいほどセキュリティが緩くなります。
    警告     : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。セキュリティに関しても自己責任で行ってください。

参考情報

  • セキュリティ更新プログラム MS05-026 またはセキュリティ更新プログラム MS05-001 のインストール後、一部の Web サイトで特定の HTML ヘルプ機能を使用できなくなることがある
    http://support.microsoft.com/default.aspx?scid=kb;ja;892675
  • セキュリティ更新プログラム 896358 のインストール後、ダウンロードした CHM ファイルを開けない http://support.microsoft.com/default.aspx?scid=kb;ja;902225
  • Windows Server 2003 Service Pack 1、セキュリティ更新プログラム MS05-026 または MS04-023 のインストール後、InfoTech プロトコルを使用する一部の Web アプリケーションが使用できなくなる
    http://support.microsoft.com/default.aspx?scid=kb;ja;896054